Update to 10.0.15

This commit is contained in:
Jakub Dorňák 2014-11-27 15:30:37 +01:00
parent c0c63684bf
commit 7f3fe0a2f7
13 changed files with 64 additions and 187 deletions

1
.gitignore vendored
View File

@ -12,3 +12,4 @@
/mariadb-10.0.12.tar.gz /mariadb-10.0.12.tar.gz
/mariadb-10.0.13.tar.gz /mariadb-10.0.13.tar.gz
/mariadb-10.0.14.tar.gz /mariadb-10.0.14.tar.gz
/mariadb-10.0.15.tar.gz

View File

@ -1,20 +0,0 @@
# Fix leftover warning flags on mysql_config --cflags
--- scripts/mysql_config.sh 2014-10-08 07:35:00 +0000
+++ scripts/mysql_config.sh 2014-11-18 14:43:01 +0000
@@ -136,12 +136,12 @@
for remove in DDBUG_OFF DSAFE_MUTEX DUNIV_MUST_NOT_INLINE DFORCE_INIT_OF_VARS \
DEXTRA_DEBUG DHAVE_valgrind O 'O[0-9]' 'xO[0-9]' 'W[-A-Za-z]*' \
'mtune=[-A-Za-z0-9]*' 'mcpu=[-A-Za-z0-9]*' 'march=[-A-Za-z0-9]*' \
- Xa xstrconst "xc99=none" AC99 \
+ Xa xstrconst "xc99=none" AC99 'W[-A-Za-z]*=[-A-Za-z0-9]*' \
unroll2 ip mp restrict
do
# The first option we might strip will always have a space before it because
# we set -I$pkgincludedir as the first option
- cflags=`echo "$cflags"|sed -e "s/ -$remove */ /g"`
+ cflags=`echo "$cflags"|sed -e ':again' -e "s/ -$remove */ /g" -e 't again'`
done
cflags=`echo "$cflags"|sed -e 's/ *\$//'`

View File

@ -1,115 +0,0 @@
Some test items assume the default SSL cipher is DHE-RSA-AES256-SHA,
which is no longer the case as of openssl 1.0.1.
This patch enhances connect command by an option to specify a cipher
and tests are adjusted to specify the expected cipher explicitly.
Upstream bug report: http://bugs.mysql.com/bug.php?id=64461
diff -up --recursive mariadb-10.0.12.orig/client/mysqltest.cc mariadb-10.0.12/client/mysqltest.cc
--- mariadb-10.0.12.orig/client/mysqltest.cc 2014-06-12 11:26:05.000000000 +0200
+++ mariadb-10.0.12/client/mysqltest.cc 2014-06-18 11:24:49.623171255 +0200
@@ -5912,6 +5912,7 @@ void do_connect(struct st_command *comma
my_bool con_pipe= 0;
my_bool con_shm __attribute__ ((unused))= 0;
struct st_connection* con_slot;
+ char *con_cipher=NULL;
static DYNAMIC_STRING ds_connection_name;
static DYNAMIC_STRING ds_host;
@@ -6002,6 +6003,8 @@ void do_connect(struct st_command *comma
con_pipe= 1;
else if (length == 3 && !strncmp(con_options, "SHM", 3))
con_shm= 1;
+ else if (!strncmp(con_options, "CIPHER:", 7))
+ con_cipher = con_options + 7;
else
die("Illegal option to connect: %.*s",
(int) (end - con_options), con_options);
@@ -6051,8 +6054,11 @@ void do_connect(struct st_command *comma
if (con_ssl)
{
#if defined(HAVE_OPENSSL) && !defined(EMBEDDED_LIBRARY)
+ /* default cipher */
+ if (con_cipher == NULL && opt_ssl_cipher != NULL)
+ con_cipher = opt_ssl_cipher;
mysql_ssl_set(con_slot->mysql, opt_ssl_key, opt_ssl_cert, opt_ssl_ca,
- opt_ssl_capath, opt_ssl_cipher);
+ opt_ssl_capath, con_cipher);
mysql_options(con_slot->mysql, MYSQL_OPT_SSL_CRL, opt_ssl_crl);
mysql_options(con_slot->mysql, MYSQL_OPT_SSL_CRLPATH, opt_ssl_crlpath);
#if MYSQL_VERSION_ID >= 50000
diff -up --recursive mariadb-10.0.12.orig/mysql-test/t/openssl_1.test mariadb-10.0.12/mysql-test/t/openssl_1.test
--- mariadb-10.0.12.orig/mysql-test/t/openssl_1.test 2014-06-12 11:26:05.000000000 +0200
+++ mariadb-10.0.12/mysql-test/t/openssl_1.test 2014-06-18 11:24:49.624171253 +0200
@@ -20,13 +20,13 @@ grant select on test.* to ssl_user4@loca
grant select on test.* to ssl_user5@localhost require cipher "DHE-RSA-AES256-SHA" AND SUBJECT "xxx";
flush privileges;
-connect (con1,localhost,ssl_user1,,,,,SSL);
-connect (con2,localhost,ssl_user2,,,,,SSL);
-connect (con3,localhost,ssl_user3,,,,,SSL);
-connect (con4,localhost,ssl_user4,,,,,SSL);
+connect (con1,localhost,ssl_user1,,,,,SSL CIPHER:DHE-RSA-AES256-SHA);
+connect (con2,localhost,ssl_user2,,,,,SSL CIPHER:DHE-RSA-AES256-SHA);
+connect (con3,localhost,ssl_user3,,,,,SSL CIPHER:DHE-RSA-AES256-SHA);
+connect (con4,localhost,ssl_user4,,,,,SSL CIPHER:DHE-RSA-AES256-SHA);
--replace_result $MASTER_MYSOCK MASTER_SOCKET $MASTER_MYPORT MASTER_PORT
--error ER_ACCESS_DENIED_ERROR
-connect (con5,localhost,ssl_user5,,,,,SSL);
+connect (con5,localhost,ssl_user5,,,,,SSL CIPHER:DHE-RSA-AES256-SHA);
connection con1;
# Check ssl turned on
@@ -129,7 +129,7 @@ drop table t1;
# verification of servers certificate by setting both ca certificate
# and ca path to NULL
#
---exec $MYSQL --ssl --ssl-key=$MYSQL_TEST_DIR/std_data/client-key.pem --ssl-cert=$MYSQL_TEST_DIR/std_data/client-cert.pem -e "SHOW STATUS LIKE 'ssl_Cipher'" 2>&1
+--exec $MYSQL --ssl --ssl-key=$MYSQL_TEST_DIR/std_data/client-key.pem --ssl-cert=$MYSQL_TEST_DIR/std_data/client-cert.pem --ssl-cipher=DHE-RSA-AES256-SHA -e "SHOW STATUS LIKE 'ssl_Cipher'" 2>&1
--echo End of 5.0 tests
#
@@ -254,7 +254,7 @@ select 'is still running; no cipher requ
GRANT SELECT ON test.* TO bug42158@localhost REQUIRE X509;
FLUSH PRIVILEGES;
-connect(con1,localhost,bug42158,,,,,SSL);
+connect(con1,localhost,bug42158,,,,,SSL CIPHER:DHE-RSA-AES256-SHA);
SHOW STATUS LIKE 'Ssl_cipher';
disconnect con1;
connection default;
diff -up --recursive mariadb-10.0.12.orig/mysql-test/t/ssl_compress.test mariadb-10.0.12/mysql-test/t/ssl_compress.test
--- mariadb-10.0.12.orig/mysql-test/t/ssl_compress.test 2014-06-12 11:26:07.000000000 +0200
+++ mariadb-10.0.12/mysql-test/t/ssl_compress.test 2014-06-18 11:24:49.624171253 +0200
@@ -8,7 +8,7 @@
# Save the initial number of concurrent sessions
--source include/count_sessions.inc
-connect (ssl_compress_con,localhost,root,,,,,SSL COMPRESS);
+connect (ssl_compress_con,localhost,root,,,,,SSL COMPRESS CIPHER:DHE-RSA-AES256-SHA);
# Check ssl turned on
SHOW STATUS LIKE 'Ssl_cipher';
diff -up --recursive mariadb-10.0.12.orig/mysql-test/t/ssl.test mariadb-10.0.12/mysql-test/t/ssl.test
--- mariadb-10.0.12.orig/mysql-test/t/ssl.test 2014-06-12 11:26:05.000000000 +0200
+++ mariadb-10.0.12/mysql-test/t/ssl.test 2014-06-18 11:24:49.624171253 +0200
@@ -8,7 +8,7 @@
# Save the initial number of concurrent sessions
--source include/count_sessions.inc
-connect (ssl_con,localhost,root,,,,,SSL);
+connect (ssl_con,localhost,root,,,,,SSL CIPHER:DHE-RSA-AES256-SHA);
# Check ssl turned on
SHOW STATUS LIKE 'Ssl_cipher';
diff -up --recursive mariadb-10.0.12.orig/mysql-test/t/ssl_8k_key.test mariadb-10.0.12/mysql-test/t/ssl_8k_key.test
--- mariadb-10.0.12.orig/mysql-test/t/ssl_8k_key.test 2014-06-12 11:26:05.000000000 +0200
+++ mariadb-10.0.12/mysql-test/t/ssl_8k_key.test 2014-06-18 11:24:49.624171253 +0200
@@ -5,7 +5,7 @@
#
# Bug#29784 YaSSL assertion failure when reading 8k key.
#
---exec $MYSQL --ssl --ssl-key=$MYSQL_TEST_DIR/std_data/client-key.pem --ssl-cert=$MYSQL_TEST_DIR/std_data/client-cert.pem -e "SHOW STATUS LIKE 'ssl_Cipher'" 2>&1
+--exec $MYSQL --ssl --ssl-key=$MYSQL_TEST_DIR/std_data/client-key.pem --ssl-cert=$MYSQL_TEST_DIR/std_data/client-cert.pem --ssl-cipher=DHE-RSA-AES256-SHA -e "SHOW STATUS LIKE 'ssl_Cipher'" 2>&1
## This test file is for testing encrypted communication only, not other
## encryption routines that the SSL library happens to provide!

View File

@ -2,10 +2,10 @@ This issue has been found by Coverity - static analysis tool.
mysql-5.5.31/strings/ctype-ucs2.c:1707:sign_extension Suspicious implicit sign extension: "s[0]" with type "unsigned char" (8 bits, unsigned) is promoted in "(s[0] << 24) + (s[1] << 16) + (s[2] << 8) + s[3]" to type "int" (32 bits, signed), then sign-extended to type "unsigned long" (64 bits, unsigned). If "(s[0] << 24) + (s[1] << 16) + (s[2] << 8) + s[3]" is greater than 0x7FFFFFFF, the upper bits of the result will all be 1. mysql-5.5.31/strings/ctype-ucs2.c:1707:sign_extension Suspicious implicit sign extension: "s[0]" with type "unsigned char" (8 bits, unsigned) is promoted in "(s[0] << 24) + (s[1] << 16) + (s[2] << 8) + s[3]" to type "int" (32 bits, signed), then sign-extended to type "unsigned long" (64 bits, unsigned). If "(s[0] << 24) + (s[1] << 16) + (s[2] << 8) + s[3]" is greater than 0x7FFFFFFF, the upper bits of the result will all be 1.
diff -up mariadb-10.0.10/strings/ctype-ucs2.c.p11 mariadb-10.0.10/strings/ctype-ucs2.c diff -up mariadb-10.0.15/strings/ctype-ucs2.c.orig mariadb-10.0.15/strings/ctype-ucs2.c
--- mariadb-10.0.10/strings/ctype-ucs2.c.p11 2014-03-30 19:56:37.000000000 +0200 --- mariadb-10.0.15/strings/ctype-ucs2.c.orig 2014-11-27 15:14:11.129554529 +0100
+++ mariadb-10.0.10/strings/ctype-ucs2.c 2014-04-07 18:56:01.145454666 +0200 +++ mariadb-10.0.15/strings/ctype-ucs2.c 2014-11-27 15:13:06.806439653 +0100
@@ -1930,7 +1930,7 @@ my_utf32_uni(CHARSET_INFO *cs __attribut @@ -1932,7 +1932,7 @@ my_utf32_uni(CHARSET_INFO *cs __attribut
{ {
if (s + 4 > e) if (s + 4 > e)
return MY_CS_TOOSMALL4; return MY_CS_TOOSMALL4;

View File

@ -6,9 +6,9 @@ mysql-5.5.31/plugin/semisync/semisync_master.cc:661:parameter_as_source Note
mysql-5.5.31/plugin/semisync/semisync_master.cc:555:parameter_as_source Note: This defect has an elevated risk because the source argument is a parameter of the current function. mysql-5.5.31/plugin/semisync/semisync_master.cc:555:parameter_as_source Note: This defect has an elevated risk because the source argument is a parameter of the current function.
diff -up mariadb-10.0.10/plugin/semisync/semisync_master.cc.p12 mariadb-10.0.10/plugin/semisync/semisync_master.cc diff -up mariadb-10.0.15/plugin/semisync/semisync_master.cc.orig mariadb-10.0.15/plugin/semisync/semisync_master.cc
--- mariadb-10.0.10/plugin/semisync/semisync_master.cc.p12 2014-03-30 19:56:37.000000000 +0200 --- mariadb-10.0.15/plugin/semisync/semisync_master.cc.orig 2014-11-27 15:16:59.664855517 +0100
+++ mariadb-10.0.10/plugin/semisync/semisync_master.cc 2014-04-07 20:02:49.614944992 +0200 +++ mariadb-10.0.15/plugin/semisync/semisync_master.cc 2014-11-27 15:16:17.029779375 +0100
@@ -553,7 +553,8 @@ int ReplSemiSyncMaster::reportReplyBinlo @@ -553,7 +553,8 @@ int ReplSemiSyncMaster::reportReplyBinlo
if (need_copy_send_pos) if (need_copy_send_pos)
@ -42,9 +42,10 @@ diff -up mariadb-10.0.10/plugin/semisync/semisync_master.cc.p12 mariadb-10.0.10/
mysql-5.5.31/sql/rpl_handler.cc:306:fixed_size_dest You might overrun the 512 byte fixed-size string "log_info->log_file" by copying "log_file + dirname_length(log_file)" without checking the length. diff -up mysql-5.5.31/sql/rpl_handler.cc.covscan-stroverflow mysql-5.5.31/sql/rpl_handler.cc mysql-5.5.31/sql/rpl_handler.cc:306:fixed_size_dest You might overrun the 512 byte fixed-size string "log_info->log_file" by copying "log_file + dirname_length(log_file)" without checking the length. diff -up mysql-5.5.31/sql/rpl_handler.cc.covscan-stroverflow mysql-5.5.31/sql/rpl_handler.cc
--- mariadb-10.0.10/sql/rpl_handler.cc.p12 2014-03-30 19:56:34.000000000 +0200 diff -up mariadb-10.0.15/sql/rpl_handler.cc.orig mariadb-10.0.15/sql/rpl_handler.cc
+++ mariadb-10.0.10/sql/rpl_handler.cc 2014-04-07 20:07:58.851123497 +0200 --- mariadb-10.0.15/sql/rpl_handler.cc.orig 2014-11-27 15:17:28.000906123 +0100
@@ -303,7 +303,8 @@ int Binlog_storage_delegate::after_flush +++ mariadb-10.0.15/sql/rpl_handler.cc 2014-11-27 15:16:17.030779377 +0100
@@ -270,7 +270,8 @@ int Binlog_storage_delegate::after_flush
my_pthread_setspecific_ptr(RPL_TRANS_BINLOG_INFO, log_info); my_pthread_setspecific_ptr(RPL_TRANS_BINLOG_INFO, log_info);
} }

View File

@ -5,9 +5,9 @@ mode is on, but it doesn't seem worth the trouble.)
The new parameter value was generated using "openssl dhparam -C 1024". The new parameter value was generated using "openssl dhparam -C 1024".
diff -up mariadb-10.0.10/vio/viosslfactories.c.p9 mariadb-10.0.10/vio/viosslfactories.c diff -up mariadb-10.0.15/vio/viosslfactories.c.orig mariadb-10.0.15/vio/viosslfactories.c
--- mariadb-10.0.10/vio/viosslfactories.c.p9 2014-03-30 19:56:42.000000000 +0200 --- mariadb-10.0.15/vio/viosslfactories.c.orig 2014-11-27 15:02:22.757315487 +0100
+++ mariadb-10.0.10/vio/viosslfactories.c 2014-04-07 18:50:55.068255050 +0200 +++ mariadb-10.0.15/vio/viosslfactories.c 2014-11-27 15:00:44.847144887 +0100
@@ -20,27 +20,32 @@ @@ -20,27 +20,32 @@
static my_bool ssl_algorithms_added = FALSE; static my_bool ssl_algorithms_added = FALSE;
static my_bool ssl_error_strings_loaded= FALSE; static my_bool ssl_error_strings_loaded= FALSE;
@ -52,7 +52,7 @@ diff -up mariadb-10.0.10/vio/viosslfactories.c.p9 mariadb-10.0.10/vio/viosslfact
if (! dh->p || ! dh->g) if (! dh->p || ! dh->g)
{ {
DH_free(dh); DH_free(dh);
@@ -282,7 +287,7 @@ new_VioSSLFd(const char *key_file, const @@ -284,7 +289,7 @@ new_VioSSLFd(const char *key_file, const
} }
/* DH stuff */ /* DH stuff */

View File

@ -1,7 +1,7 @@
diff -up mariadb-10.0.12/scripts/CMakeLists.txt.systemd mariadb-10.0.12/scripts/CMakeLists.txt diff -up mariadb-10.0.15/scripts/CMakeLists.txt.systemd mariadb-10.0.15/scripts/CMakeLists.txt
--- mariadb-10.0.12/scripts/CMakeLists.txt.systemd 2014-07-21 10:49:58.491470586 +0200 --- mariadb-10.0.15/scripts/CMakeLists.txt.systemd 2014-11-27 15:06:24.670736998 +0100
+++ mariadb-10.0.12/scripts/CMakeLists.txt 2014-07-21 14:21:22.673329708 +0200 +++ mariadb-10.0.15/scripts/CMakeLists.txt 2014-11-27 15:04:26.252530666 +0100
@@ -368,6 +368,34 @@ ELSE() @@ -374,6 +374,34 @@ ELSE()
COMPONENT ${${file}_COMPONENT} COMPONENT ${${file}_COMPONENT}
) )
ENDFOREACH() ENDFOREACH()
@ -36,10 +36,10 @@ diff -up mariadb-10.0.12/scripts/CMakeLists.txt.systemd mariadb-10.0.12/scripts/
ENDIF() ENDIF()
# Install libgcc as mylibgcc.a # Install libgcc as mylibgcc.a
diff -up mariadb-10.0.12/support-files/CMakeLists.txt.cmakescripts mariadb-10.0.12/support-files/CMakeLists.txt diff -up mariadb-10.0.15/support-files/CMakeLists.txt.cmakescripts mariadb-10.0.15/support-files/CMakeLists.txt
--- mariadb-10.0.12/support-files/CMakeLists.txt.cmakescripts 2014-07-24 22:31:38.116002679 +0200 --- mariadb-10.0.15/support-files/CMakeLists.txt.cmakescripts 2014-11-27 15:07:13.203821563 +0100
+++ mariadb-10.0.12/support-files/CMakeLists.txt 2014-07-24 22:35:00.532233645 +0200 +++ mariadb-10.0.15/support-files/CMakeLists.txt 2014-11-27 15:04:26.252530666 +0100
@@ -110,6 +110,8 @@ IF(UNIX) @@ -112,6 +112,8 @@ IF(UNIX)
COMPONENT SharedLibraries) COMPONENT SharedLibraries)
INSTALL(FILES rpm/mysql-clients.cnf DESTINATION ${INSTALL_SYSCONF2DIR} INSTALL(FILES rpm/mysql-clients.cnf DESTINATION ${INSTALL_SYSCONF2DIR}
COMPONENT Client) COMPONENT Client)

View File

@ -4,10 +4,10 @@ which now makes mariadb/mysql FTBFS because openssl_1 test fails
Related: #1044565 Related: #1044565
diff -up mariadb-10.0.10/mysql-test/r/openssl_1.result.p14 mariadb-10.0.10/mysql-test/r/openssl_1.result diff -up mariadb-10.0.15/mysql-test/r/openssl_1.result.orig mariadb-10.0.15/mysql-test/r/openssl_1.result
--- mariadb-10.0.10/mysql-test/r/openssl_1.result.p14 2014-03-30 19:56:35.000000000 +0200 --- mariadb-10.0.15/mysql-test/r/openssl_1.result.orig 2014-11-27 15:25:32.582771542 +0100
+++ mariadb-10.0.10/mysql-test/r/openssl_1.result 2014-04-07 20:14:24.702980342 +0200 +++ mariadb-10.0.15/mysql-test/r/openssl_1.result 2014-11-27 15:22:46.353474672 +0100
@@ -196,8 +196,6 @@ Ssl_cipher DHE-RSA-AES256-SHA @@ -198,8 +198,6 @@ Ssl_cipher DHE-RSA-AES256-SHA
Variable_name Value Variable_name Value
Ssl_cipher EDH-RSA-DES-CBC3-SHA Ssl_cipher EDH-RSA-DES-CBC3-SHA
Variable_name Value Variable_name Value
@ -16,10 +16,10 @@ diff -up mariadb-10.0.10/mysql-test/r/openssl_1.result.p14 mariadb-10.0.10/mysql
Ssl_cipher RC4-SHA Ssl_cipher RC4-SHA
select 'is still running; no cipher request crashed the server' as result from dual; select 'is still running; no cipher request crashed the server' as result from dual;
result result
diff -up mariadb-10.0.10/mysql-test/t/openssl_1.test.p14 mariadb-10.0.10/mysql-test/t/openssl_1.test diff -up mariadb-10.0.15/mysql-test/t/openssl_1.test.orig mariadb-10.0.15/mysql-test/t/openssl_1.test
--- mariadb-10.0.10/mysql-test/t/openssl_1.test.p14 2014-04-07 20:14:24.686980712 +0200 --- mariadb-10.0.15/mysql-test/t/openssl_1.test.orig 2014-11-27 15:25:16.637743066 +0100
+++ mariadb-10.0.10/mysql-test/t/openssl_1.test 2014-04-07 20:14:24.702980342 +0200 +++ mariadb-10.0.15/mysql-test/t/openssl_1.test 2014-11-27 15:22:46.354474674 +0100
@@ -218,7 +218,7 @@ DROP TABLE t1; @@ -222,7 +222,7 @@ DROP TABLE t1;
# Common ciphers to openssl and yassl # Common ciphers to openssl and yassl
--exec $MYSQL --host=localhost -e "SHOW STATUS LIKE 'Ssl_cipher';" --ssl-cipher=DHE-RSA-AES256-SHA --exec $MYSQL --host=localhost -e "SHOW STATUS LIKE 'Ssl_cipher';" --ssl-cipher=DHE-RSA-AES256-SHA
--exec $MYSQL --host=localhost -e "SHOW STATUS LIKE 'Ssl_cipher';" --ssl-cipher=EDH-RSA-DES-CBC3-SHA --exec $MYSQL --host=localhost -e "SHOW STATUS LIKE 'Ssl_cipher';" --ssl-cipher=EDH-RSA-DES-CBC3-SHA

View File

@ -12,10 +12,10 @@ ability to detect this type of error is low, and I also see little evidence
of any real performance gain from optimizing these calls. So I'm keeping of any real performance gain from optimizing these calls. So I'm keeping
this patch. this patch.
diff -up mariadb-10.0.10/include/m_string.h.orig mariadb-10.0.10/include/m_string.h diff -up mariadb-10.0.15/include/m_string.h.orig mariadb-10.0.15/include/m_string.h
--- mariadb-10.0.10/include/m_string.h.p2 2014-04-07 15:36:44.694806871 +0200 --- mariadb-10.0.15/include/m_string.h.orig 2014-11-27 14:40:32.622032698 +0100
+++ mariadb-10.0.10/include/m_string.h 2014-04-07 15:37:17.044786762 +0200 +++ mariadb-10.0.15/include/m_string.h 2014-11-27 14:38:56.211864712 +0100
@@ -81,12 +81,6 @@ extern void *(*my_str_malloc)(size_t); @@ -73,12 +73,6 @@ extern void *(*my_str_malloc)(size_t);
extern void *(*my_str_realloc)(void *, size_t); extern void *(*my_str_realloc)(void *, size_t);
extern void (*my_str_free)(void *); extern void (*my_str_free)(void *);

View File

@ -26,6 +26,14 @@
%bcond_with tokudb %bcond_with tokudb
%endif %endif
# Mroonga engine is now part of MariaDB, but it only builds for x86_64;
# variable mroonga allows to build with Mroonga storage engine
%ifarch x86_64 i686
%bcond_without mroonga
%else
%bcond_with mroonga
%endif
# The Open Query GRAPH engine (OQGRAPH) is a computation engine allowing # The Open Query GRAPH engine (OQGRAPH) is a computation engine allowing
# hierarchies and more complex graph structures to be handled in a relational # hierarchies and more complex graph structures to be handled in a relational
# fashion; enabled by default # fashion; enabled by default
@ -103,11 +111,11 @@
# Make long macros shorter # Make long macros shorter
%global sameevr %{epoch}:%{version}-%{release} %global sameevr %{epoch}:%{version}-%{release}
%global compatver 10.0 %global compatver 10.0
%global bugfixver 14 %global bugfixver 15
Name: %{pkgname} Name: %{pkgname}
Version: %{compatver}.%{bugfixver} Version: %{compatver}.%{bugfixver}
Release: 8%{?with_debug:.debug}%{?dist} Release: 1%{?with_debug:.debug}%{?dist}
Epoch: 1 Epoch: 1
Summary: A community developed branch of MySQL Summary: A community developed branch of MySQL
@ -148,11 +156,10 @@ Patch1: %{pkgnamepatch}-strmov.patch
Patch2: %{pkgnamepatch}-install-test.patch Patch2: %{pkgnamepatch}-install-test.patch
Patch3: %{pkgnamepatch}-s390-tsc.patch Patch3: %{pkgnamepatch}-s390-tsc.patch
Patch4: %{pkgnamepatch}-logrotate.patch Patch4: %{pkgnamepatch}-logrotate.patch
Patch5: %{pkgnamepatch}-cipherspec.patch Patch5: %{pkgnamepatch}-file-contents.patch
Patch6: %{pkgnamepatch}-file-contents.patch Patch6: %{pkgnamepatch}-dh1024.patch
Patch7: %{pkgnamepatch}-dh1024.patch Patch7: %{pkgnamepatch}-scripts.patch
Patch8: %{pkgnamepatch}-scripts.patch Patch8: %{pkgnamepatch}-install-db-sharedir.patch
Patch9: %{pkgnamepatch}-install-db-sharedir.patch
# Patches specific for this mysql package # Patches specific for this mysql package
Patch30: %{pkgnamepatch}-errno.patch Patch30: %{pkgnamepatch}-errno.patch
@ -162,7 +169,6 @@ Patch33: %{pkgnamepatch}-covscan-signexpr.patch
Patch34: %{pkgnamepatch}-covscan-stroverflow.patch Patch34: %{pkgnamepatch}-covscan-stroverflow.patch
Patch35: %{pkgnamepatch}-config.patch Patch35: %{pkgnamepatch}-config.patch
Patch36: %{pkgnamepatch}-ssltest.patch Patch36: %{pkgnamepatch}-ssltest.patch
Patch37: mariadb-10.0.14-mysql_config-cflags.patch
BuildRequires: cmake BuildRequires: cmake
BuildRequires: libaio-devel BuildRequires: libaio-devel
@ -488,7 +494,6 @@ MariaDB is a community developed branch of MySQL.
%patch6 -p1 %patch6 -p1
%patch7 -p1 %patch7 -p1
%patch8 -p1 %patch8 -p1
%patch9 -p1
%patch30 -p1 %patch30 -p1
%patch31 -p1 %patch31 -p1
%patch32 -p1 %patch32 -p1
@ -496,7 +501,6 @@ MariaDB is a community developed branch of MySQL.
%patch34 -p1 %patch34 -p1
%patch35 -p1 %patch35 -p1
%patch36 -p1 %patch36 -p1
%patch37 -p0
# removing bundled cmd-line-utils # removing bundled cmd-line-utils
rm -r cmd-line-utils rm -r cmd-line-utils
@ -617,6 +621,7 @@ export LDFLAGS
%{?with_pcre: -DWITH_PCRE=system}\ %{?with_pcre: -DWITH_PCRE=system}\
-DWITH_JEMALLOC=no \ -DWITH_JEMALLOC=no \
%{!?with_tokudb: -DWITHOUT_TOKUDB=ON}\ %{!?with_tokudb: -DWITHOUT_TOKUDB=ON}\
%{!?with_mroonga: -DWITHOUT_MROONGA=ON}\
-DTMPDIR=/var/tmp \ -DTMPDIR=/var/tmp \
%{?with_debug: -DCMAKE_BUILD_TYPE=Debug}\ %{?with_debug: -DCMAKE_BUILD_TYPE=Debug}\
%{?_hardened_build:-DWITH_MYSQLD_LDFLAGS="-pie -Wl,-z,relro,-z,now"} %{?_hardened_build:-DWITH_MYSQLD_LDFLAGS="-pie -Wl,-z,relro,-z,now"}
@ -1116,6 +1121,8 @@ fi
%{_datadir}/%{name}/mysql_system_tables_data.sql %{_datadir}/%{name}/mysql_system_tables_data.sql
%{_datadir}/%{name}/mysql_test_data_timezone.sql %{_datadir}/%{name}/mysql_test_data_timezone.sql
%{_datadir}/%{name}/mysql_performance_tables.sql %{_datadir}/%{name}/mysql_performance_tables.sql
%{?with_mroonga:%{_datadir}/%{name}/mroonga/install.sql}
%{?with_mroonga:%{_datadir}/%{name}/mroonga/uninstall.sql}
%{_datadir}/%{name}/my-*.cnf %{_datadir}/%{name}/my-*.cnf
%{?mysqld_unit:%{_unitdir}/%{mysqld_unit}.service} %{?mysqld_unit:%{_unitdir}/%{mysqld_unit}.service}
@ -1188,6 +1195,9 @@ fi
%endif %endif
%changelog %changelog
* Thu Nov 27 2014 Jakub Dorňák <jdornak@redhat.com> - 1:10.0.15-1
- Update to 10.0.15
* Thu Nov 20 2014 Jan Stanek <jstanek@redhat.com> - 1:10.0.14-8 * Thu Nov 20 2014 Jan Stanek <jstanek@redhat.com> - 1:10.0.14-8
- Applied upstream fix for mysql_config --cflags output. - Applied upstream fix for mysql_config --cflags output.
Resolves: #1160845 Resolves: #1160845

View File

@ -8,8 +8,5 @@ perfschema.func_file_io : rhbz#773116 cycle counter does not work on arm
perfschema.func_mutex : rhbz#773116 cycle counter does not work on arm perfschema.func_mutex : rhbz#773116 cycle counter does not work on arm
connect.bin : rhbz#1096787 (pass on aarch64) connect.bin : rhbz#1096787 (pass on aarch64)
main.gis-precise : rhbz#1096787 (pass on armv7hl)
main.openssl_1 : rhbz#1096787
perfschema.setup_objects : rhbz#1096787 perfschema.setup_objects : rhbz#1096787
innodb.innodb_simulate_comp_failures_small : rhbz#1096787 vcol.vcol_supported_sql_funcs_myisam : rhbz#1096787
main.key_cache : rhbz#1096787

View File

@ -1,9 +1,12 @@
# These tests fail with MariaDB 10: # These tests fail with MariaDB 10:
main.func_str : rhbz#1096787 main.func_str : rhbz#1096787
main.openssl_1 : rhbz#1096787
main.ssl : rhbz#1096787
main.ssl_compress : rhbz#1096787
main.ssl_crl_clients : rhbz#1096787 main.ssl_crl_clients : rhbz#1096787
main.ssl_8k_key : rhbz#1096787
perfschema.nesting : rhbz#1096787 perfschema.nesting : rhbz#1096787
perfschema.socket_summary_by_event_name_func : rhbz#1096787 perfschema.socket_summary_by_event_name_func : rhbz#1096787
perfschema.socket_summary_by_instance_func : rhbz#1096787 perfschema.socket_summary_by_instance_func : rhbz#1096787
vcol.vcol_supported_sql_funcs_innodb : rhbz#1096787 vcol.vcol_supported_sql_funcs_innodb : rhbz#1096787
vcol.vcol_supported_sql_funcs_myisam : rhbz#1096787

View File

@ -1 +1 @@
80fea71de54a9cfa7f5508df53d3f06d mariadb-10.0.14.tar.gz 07e2ca1ad684c2dc5cb260717c4db41d mariadb-10.0.15.tar.gz