Rebase to 10.2.13 version
Update lists of failing tests
This commit is contained in:
parent
f805d55b33
commit
7195667067
@ -1,16 +0,0 @@
|
||||
Wrong path used for mysqld
|
||||
|
||||
rhbz: #1403416
|
||||
|
||||
diff -Naurp mariadb-10.2.9/scripts/galera_recovery.sh mariadb-10.2.9/scripts/galera_recovery.sh_patched
|
||||
--- mariadb-10.2.9/scripts/galera_recovery.sh 2017-09-25 08:33:25.000000000 +0200
|
||||
+++ mariadb-10.2.9/scripts/galera_recovery.sh_patched 2017-09-28 09:58:54.242618594 +0200
|
||||
@@ -68,7 +68,7 @@ parse_arguments() {
|
||||
|
||||
wsrep_recover_position() {
|
||||
# Redirect server's error log to the log file.
|
||||
- eval /usr/sbin/mysqld $cmdline_args --user=$user --wsrep_recover \
|
||||
+ eval @libexecdir@/mysqld $cmdline_args --user=$user --wsrep_recover \
|
||||
--disable-log-error 2> "$log_file"
|
||||
ret=$?
|
||||
if [ $ret -ne 0 ]; then
|
10
mariadb.spec
10
mariadb.spec
@ -118,11 +118,11 @@
|
||||
# Make long macros shorter
|
||||
%global sameevr %{epoch}:%{version}-%{release}
|
||||
%global compatver 10.2
|
||||
%global bugfixver 12
|
||||
%global bugfixver 13
|
||||
|
||||
Name: mariadb
|
||||
Version: %{compatver}.%{bugfixver}
|
||||
Release: 8%{?with_debug:.debug}%{?dist}
|
||||
Release: 1%{?with_debug:.debug}%{?dist}
|
||||
Epoch: 3
|
||||
|
||||
Summary: A community developed branch of MySQL
|
||||
@ -169,7 +169,6 @@ Patch37: %{pkgnamepatch}-notestdb.patch
|
||||
|
||||
# Patches for galera
|
||||
Patch40: %{pkgnamepatch}-galera.cnf.patch
|
||||
Patch43: %{pkgnamepatch}-recovery.patch
|
||||
|
||||
BuildRequires: cmake gcc-c++
|
||||
BuildRequires: zlib-devel
|
||||
@ -676,7 +675,6 @@ find . -name "*.jar" -type f -exec rm --verbose -f {} \;
|
||||
%patch9 -p1
|
||||
%patch37 -p1
|
||||
%patch40 -p1
|
||||
%patch43 -p1
|
||||
|
||||
# workaround for upstream bug #56342
|
||||
rm mysql-test/t/ssl_8k_key-master.opt
|
||||
@ -1432,6 +1430,7 @@ fi
|
||||
%if %{with rocksdb}
|
||||
%files rocksdb-engine
|
||||
%config(noreplace) %{_sysconfdir}/my.cnf.d/rocksdb.cnf
|
||||
%{_bindir}/myrocks_hotbackup
|
||||
%{_bindir}/mysql_ldb
|
||||
%{_bindir}/sst_dump
|
||||
%{_libdir}/%{pkg_name}/plugin/ha_rocksdb.so
|
||||
@ -1540,6 +1539,9 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Thu Mar 1 2018 Michal Schorm <mschorm@redhat.com> - 3:10.2.13-1
|
||||
- Rebase to 10.2.13
|
||||
|
||||
* Mon Feb 26 2018 Michal Schorm <mschorm@redhat.com> - 3:10.2.12-8
|
||||
- SPECfile refresh, RHEL6, SySV init and old fedora stuff removed
|
||||
|
||||
|
@ -56,3 +56,14 @@ spider.function :
|
||||
spider.ha :
|
||||
spider.ha_part :
|
||||
spider.vp_fixes :
|
||||
|
||||
# 10.2.12 and 10.2.13 after some unidentified change in Rawhide buildroot
|
||||
mroonga/storage.index_multiple_column_range_all_used_less_than :
|
||||
mroonga/storage.index_multiple_column_range_all_used_less_than_or_equal :
|
||||
mroonga/storage.index_multiple_column_range_partially_used_have_prefix_less_than :
|
||||
mroonga/storage.index_multiple_column_range_partially_used_have_prefix_less_than_or_equal :
|
||||
mroonga/storage.index_multiple_column_range_partially_used_no_prefix_less_than :
|
||||
mroonga/storage.index_multiple_column_range_partially_used_no_prefix_less_than_or_equal :
|
||||
mroonga/storage.optimization_order_limit_optimized_datetime_less_than :
|
||||
mroonga/storage.optimization_order_limit_optimized_datetime_less_than_or_equal :
|
||||
|
||||
|
@ -4,3 +4,58 @@ innodb_fts.fulltext :
|
||||
innodb.innodb_defrag_concurrent :
|
||||
parts.partition_alter1_2_innodb :
|
||||
|
||||
# 10.2.12 & 10.2.13 after some uninedtified Rawhide (and the forked f28) buildroot change
|
||||
# failed: 1045: Access denied for user '.....'@'localhost' (using password: YES)
|
||||
binlog_encryption.encrypted_slave :
|
||||
rpl.rpl_create_drop_user :
|
||||
rpl.rpl_do_grant :
|
||||
rpl.rpl_temporary :
|
||||
main.connect :
|
||||
main.events_bugs :
|
||||
main.mysql_client_test :
|
||||
main.mysql_upgrade-6984 :
|
||||
innodb.innodb_defragment :
|
||||
innodb.innodb_defrag_stats :
|
||||
main.mysql_upgrade :
|
||||
innodb.temporary_table_optimization :
|
||||
main.plugin_auth :
|
||||
funcs_1.innodb_trig_03 :
|
||||
funcs_1.innodb_trig_03e :
|
||||
funcs_1.innodb_trig_0407 :
|
||||
funcs_1.innodb_trig_08 :
|
||||
innodb.innodb_bug34053 :
|
||||
main.select_pkeycache :
|
||||
main.mysql_client_test_comp :
|
||||
main.plugin_auth_qa_1 :
|
||||
sys_vars.secure_auth_func :
|
||||
funcs_1.memory_trig_03 :
|
||||
funcs_1.memory_trig_03e :
|
||||
funcs_1.memory_trig_0407 :
|
||||
funcs_1.memory_trig_08 :
|
||||
funcs_1.myisam_trig_03 :
|
||||
funcs_1.myisam_trig_03e :
|
||||
funcs_1.myisam_trig_0407 :
|
||||
funcs_1.myisam_trig_08 :
|
||||
funcs_1.processlist_priv_no_prot :
|
||||
funcs_1.processlist_val_no_prot :
|
||||
main.change_user :
|
||||
main.grant :
|
||||
main.grant2 :
|
||||
main.lowercase_fs_off :
|
||||
main.ps_grant :
|
||||
main.select :
|
||||
main.select_jcl6 :
|
||||
main.set_password_plugin-9835 :
|
||||
main.show_grants_with_plugin-7985 :
|
||||
main.sp-security :
|
||||
main.sp_notembedded :
|
||||
main.type_float :
|
||||
main.type_newdecimal :
|
||||
main.type_ranges :
|
||||
main.userstat-badlogin-4824 :
|
||||
main.view_grant :
|
||||
plugins.auth_ed25519 :
|
||||
roles.grant_role_auto_create_user :
|
||||
sys_vars.old_passwords_func :
|
||||
unit.conc_connection :
|
||||
unit.ed25519 :
|
||||
|
Loading…
Reference in New Issue
Block a user