Rebase to 10.3.7
Merge branch 'private-10.3-COPR'
This commit is contained in:
commit
6d5dc963e2
@ -1,16 +0,0 @@
|
||||
diff -up mariadb-10.0.16/scripts/mysql_install_db.pl.in.createtestdb mariadb-10.0.16/scripts/mysql_install_db.pl.in
|
||||
--- mariadb-10.0.16/scripts/mysql_install_db.pl.in.createtestdb 2015-03-03 23:02:33.287620715 +0100
|
||||
+++ mariadb-10.0.16/scripts/mysql_install_db.pl.in 2015-03-03 23:02:56.664641960 +0100
|
||||
@@ -398,10 +398,10 @@ if ( $opt->{'skip-name-resolve'} and $re
|
||||
}
|
||||
|
||||
# ----------------------------------------------------------------------
|
||||
-# Create database directories mysql & test
|
||||
+# Create database directories mysql
|
||||
# ----------------------------------------------------------------------
|
||||
|
||||
-foreach my $dir ( $opt->{ldata}, "$opt->{ldata}/mysql", "$opt->{ldata}/test" )
|
||||
+foreach my $dir ( $opt->{ldata}, "$opt->{ldata}/mysql" )
|
||||
{
|
||||
# FIXME not really the same as original "mkdir -p", but ok?
|
||||
mkdir($dir, 0700) unless -d $dir;
|
24
mariadb.spec
24
mariadb.spec
@ -144,12 +144,12 @@
|
||||
|
||||
# Make long macros shorter
|
||||
%global sameevr %{epoch}:%{version}-%{release}
|
||||
%global compatver 10.2
|
||||
%global bugfixver 15
|
||||
%global compatver 10.3
|
||||
%global bugfixver 7
|
||||
|
||||
Name: mariadb
|
||||
Version: %{compatver}.%{bugfixver}
|
||||
Release: 2%{?with_debug:.debug}%{?dist}
|
||||
Release: 1%{?with_debug:.debug}%{?dist}
|
||||
Epoch: 3
|
||||
|
||||
Summary: A community developed branch of MySQL
|
||||
@ -190,10 +190,6 @@ Patch7: %{pkgnamepatch}-scripts.patch
|
||||
# Patch9: pre-configure to comply with guidelines
|
||||
Patch9: %{pkgnamepatch}-ownsetup.patch
|
||||
|
||||
# Patches specific for this mysql package
|
||||
# Patch37: don't create a test DB: https://jira.mariadb.org/browse/MDEV-12645
|
||||
Patch37: %{pkgnamepatch}-notestdb.patch
|
||||
|
||||
# Patches for galera
|
||||
Patch40: %{pkgnamepatch}-galera.cnf.patch
|
||||
|
||||
@ -703,13 +699,12 @@ sources.
|
||||
%prep
|
||||
%setup -q -n mariadb-%{version}
|
||||
|
||||
# Removt JAR files that upstream puts into tarball
|
||||
# Remove JAR files that upstream puts into tarball
|
||||
find . -name "*.jar" -type f -exec rm --verbose -f {} \;
|
||||
|
||||
%patch4 -p1
|
||||
%patch7 -p1
|
||||
%patch9 -p1
|
||||
%patch37 -p1
|
||||
%patch40 -p1
|
||||
|
||||
# workaround for upstream bug #56342
|
||||
@ -1027,7 +1022,7 @@ rm %{buildroot}%{_mandir}/man1/{mysql_client_test_embedded,mysqltest_embedded}.1
|
||||
%if %{without clibrary}
|
||||
rm %{buildroot}%{_sysconfdir}/my.cnf.d/client.cnf
|
||||
# Client library and links
|
||||
rm %{buildroot}%{_libdir}/libmariadb*.so.*
|
||||
rm %{buildroot}%{_libdir}/libmariadb.so.*
|
||||
unlink %{buildroot}%{_libdir}/libmysqlclient.so
|
||||
unlink %{buildroot}%{_libdir}/libmysqlclient_r.so
|
||||
unlink %{buildroot}%{_libdir}/libmariadb.so
|
||||
@ -1166,8 +1161,8 @@ export MTR_BUILD_THREAD=%{__isa_bits}
|
||||
%endif
|
||||
|
||||
# Second run for the SPIDER suites that fail with SCA (ssl self signed certificate)
|
||||
perl ./mysql-test-run.pl --force --retry=0 \
|
||||
--suite-timeout=720 --testcase-timeout=30 \
|
||||
perl ./mysql-test-run.pl --force --retry=1 \
|
||||
--suite-timeout=60 --testcase-timeout=10 \
|
||||
--mysqld=--binlog-format=mixed --force-restart \
|
||||
--shutdown-timeout=60 --max-test-fail=0 --big-test \
|
||||
--skip-ssl --suite=spider,spider/bg \
|
||||
@ -1419,6 +1414,7 @@ fi
|
||||
%{_datadir}/%{pkg_name}/mysql_test_data_timezone.sql
|
||||
%{_datadir}/%{pkg_name}/mysql_to_mariadb.sql
|
||||
%{_datadir}/%{pkg_name}/mysql_performance_tables.sql
|
||||
%{_datadir}/%{pkg_name}/mysql_test_db.sql
|
||||
%if %{with mroonga}
|
||||
%{_datadir}/%{pkg_name}/mroonga/install.sql
|
||||
%{_datadir}/%{pkg_name}/mroonga/uninstall.sql
|
||||
@ -1429,7 +1425,6 @@ fi
|
||||
%doc %{_datadir}/groonga-normalizer-mysql/README.md
|
||||
%doc %{_datadir}/groonga/README.md
|
||||
%endif
|
||||
%{_datadir}/%{pkg_name}/my-*.cnf
|
||||
%{_datadir}/%{pkg_name}/wsrep.cnf
|
||||
%{_datadir}/%{pkg_name}/wsrep_notify
|
||||
%dir %{_datadir}/%{pkg_name}/policy
|
||||
@ -1562,10 +1557,11 @@ fi
|
||||
|
||||
%if %{with embedded}
|
||||
%files embedded
|
||||
%{_libdir}/libmysqld.so.*
|
||||
%{_libdir}/libmariadbd.so.*
|
||||
|
||||
%files embedded-devel
|
||||
%{_libdir}/libmysqld.so
|
||||
%{_libdir}/libmariadbd.so
|
||||
%endif
|
||||
|
||||
%if %{with bench}
|
||||
|
@ -97,7 +97,7 @@ if should_initialize "$datadir" ; then
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1335849#c19
|
||||
INITDB_TIMESTAMP=`LANG=C date -u`
|
||||
sleep 1
|
||||
@bindir@/mysql_install_db --rpm --datadir="$datadir" --user="$myuser" >&2
|
||||
@bindir@/mysql_install_db --rpm --datadir="$datadir" --user="$myuser" --skip-test-db >&2
|
||||
ret=$?
|
||||
if [ $ret -ne 0 ] ; then
|
||||
echo "Initialization of @NICE_PROJECT_NAME@ database failed." >&2
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (mariadb-10.2.15.tar.gz) = 7702af8787973b15784dc8a89f9d56765725a420e2e68f1924b67c88c134c7d83d3249dddd16707fa9e5f05ed747f813f16feefbb477e999a6698b1dcfb5a88f
|
||||
SHA512 (mariadb-10.3.7.tar.gz) = b1b3ad9ddc45bdfd3d03888ba160f9991b23187341deac402d5dc4b735511e29767a5dc64ca557bea9bf3d3b413b941ef2e1f5fa30be056dfaec4542a43895f1
|
||||
|
Loading…
Reference in New Issue
Block a user