Import rpm: bc80396207c22012a0d7db4349972cc8a9fef0c9
This commit is contained in:
parent
9b4fc35792
commit
64f4072b1c
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
|||||||
SOURCES/mariadb-10.3.28.tar.gz
|
SOURCES/mariadb-10.5.8.tar.gz
|
||||||
|
13
README.mysql-cnf
Normal file
13
README.mysql-cnf
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
This directory contains prepared configuration files with .cnf extension,
|
||||||
|
which provide a configuration for some common MariaDB deployment scenarios.
|
||||||
|
These configuration files do not include the default configuration of datadir,
|
||||||
|
log-file and pid-file locations, as specified in the default my.cnf file,
|
||||||
|
provided in this distribution.
|
||||||
|
|
||||||
|
Thus, it is recommended to use these configuration files as an addition to the
|
||||||
|
default my.cnf configuration file.
|
||||||
|
|
||||||
|
Since default my.cnf contains `!includedir @INSTALL_SYSCONF2DIR@` directive, it is
|
||||||
|
recommended to copy required configuration under @INSTALL_SYSCONF2DIR@ directory,
|
||||||
|
so the default my.cnf specifications will be extended.
|
||||||
|
|
29
mariadb-auth_pam_tool_dir.patch
Normal file
29
mariadb-auth_pam_tool_dir.patch
Normal file
@ -0,0 +1,29 @@
|
|||||||
|
This scirpt is ran by the systemd service.
|
||||||
|
In Fedora the service has priviledges dropped to the mysql user.
|
||||||
|
Thus "chown 0" will always fail
|
||||||
|
|
||||||
|
Never parse 'ls' output!
|
||||||
|
http://mywiki.wooledge.org/BashFAQ/087
|
||||||
|
|
||||||
|
--- mariadb-10.4.12/scripts/mysql_install_db.sh 2020-01-26 21:43:53.000000000 +0100
|
||||||
|
+++ mariadb-10.4.12/scripts/mysql_install_db.sh_patched 2020-01-29 11:11:09.448812331 +0100
|
||||||
|
@@ -482,13 +482,16 @@ if test -n "$user"
|
||||||
|
then
|
||||||
|
if test -z "$srcdir" -a "$in_rpm" -eq 0
|
||||||
|
then
|
||||||
|
- chown 0 "$pamtooldir/auth_pam_tool_dir/auth_pam_tool" && \
|
||||||
|
- chmod 04755 "$pamtooldir/auth_pam_tool_dir/auth_pam_tool"
|
||||||
|
- if test $? -ne 0
|
||||||
|
+ if [ `stat "$pamtooldir/auth_pam_tool_dir/auth_pam_tool" -c %u` -ne 0 ]
|
||||||
|
then
|
||||||
|
+ chown 0 "$pamtooldir/auth_pam_tool_dir/auth_pam_tool" && \
|
||||||
|
+ chmod 04755 "$pamtooldir/auth_pam_tool_dir/auth_pam_tool"
|
||||||
|
+ if test $? -ne 0
|
||||||
|
+ then
|
||||||
|
echo "Couldn't set an owner to '$pamtooldir/auth_pam_tool_dir/auth_pam_tool'."
|
||||||
|
echo "It must be root, the PAM authentication plugin doesn't work otherwise.."
|
||||||
|
echo
|
||||||
|
+ fi
|
||||||
|
fi
|
||||||
|
chown $user "$pamtooldir/auth_pam_tool_dir" && \
|
||||||
|
chmod 0700 "$pamtooldir/auth_pam_tool_dir"
|
@ -26,8 +26,8 @@ Update 6/2018
|
|||||||
beeing able to send the SIGHUP to the process and read the mysqld pid file, which root can.
|
beeing able to send the SIGHUP to the process and read the mysqld pid file, which root can.
|
||||||
* Submited as PR: https://github.com/MariaDB/server/pull/807
|
* Submited as PR: https://github.com/MariaDB/server/pull/807
|
||||||
|
|
||||||
--- mariadb-10.3.19/support-files/mysql-log-rotate.sh 2019-11-03 17:03:27.000000000 +0100
|
--- mariadb-10.5.4/support-files/mysql-log-rotate.sh.old 2020-09-16 13:36:57.247955135 +0200
|
||||||
+++ mariadb-10.3.19/support-files/mysql-log-rotate.sh_patched 2019-11-06 15:07:54.205379672 +0100
|
+++ mariadb-10.5.4/support-files/mysql-log-rotate.sh 2020-09-16 13:40:59.744220908 +0200
|
||||||
@@ -3,23 +3,10 @@
|
@@ -3,23 +3,10 @@
|
||||||
# in the [mysqld] section as follows:
|
# in the [mysqld] section as follows:
|
||||||
#
|
#
|
||||||
@ -58,7 +58,7 @@ Update 6/2018
|
|||||||
@@ -27,11 +14,9 @@
|
@@ -27,11 +14,9 @@
|
||||||
compress
|
compress
|
||||||
postrotate
|
postrotate
|
||||||
# just if mysqld is really running
|
# just if mariadbd is really running
|
||||||
- if test -x @bindir@/mysqladmin && \
|
- if test -x @bindir@/mysqladmin && \
|
||||||
- @bindir@/mysqladmin ping &>/dev/null
|
- @bindir@/mysqladmin ping &>/dev/null
|
||||||
- then
|
- then
|
||||||
|
@ -1,16 +1,14 @@
|
|||||||
diff -up mariadb-10.1.8/support-files/CMakeLists.txt.p9 mariadb-10.1.8/support-files/CMakeLists.txt
|
--- mariadb-10.4.14/support-files/CMakeLists.txt 2020-08-06 17:28:28.000000000 +0200
|
||||||
--- mariadb-10.2.32/support-files/CMakeLists.txt 2020-05-08 13:45:27.000000000 +0200
|
+++ mariadb-10.4.14/support-files/CMakeLists.txt_patched 2020-09-03 13:21:07.826658279 +0200
|
||||||
+++ mariadb-10.2.32/support-files/CMakeLists.txt_pacthed 2020-05-13 10:11:30.884190396 +0200
|
@@ -187,6 +187,7 @@ IF(UNIX)
|
||||||
@@ -100,7 +100,8 @@ IF(UNIX)
|
COMPONENT SharedLibraries)
|
||||||
ENDIF()
|
INSTALL(FILES rpm/mysql-clients.cnf DESTINATION ${INSTALL_SYSCONF2DIR}
|
||||||
|
COMPONENT Client)
|
||||||
CONFIGURE_FILE(mariadb.pc.in ${CMAKE_CURRENT_BINARY_DIR}/mariadb.pc @ONLY)
|
+ CONFIGURE_FILE(rpm/server.cnf ${CMAKE_CURRENT_SOURCE_DIR}/rpm/server.cnf @ONLY)
|
||||||
- INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/mariadb.pc DESTINATION ${INSTALL_LIBDIR}/pkgconfig COMPONENT Development)
|
INSTALL(FILES rpm/server.cnf DESTINATION ${INSTALL_SYSCONF2DIR}
|
||||||
+ CONFIGURE_FILE(rpm/server.cnf ${CMAKE_CURRENT_BINARY_DIR}/rpm/server.cnf @ONLY)
|
COMPONENT IniFiles)
|
||||||
+ INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/mariadb.pc DESTINATION ${INSTALL_SHAREDIR}/pkgconfig COMPONENT Development)
|
INSTALL(FILES rpm/enable_encryption.preset DESTINATION ${INSTALL_SYSCONF2DIR}
|
||||||
|
|
||||||
INSTALL(FILES mysql.m4 DESTINATION ${INSTALL_SHAREDIR}/aclocal COMPONENT Development)
|
|
||||||
|
|
||||||
diff -up mariadb-10.0.15/support-files/rpm/server.cnf.ownsetup mariadb-10.0.15/support-files/rpm/server.cnf
|
diff -up mariadb-10.0.15/support-files/rpm/server.cnf.ownsetup mariadb-10.0.15/support-files/rpm/server.cnf
|
||||||
--- mariadb-10.0.15/support-files/rpm/server.cnf.ownsetup 2015-01-24 23:55:55.110063592 +0100
|
--- mariadb-10.0.15/support-files/rpm/server.cnf.ownsetup 2015-01-24 23:55:55.110063592 +0100
|
||||||
+++ mariadb-10.0.15/support-files/rpm/server.cnf 2015-01-24 23:57:42.308114387 +0100
|
+++ mariadb-10.0.15/support-files/rpm/server.cnf 2015-01-24 23:57:42.308114387 +0100
|
||||||
|
@ -3,18 +3,17 @@ Use PCDIR CMake option, if configured
|
|||||||
Upstream install the server pkgconfig file into arch-independent directory
|
Upstream install the server pkgconfig file into arch-independent directory
|
||||||
Reported to upstream as: https://jira.mariadb.org/browse/MDEV-14340
|
Reported to upstream as: https://jira.mariadb.org/browse/MDEV-14340
|
||||||
|
|
||||||
--- mariadb-10.3.12/support-files/CMakeLists.txt 2019-03-20 15:25:53.423283135 +0100
|
--- mariadb-10.5.5/support-files/CMakeLists.txt.old 2020-09-30 10:36:08.582490318 +0200
|
||||||
+++ mariadb-10.3.12/support-files/CMakeLists.txt_patched 2019-03-20 15:38:56.372819958 +0100
|
+++ mariadb-10.5.5/support-files/CMakeLists.txt 2020-09-30 10:38:58.079710848 +0200
|
||||||
@@ -82,7 +82,12 @@ IF(UNIX)
|
@@ -91,7 +91,11 @@
|
||||||
|
ENDIF()
|
||||||
|
|
||||||
CONFIGURE_FILE(mariadb.pc.in ${CMAKE_CURRENT_BINARY_DIR}/mariadb.pc @ONLY)
|
CONFIGURE_FILE(mariadb.pc.in ${CMAKE_CURRENT_BINARY_DIR}/mariadb.pc @ONLY)
|
||||||
CONFIGURE_FILE(rpm/server.cnf ${CMAKE_CURRENT_BINARY_DIR}/rpm/server.cnf @ONLY)
|
|
||||||
+IF(INSTALL_PCDIR)
|
+IF(INSTALL_PCDIR)
|
||||||
+ INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/mariadb.pc DESTINATION ${INSTALL_PCDIR} COMPONENT Development)
|
+ INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/mariadb.pc DESTINATION ${INSTALL_PCDIR} COMPONENT Development)
|
||||||
+ELSE()
|
+ELSE()
|
||||||
INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/mariadb.pc DESTINATION ${INSTALL_SHAREDIR}/pkgconfig COMPONENT Development)
|
INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/mariadb.pc DESTINATION ${INSTALL_LIBDIR}/pkgconfig COMPONENT Development)
|
||||||
+ENDIF()
|
+ENDIF()
|
||||||
+
|
|
||||||
|
|
||||||
INSTALL(FILES mysql.m4 DESTINATION ${INSTALL_SHAREDIR}/aclocal COMPONENT Development)
|
INSTALL(FILES mysql.m4 DESTINATION ${INSTALL_SHAREDIR}/aclocal COMPONENT Development)
|
||||||
|
|
||||||
|
@ -1,11 +1,12 @@
|
|||||||
We have some downstream patches and other scripts that include variables to
|
We have some downstream patches and other scripts that include variables to
|
||||||
be expanded by cmake. Cmake needs to know about them, so adding them manually.
|
be expanded by cmake. Cmake needs to know about them, so adding them manually.
|
||||||
|
|
||||||
--- mariadb-10.3.8/scripts/CMakeLists.txt 2018-07-02 09:34:11.000000000 +0200
|
# Install libgcc as mylibgcc.a
|
||||||
+++ mariadb-10.3.8/scripts/CMakeLists.txt_patched 2018-07-03 10:58:15.954670153 +0200
|
--- mariadb-10.5.5/scripts/CMakeLists.txt.old 2020-09-24 10:13:35.272589689 +0200
|
||||||
@@ -361,6 +361,34 @@ ELSE()
|
+++ mariadb-10.5.5/scripts/CMakeLists.txt 2020-09-24 10:17:31.428985798 +0200
|
||||||
COMPONENT ${${file}_COMPONENT}
|
@@ -377,6 +377,34 @@
|
||||||
)
|
INSTALL_LINK(${file} ${binname} ${INSTALL_BINDIR} ${${file}_COMPONENT})
|
||||||
|
ENDIF()
|
||||||
ENDFOREACH()
|
ENDFOREACH()
|
||||||
+
|
+
|
||||||
+ # files for systemd
|
+ # files for systemd
|
||||||
|
1078
mariadb-spider_on_armv7hl.patch
Normal file
1078
mariadb-spider_on_armv7hl.patch
Normal file
File diff suppressed because it is too large
Load Diff
898
mariadb.spec
898
mariadb.spec
File diff suppressed because it is too large
Load Diff
@ -1,3 +1,2 @@
|
|||||||
# Fails on aarch64
|
# Fails since 10.3.17, only on armv7hl
|
||||||
innodb.innodb_buffer_pool_resize :
|
versioning.partition :
|
||||||
innodb.innodb_buffer_pool_resize_with_chunks :
|
|
||||||
|
@ -1,27 +1,54 @@
|
|||||||
# Fails everywhere
|
# The SSL test are failing correctly. Fro more explanation, see:
|
||||||
innodb.innodb_defrag_binlog :
|
# https://jira.mariadb.org/browse/MDEV-8404?focusedCommentId=84275&page=com.atlassian.jira.plugin.system.issuetabpanels%3Acomment-tabpanel#comment-84275
|
||||||
|
main.ssl_7937 : #1399847
|
||||||
|
main.ssl_8k_key :
|
||||||
|
main.ssl_crl : #1399847
|
||||||
|
|
||||||
main.ssl_7937 :
|
# ------------------------------
|
||||||
main.ssl_8k_key :
|
# Tests that fails because of 'Self Signed Certificate in the Certificate Chain'
|
||||||
main.ssl_crl :
|
perfschema.cnf_option :
|
||||||
main.ssl_system_ca :
|
|
||||||
main.userstat :
|
|
||||||
|
|
||||||
perfschema.cnf_option :
|
rpl.rpl_row_img_blobs :
|
||||||
perfschema.nesting :
|
rpl.rpl_row_img_eng_min :
|
||||||
|
rpl.rpl_row_img_eng_noblob :
|
||||||
|
|
||||||
|
sys_vars.slave_parallel_threads_basic :
|
||||||
|
|
||||||
|
# ------------------------------
|
||||||
|
# Expected to fail, the plugin is not build with server, but 'mariadb-connector-c' instead
|
||||||
|
plugins.auth_ed25519 :
|
||||||
|
plugins.multiauth :
|
||||||
|
|
||||||
|
# ------------------------------
|
||||||
|
perfschema.nesting : #1399847
|
||||||
|
perfschema.socket_summary_by_instance_func : #1399847
|
||||||
perfschema.socket_summary_by_event_name_func :
|
perfschema.socket_summary_by_event_name_func :
|
||||||
perfschema.socket_summary_by_instance_func :
|
|
||||||
|
|
||||||
plugins.feedback_plugin_load :
|
# ------------------------------
|
||||||
|
# Fails since 10.1.12
|
||||||
|
innodb.innodb_defrag_binlog :
|
||||||
|
|
||||||
rpl.rpl_row_img_blobs :
|
# Fails everywhere since 10.2.15
|
||||||
rpl.rpl_row_img_eng_min :
|
main.userstat :
|
||||||
rpl.rpl_row_img_eng_noblob :
|
|
||||||
|
|
||||||
sys_vars.slave_parallel_threads_basic :
|
# Fails everywhere since 10.4.11
|
||||||
|
main.events_bugs :
|
||||||
|
sys_vars.tcp_nodelay :
|
||||||
|
|
||||||
# Fails only on i686
|
# Fails on i686
|
||||||
main.myisampack :
|
encryption.innodb-redo-badkey :
|
||||||
|
|
||||||
# We don't build the plugin in server; we build it in mariadb-connector-c instead
|
# Fails since 10.5.2
|
||||||
plugins.auth_ed25519 :
|
main.mysqld--help2 :
|
||||||
|
disks.disks :
|
||||||
|
disks.disks_notembedded :
|
||||||
|
|
||||||
|
# Fails since 10.5.3
|
||||||
|
main.mysqld--help-aria :
|
||||||
|
|
||||||
|
# Fails since 10.5.4
|
||||||
|
main.ssl_system_ca :
|
||||||
|
|
||||||
|
# Fails since 10.5.7
|
||||||
|
innodb.innodb_wl6326_big :
|
||||||
|
plugins.feedback_plugin_load :
|
||||||
|
@ -1,30 +1,5 @@
|
|||||||
# Fails on ppc64le
|
# Fails on ppc64le since 10.4.12
|
||||||
parts.partition_alter1_1_innodb :
|
oqgraph.social :
|
||||||
parts.partition_alter1_2_innodb :
|
|
||||||
parts.partition_alter1_1_2_innodb :
|
|
||||||
parts.partition_alter1_2_1_innodb :
|
|
||||||
parts.partition_alter2_1_1_innodb :
|
|
||||||
parts.partition_alter1_2_2_innodb :
|
|
||||||
parts.partition_alter2_1_2_innodb :
|
|
||||||
parts.partition_alter2_2_1_innodb :
|
|
||||||
parts.partition_alter2_2_2_innodb :
|
|
||||||
parts.partition_alter4_innodb :
|
|
||||||
parts.partition_basic_innodb :
|
|
||||||
parts.part_supported_sql_func_innodb :
|
|
||||||
|
|
||||||
rpl.rpl_loaddata_m :
|
# Fails since 10.5.2
|
||||||
|
rh-skipped-tests-ppc.list :
|
||||||
#
|
|
||||||
stress.ddl_innodb :
|
|
||||||
|
|
||||||
innodb.innodb_buffer_pool_resize :
|
|
||||||
innodb.innodb_buffer_pool_resize_with_chunks :
|
|
||||||
innodb.innodb_bulk_create_index :
|
|
||||||
innodb.innodb_defrag_binlog :
|
|
||||||
innodb.innodb_defrag_concurrent :
|
|
||||||
innodb_gis.kill_server :
|
|
||||||
gcol.innodb_virtual_basic :
|
|
||||||
|
|
||||||
# Unstable (randomly failing) tests
|
|
||||||
innodb_gis.rtree_search :
|
|
||||||
main.type_ranges :
|
|
||||||
|
@ -1,3 +1,3 @@
|
|||||||
# Fails on s390x
|
# Fails since 10.5.2
|
||||||
disks.disks :
|
perfschema.memory_aggregate_32bit :
|
||||||
disks.disks_notembedded :
|
period.overlaps :
|
||||||
|
Loading…
Reference in New Issue
Block a user