Rebase to 5.5.29

Fix inaccurate default for socket location in mysqld-wait-ready
Resolves: #890535
This commit is contained in:
Honza Horák 2013-02-01 11:35:51 +01:00
parent 1e074eeb80
commit 5cefe26150
6 changed files with 23 additions and 16 deletions

1
.gitignore vendored
View File

@ -1 +1,2 @@
/mariadb-5.5.28a.tar.gz
/mariadb-5.5.29.tar.gz

View File

@ -4,14 +4,14 @@ forgotten the issue entirely. So we now maintain our own list of exported
symbols and jam it into the build with this hack.
diff -up mysql-5.5.28/libmysql/CMakeLists.txt.p7 mysql-5.5.28/libmysql/CMakeLists.txt
--- mysql-5.5.28/libmysql/CMakeLists.txt.p7 2012-08-29 10:50:46.000000000 +0200
+++ mysql-5.5.28/libmysql/CMakeLists.txt 2012-12-06 14:15:03.905461517 +0100
@@ -209,7 +209,7 @@ IF(NOT DISABLE_SHARED)
diff -up mariadb-5.5.29/libmysql/CMakeLists.txt.p5 mariadb-5.5.29/libmysql/CMakeLists.txt
--- mariadb-5.5.29/libmysql/CMakeLists.txt.p5 2013-01-29 15:12:46.000000000 +0100
+++ mariadb-5.5.29/libmysql/CMakeLists.txt 2013-02-01 10:44:28.449544405 +0100
@@ -363,7 +363,7 @@ IF(NOT DISABLE_SHARED)
SET(libmysql_link_flags)
ENDIF()
SET_TARGET_PROPERTIES(libmysql PROPERTIES LINK_FLAGS
- "${libmysql_link_flags} ${LINK_FLAG_NO_UNDEFINED}")
- "${libmysql_link_flags} ${LINK_FLAG_NO_UNDEFINED} ${VERSION_SCRIPT_LINK_FLAGS}")
+ "${libmysql_link_flags} -Wl,--version-script=libmysql.version ${LINK_FLAG_NO_UNDEFINED}")
ENDIF()
# clean direct output needs to be set several targets have the same name

View File

@ -1,6 +1,6 @@
Name: mariadb
Version: 5.5.28a
Release: 8%{?dist}
Version: 5.5.29
Release: 1%{?dist}
Summary: A community developed branch of MySQL
Group: Applications/Databases
@ -83,9 +83,8 @@ Obsoletes: mysql-cluster < 5.1.44
%global __perl_requires %{SOURCE999}
%global __perllib_requires %{SOURCE999}
# patch utility does automatically back-up of chunks that didn't apply
# smoothly, but we don't want to create that files because they could be
# included in RPM incorrectly
# By default, patch(1) creates backup files when chunks apply with offsets.
# Turn that off to ensure such files don't get included in RPMs (cf bz#884755).
%global _default_patch_flags --no-backup-if-mismatch
%description
@ -709,6 +708,7 @@ fi
%{_datadir}/mysql/mysql_system_tables.sql
%{_datadir}/mysql/mysql_system_tables_data.sql
%{_datadir}/mysql/mysql_test_data_timezone.sql
%{_datadir}/mysql/mysql_performance_tables.sql
%{_datadir}/mysql/my-*.cnf
%{_datadir}/mysql/config.*.ini
@ -751,6 +751,12 @@ fi
%{_mandir}/man1/mysql_client_test.1*
%changelog
* Thu Jan 31 2013 Honza Horak <hhorak@redhat.com> 5.5.29-1
- Rebase to 5.5.29
https://kb.askmonty.org/en/mariadb-5529-changelog/
- Fix inaccurate default for socket location in mysqld-wait-ready
Resolves: #890535
* Thu Jan 31 2013 Honza Horak <hhorak@redhat.com> 5.5.28a-8
- Enable obsoleting mysql

8
my.cnf
View File

@ -1,12 +1,12 @@
[mysqld]
# Settings user and group are ignored when systemd is used.
# If you need to run mysqld under different user or group,
# customize your systemd unit file for mysqld according to the
# instructions in http://fedoraproject.org/wiki/Systemd
datadir=/var/lib/mysql
socket=/var/lib/mysql/mysql.sock
# Disabling symbolic-links is recommended to prevent assorted security risks
symbolic-links=0
# Settings user and group are ignored when systemd is used.
# If you need to run mysqld under a different user or group,
# customize your systemd unit file for mysqld according to the
# instructions in http://fedoraproject.org/wiki/Systemd
[mysqld_safe]
log-error=/var/log/mysqld.log

View File

@ -25,7 +25,7 @@ get_mysql_option(){
# Defaults here had better match what mysqld_safe will default to
get_mysql_option mysqld datadir "/var/lib/mysql"
datadir="$result"
get_mysql_option mysqld socket "$datadir/mysql.sock"
get_mysql_option mysqld socket "/var/lib/mysql/mysql.sock"
socketfile="$result"
# Wait for the server to come up or for the mysqld process to disappear

View File

@ -1 +1 @@
a2d20a040ef1e49944a4ffe65ed7fefa mariadb-5.5.28a.tar.gz
643cca7f07f7b00ca3ae1515e6f245d6 mariadb-5.5.29.tar.gz