import mariadb-10.3.17-1.module+el8.1.0+3974+90eded84
This commit is contained in:
parent
d832852395
commit
540d392171
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
|||||||
SOURCES/mariadb-10.3.11.tar.gz
|
SOURCES/mariadb-10.3.17.tar.gz
|
||||||
|
@ -1 +1 @@
|
|||||||
7b75d7ec06642f26ce197e07f5ba16283061cc87 SOURCES/mariadb-10.3.11.tar.gz
|
16edbd4762c8804118dda10de713cbddc675df5a SOURCES/mariadb-10.3.17.tar.gz
|
||||||
|
@ -17,23 +17,3 @@ Error: SHELLCHECK_WARNING:
|
|||||||
echo "Fatal error Can't create database directory '$dir'"
|
echo "Fatal error Can't create database directory '$dir'"
|
||||||
link_to_help
|
link_to_help
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
Error: SHELLCHECK_WARNING:
|
|
||||||
/usr/bin/mysqld_safe:716:8: warning: Remove backticks to avoid executing output. [SC2092]
|
|
||||||
# 714| if [ ! -d $mysql_unix_port_dir ]
|
|
||||||
# 715| then
|
|
||||||
# 716|-> if ! `mkdir -p $mysql_unix_port_dir`
|
|
||||||
# 717| then
|
|
||||||
# 718| log_error "Fatal error Can't create database directory '$mysql_unix_port'"
|
|
||||||
--- mariadb-10.3.10/scripts/mysqld_safe.sh 2018-10-02 11:45:42.000000000 +0200
|
|
||||||
+++ mariadb-10.3.10/scripts/mysqld_safe.sh_patched 2018-11-14 10:10:45.325464636 +0100
|
|
||||||
@@ -713,7 +713,7 @@ safe_mysql_unix_port=${mysql_unix_port:-
|
|
||||||
mysql_unix_port_dir=`dirname $safe_mysql_unix_port`
|
|
||||||
if [ ! -d $mysql_unix_port_dir ]
|
|
||||||
then
|
|
||||||
- if ! `mkdir -p $mysql_unix_port_dir`
|
|
||||||
+ if ! mkdir -p $mysql_unix_port_dir
|
|
||||||
then
|
|
||||||
log_error "Fatal error Can't create database directory '$mysql_unix_port'"
|
|
||||||
exit 1
|
|
||||||
|
20
SOURCES/mariadb-pcdir.patch
Normal file
20
SOURCES/mariadb-pcdir.patch
Normal file
@ -0,0 +1,20 @@
|
|||||||
|
Use PCDIR CMake option, if configured
|
||||||
|
|
||||||
|
Upstream install the server pkgconfig file into arch-independent directory
|
||||||
|
Reported to upstream as: https://jira.mariadb.org/browse/MDEV-14340
|
||||||
|
|
||||||
|
--- mariadb-10.3.12/support-files/CMakeLists.txt 2019-03-20 15:25:53.423283135 +0100
|
||||||
|
+++ mariadb-10.3.12/support-files/CMakeLists.txt_patched 2019-03-20 15:38:56.372819958 +0100
|
||||||
|
@@ -82,7 +82,12 @@ IF(UNIX)
|
||||||
|
|
||||||
|
CONFIGURE_FILE(mariadb.pc.in ${CMAKE_CURRENT_BINARY_DIR}/mariadb.pc @ONLY)
|
||||||
|
CONFIGURE_FILE(rpm/server.cnf ${CMAKE_CURRENT_BINARY_DIR}/rpm/server.cnf @ONLY)
|
||||||
|
+IF(INSTALL_PCDIR)
|
||||||
|
+ INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/mariadb.pc DESTINATION ${INSTALL_PCDIR} COMPONENT Development)
|
||||||
|
+ELSE()
|
||||||
|
INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/mariadb.pc DESTINATION ${INSTALL_SHAREDIR}/pkgconfig COMPONENT Development)
|
||||||
|
+ENDIF()
|
||||||
|
+
|
||||||
|
|
||||||
|
INSTALL(FILES mysql.m4 DESTINATION ${INSTALL_SHAREDIR}/aclocal COMPONENT Development)
|
||||||
|
|
@ -1,15 +0,0 @@
|
|||||||
*** WARNING: mangling shebang in /usr/bin/myrocks_hotbackup from #!/usr/bin/env python to #!/usr/bin/python2. This will become an ERROR, fix it manually!
|
|
||||||
|
|
||||||
Maintainer's note:
|
|
||||||
This script is not python3 compatible:
|
|
||||||
ModuleNotFoundError: No module named 'commands'
|
|
||||||
|
|
||||||
diff -Naurp mariadb-10.3.10/storage/rocksdb/myrocks_hotbackup mariadb-10.3.10/storage/rocksdb/myrocks_hotbackup_patched
|
|
||||||
--- mariadb-10.3.10/storage/rocksdb/myrocks_hotbackup 2018-10-02 11:45:43.000000000 +0200
|
|
||||||
+++ mariadb-10.3.10/storage/rocksdb/myrocks_hotbackup_patched 2018-10-05 14:27:02.960060700 +0200
|
|
||||||
@@ -1,4 +1,4 @@
|
|
||||||
-#!/usr/bin/env python
|
|
||||||
+#!/usr/bin/python2
|
|
||||||
|
|
||||||
from __future__ import division
|
|
||||||
from optparse import OptionParser
|
|
@ -1,12 +1,9 @@
|
|||||||
# Fails on aarch64
|
# Fails on aarch64
|
||||||
encryption.create_or_replace :
|
encryption.create_or_replace :
|
||||||
encryption.innodb-redo-badkey :
|
innodb_gis.rtree_compress2 :
|
||||||
encryption.innochecksum :
|
innodb.innodb_buffer_pool_resize :
|
||||||
innodb_gis.kill_server :
|
innodb.innodb_defrag_concurrent :
|
||||||
innodb_gis.rtree_compress2 :
|
|
||||||
innodb_gis.rtree_search :
|
|
||||||
innodb_zip.wl6347_comp_indx_stat :
|
|
||||||
innodb.innodb_defrag_concurrent :
|
|
||||||
parts.partition_alter1_1_innodb :
|
parts.partition_alter1_1_innodb :
|
||||||
parts.partition_alter1_2_innodb :
|
parts.partition_alter1_2_innodb :
|
||||||
parts.partition_alter1_1_2_innodb :
|
parts.partition_alter1_1_2_innodb :
|
||||||
@ -19,3 +16,6 @@ parts.partition_alter2_2_2_innodb :
|
|||||||
parts.partition_alter4_innodb :
|
parts.partition_alter4_innodb :
|
||||||
parts.partition_basic_innodb :
|
parts.partition_basic_innodb :
|
||||||
parts.part_supported_sql_func_innodb :
|
parts.part_supported_sql_func_innodb :
|
||||||
|
|
||||||
|
# Check of testcase failed:
|
||||||
|
sys_vars.innodb_buffer_pool_size_basic :
|
@ -1,21 +1,27 @@
|
|||||||
# Fails everywhere
|
# Fails everywhere
|
||||||
innodb.innodb_defrag_binlog :
|
innodb.innodb_defrag_binlog :
|
||||||
main.openssl_1 :
|
main.mysql :
|
||||||
main.openssl_6975 :
|
main.ssl_7937 :
|
||||||
main.ssl :
|
main.ssl_8k_key :
|
||||||
main.ssl_cert_verify :
|
main.ssl_crl :
|
||||||
main.ssl_cipher :
|
main.userstat :
|
||||||
main.ssl_crl_clients :
|
perfschema.cnf_option :
|
||||||
main.ssl_7937 :
|
perfschema.nesting :
|
||||||
main.ssl_8k_key :
|
perfschema.socket_summary_by_event_name_func :
|
||||||
main.userstat :
|
perfschema.socket_summary_by_instance_func :
|
||||||
perfschema.cnf_option :
|
rpl.rpl_row_img_blobs :
|
||||||
perfschema.nesting :
|
rpl.rpl_row_img_eng_min :
|
||||||
perfschema.socket_summary_by_event_name_func :
|
rpl.rpl_row_img_eng_noblob :
|
||||||
perfschema.socket_summary_by_instance_func :
|
sys_vars.slave_parallel_threads_basic :
|
||||||
rpl.rpl_row_img_blobs :
|
unit.conc_ps_bugs :
|
||||||
rpl.rpl_row_img_eng_min :
|
versioning.update-big :
|
||||||
rpl.rpl_row_img_eng_noblob :
|
# Fails only on i686
|
||||||
sys_vars.slave_parallel_threads_basic :
|
|
||||||
# Fails on i686
|
|
||||||
main.myisampack :
|
main.myisampack :
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
|
@ -1,30 +1,21 @@
|
|||||||
# Fails on ppc64le
|
# Fails on ppc64le
|
||||||
binlog_encryption.rpl_semi_sync :
|
encryption.create_or_replace :
|
||||||
encryption.create_or_replace :
|
innodb_gis.rtree_compress2 :
|
||||||
innodb_gis.kill_server :
|
innodb.innodb_buffer_pool_resize :
|
||||||
innodb_gis.rtree_compress2 :
|
innodb.innodb_defrag_concurrent :
|
||||||
innodb.innodb_defrag_concurrent :
|
|
||||||
innodb.temporary_table_optimization :
|
parts.partition_alter1_1_innodb :
|
||||||
main.derived_cond_pushdown :
|
|
||||||
main.ps :
|
|
||||||
main.select :
|
|
||||||
main.select_jcl6 :
|
|
||||||
main.select_pkeycache :
|
|
||||||
main.sp :
|
|
||||||
main.type_float :
|
|
||||||
main.type_newdecimal :
|
|
||||||
main.type_ranges :
|
|
||||||
parts.partition_alter1_1_innodb :
|
|
||||||
parts.partition_alter1_2_innodb :
|
parts.partition_alter1_2_innodb :
|
||||||
parts.partition_alter2_1_innodb :
|
parts.partition_alter1_1_2_innodb :
|
||||||
parts.partition_alter2_2_innodb :
|
parts.partition_alter1_2_1_innodb :
|
||||||
parts.partition_alter1_1_2_innodb :
|
|
||||||
parts.partition_alter1_2_1_innodb :
|
|
||||||
parts.partition_alter2_1_1_innodb :
|
parts.partition_alter2_1_1_innodb :
|
||||||
parts.partition_alter1_2_2_innodb :
|
parts.partition_alter1_2_2_innodb :
|
||||||
parts.partition_alter2_1_2_innodb :
|
parts.partition_alter2_1_2_innodb :
|
||||||
parts.partition_alter2_2_1_innodb :
|
parts.partition_alter2_2_1_innodb :
|
||||||
parts.partition_alter2_2_2_innodb :
|
parts.partition_alter2_2_2_innodb :
|
||||||
parts.partition_alter4_innodb :
|
parts.partition_alter4_innodb :
|
||||||
parts.partition_basic_innodb :
|
parts.partition_basic_innodb :
|
||||||
parts.part_supported_sql_func_innodb :
|
parts.part_supported_sql_func_innodb :
|
||||||
|
|
||||||
|
# Check of testcase failed:
|
||||||
|
sys_vars.innodb_buffer_pool_size_basic :
|
@ -1,6 +1,2 @@
|
|||||||
# Fails on s390x
|
# Fails on s390x
|
||||||
binlog.binlog_flush_binlogs_delete_domain :
|
handler.heap :
|
||||||
handler.heap :
|
|
||||||
handler.interface :
|
|
||||||
innodb_fts.innodb_fts_misc :
|
|
||||||
rpl.rpl_gtid_delete_domain :
|
|
||||||
|
@ -1,114 +0,0 @@
|
|||||||
Patch for https://bugzilla.redhat.com/show_bug.cgi?id=1686818
|
|
||||||
Picked from https://github.com/MariaDB/server/commit/802ce9672f
|
|
||||||
|
|
||||||
Fixed by rebase to 10.3.12
|
|
||||||
|
|
||||||
--- mariadb-10.3.11/storage/innobase/handler/handler0alter.cc 2018-11-16 19:04:53.000000000 +0100
|
|
||||||
+++ mariadb-10.3.11/storage/innobase/handler/handler0alter.cc_patched 2019-03-13 11:52:15.752268825 +0100
|
|
||||||
@@ -7712,36 +7712,40 @@ err_exit:
|
|
||||||
index != NULL;
|
|
||||||
index = dict_table_get_next_index(index)) {
|
|
||||||
|
|
||||||
+ bool has_prefixes = false;
|
|
||||||
+ for (size_t i = 0; i < dict_index_get_n_fields(index); i++) {
|
|
||||||
+ if (dict_index_get_nth_field(index, i)->prefix_len) {
|
|
||||||
+ has_prefixes = true;
|
|
||||||
+ break;
|
|
||||||
+ }
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
for (ulint i = 0; i < dict_index_get_n_fields(index); i++) {
|
|
||||||
- if (my_strcasecmp(
|
|
||||||
- system_charset_info,
|
|
||||||
- dict_index_get_nth_field(index, i)->name,
|
|
||||||
- from)) {
|
|
||||||
+ const dict_field_t* field
|
|
||||||
+ = dict_index_get_nth_field(index, i);
|
|
||||||
+ if (my_strcasecmp(system_charset_info, field->name,
|
|
||||||
+ from)) {
|
|
||||||
continue;
|
|
||||||
}
|
|
||||||
|
|
||||||
info = pars_info_create();
|
|
||||||
|
|
||||||
+ int pos = i;
|
|
||||||
+ if (has_prefixes) {
|
|
||||||
+ pos = (pos << 16) + field->prefix_len;
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
pars_info_add_ull_literal(info, "indexid", index->id);
|
|
||||||
- pars_info_add_int4_literal(info, "nth", i);
|
|
||||||
+ pars_info_add_int4_literal(info, "nth", pos);
|
|
||||||
pars_info_add_str_literal(info, "new", to);
|
|
||||||
|
|
||||||
error = que_eval_sql(
|
|
||||||
info,
|
|
||||||
"PROCEDURE RENAME_SYS_FIELDS_PROC () IS\n"
|
|
||||||
"BEGIN\n"
|
|
||||||
-
|
|
||||||
"UPDATE SYS_FIELDS SET COL_NAME=:new\n"
|
|
||||||
"WHERE INDEX_ID=:indexid\n"
|
|
||||||
"AND POS=:nth;\n"
|
|
||||||
-
|
|
||||||
- /* Try again, in case there is a prefix_len
|
|
||||||
- encoded in SYS_FIELDS.POS */
|
|
||||||
-
|
|
||||||
- "UPDATE SYS_FIELDS SET COL_NAME=:new\n"
|
|
||||||
- "WHERE INDEX_ID=:indexid\n"
|
|
||||||
- "AND POS>=65536*:nth AND POS<65536*(:nth+1);\n"
|
|
||||||
-
|
|
||||||
"END;\n",
|
|
||||||
FALSE, trx);
|
|
||||||
|
|
||||||
--- mariadb-10.3.11/mysql-test/suite/innodb/r/innodb-alter.result 2018-11-16 19:04:50.000000000 +0100
|
|
||||||
+++ mariadb-10.3.11/mysql-test/suite/innodb/r/innodb-alter.result_patched 2019-03-13 12:06:48.788107502 +0100
|
|
||||||
@@ -879,6 +879,27 @@ NAME
|
|
||||||
a
|
|
||||||
b
|
|
||||||
DROP TABLE t1;
|
|
||||||
+# and an MDEV-18041 regression related to indexes prefixes
|
|
||||||
+create table `test` (
|
|
||||||
+`test_old` varchar(255) NOT NULL,
|
|
||||||
+`other` varchar(255) NOT NULL,
|
|
||||||
+PRIMARY KEY (`test_old`,`other`),
|
|
||||||
+UNIQUE KEY uk (`test_old`(100), `other`)
|
|
||||||
+) ENGINE=InnoDB;
|
|
||||||
+select name, pos from information_schema.innodb_SYS_FIELDS where name in ('test_old', 'other', 'test_new');
|
|
||||||
+name pos
|
|
||||||
+test_old 0
|
|
||||||
+other 1
|
|
||||||
+test_old 0
|
|
||||||
+other 1
|
|
||||||
+alter table `test` CHANGE COLUMN `test_old` `test_new` varchar(255) NOT NULL;
|
|
||||||
+select name, pos from information_schema.innodb_SYS_FIELDS where name in ('test_old', 'other', 'test_new');
|
|
||||||
+name pos
|
|
||||||
+test_new 0
|
|
||||||
+other 1
|
|
||||||
+test_new 0
|
|
||||||
+other 1
|
|
||||||
+drop table `test`;
|
|
||||||
#
|
|
||||||
# BUG 20029625 - HANDLE_FATAL_SIGNAL (SIG=11) IN
|
|
||||||
# DICT_MEM_TABLE_COL_RENAME_LOW
|
|
||||||
--- mariadb-10.3.11/mysql-test/suite/innodb/t/innodb-alter.test 2018-11-16 19:04:50.000000000 +0100
|
|
||||||
+++ mariadb-10.3.11/mysql-test/suite/innodb/t/innodb-alter.test_patched 2019-03-13 12:08:36.398847184 +0100
|
|
||||||
@@ -545,6 +545,19 @@ SELECT C.NAME FROM INFORMATION_SCHEMA.IN
|
|
||||||
WHERE T.NAME='test/t1';
|
|
||||||
DROP TABLE t1;
|
|
||||||
|
|
||||||
+--echo # and an MDEV-18041 regression related to indexes prefixes
|
|
||||||
+create table `test` (
|
|
||||||
+ `test_old` varchar(255) NOT NULL,
|
|
||||||
+ `other` varchar(255) NOT NULL,
|
|
||||||
+ PRIMARY KEY (`test_old`,`other`),
|
|
||||||
+ UNIQUE KEY uk (`test_old`(100), `other`)
|
|
||||||
+) ENGINE=InnoDB;
|
|
||||||
+
|
|
||||||
+select name, pos from information_schema.innodb_SYS_FIELDS where name in ('test_old', 'other', 'test_new');
|
|
||||||
+alter table `test` CHANGE COLUMN `test_old` `test_new` varchar(255) NOT NULL;
|
|
||||||
+select name, pos from information_schema.innodb_SYS_FIELDS where name in ('test_old', 'other', 'test_new');
|
|
||||||
+drop table `test`;
|
|
||||||
+
|
|
||||||
|
|
||||||
--echo #
|
|
||||||
--echo # BUG 20029625 - HANDLE_FATAL_SIGNAL (SIG=11) IN
|
|
@ -62,7 +62,7 @@
|
|||||||
%bcond_without gssapi
|
%bcond_without gssapi
|
||||||
|
|
||||||
# For some use cases we do not need some parts of the package. Set to "...with" to exclude
|
# For some use cases we do not need some parts of the package. Set to "...with" to exclude
|
||||||
%if 0%{?fedora} >= 28 || 0%{?rhel} > 7
|
%if 0%{?fedora} || 0%{?rhel} > 7
|
||||||
%bcond_with clibrary
|
%bcond_with clibrary
|
||||||
%else
|
%else
|
||||||
%bcond_without clibrary
|
%bcond_without clibrary
|
||||||
@ -106,7 +106,7 @@
|
|||||||
%bcond_without unbundled_pcre
|
%bcond_without unbundled_pcre
|
||||||
%else
|
%else
|
||||||
%bcond_with unbundled_pcre
|
%bcond_with unbundled_pcre
|
||||||
%global pcre_bundled_version 8.42
|
%global pcre_bundled_version 8.43
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
# Include systemd files
|
# Include systemd files
|
||||||
@ -148,14 +148,14 @@
|
|||||||
%global sameevr %{epoch}:%{version}-%{release}
|
%global sameevr %{epoch}:%{version}-%{release}
|
||||||
|
|
||||||
Name: mariadb
|
Name: mariadb
|
||||||
Version: 10.3.11
|
Version: 10.3.17
|
||||||
Release: 2%{?with_debug:.debug}%{?dist}
|
Release: 1%{?with_debug:.debug}%{?dist}
|
||||||
Epoch: 3
|
Epoch: 3
|
||||||
|
|
||||||
Summary: A very fast and robust SQL database server
|
Summary: A very fast and robust SQL database server
|
||||||
URL: http://mariadb.org
|
URL: http://mariadb.org
|
||||||
# Exceptions allow client libraries to be linked with most open source SW, not only GPL code. See README.mysql-license
|
# Exceptions allow client libraries to be linked with most open source SW, not only GPL code. See README.mysql-license
|
||||||
License: GPLv2 with exceptions and LGPLv2 and BSD.
|
License: GPLv2 with exceptions and LGPLv2 and BSD
|
||||||
|
|
||||||
Source0: https://downloads.mariadb.org/interstitial/mariadb-%{version}/source/mariadb-%{version}.tar.gz
|
Source0: https://downloads.mariadb.org/interstitial/mariadb-%{version}/source/mariadb-%{version}.tar.gz
|
||||||
Source2: mysql_config_multilib.sh
|
Source2: mysql_config_multilib.sh
|
||||||
@ -185,10 +185,6 @@ Source72: mariadb-server-galera.te
|
|||||||
# https://github.com/dciabrin/wsrep_sst_rsync_tunnel/blob/master/wsrep_sst_rsync_tunnel
|
# https://github.com/dciabrin/wsrep_sst_rsync_tunnel/blob/master/wsrep_sst_rsync_tunnel
|
||||||
Source73: wsrep_sst_rsync_tunnel
|
Source73: wsrep_sst_rsync_tunnel
|
||||||
|
|
||||||
# Patch1: Fix python shebang to specificaly say the python version
|
|
||||||
Patch1: %{pkgnamepatch}-shebang.patch
|
|
||||||
# Patch2: rhbz#1686818
|
|
||||||
Patch2: rhbz_1686818.patch
|
|
||||||
# Patch4: Red Hat distributions specific logrotate fix
|
# Patch4: Red Hat distributions specific logrotate fix
|
||||||
# it would be big unexpected change, if we start shipping it now. Better wait for MariaDB 10.2
|
# it would be big unexpected change, if we start shipping it now. Better wait for MariaDB 10.2
|
||||||
Patch4: %{pkgnamepatch}-logrotate.patch
|
Patch4: %{pkgnamepatch}-logrotate.patch
|
||||||
@ -200,6 +196,8 @@ Patch9: %{pkgnamepatch}-ownsetup.patch
|
|||||||
Patch10: %{pkgnamepatch}-annocheck.patch
|
Patch10: %{pkgnamepatch}-annocheck.patch
|
||||||
# Patch11: Fix issues found by static analysis
|
# Patch11: Fix issues found by static analysis
|
||||||
Patch11: %{pkgnamepatch}-covscan.patch
|
Patch11: %{pkgnamepatch}-covscan.patch
|
||||||
|
# Patch12: Downstream fix for a correct pkgconfig file location
|
||||||
|
Patch12: %{pkgnamepatch}-pcdir.patch
|
||||||
|
|
||||||
BuildRequires: cmake gcc-c++
|
BuildRequires: cmake gcc-c++
|
||||||
BuildRequires: multilib-rpm-config
|
BuildRequires: multilib-rpm-config
|
||||||
@ -695,13 +693,12 @@ sources.
|
|||||||
# Remove JAR files that upstream puts into tarball
|
# Remove JAR files that upstream puts into tarball
|
||||||
find . -name "*.jar" -type f -exec rm --verbose -f {} \;
|
find . -name "*.jar" -type f -exec rm --verbose -f {} \;
|
||||||
|
|
||||||
%patch1 -p1
|
|
||||||
%patch2 -p1
|
|
||||||
%patch4 -p1
|
%patch4 -p1
|
||||||
%patch7 -p1
|
%patch7 -p1
|
||||||
%patch9 -p1
|
%patch9 -p1
|
||||||
%patch10 -p1
|
%patch10 -p1
|
||||||
%patch11 -p1
|
%patch11 -p1
|
||||||
|
%patch12 -p1
|
||||||
|
|
||||||
# workaround for upstream bug #56342
|
# workaround for upstream bug #56342
|
||||||
#rm mysql-test/t/ssl_8k_key-master.opt
|
#rm mysql-test/t/ssl_8k_key-master.opt
|
||||||
@ -763,6 +760,7 @@ rm -r storage/tokudb/mysql-test/tokudb/t/*.py
|
|||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
%{set_build_flags}
|
||||||
|
|
||||||
# fail quickly and obviously if user tries to build as root
|
# fail quickly and obviously if user tries to build as root
|
||||||
%if %runselftest
|
%if %runselftest
|
||||||
@ -774,15 +772,13 @@ rm -r storage/tokudb/mysql-test/tokudb/t/*.py
|
|||||||
fi
|
fi
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
CFLAGS="%{optflags} -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE"
|
CFLAGS="$CFLAGS -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE"
|
||||||
# force PIC mode so that we can build libmysqld.so
|
|
||||||
CFLAGS="$CFLAGS -fPIC"
|
|
||||||
# Override all optimization flags when making a debug build
|
# Override all optimization flags when making a debug build
|
||||||
%{?with_debug: CFLAGS="$CFLAGS -O0 -g"}
|
%{?with_debug: CFLAGS="$CFLAGS -O0 -g"}
|
||||||
|
|
||||||
CXXFLAGS="$CFLAGS"
|
CXXFLAGS="$CFLAGS"
|
||||||
export CFLAGS CXXFLAGS
|
CPPFLAGS="$CFLAGS"
|
||||||
|
export CFLAGS CXXFLAGS CPPFLAGS
|
||||||
|
|
||||||
# The INSTALL_xxx macros have to be specified relative to CMAKE_INSTALL_PREFIX
|
# The INSTALL_xxx macros have to be specified relative to CMAKE_INSTALL_PREFIX
|
||||||
# so we can't use %%{_datadir} and so forth here.
|
# so we can't use %%{_datadir} and so forth here.
|
||||||
@ -812,6 +808,7 @@ export CFLAGS CXXFLAGS
|
|||||||
-DINSTALL_SCRIPTDIR=bin \
|
-DINSTALL_SCRIPTDIR=bin \
|
||||||
-DINSTALL_SQLBENCHDIR=share \
|
-DINSTALL_SQLBENCHDIR=share \
|
||||||
-DINSTALL_SUPPORTFILESDIR=share/%{pkg_name} \
|
-DINSTALL_SUPPORTFILESDIR=share/%{pkg_name} \
|
||||||
|
-DINSTALL_PCDIR=%{_lib}/pkgconfig \
|
||||||
-DMYSQL_DATADIR="%{dbdatadir}" \
|
-DMYSQL_DATADIR="%{dbdatadir}" \
|
||||||
-DMYSQL_UNIX_ADDR="/var/lib/mysql/mysql.sock" \
|
-DMYSQL_UNIX_ADDR="/var/lib/mysql/mysql.sock" \
|
||||||
-DTMPDIR=/var/tmp \
|
-DTMPDIR=/var/tmp \
|
||||||
@ -826,9 +823,11 @@ export CFLAGS CXXFLAGS
|
|||||||
-DCONC_WITH_SSL=%{?with_clibrary:ON}%{!?with_clibrary:NO} \
|
-DCONC_WITH_SSL=%{?with_clibrary:ON}%{!?with_clibrary:NO} \
|
||||||
-DWITH_SSL=system \
|
-DWITH_SSL=system \
|
||||||
-DWITH_ZLIB=system \
|
-DWITH_ZLIB=system \
|
||||||
-DWITH_JEMALLOC=%{?with_tokudb:YES}%{!?with_tokudb:NO} \
|
-DWITH_JEMALLOC=%{?with_tokudb:yes}%{!?with_tokudb:no} \
|
||||||
-DLZ4_LIBS=%{_libdir}/liblz4.so \
|
-DLZ4_LIBS=%{_libdir}/liblz4.so \
|
||||||
|
-DLZ4_LIBS=%{?with_lz4:%{_libdir}/liblz4.so}%{!?with_lz4:} \
|
||||||
-DWITH_INNODB_LZ4=%{?with_lz4:ON}%{!?with_lz4:OFF} \
|
-DWITH_INNODB_LZ4=%{?with_lz4:ON}%{!?with_lz4:OFF} \
|
||||||
|
-DWITH_ROCKSDB_LZ4=%{?with_lz4:ON}%{!?with_lz4:OFF} \
|
||||||
-DPLUGIN_MROONGA=%{?with_mroonga:DYNAMIC}%{!?with_mroonga:NO} \
|
-DPLUGIN_MROONGA=%{?with_mroonga:DYNAMIC}%{!?with_mroonga:NO} \
|
||||||
-DPLUGIN_OQGRAPH=%{?with_oqgraph:DYNAMIC}%{!?with_oqgraph:NO} \
|
-DPLUGIN_OQGRAPH=%{?with_oqgraph:DYNAMIC}%{!?with_oqgraph:NO} \
|
||||||
-DPLUGIN_CRACKLIB_PASSWORD_CHECK=%{?with_cracklib:DYNAMIC}%{!?with_cracklib:NO} \
|
-DPLUGIN_CRACKLIB_PASSWORD_CHECK=%{?with_cracklib:DYNAMIC}%{!?with_cracklib:NO} \
|
||||||
@ -837,6 +836,7 @@ export CFLAGS CXXFLAGS
|
|||||||
-DPLUGIN_TOKUDB=%{?with_tokudb:DYNAMIC}%{!?with_tokudb:NO} \
|
-DPLUGIN_TOKUDB=%{?with_tokudb:DYNAMIC}%{!?with_tokudb:NO} \
|
||||||
-DPLUGIN_CONNECT=%{?with_connect:DYNAMIC}%{!?with_connect:NO} \
|
-DPLUGIN_CONNECT=%{?with_connect:DYNAMIC}%{!?with_connect:NO} \
|
||||||
-DWITH_CASSANDRA=%{?with_cassandra:TRUE}%{!?with_cassandra:FALSE} \
|
-DWITH_CASSANDRA=%{?with_cassandra:TRUE}%{!?with_cassandra:FALSE} \
|
||||||
|
-DPLUGIN_CACHING_SHA2_PASSWORD=%{?with_clibrary:DYNAMIC}%{!?with_clibrary:OFF} \
|
||||||
-DPLUGIN_AWS_KEY_MANAGEMENT=NO \
|
-DPLUGIN_AWS_KEY_MANAGEMENT=NO \
|
||||||
-DCONNECT_WITH_MONGO=OFF \
|
-DCONNECT_WITH_MONGO=OFF \
|
||||||
-DCONNECT_WITH_JDBC=OFF \
|
-DCONNECT_WITH_JDBC=OFF \
|
||||||
@ -846,7 +846,7 @@ export CFLAGS CXXFLAGS
|
|||||||
# cmake -LAH for List Advanced Help
|
# cmake -LAH for List Advanced Help
|
||||||
cmake -LA
|
cmake -LA
|
||||||
|
|
||||||
make %{?_smp_mflags} VERBOSE=1
|
%make_build VERBOSE=1
|
||||||
|
|
||||||
|
|
||||||
# build selinux policy
|
# build selinux policy
|
||||||
@ -856,7 +856,7 @@ make -f /usr/share/selinux/devel/Makefile %{name}-server-galera.pp
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%install
|
%install
|
||||||
make DESTDIR=%{buildroot} install
|
%make_install
|
||||||
|
|
||||||
# multilib header support #1625157
|
# multilib header support #1625157
|
||||||
for header in mysql/server/my_config.h mysql/server/private/config.h; do
|
for header in mysql/server/my_config.h mysql/server/private/config.h; do
|
||||||
@ -875,12 +875,10 @@ install -p -m 0755 scripts/mysql_config_multilib %{buildroot}%{_bindir}/mysql_co
|
|||||||
ln -s mysql_config.1 %{buildroot}%{_mandir}/man1/mysql_config-%{__isa_bits}.1
|
ln -s mysql_config.1 %{buildroot}%{_mandir}/man1/mysql_config-%{__isa_bits}.1
|
||||||
fi
|
fi
|
||||||
|
|
||||||
# Upstream install this into arch-independent directory
|
%if %{without clibrary}
|
||||||
# Reported to upstream as: https://jira.mariadb.org/browse/MDEV-14340
|
# Client part should be included in package 'mariadb-connector-c'
|
||||||
# TODO: check, if it changes location inside that file depending on values passed to Cmake
|
rm %{buildroot}%{_libdir}/pkgconfig/libmariadb.pc
|
||||||
mkdir -p %{buildroot}/%{_libdir}/pkgconfig
|
%endif
|
||||||
mv %{buildroot}/%{_datadir}/pkgconfig/mariadb.pc %{buildroot}/%{_libdir}/pkgconfig
|
|
||||||
rm %{buildroot}/usr/lib/pkgconfig/libmariadb.pc
|
|
||||||
|
|
||||||
# install INFO_SRC, INFO_BIN into libdir (upstream thinks these are doc files,
|
# install INFO_SRC, INFO_BIN into libdir (upstream thinks these are doc files,
|
||||||
# but that's pretty wacko --- see also %%{name}-file-contents.patch)
|
# but that's pretty wacko --- see also %%{name}-file-contents.patch)
|
||||||
@ -990,7 +988,7 @@ touch %{buildroot}%{_sysconfdir}/sysconfig/clustercheck
|
|||||||
install -p -m 0755 scripts/clustercheck %{buildroot}%{_bindir}/clustercheck
|
install -p -m 0755 scripts/clustercheck %{buildroot}%{_bindir}/clustercheck
|
||||||
|
|
||||||
# remove duplicate logrotate script
|
# remove duplicate logrotate script
|
||||||
rm %{buildroot}%{_sysconfdir}/logrotate.d/mysql
|
rm %{buildroot}%{logrotateddir}/mysql
|
||||||
# Remove AppArmor files
|
# Remove AppArmor files
|
||||||
rm -r %{buildroot}%{_datadir}/%{pkg_name}/policy/apparmor
|
rm -r %{buildroot}%{_datadir}/%{pkg_name}/policy/apparmor
|
||||||
|
|
||||||
@ -1001,8 +999,9 @@ chmod -x %{buildroot}%{_datadir}/sql-bench/myisam.cnf
|
|||||||
install -p -m 0755 scripts/wsrep_sst_rsync_tunnel %{buildroot}%{_bindir}/wsrep_sst_rsync_tunnel
|
install -p -m 0755 scripts/wsrep_sst_rsync_tunnel %{buildroot}%{_bindir}/wsrep_sst_rsync_tunnel
|
||||||
|
|
||||||
# Disable plugins
|
# Disable plugins
|
||||||
%if %{with ggsapi}
|
%if %{with gssapi}
|
||||||
sed -i 's/^plugin-load-add/#plugin-load-add/' %{buildroot}%{_sysconfdir}/my.cnf.d/auth_gssapi.cnf
|
# Comment out the line to keep RHEL8 behaviour the same
|
||||||
|
#sed -i 's/^plugin-load-add/#plugin-load-add/' %{buildroot}%{_sysconfdir}/my.cnf.d/auth_gssapi.cnf
|
||||||
%endif
|
%endif
|
||||||
%if %{with cracklib}
|
%if %{with cracklib}
|
||||||
sed -i 's/^plugin-load-add/#plugin-load-add/' %{buildroot}%{_sysconfdir}/my.cnf.d/cracklib_password_check.cnf
|
sed -i 's/^plugin-load-add/#plugin-load-add/' %{buildroot}%{_sysconfdir}/my.cnf.d/cracklib_password_check.cnf
|
||||||
@ -1065,11 +1064,10 @@ rm %{buildroot}%{_sysconfdir}/my.cnf.d/mysql-clients.cnf
|
|||||||
rm %{buildroot}%{_mandir}/man1/tokuftdump.1*
|
rm %{buildroot}%{_mandir}/man1/tokuftdump.1*
|
||||||
rm %{buildroot}%{_mandir}/man1/tokuft_logprint.1*
|
rm %{buildroot}%{_mandir}/man1/tokuft_logprint.1*
|
||||||
%else
|
%else
|
||||||
%if 0%{?fedora} >= 28 || 0%{?rhel} > 7
|
%if 0%{?fedora} || 0%{?rhel} > 7
|
||||||
echo 'Environment="LD_PRELOAD=%{_libdir}/libjemalloc.so.2"' >> %{buildroot}%{_sysconfdir}/systemd/system/mariadb.service.d/tokudb.conf
|
# Move the upstream file to the correct location
|
||||||
|
mv %{buildroot}/etc/systemd/system/mariadb.service.d/tokudb.conf %{buildroot}%{_unitdir}/mariadb.service.d/tokudb.conf
|
||||||
%endif
|
%endif
|
||||||
# Move to better location, systemd config files has to be in /lib/
|
|
||||||
mv %{buildroot}%{_sysconfdir}/systemd/system/mariadb.service.d %{buildroot}%{_unitdir}
|
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%if %{without config}
|
%if %{without config}
|
||||||
@ -1366,7 +1364,7 @@ fi
|
|||||||
%{?with_cracklib:%exclude %{_libdir}/%{pkg_name}/plugin/cracklib_password_check.so}
|
%{?with_cracklib:%exclude %{_libdir}/%{pkg_name}/plugin/cracklib_password_check.so}
|
||||||
%{?with_rocksdb:%exclude %{_libdir}/%{pkg_name}/plugin/ha_rocksdb.so}
|
%{?with_rocksdb:%exclude %{_libdir}/%{pkg_name}/plugin/ha_rocksdb.so}
|
||||||
%{?with_tokudb:%exclude %{_libdir}/%{pkg_name}/plugin/ha_tokudb.so}
|
%{?with_tokudb:%exclude %{_libdir}/%{pkg_name}/plugin/ha_tokudb.so}
|
||||||
%{?with_ggsapi:%exclude %{_libdir}/%{pkg_name}/plugin/auth_gssapi.so}
|
%{?with_gssapi:%exclude %{_libdir}/%{pkg_name}/plugin/auth_gssapi.so}
|
||||||
%{?with_sphinx:%exclude %{_libdir}/%{pkg_name}/plugin/ha_sphinx.so}
|
%{?with_sphinx:%exclude %{_libdir}/%{pkg_name}/plugin/ha_sphinx.so}
|
||||||
%{?with_cassandra:%exclude %{_libdir}/%{pkg_name}/plugin/ha_cassandra.so}
|
%{?with_cassandra:%exclude %{_libdir}/%{pkg_name}/plugin/ha_cassandra.so}
|
||||||
%if %{with clibrary}
|
%if %{with clibrary}
|
||||||
@ -1433,7 +1431,9 @@ fi
|
|||||||
%{_datadir}/%{pkg_name}/systemd/mariadb@.service
|
%{_datadir}/%{pkg_name}/systemd/mariadb@.service
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%{daemondir}/%{daemon_name}*
|
%{_unitdir}/%{daemon_name}*
|
||||||
|
%{?with_tokudb:%exclude %{_unitdir}/mariadb.service.d/tokudb.conf}
|
||||||
|
|
||||||
%{_libexecdir}/mysql-prepare-db-dir
|
%{_libexecdir}/mysql-prepare-db-dir
|
||||||
%{_libexecdir}/mysql-check-socket
|
%{_libexecdir}/mysql-check-socket
|
||||||
%{_libexecdir}/mysql-check-upgrade
|
%{_libexecdir}/mysql-check-upgrade
|
||||||
@ -1589,9 +1589,18 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Wed Mar 13 2019 Michal Schorm <mschorm@redhat.com> - 3:10.3.11-2
|
* Thu Aug 01 2019 Michal Schorm <mschorm@redhat.com> - 3:10.3.17-1
|
||||||
- Added patch for rhbz#1686818
|
- Rebase to 10.3.17
|
||||||
Resolves: #1686818
|
Resolves: #1711265
|
||||||
|
Resolves: #1701687
|
||||||
|
- Add patch for server pkgconfig file location
|
||||||
|
- Use logrotatedir macro on one more spot
|
||||||
|
- Fix building of TokuDB with Jemalloc 5
|
||||||
|
- Fix building with / without lz4
|
||||||
|
- Fix "ggsapi" -> "gssapi" typo but keep the broken behaviour
|
||||||
|
- Control building of the CACHING_SHA2_PASSWORD plugin
|
||||||
|
- Fix the license tag
|
||||||
|
Resolves: #1702707
|
||||||
|
|
||||||
* Mon Dec 10 2018 Michal Schorm <mschorm@redhat.com> - 3:10.3.11-1
|
* Mon Dec 10 2018 Michal Schorm <mschorm@redhat.com> - 3:10.3.11-1
|
||||||
- Rebase to 10.3.11
|
- Rebase to 10.3.11
|
||||||
|
Loading…
Reference in New Issue
Block a user