import mariadb-10.5.16-2.module+el8.6.0+15639+405b7427
This commit is contained in:
parent
598987a975
commit
20eba6fac7
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
||||
SOURCES/mariadb-10.5.13-downstream_modified.tar.gz
|
||||
SOURCES/mariadb-10.5.16-downstream_modified.tar.gz
|
||||
|
@ -1 +1 @@
|
||||
ace36fe1a0ebba69b7cab359cb9a51c5b9fecbb4 SOURCES/mariadb-10.5.13-downstream_modified.tar.gz
|
||||
10c51d806a5eba0abce079a1965a487ff104a9a1 SOURCES/mariadb-10.5.16-downstream_modified.tar.gz
|
||||
|
@ -1,30 +0,0 @@
|
||||
# Fixing conflict with groonga package
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1763287
|
||||
|
||||
--- mariadb-10.3.18/storage/mroonga/vendor/groonga/CMakeLists.txt.withoutoption 2019-11-11 14:01:07.762595716 +0100
|
||||
+++ mariadb-10.3.18/storage/mroonga/vendor/groonga/CMakeLists.txt 2019-11-11 14:33:05.224012458 +0100
|
||||
@@ -86,7 +86,9 @@
|
||||
set(INCLUDE_DIR "include")
|
||||
set(GRN_INCLUDE_DIR "include/groonga")
|
||||
set(DATA_DIR "share")
|
||||
-set(GRN_DATA_DIR "${DATA_DIR}/${GRN_PROJECT_NAME}")
|
||||
+if(NOT DEFINED GRN_DATA_DIR)
|
||||
+ set(GRN_DATA_DIR "${DATA_DIR}/${GRN_PROJECT_NAME}")
|
||||
+endif()
|
||||
set(CONFIG_DIR "etc")
|
||||
set(GRN_CONFIG_DIR "${CONFIG_DIR}/${GRN_PROJECT_NAME}")
|
||||
set(GRN_CONFIG_PATH "${CMAKE_INSTALL_PREFIX}/${GRN_CONFIG_DIR}/groonga.conf")
|
||||
|
||||
--- mariadb-10.3.18/storage/mroonga/vendor/groonga/vendor/plugins/groonga-normalizer-mysql/CMakeLists.txt.withoutoption 2019-11-11 14:34:22.661005715 +0100
|
||||
+++ mariadb-10.3.18/storage/mroonga/vendor/groonga/vendor/plugins/groonga-normalizer-mysql/CMakeLists.txt 2019-11-11 14:35:59.962244120 +0100
|
||||
@@ -16,7 +16,9 @@
|
||||
# MA 02110-1335 USA
|
||||
|
||||
cmake_minimum_required(VERSION 2.6)
|
||||
-set(GROONGA_NORMALIZER_MYSQL_PROJECT_NAME "groonga-normalizer-mysql")
|
||||
+if (NOT DEFINED GROONGA_NORMALIZER_MYSQL_PROJECT_NAME)
|
||||
+ set(GROONGA_NORMALIZER_MYSQL_PROJECT_NAME "groonga-normalizer-mysql")
|
||||
+endif()
|
||||
project("${GROONGA_NORMALIZER_MYSQL_PROJECT_NAME}")
|
||||
|
||||
if(DEFINED GROONGA_NORMALIZER_MYSQL_EMBED)
|
@ -32,9 +32,9 @@ Update 02/2021
|
||||
* Discussion continues in:
|
||||
https://jira.mariadb.org/browse/MDEV-16621
|
||||
|
||||
--- mariadb-10.5.8/support-files/mysql-log-rotate.sh 2021-02-12 08:37:47.857289694 +0100
|
||||
+++ mariadb-10.5.8/support-files/mysql-log-rotate.sh_pacthed 2021-02-12 08:40:26.420372325 +0100
|
||||
@@ -3,35 +3,22 @@
|
||||
--- mariadb-10.5.13-downstream_modified/support-files/mysql-log-rotate.sh 2022-02-22 04:56:35.571185622 +0100
|
||||
+++ mariadb-10.5.13-downstream_modified/support-files/mysql-log-rotate.sh_patched 2022-02-22 04:56:15.121003580 +0100
|
||||
@@ -3,36 +3,23 @@
|
||||
# in the [mysqld] section as follows:
|
||||
#
|
||||
# [mysqld]
|
||||
@ -58,6 +58,7 @@ Update 02/2021
|
||||
- # create 600 mysql mysql
|
||||
+@LOG_LOCATION@ {
|
||||
+ create 600 mysql mysql
|
||||
su mysql mysql
|
||||
notifempty
|
||||
daily
|
||||
rotate 3
|
||||
|
@ -1,378 +0,0 @@
|
||||
From c80991c79f701dac42c630af4bd39593b0c7efb4 Mon Sep 17 00:00:00 2001
|
||||
From: Vladislav Vaintroub <wlad@mariadb.com>
|
||||
Date: Mon, 8 Nov 2021 18:48:19 +0100
|
||||
Subject: [PATCH] MDEV-25785 Add support for OpenSSL 3.0
|
||||
|
||||
Summary of changes
|
||||
|
||||
- MD_CTX_SIZE is increased
|
||||
|
||||
- EVP_CIPHER_CTX_buf_noconst(ctx) does not work anymore, points
|
||||
to nobody knows where. The assumption made previously was that
|
||||
(since the function does not seem to be documented)
|
||||
was that it points to the last partial source block.
|
||||
Add own partial block buffer for NOPAD encryption instead
|
||||
|
||||
- SECLEVEL in CipherString in openssl.cnf
|
||||
had been downgraded to 0, from 1, to make TLSv1.0 and TLSv1.1 possible
|
||||
|
||||
- Workaround Ssl_cipher_list issue, it now returns TLSv1.3 ciphers,
|
||||
in addition to what was set in --ssl-cipher
|
||||
|
||||
- ctx_buf buffer now must be aligned to 16 bytes with openssl(
|
||||
previously with WolfSSL only), ot crashes will happen
|
||||
|
||||
- updated aes-t , to be better debuggable
|
||||
using function, rather than a huge multiline macro
|
||||
added test that does "nopad" encryption piece-wise, to test
|
||||
replacement of EVP_CIPHER_CTX_buf_noconst
|
||||
---
|
||||
cmake/ssl.cmake | 19 ++++-
|
||||
include/ssl_compat.h | 3 +-
|
||||
mysql-test/lib/openssl.cnf | 2 +-
|
||||
mysql-test/main/ssl_cipher.result | 6 +-
|
||||
mysql-test/main/ssl_cipher.test | 2 +-
|
||||
mysys_ssl/my_crypt.cc | 46 +++++++-----
|
||||
unittest/mysys/aes-t.c | 121 ++++++++++++++++++++++--------
|
||||
7 files changed, 141 insertions(+), 58 deletions(-)
|
||||
|
||||
|
||||
diff -up mariadb-10.5.12-downstream_modified/cmake/ssl.cmake.patch16 mariadb-10.5.12-downstream_modified/cmake/ssl.cmake
|
||||
--- mariadb-10.5.12-downstream_modified/cmake/ssl.cmake.patch16 2021-08-03 10:29:07.000000000 +0200
|
||||
+++ mariadb-10.5.12-downstream_modified/cmake/ssl.cmake 2021-11-18 16:58:41.552440737 +0100
|
||||
@@ -139,9 +139,20 @@ MACRO (MYSQL_CHECK_SSL)
|
||||
SET(SSL_INTERNAL_INCLUDE_DIRS "")
|
||||
SET(SSL_DEFINES "-DHAVE_OPENSSL")
|
||||
|
||||
+ FOREACH(x INCLUDES LIBRARIES DEFINITIONS)
|
||||
+ SET(SAVE_CMAKE_REQUIRED_${x} ${CMAKE_REQUIRED_${x}})
|
||||
+ ENDFOREACH()
|
||||
+
|
||||
+ # Silence "deprecated in OpenSSL 3.0"
|
||||
+ IF((NOT OPENSSL_VERSION) # 3.0 not determined by older cmake
|
||||
+ OR NOT(OPENSSL_VERSION VERSION_LESS "3.0.0"))
|
||||
+ SET(SSL_DEFINES "${SSL_DEFINES} -DOPENSSL_API_COMPAT=0x10100000L")
|
||||
+ SET(CMAKE_REQUIRED_DEFINITIONS -DOPENSSL_API_COMPAT=0x10100000L)
|
||||
+ ENDIF()
|
||||
+
|
||||
SET(CMAKE_REQUIRED_INCLUDES ${OPENSSL_INCLUDE_DIR})
|
||||
SET(CMAKE_REQUIRED_LIBRARIES ${SSL_LIBRARIES})
|
||||
- SET(CMAKE_REQUIRED_INCLUDES ${OPENSSL_INCLUDE_DIR})
|
||||
+
|
||||
CHECK_SYMBOL_EXISTS(ERR_remove_thread_state "openssl/err.h"
|
||||
HAVE_ERR_remove_thread_state)
|
||||
CHECK_SYMBOL_EXISTS(EVP_aes_128_ctr "openssl/evp.h"
|
||||
@@ -150,8 +161,10 @@ MACRO (MYSQL_CHECK_SSL)
|
||||
HAVE_EncryptAes128Gcm)
|
||||
CHECK_SYMBOL_EXISTS(X509_check_host "openssl/x509v3.h"
|
||||
HAVE_X509_check_host)
|
||||
- SET(CMAKE_REQUIRED_INCLUDES)
|
||||
- SET(CMAKE_REQUIRED_LIBRARIES)
|
||||
+
|
||||
+ FOREACH(x INCLUDES LIBRARIES DEFINITIONS)
|
||||
+ SET(CMAKE_REQUIRED_${x} ${SAVE_CMAKE_REQUIRED_${x}})
|
||||
+ ENDFOREACH()
|
||||
ELSE()
|
||||
IF(WITH_SSL STREQUAL "system")
|
||||
MESSAGE(FATAL_ERROR "Cannot find appropriate system libraries for SSL. Use WITH_SSL=bundled to enable SSL support")
|
||||
diff -up mariadb-10.5.12-downstream_modified/include/ssl_compat.h.patch16 mariadb-10.5.12-downstream_modified/include/ssl_compat.h
|
||||
--- mariadb-10.5.12-downstream_modified/include/ssl_compat.h.patch16 2021-08-03 10:29:07.000000000 +0200
|
||||
+++ mariadb-10.5.12-downstream_modified/include/ssl_compat.h 2021-11-18 16:58:41.552440737 +0100
|
||||
@@ -24,7 +24,7 @@
|
||||
#define SSL_LIBRARY OpenSSL_version(OPENSSL_VERSION)
|
||||
#define ERR_remove_state(X) ERR_clear_error()
|
||||
#define EVP_CIPHER_CTX_SIZE 176
|
||||
-#define EVP_MD_CTX_SIZE 48
|
||||
+#define EVP_MD_CTX_SIZE 72
|
||||
#undef EVP_MD_CTX_init
|
||||
#define EVP_MD_CTX_init(X) do { memset((X), 0, EVP_MD_CTX_SIZE); EVP_MD_CTX_reset(X); } while(0)
|
||||
#undef EVP_CIPHER_CTX_init
|
||||
@@ -74,7 +74,6 @@
|
||||
#endif
|
||||
|
||||
#define DH_set0_pqg(D,P,Q,G) ((D)->p= (P), (D)->g= (G))
|
||||
-#define EVP_CIPHER_CTX_buf_noconst(ctx) ((ctx)->buf)
|
||||
#define EVP_CIPHER_CTX_encrypting(ctx) ((ctx)->encrypt)
|
||||
#define EVP_CIPHER_CTX_SIZE sizeof(EVP_CIPHER_CTX)
|
||||
|
||||
diff -up mariadb-10.5.12-downstream_modified/mysql-test/lib/openssl.cnf.patch16 mariadb-10.5.12-downstream_modified/mysql-test/lib/openssl.cnf
|
||||
--- mariadb-10.5.12-downstream_modified/mysql-test/lib/openssl.cnf.patch16 2021-08-03 10:29:07.000000000 +0200
|
||||
+++ mariadb-10.5.12-downstream_modified/mysql-test/lib/openssl.cnf 2021-11-18 16:58:41.552440737 +0100
|
||||
@@ -9,4 +9,4 @@ ssl_conf = ssl_section
|
||||
system_default = system_default_section
|
||||
|
||||
[system_default_section]
|
||||
-CipherString = ALL:@SECLEVEL=1
|
||||
+CipherString = ALL:@SECLEVEL=0
|
||||
diff -up mariadb-10.5.12-downstream_modified/mysql-test/main/ssl_cipher.result.patch16 mariadb-10.5.12-downstream_modified/mysql-test/main/ssl_cipher.result
|
||||
--- mariadb-10.5.12-downstream_modified/mysql-test/main/ssl_cipher.result.patch16 2021-08-03 10:29:08.000000000 +0200
|
||||
+++ mariadb-10.5.12-downstream_modified/mysql-test/main/ssl_cipher.result 2021-11-18 16:58:41.552440737 +0100
|
||||
@@ -61,8 +61,8 @@ connect ssl_con,localhost,root,,,,,SSL;
|
||||
SHOW STATUS LIKE 'Ssl_cipher';
|
||||
Variable_name Value
|
||||
Ssl_cipher AES128-SHA
|
||||
-SHOW STATUS LIKE 'Ssl_cipher_list';
|
||||
-Variable_name Value
|
||||
-Ssl_cipher_list AES128-SHA
|
||||
+SELECT VARIABLE_VALUE like '%AES128-SHA%' FROM INFORMATION_SCHEMA.SESSION_STATUS WHERE VARIABLE_NAME='Ssl_cipher_list';
|
||||
+VARIABLE_VALUE like '%AES128-SHA%'
|
||||
+1
|
||||
disconnect ssl_con;
|
||||
connection default;
|
||||
diff -up mariadb-10.5.12-downstream_modified/mysql-test/main/ssl_cipher.test.patch16 mariadb-10.5.12-downstream_modified/mysql-test/main/ssl_cipher.test
|
||||
--- mariadb-10.5.12-downstream_modified/mysql-test/main/ssl_cipher.test.patch16 2021-11-18 16:58:41.552440737 +0100
|
||||
+++ mariadb-10.5.12-downstream_modified/mysql-test/main/ssl_cipher.test 2021-11-18 17:00:47.753839711 +0100
|
||||
@@ -100,6 +100,6 @@ connect (ssl_con,localhost,root,,,,,SSL)
|
||||
--replace_regex /TLS_AES_.*/AES128-SHA/
|
||||
SHOW STATUS LIKE 'Ssl_cipher';
|
||||
--replace_regex /TLS_AES_.*/AES128-SHA/
|
||||
-SHOW STATUS LIKE 'Ssl_cipher_list';
|
||||
+SELECT VARIABLE_VALUE like '%AES128-SHA%' FROM INFORMATION_SCHEMA.SESSION_STATUS WHERE VARIABLE_NAME='Ssl_cipher_list';
|
||||
disconnect ssl_con;
|
||||
connection default;
|
||||
diff -up mariadb-10.5.12-downstream_modified/mysys_ssl/my_crypt.cc.patch16 mariadb-10.5.12-downstream_modified/mysys_ssl/my_crypt.cc
|
||||
--- mariadb-10.5.12-downstream_modified/mysys_ssl/my_crypt.cc.patch16 2021-08-03 10:29:08.000000000 +0200
|
||||
+++ mariadb-10.5.12-downstream_modified/mysys_ssl/my_crypt.cc 2021-11-18 16:58:41.552440737 +0100
|
||||
@@ -29,11 +29,7 @@
|
||||
#include <ssl_compat.h>
|
||||
#include <cstdint>
|
||||
|
||||
-#ifdef HAVE_WOLFSSL
|
||||
#define CTX_ALIGN 16
|
||||
-#else
|
||||
-#define CTX_ALIGN 0
|
||||
-#endif
|
||||
|
||||
class MyCTX
|
||||
{
|
||||
@@ -100,8 +96,9 @@ class MyCTX_nopad : public MyCTX
|
||||
{
|
||||
public:
|
||||
const uchar *key;
|
||||
- uint klen, buf_len;
|
||||
+ uint klen, source_tail_len;
|
||||
uchar oiv[MY_AES_BLOCK_SIZE];
|
||||
+ uchar source_tail[MY_AES_BLOCK_SIZE];
|
||||
|
||||
MyCTX_nopad() : MyCTX() { }
|
||||
~MyCTX_nopad() { }
|
||||
@@ -112,7 +109,7 @@ public:
|
||||
compile_time_assert(MY_AES_CTX_SIZE >= sizeof(MyCTX_nopad));
|
||||
this->key= key;
|
||||
this->klen= klen;
|
||||
- this->buf_len= 0;
|
||||
+ this->source_tail_len= 0;
|
||||
if (ivlen)
|
||||
memcpy(oiv, iv, ivlen);
|
||||
DBUG_ASSERT(ivlen == 0 || ivlen == sizeof(oiv));
|
||||
@@ -123,26 +120,41 @@ public:
|
||||
return res;
|
||||
}
|
||||
|
||||
+ /** Update last partial source block, stored in source_tail array. */
|
||||
+ void update_source_tail(const uchar* src, uint slen)
|
||||
+ {
|
||||
+ if (!slen)
|
||||
+ return;
|
||||
+ uint new_tail_len= (source_tail_len + slen) % MY_AES_BLOCK_SIZE;
|
||||
+ if (new_tail_len)
|
||||
+ {
|
||||
+ if (slen + source_tail_len < MY_AES_BLOCK_SIZE)
|
||||
+ {
|
||||
+ memcpy(source_tail + source_tail_len, src, slen);
|
||||
+ }
|
||||
+ else
|
||||
+ {
|
||||
+ DBUG_ASSERT(slen > new_tail_len);
|
||||
+ memcpy(source_tail, src + slen - new_tail_len, new_tail_len);
|
||||
+ }
|
||||
+ }
|
||||
+ source_tail_len= new_tail_len;
|
||||
+ }
|
||||
+
|
||||
int update(const uchar *src, uint slen, uchar *dst, uint *dlen)
|
||||
{
|
||||
- buf_len+= slen;
|
||||
+ update_source_tail(src, slen);
|
||||
return MyCTX::update(src, slen, dst, dlen);
|
||||
}
|
||||
|
||||
int finish(uchar *dst, uint *dlen)
|
||||
{
|
||||
- buf_len %= MY_AES_BLOCK_SIZE;
|
||||
- if (buf_len)
|
||||
+ if (source_tail_len)
|
||||
{
|
||||
- uchar *buf= EVP_CIPHER_CTX_buf_noconst(ctx);
|
||||
/*
|
||||
Not much we can do, block ciphers cannot encrypt data that aren't
|
||||
a multiple of the block length. At least not without padding.
|
||||
Let's do something CTR-like for the last partial block.
|
||||
-
|
||||
- NOTE this assumes that there are only buf_len bytes in the buf.
|
||||
- If OpenSSL will change that, we'll need to change the implementation
|
||||
- of this class too.
|
||||
*/
|
||||
uchar mask[MY_AES_BLOCK_SIZE];
|
||||
uint mlen;
|
||||
@@ -154,10 +166,10 @@ public:
|
||||
return rc;
|
||||
DBUG_ASSERT(mlen == sizeof(mask));
|
||||
|
||||
- for (uint i=0; i < buf_len; i++)
|
||||
- dst[i]= buf[i] ^ mask[i];
|
||||
+ for (uint i=0; i < source_tail_len; i++)
|
||||
+ dst[i]= source_tail[i] ^ mask[i];
|
||||
}
|
||||
- *dlen= buf_len;
|
||||
+ *dlen= source_tail_len;
|
||||
return MY_AES_OK;
|
||||
}
|
||||
};
|
||||
diff -up mariadb-10.5.12-downstream_modified/unittest/mysys/aes-t.c.patch16 mariadb-10.5.12-downstream_modified/unittest/mysys/aes-t.c
|
||||
--- mariadb-10.5.12-downstream_modified/unittest/mysys/aes-t.c.patch16 2021-08-03 10:29:10.000000000 +0200
|
||||
+++ mariadb-10.5.12-downstream_modified/unittest/mysys/aes-t.c 2021-11-18 16:58:41.553440740 +0100
|
||||
@@ -21,27 +21,96 @@
|
||||
#include <string.h>
|
||||
#include <ctype.h>
|
||||
|
||||
-#define DO_TEST(mode, nopad, slen, fill, dlen, hash) \
|
||||
- SKIP_BLOCK_IF(mode == 0xDEADBEAF, nopad ? 4 : 5, #mode " not supported") \
|
||||
- { \
|
||||
- memset(src, fill, src_len= slen); \
|
||||
- ok(my_aes_crypt(mode, nopad | ENCRYPTION_FLAG_ENCRYPT, \
|
||||
- src, src_len, dst, &dst_len, \
|
||||
- key, sizeof(key), iv, sizeof(iv)) == MY_AES_OK, \
|
||||
- "encrypt " #mode " %u %s", src_len, nopad ? "nopad" : "pad"); \
|
||||
- if (!nopad) \
|
||||
- ok (dst_len == my_aes_get_size(mode, src_len), "my_aes_get_size");\
|
||||
- my_md5(md5, (char*)dst, dst_len); \
|
||||
- ok(dst_len == dlen && memcmp(md5, hash, sizeof(md5)) == 0, "md5"); \
|
||||
- ok(my_aes_crypt(mode, nopad | ENCRYPTION_FLAG_DECRYPT, \
|
||||
- dst, dst_len, ddst, &ddst_len, \
|
||||
- key, sizeof(key), iv, sizeof(iv)) == MY_AES_OK, \
|
||||
- "decrypt " #mode " %u", dst_len); \
|
||||
- ok(ddst_len == src_len && memcmp(src, ddst, src_len) == 0, "memcmp"); \
|
||||
+
|
||||
+/** Test streaming encryption, bytewise update.*/
|
||||
+static int aes_crypt_bytewise(enum my_aes_mode mode, int flags, const unsigned char *src,
|
||||
+ unsigned int slen, unsigned char *dst, unsigned int *dlen,
|
||||
+ const unsigned char *key, unsigned int klen,
|
||||
+ const unsigned char *iv, unsigned int ivlen)
|
||||
+{
|
||||
+ /* Allocate context on odd address on stack, in order to
|
||||
+ catch misalignment errors.*/
|
||||
+ void *ctx= (char *)alloca(MY_AES_CTX_SIZE+1)+1;
|
||||
+
|
||||
+ int res1, res2;
|
||||
+ uint d1= 0, d2;
|
||||
+ uint i;
|
||||
+
|
||||
+ if ((res1= my_aes_crypt_init(ctx, mode, flags, key, klen, iv, ivlen)))
|
||||
+ return res1;
|
||||
+ for (i= 0; i < slen; i++)
|
||||
+ {
|
||||
+ uint tmp_d1=0;
|
||||
+ res1= my_aes_crypt_update(ctx, src+i,1, dst, &tmp_d1);
|
||||
+ if (res1)
|
||||
+ return res1;
|
||||
+ d1+= tmp_d1;
|
||||
+ dst+= tmp_d1;
|
||||
+ }
|
||||
+ res2= my_aes_crypt_finish(ctx, dst, &d2);
|
||||
+ *dlen= d1 + d2;
|
||||
+ return res1 ? res1 : res2;
|
||||
+}
|
||||
+
|
||||
+
|
||||
+#ifndef HAVE_EncryptAes128Ctr
|
||||
+const uint MY_AES_CTR=0xDEADBEAF;
|
||||
+#endif
|
||||
+#ifndef HAVE_EncryptAes128Gcm
|
||||
+const uint MY_AES_GCM=0xDEADBEAF;
|
||||
+#endif
|
||||
+
|
||||
+#define MY_AES_UNSUPPORTED(x) (x == 0xDEADBEAF)
|
||||
+
|
||||
+static void do_test(uint mode, const char *mode_str, int nopad, uint slen,
|
||||
+ char fill, size_t dlen, const char *hash)
|
||||
+{
|
||||
+ uchar key[16]= {1, 2, 3, 4, 5, 6, 7, 8, 9, 0, 1, 2, 3, 4, 5, 6};
|
||||
+ uchar iv[16]= {2, 3, 4, 5, 6, 7, 8, 9, 0, 1, 2, 3, 4, 5, 6, 7};
|
||||
+ uchar src[1000], dst[1100], dst2[1100], ddst[1000];
|
||||
+ uchar md5[MY_MD5_HASH_SIZE];
|
||||
+ uint src_len, dst_len, dst_len2, ddst_len;
|
||||
+ int result;
|
||||
+
|
||||
+ if (MY_AES_UNSUPPORTED(mode))
|
||||
+ {
|
||||
+ skip(nopad?7:6, "%s not supported", mode_str);
|
||||
+ return;
|
||||
+ }
|
||||
+ memset(src, fill, src_len= slen);
|
||||
+ result= my_aes_crypt(mode, nopad | ENCRYPTION_FLAG_ENCRYPT, src, src_len,
|
||||
+ dst, &dst_len, key, sizeof(key), iv, sizeof(iv));
|
||||
+ ok(result == MY_AES_OK, "encrypt %s %u %s", mode_str, src_len,
|
||||
+ nopad ? "nopad" : "pad");
|
||||
+
|
||||
+ if (nopad)
|
||||
+ {
|
||||
+ result= aes_crypt_bytewise(mode, nopad | ENCRYPTION_FLAG_ENCRYPT, src,
|
||||
+ src_len, dst2, &dst_len2, key, sizeof(key),
|
||||
+ iv, sizeof(iv));
|
||||
+ ok(result == MY_AES_OK, "encrypt bytewise %s %u", mode_str, src_len);
|
||||
+ /* Compare with non-bytewise encryption result*/
|
||||
+ ok(dst_len == dst_len2 && memcmp(dst, dst2, dst_len) == 0,
|
||||
+ "memcmp bytewise %s %u", mode_str, src_len);
|
||||
}
|
||||
+ else
|
||||
+ {
|
||||
+ int dst_len_real= my_aes_get_size(mode, src_len);
|
||||
+ ok(dst_len_real= dst_len, "my_aes_get_size");
|
||||
+ }
|
||||
+ my_md5(md5, (char *) dst, dst_len);
|
||||
+ ok(dst_len == dlen, "md5 len");
|
||||
+ ok(memcmp(md5, hash, sizeof(md5)) == 0, "md5");
|
||||
+ result= my_aes_crypt(mode, nopad | ENCRYPTION_FLAG_DECRYPT,
|
||||
+ dst, dst_len, ddst, &ddst_len, key, sizeof(key), iv,
|
||||
+ sizeof(iv));
|
||||
+
|
||||
+ ok(result == MY_AES_OK, "decrypt %s %u", mode_str, dst_len);
|
||||
+ ok(ddst_len == src_len && memcmp(src, ddst, src_len) == 0, "memcmp");
|
||||
+}
|
||||
|
||||
-#define DO_TEST_P(M,S,F,D,H) DO_TEST(M,0,S,F,D,H)
|
||||
-#define DO_TEST_N(M,S,F,D,H) DO_TEST(M,ENCRYPTION_FLAG_NOPAD,S,F,D,H)
|
||||
+#define DO_TEST_P(M, S, F, D, H) do_test(M, #M, 0, S, F, D, H)
|
||||
+#define DO_TEST_N(M, S, F, D, H) do_test(M, #M, ENCRYPTION_FLAG_NOPAD, S, F, D, H)
|
||||
|
||||
/* useful macro for debugging */
|
||||
#define PRINT_MD5() \
|
||||
@@ -53,25 +122,15 @@
|
||||
printf("\"\n"); \
|
||||
} while(0);
|
||||
|
||||
-#ifndef HAVE_EncryptAes128Ctr
|
||||
-const uint MY_AES_CTR=0xDEADBEAF;
|
||||
-#endif
|
||||
-#ifndef HAVE_EncryptAes128Gcm
|
||||
-const uint MY_AES_GCM=0xDEADBEAF;
|
||||
-#endif
|
||||
|
||||
int
|
||||
main(int argc __attribute__((unused)),char *argv[])
|
||||
{
|
||||
- uchar key[16]= {1,2,3,4,5,6,7,8,9,0,1,2,3,4,5,6};
|
||||
- uchar iv[16]= {2,3,4,5,6,7,8,9,0,1,2,3,4,5,6,7};
|
||||
- uchar src[1000], dst[1100], ddst[1000];
|
||||
- uchar md5[MY_MD5_HASH_SIZE];
|
||||
- uint src_len, dst_len, ddst_len;
|
||||
|
||||
MY_INIT(argv[0]);
|
||||
|
||||
- plan(87);
|
||||
+ plan(122);
|
||||
+
|
||||
DO_TEST_P(MY_AES_ECB, 200, '.', 208, "\xd8\x73\x8e\x3a\xbc\x66\x99\x13\x7f\x90\x23\x52\xee\x97\x6f\x9a");
|
||||
DO_TEST_P(MY_AES_ECB, 128, '?', 144, "\x19\x58\x33\x85\x4c\xaa\x7f\x06\xd1\xb2\xec\xd7\xb7\x6a\xa9\x5b");
|
||||
DO_TEST_P(MY_AES_CBC, 159, '%', 160, "\x4b\x03\x18\x3d\xf1\xa7\xcd\xa1\x46\xb3\xc6\x8a\x92\xc0\x0f\xc9");
|
@ -1,19 +0,0 @@
|
||||
Use PCDIR CMake option, if configured
|
||||
|
||||
Upstream install the server pkgconfig file into arch-independent directory
|
||||
Reported to upstream as: https://jira.mariadb.org/browse/MDEV-14340
|
||||
|
||||
--- mariadb-10.5.5/support-files/CMakeLists.txt.old 2020-09-30 10:36:08.582490318 +0200
|
||||
+++ mariadb-10.5.5/support-files/CMakeLists.txt 2020-09-30 10:38:58.079710848 +0200
|
||||
@@ -91,7 +91,11 @@
|
||||
ENDIF()
|
||||
|
||||
CONFIGURE_FILE(mariadb.pc.in ${CMAKE_CURRENT_BINARY_DIR}/mariadb.pc @ONLY)
|
||||
+IF(INSTALL_PCDIR)
|
||||
+ INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/mariadb.pc DESTINATION ${INSTALL_PCDIR} COMPONENT Development)
|
||||
+ELSE()
|
||||
INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/mariadb.pc DESTINATION ${INSTALL_LIBDIR}/pkgconfig COMPONENT Development)
|
||||
+ENDIF()
|
||||
|
||||
INSTALL(FILES mysql.m4 DESTINATION ${INSTALL_SHAREDIR}/aclocal COMPONENT Development)
|
||||
|
File diff suppressed because it is too large
Load Diff
@ -3,3 +3,5 @@ perfschema.memory_aggregate_32bit :
|
||||
period.overlaps :
|
||||
# Fails since 10.5.9
|
||||
bugfix.wait_timeout :
|
||||
#Fails since 10.5.16
|
||||
innodb.row_size_error_log_warnings_3 :
|
||||
|
@ -15,7 +15,7 @@
|
||||
# The last version on which the full testsuite has been run
|
||||
# In case of further rebuilds of that version, don't require full testsuite to be run
|
||||
# run only "main" suite
|
||||
%global last_tested_version 10.5.12
|
||||
%global last_tested_version 10.5.16
|
||||
# Set to 1 to force run the testsuite even if it was already tested in current version
|
||||
%global force_run_testsuite 0
|
||||
|
||||
@ -109,7 +109,7 @@
|
||||
%bcond_without unbundled_pcre
|
||||
%else
|
||||
%bcond_with unbundled_pcre
|
||||
%global pcre_bundled_version 10.37
|
||||
%global pcre_bundled_version 10.40
|
||||
%endif
|
||||
|
||||
# Use main python interpretter version
|
||||
@ -147,8 +147,8 @@
|
||||
%global sameevr %{epoch}:%{version}-%{release}
|
||||
|
||||
Name: mariadb
|
||||
Version: 10.5.13
|
||||
Release: 1%{?with_debug:.debug}%{?dist}
|
||||
Version: 10.5.16
|
||||
Release: 2%{?with_debug:.debug}%{?dist}
|
||||
Epoch: 3
|
||||
|
||||
Summary: A very fast and robust SQL database server
|
||||
@ -205,10 +205,6 @@ Source72: mariadb-server-galera.te
|
||||
# https://github.com/dciabrin/wsrep_sst_rsync_tunnel/blob/master/wsrep_sst_rsync_tunnel
|
||||
Source73: wsrep_sst_rsync_tunnel
|
||||
|
||||
# Patch1: OpenSSL 3 patch
|
||||
# Picked from the upstream developement branch for MariaDB 10.8.
|
||||
# https://jira.mariadb.org/browse/MDEV-25785
|
||||
Patch1: %{pkgnamepatch}-openssl3.patch
|
||||
# Patch4: Red Hat distributions specific logrotate fix
|
||||
# it would be big unexpected change, if we start shipping it now. Better wait for MariaDB 10.2
|
||||
Patch4: %{pkgnamepatch}-logrotate.patch
|
||||
@ -218,12 +214,6 @@ Patch7: %{pkgnamepatch}-scripts.patch
|
||||
Patch9: %{pkgnamepatch}-ownsetup.patch
|
||||
# Patch10: Fix cipher name in the SSL Cipher name test
|
||||
Patch10: %{pkgnamepatch}-ssl-cipher-tests.patch
|
||||
# Patch11: Use PCDIR CMake option, if configured
|
||||
Patch11: %{pkgnamepatch}-pcdir.patch
|
||||
# Patch13: Fix Spider code on armv7hl; https://jira.mariadb.org/browse/MDEV-18737
|
||||
Patch13: %{pkgnamepatch}-spider_on_armv7hl.patch
|
||||
# Patch15: Add option to edit groonga's and groonga-normalizer-mysql install path
|
||||
Patch15: %{pkgnamepatch}-groonga.patch
|
||||
# Patch16: Workaround for "chown 0" with priviledges dropped to "mysql" user
|
||||
Patch16: %{pkgnamepatch}-auth_pam_tool_dir.patch
|
||||
# Patch17: Revert of an upstream commit
|
||||
@ -738,16 +728,10 @@ rm -r storage/rocksdb/
|
||||
%endif
|
||||
|
||||
|
||||
%if 0%{?fedora} >= 35 || 0%{?rhel} >= 9
|
||||
%patch1 -p1
|
||||
%endif
|
||||
%patch4 -p1
|
||||
%patch7 -p1
|
||||
%patch9 -p1
|
||||
%patch10 -p1
|
||||
%patch11 -p1
|
||||
#%patch13 -p1
|
||||
%patch15 -p1
|
||||
%patch16 -p1
|
||||
%patch17 -R -p1
|
||||
|
||||
@ -798,10 +782,6 @@ fi
|
||||
|
||||
|
||||
%build
|
||||
# This package has static probe points which do not currently
|
||||
# work with LTO and result in undefined symbols at link time.
|
||||
# This is being worked on in upstream GCC
|
||||
%define _lto_cflags %{nil}
|
||||
|
||||
# fail quickly and obviously if user tries to build as root
|
||||
%if %runselftest
|
||||
@ -840,7 +820,6 @@ fi
|
||||
-DINSTALL_SBINDIR=libexec \
|
||||
-DINSTALL_SCRIPTDIR=bin \
|
||||
-DINSTALL_SUPPORTFILESDIR=share/%{pkg_name} \
|
||||
-DINSTALL_PCDIR=%{_lib}/pkgconfig \
|
||||
-DMYSQL_DATADIR="%{dbdatadir}" \
|
||||
-DMYSQL_UNIX_ADDR="/var/lib/mysql/mysql.sock" \
|
||||
-DTMPDIR=/var/tmp \
|
||||
@ -848,7 +827,7 @@ fi
|
||||
-DGROONGA_NORMALIZER_MYSQL_PROJECT_NAME=%{name}-server/groonga-normalizer-mysql \
|
||||
-DENABLED_LOCAL_INFILE=ON \
|
||||
-DENABLE_DTRACE=ON \
|
||||
-DSECURITY_HARDENED=ON \
|
||||
-DSECURITY_HARDENED=OFF \
|
||||
-DWITH_WSREP=%{?with_galera:ON}%{!?with_galera:OFF} \
|
||||
-DWITH_INNODB_DISALLOW_WRITES=%{?with_galera:ON}%{!?with_galera:OFF} \
|
||||
-DWITH_EMBEDDED_SERVER=%{?with_embedded:ON}%{!?with_embedded:OFF} \
|
||||
@ -876,6 +855,10 @@ fi
|
||||
-DCONNECT_WITH_JDBC=OFF \
|
||||
%{?with_debug: -DCMAKE_BUILD_TYPE=Debug -DWITH_ASAN=OFF -DWITH_INNODB_EXTRA_DEBUG=ON -DWITH_VALGRIND=ON}
|
||||
|
||||
# The -DSECURITY_HARDENED is used to force a set of compilation flags for hardening
|
||||
# The issue is that the MariaDB upstream level of hardening is lower than expected by Red Hat
|
||||
# We disable this option to the default compilation flags (which have higher level of hardening) will be used
|
||||
|
||||
|
||||
CFLAGS="$CFLAGS -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE"
|
||||
# force PIC mode so that we can build libmysqld.so
|
||||
@ -904,7 +887,7 @@ export CFLAGS CXXFLAGS CPPFLAGS
|
||||
# Print all Cmake options values; "-LAH" means "List Advanced Help"
|
||||
cmake -B %{_vpath_builddir} -LAH
|
||||
|
||||
%cmake_build -j2
|
||||
%cmake_build
|
||||
|
||||
# build selinux policy
|
||||
%if %{with galera}
|
||||
@ -1154,7 +1137,8 @@ rm -r %{buildroot}%{_datadir}/%{pkg_name}/charsets
|
||||
rm %{buildroot}%{_datadir}/%{pkg_name}/errmsg-utf8.txt
|
||||
rm -r %{buildroot}%{_datadir}/%{pkg_name}/{english,czech,danish,dutch,estonian,\
|
||||
french,german,greek,hungarian,italian,japanese,korean,norwegian,norwegian-ny,\
|
||||
polish,portuguese,romanian,russian,serbian,slovak,spanish,swedish,ukrainian,hindi}
|
||||
polish,portuguese,romanian,russian,serbian,slovak,spanish,swedish,ukrainian,hindi,\
|
||||
bulgarian,chinese}
|
||||
%endif
|
||||
|
||||
%if %{without test}
|
||||
@ -1367,6 +1351,8 @@ fi
|
||||
%lang(es) %{_datadir}/%{pkg_name}/spanish
|
||||
%lang(sv) %{_datadir}/%{pkg_name}/swedish
|
||||
%lang(uk) %{_datadir}/%{pkg_name}/ukrainian
|
||||
%lang(bg) %{_datadir}/%{pkg_name}/bulgarian
|
||||
%lang(zh) %{_datadir}/%{pkg_name}/chinese
|
||||
%endif
|
||||
|
||||
%if %{with galera}
|
||||
@ -1637,6 +1623,15 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Jun 13 2022 Michal Schorm <mschorm@redhat.com> - 3:10.5.16-2
|
||||
- Release bump for rebuild
|
||||
|
||||
* Mon May 23 2022 Michal Schorm <mschorm@redhat.com> - 3:10.5.16-1
|
||||
- Rebase to 10.5.16
|
||||
|
||||
* Sun Feb 20 2022 Michal Schorm <mschorm@redhat.com> - 3:10.5.15-1
|
||||
- Rebase to 10.5.15
|
||||
|
||||
* Tue Jan 11 2022 Michal Schorm <mschorm@redhat.com> - 3:10.5.13-1
|
||||
- Rebase to 10.5.13
|
||||
- Add wsrep_sst_rsync_tunnel script
|
||||
|
Loading…
Reference in New Issue
Block a user