Rebase to 10.5.0 - Alpha

This commit is contained in:
Michal Schorm 2020-09-11 09:33:59 +02:00
parent da6d1476e3
commit 1dd39c3767
4 changed files with 45 additions and 20 deletions

View File

@ -0,0 +1,14 @@
Based on this upstream commit:
https://github.com/MariaDB/server/commit/92d6c13206b199f24384ed2504ed479b0f59c314
--- mariadb-10.5.0/sql/CMakeLists.txt 2019-11-28 16:19:01.000000000 +0100
+++ mariadb-10.5.0/sql/CMakeLists.txt_patched 2020-01-22 00:52:28.858844312 +0100
@@ -277,7 +277,7 @@ IF(MSVC AND NOT WITHOUT_DYNAMIC_PLUGINS)
SET_TARGET_PROPERTIES(mysqld_import_lib PROPERTIES IMPORTED_LOCATION ${MYSQLD_LIB})
ENDIF()
-ADD_LIBRARY( sql_builtins ${CMAKE_CURRENT_BINARY_DIR}/sql_builtin.cc)
+ADD_LIBRARY(sql_builtins STATIC ${CMAKE_CURRENT_BINARY_DIR}/sql_builtin.cc)
TARGET_LINK_LIBRARIES(sql_builtins ${MYSQLD_STATIC_PLUGIN_LIBS})
MYSQL_ADD_EXECUTABLE(mysqld ${MYSQLD_SOURCE} DESTINATION ${INSTALL_SBINDIR} COMPONENT Server)

View File

@ -5,25 +5,30 @@ Thus "chown 0" will always fail
Never parse 'ls' output!
http://mywiki.wooledge.org/BashFAQ/087
--- mariadb-10.4.12/scripts/mysql_install_db.sh 2020-01-26 21:43:53.000000000 +0100
+++ mariadb-10.4.12/scripts/mysql_install_db.sh_patched 2020-01-29 11:11:09.448812331 +0100
@@ -482,13 +482,16 @@ if test -n "$user"
then
if test -z "$srcdir" -a "$in_rpm" -eq 0
diff -Nau mariadb-10.5.0/scripts/mysql_install_db.sh.old mariadb-10.5.0/scripts/mysql_install_db.sh
--- mariadb-10.5.0/scripts/mysql_install_db.sh.old 2020-09-08 15:20:02.075081944 +0200
+++ mariadb-10.5.0/scripts/mysql_install_db.sh 2020-09-08 15:21:36.251043330 +0200
@@ -490,13 +490,16 @@
fi
if test -z "$srcdir"
then
- chown 0 "$pamtooldir/auth_pam_tool_dir/auth_pam_tool" && \
- chmod 04755 "$pamtooldir/auth_pam_tool_dir/auth_pam_tool"
- if test $? -ne 0
+ if [ `stat "$pamtooldir/auth_pam_tool_dir/auth_pam_tool" -c %u` -ne 0 ]
then
+ chown 0 "$pamtooldir/auth_pam_tool_dir/auth_pam_tool" && \
+ chmod 04755 "$pamtooldir/auth_pam_tool_dir/auth_pam_tool"
+ if test $? -ne 0
+ then
echo "Couldn't set an owner to '$pamtooldir/auth_pam_tool_dir/auth_pam_tool'."
echo "It must be root, the PAM authentication plugin doesn't work otherwise.."
echo
+ fi
- echo "Couldn't set an owner to '$pamtooldir/auth_pam_tool_dir/auth_pam_tool'."
- echo " It must be root, the PAM authentication plugin doesn't work otherwise.."
- echo
+ chown 0 "$pamtooldir/auth_pam_tool_dir/auth_pam_tool" && \
+ chmod 04755 "$pamtooldir/auth_pam_tool_dir/auth_pam_tool"
+ if test $? -ne 0
+ then
+ echo "Couldn't set an owner to '$pamtooldir/auth_pam_tool_dir/auth_pam_tool'."
+ echo " It must be root, the PAM authentication plugin doesn't work otherwise.."
+ echo
+ fi
fi
chown $user "$pamtooldir/auth_pam_tool_dir" && \
chmod 0700 "$pamtooldir/auth_pam_tool_dir"
fi
args="$args --user=$user"

View File

@ -111,7 +111,7 @@
%bcond_without unbundled_pcre
%else
%bcond_with unbundled_pcre
%global pcre_bundled_version 8.44
%global pcre_bundled_version 8.43
%endif
# Use main python interpretter version
@ -151,8 +151,8 @@
%global sameevr %{epoch}:%{version}-%{release}
Name: mariadb
Version: 10.4.14
Release: 3%{?with_debug:.debug}%{?dist}
Version: 10.5.0
Release: 1%{?with_debug:.debug}%{?dist}
Epoch: 3
Summary: A very fast and robust SQL database server
@ -200,6 +200,8 @@ Patch13: %{pkgnamepatch}-spider_on_armv7hl.patch
Patch15: %{pkgnamepatch}-groonga.patch
# Patch16: Workaround for "chown 0" with priviledges dropped to "mysql" user
Patch16: %{pkgnamepatch}-auth_pam_tool_dir.patch
# Patch17: Fix of an upstream bug. Fixed in the next (10.5.1) version.
Patch17: %{pkgnamepatch}-10.5.0-libsql_builtins.patch
BuildRequires: cmake gcc-c++
BuildRequires: multilib-rpm-config
@ -709,9 +711,10 @@ rm -r storage/rocksdb/
%patch7 -p1
%patch9 -p1
%patch10 -p1
%patch13 -p1
#%patch13 -p1
%patch15 -p1
%patch16 -p1
%patch17 -p1
# workaround for upstream bug #56342
#rm mysql-test/t/ssl_8k_key-master.opt
@ -1580,6 +1583,9 @@ fi
%endif
%changelog
* Tue Sep 08 2020 Michal Schorm <mschorm@redhat.com> - 10.5.0-1
- Test rebase to 10.5.0 - Alpha
* Sun Sep 06 2020 Michal Schorm <mschorm@redhat.com> - 10.4.14-3
- Resolves: #1851605

View File

@ -1 +1 @@
SHA512 (mariadb-10.4.14.tar.gz) = c09817c1dd7962132bcf2886c97ad17ce43c00ee687724028e5f39f6a6a93877ae8695c2c795abba6a4f3bc40674f93a53d6d43f46788a4a8a42c4a65a22c91c
SHA512 (mariadb-10.5.0.tar.gz) = ed7226a0e0b8d0aa435691a43f457bf338b484fc2dd893b8490c65bf99915a089e6c91a86687ef2eaa3728d83a91f5c0dfd7b8ddbefec79f9ad4cd7074bda4c5