diff --git a/mariadb-java-client.spec b/mariadb-java-client.spec
index ac9a2b1..4b6471d 100644
--- a/mariadb-java-client.spec
+++ b/mariadb-java-client.spec
@@ -1,12 +1,11 @@
Name: mariadb-java-client
Version: 2.4.3
-Release: 2%{?dist}
+Release: 3%{?dist}
Summary: Connects applications developed in Java to MariaDB and MySQL databases
# added BSD license because of https://bugzilla.redhat.com/show_bug.cgi?id=1291558#c13
License: BSD and LGPLv2+
URL: https://mariadb.com/kb/en/mariadb/about-mariadb-connector-j/
Source0: https://github.com/MariaDB/mariadb-connector-j/archive/%{version}.tar.gz
-
# optional dependency not in Fedora
Patch0: remove_waffle-jna.patch
@@ -39,17 +38,6 @@ Summary: Javadoc for %{name}
%description javadoc
This package contains the API documentation for %{name}.
-%package tests
-Summary: Tests for %{name}
-Requires: mvn(ch.qos.logback:logback-classic:pom:)
-Requires: mvn(net.java.dev.jna:jna:pom:)
-Requires: mvn(net.java.dev.jna:jna-platform:pom:)
-BuildRequires: mvn(ch.qos.logback:logback-classic:pom:)
-BuildRequires: mvn(com.zaxxer:HikariCP:pom:)
-
-%description tests
-This package contains JUnit tests for %{name}.
-
%prep
%setup -qn mariadb-connector-j-%{version}
@@ -62,6 +50,10 @@ done
# remove missing optional dependency waffle-jna
%pom_remove_dep com.github.waffle:waffle-jna
+%pom_remove_dep ch.qos.logback:logback-classic
+%pom_remove_dep junit:junit
+%pom_remove_dep com.zaxxer:HikariCP
+
# also remove the file using the removed plugin
rm -f src/main/java/org/mariadb/jdbc/internal/com/send/authentication/gssapi/WindowsNativeSspiAuthentication.java
# patch the sources so that the missing file is not making trouble
@@ -84,14 +76,6 @@ rm src/main/resources/META-INF/MANIFEST.MF
%pom_xpath_set "pom:build/pom:plugins/pom:plugin[pom:artifactId='maven-jar-plugin']/pom:configuration/pom:archive/pom:manifestFile" '${project.build.outputDirectory}/META-INF/MANIFEST.MF'
%pom_xpath_remove "pom:build/pom:plugins/pom:plugin[pom:artifactId='maven-jar-plugin']/pom:configuration/pom:archive/pom:manifestEntries"
-%pom_xpath_inject "pom:build/pom:plugins/pom:plugin[pom:artifactId='maven-jar-plugin']" '
-
-
-
- test-jar
-
-
-'
%pom_add_plugin org.apache.felix:maven-bundle-plugin:2.5.4 . '
true
@@ -122,11 +106,10 @@ rm src/main/resources/META-INF/MANIFEST.MF
%build
# tests are skipped, while they require running application server
-%mvn_build -- -DskipTests
+%mvn_build -f
%install
%mvn_install
-cp target/%{name}-%{version}-tests.jar %{buildroot}/%{_jnidir}/%{name}-tests.jar
%files -f .mfiles
%doc documentation/* README.md
@@ -135,11 +118,10 @@ cp target/%{name}-%{version}-tests.jar %{buildroot}/%{_jnidir}/%{name}-tests.jar
%files javadoc -f .mfiles-javadoc
%license LICENSE
-%files tests
-%{_jnidir}/%{name}-tests.jar
-%license LICENSE
-
%changelog
+* Wed Feb 19 2020 Ondrej Dubaj - 2.4.3-3
+- Resolved FTBFS (#1799633)
+
* Wed Jan 29 2020 Fedora Release Engineering - 2.4.3-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild