diff --git a/.gitignore b/.gitignore
index 4efa5ae..a2f5c68 100644
--- a/.gitignore
+++ b/.gitignore
@@ -26,3 +26,4 @@
/2.7.1.tar.gz
/2.7.2.tar.gz
/2.7.3.tar.gz
+/3.0.0.tar.gz
diff --git a/mariadb-java-client.spec b/mariadb-java-client.spec
index 0da3476..18f5659 100644
--- a/mariadb-java-client.spec
+++ b/mariadb-java-client.spec
@@ -1,6 +1,6 @@
Name: mariadb-java-client
-Version: 2.7.3
-Release: 2%{?dist}
+Version: 3.0.0
+Release: 1%{?dist}
Summary: Connects applications developed in Java to MariaDB and MySQL databases
# added BSD license because of https://bugzilla.redhat.com/show_bug.cgi?id=1291558#c13
License: BSD and LGPLv2+
@@ -39,29 +39,27 @@ This package contains the API documentation for %{name}.
%prep
%setup -qn mariadb-connector-j-%{version}
-# convert files from dos to unix line encoding
-for file in README.md documentation/*.creole; do
- sed -i.orig 's|\r||g' $file
- touch -r $file.orig $file
- rm $file.orig
-done
-
# remove missing optional dependency waffle-jna
%pom_remove_dep com.github.waffle:waffle-jna
%pom_remove_dep ch.qos.logback:logback-classic
-%pom_remove_dep junit:junit
%pom_remove_dep com.amazonaws:aws-java-sdk-rds
+%pom_remove_dep com.amazonaws:aws-java-sdk-bom
+%pom_remove_dep org.junit:junit-bom
+
+%pom_add_dep net.java.dev.jna:jna
+%pom_add_dep net.java.dev.jna:jna-platform
+%pom_add_dep org.slf4j:slf4j-api
# use latest OSGi implementation
%pom_change_dep -r :org.osgi.core org.osgi:osgi.core
%pom_change_dep -r :org.osgi.compendium org.osgi:osgi.cmpn
-rm -r src/main/java/org/mariadb/jdbc/credential/aws
-
-sed -i 's|org.osgi.compendium|osgi.cmpn|' pom.xml
+rm -r src/main/java/org/mariadb/jdbc/plugin/credential/aws
+
+sed -i 's/public void close() {/public void close() throws Exception {/' src/main/java/org/mariadb/jdbc/pool/Pool.java
# also remove the file using the removed plugin
-rm -f src/main/java/org/mariadb/jdbc/internal/com/send/authentication/gssapi/WindowsNativeSspiAuthentication.java
+rm -f src/main/java/org/mariadb/jdbc/plugin/authentication/addon/gssapi/WindowsNativeSspiAuthentication.java
# patch the sources so that the missing file is not making trouble
%patch0 -p1
@@ -75,40 +73,6 @@ rm -f src/main/java/org/mariadb/jdbc/internal/com/send/authentication/gssapi/Win
%pom_remove_plugin -r :maven-gpg-plugin
%pom_remove_plugin -r :maven-javadoc-plugin
-# remove preconfigured OSGi manifest file and generate OSGi manifest file
-# with maven-bundle-plugin instead of using maven-jar-plugin
-rm src/main/resources/META-INF/MANIFEST.MF
-%pom_xpath_set "pom:packaging" bundle
-%pom_xpath_set "pom:build/pom:plugins/pom:plugin[pom:artifactId='maven-jar-plugin']/pom:configuration/pom:archive/pom:manifestFile" '${project.build.outputDirectory}/META-INF/MANIFEST.MF'
-%pom_xpath_remove "pom:build/pom:plugins/pom:plugin[pom:artifactId='maven-jar-plugin']/pom:configuration/pom:archive/pom:manifestEntries"
-
-%pom_add_plugin org.apache.felix:maven-bundle-plugin:2.5.4 . '
-true
-
-
- ${project.groupId}
- MariaDB JDBC Client
- ${project.version}.0
- org.mariadb.jdbc.*
-
- !com.sun.jna.*,
- javax.net;resolution:=optional,
- javax.net.ssl;resolution:=optional,
- javax.sql;resolution:=optional,
- javax.transaction.xa;resolution:=optional
-
-
-
-
-
- bundle-manifest
- process-classes
-
- manifest
-
-
-'
-
%build
# tests are skipped, while they require running application server
%mvn_build -f
@@ -117,13 +81,16 @@ rm src/main/resources/META-INF/MANIFEST.MF
%mvn_install
%files -f .mfiles
-%doc documentation/* README.md
+%doc README.md
%license LICENSE
%files javadoc -f .mfiles-javadoc
%license LICENSE
%changelog
+* Fri Jul 23 2021 Ondrej Dubaj - 3.0.0-1
+- Rebase to version 3.0.0
+
* Thu Jul 22 2021 Fedora Release Engineering - 2.7.3-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
diff --git a/remove_waffle-jna.patch b/remove_waffle-jna.patch
index e30649c..b162481 100644
--- a/remove_waffle-jna.patch
+++ b/remove_waffle-jna.patch
@@ -1,24 +1,21 @@
-From c1e587054376db950495c02672675c801f454a6b Mon Sep 17 00:00:00 2001
-From: Ondrej Dubaj
-Date: Mon, 10 Feb 2020 18:08:39 +0100
+Date: Thu, 6 May 2021 08:28:06 +0200
Subject: [PATCH] remove waffle-jna
---
- .../send/authentication/gssapi/GssUtility.java | 18 ++----------------
- 1 file changed, 2 insertions(+), 16 deletions(-)
+ .../authentication/addon/gssapi/GssUtility.java | 17 +----------------
+ 1 file changed, 1 insertion(+), 16 deletions(-)
-diff --git a/src/main/java/org/mariadb/jdbc/internal/com/send/authentication/gssapi/GssUtility.java b/src/main/java/org/mariadb/jdbc/internal/com/send/authentication/gssapi/GssUtility.java
-index 810500e..127b580 100644
---- a/src/main/java/org/mariadb/jdbc/internal/com/send/authentication/gssapi/GssUtility.java
-+++ b/src/main/java/org/mariadb/jdbc/internal/com/send/authentication/gssapi/GssUtility.java
-@@ -5,26 +5,12 @@ import com.sun.jna.*;
+diff --git a/src/main/java/org/mariadb/jdbc/plugin/authentication/addon/gssapi/GssUtility.java b/src/main/java/org/mariadb/jdbc/plugin/authentication/addon/gssapi/GssUtility.java
+index 5f050df..1801701 100644
+--- a/src/main/java/org/mariadb/jdbc/plugin/authentication/addon/gssapi/GssUtility.java
++++ b/src/main/java/org/mariadb/jdbc/plugin/authentication/addon/gssapi/GssUtility.java
+@@ -9,26 +9,11 @@ import com.sun.jna.Platform;
public class GssUtility {
/**
- * Get authentication method according to classpath. Windows native authentication is using
- * Waffle-jna.
-+ * Get authentication method according to classpath.
-+ *
++ * Get authentication method according to classpath
*
* @return authentication method
*/
@@ -41,5 +38,5 @@ index 810500e..127b580 100644
}
}
--
-2.19.1
+2.30.2
diff --git a/sources b/sources
index 342db65..877df9b 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-SHA512 (2.7.3.tar.gz) = dcc621c0169557aeeebc239f1d9402e77bb0eb4cdc39da6ae1fe83fa56652d07bbda47ec70c138dc2a12a3a720c42a0d20a03edb64f6903b326abae26afaf783
+SHA512 (3.0.0.tar.gz) = cc583bc471a2856d4e9a55c8a22f2ea319b43ec299df7380e42a3cbf3b5abb292e47e151b784beb88488618184f7a23d79b958d369be862d8e610d2766e89412