Rebase to version 3.0.2
Library libmariadb.so.3 introduced Plugin Remote-IO enabled
This commit is contained in:
parent
8c79813e4c
commit
e231d8c311
1
.gitignore
vendored
1
.gitignore
vendored
@ -3,3 +3,4 @@
|
|||||||
/mariadb-connector-c-2.3.1-src.tar.gz
|
/mariadb-connector-c-2.3.1-src.tar.gz
|
||||||
/mariadb-connector-c-2.3.2-src.tar.gz
|
/mariadb-connector-c-2.3.2-src.tar.gz
|
||||||
/mariadb-connector-c-2.3.3-src.tar.gz
|
/mariadb-connector-c-2.3.3-src.tar.gz
|
||||||
|
/mariadb-connector-c-3.0.2-src.tar.gz
|
||||||
|
16
cmake.patch
Normal file
16
cmake.patch
Normal file
@ -0,0 +1,16 @@
|
|||||||
|
--- mariadb-connector-c-3.0.2-src/cmake/install.cmake 2017-07-19 11:31:02.000000000 +0200
|
||||||
|
+++ mariadb-connector-c-3.0.2-src/cmake/install.cmake.patched 2017-07-24 18:04:45.791679206 +0200
|
||||||
|
@@ -76,11 +76,11 @@ SET(INSTALL_PLUGINDIR_DEFAULT "lib/maria
|
||||||
|
# RPM layout
|
||||||
|
#
|
||||||
|
SET(INSTALL_BINDIR_RPM "bin")
|
||||||
|
-IF(CMAKE_SYSTEM_PROCESSOR MATCHES "x86_64" AND CMAKE_SIZEOF_VOID_P EQUAL 8)
|
||||||
|
+IF((CMAKE_SYSTEM_PROCESSOR MATCHES "x86_64" OR CMAKE_SYSTEM_PROCESSOR MATCHES "ppc64" OR CMAKE_SYSTEM_PROCESSOR MATCHES "ppc64le" OR CMAKE_SYSTEM_PROCESSOR MATCHES "aarch64" OR CMAKE_SYSTEM_PROCESSOR MATCHES "s390x") AND CMAKE_SIZEOF_VOID_P EQUAL 8)
|
||||||
|
SET(INSTALL_LIBDIR_RPM "lib64/mariadb")
|
||||||
|
SET(INSTALL_PLUGINDIR_RPM "lib64/mariadb/plugin")
|
||||||
|
ELSE()
|
||||||
|
- SET(INSTALL_LIBDIR_RPM "lib")
|
||||||
|
+ SET(INSTALL_LIBDIR_RPM "lib/mariadb")
|
||||||
|
SET(INSTALL_PLUGINDIR_RPM "lib/mariadb/plugin")
|
||||||
|
ENDIF()
|
||||||
|
SET(INSTALL_INCLUDEDIR_RPM "include")
|
@ -1,17 +1,24 @@
|
|||||||
Name: mariadb-connector-c
|
Name: mariadb-connector-c
|
||||||
Version: 2.3.3
|
Version: 3.0.2
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: The MariaDB Native Client library (C driver)
|
Summary: The MariaDB Native Client library (C driver)
|
||||||
Group: Applications/Databases
|
Group: Applications/Databases
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Source: https://downloads.mariadb.org/interstitial/connector-c-%{version}/mariadb-connector-c-%{version}-src.tar.gz
|
Source: https://downloads.mariadb.org/interstitial/connector-c-%{version}/mariadb-connector-c-%{version}-src.tar.gz
|
||||||
Url: http://mariadb.org/
|
Url: http://mariadb.org/
|
||||||
|
# Informations: https://mariadb.com/kb/en/mariadb/building-connectorc-from-source/
|
||||||
|
|
||||||
BuildRequires: zlib-devel cmake openssl-devel
|
BuildRequires: zlib-devel cmake openssl-devel
|
||||||
|
# Remote-IO plugin
|
||||||
|
BuildRequires: libcurl-devel
|
||||||
|
|
||||||
# RPMLint issues of 2.3.2 release tracked on the upstream JIRA:
|
# RPMLint issues of 2.3.2 release tracked on the upstream JIRA:
|
||||||
# https://jira.mariadb.org/browse/CONC-232
|
# https://jira.mariadb.org/browse/CONC-232
|
||||||
# https://jira.mariadb.org/browse/CONC-234
|
# https://jira.mariadb.org/browse/CONC-234
|
||||||
|
|
||||||
|
# Patch for "-DINSTALL_LAYOUT=RPM"
|
||||||
|
Patch1: cmake.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
The MariaDB Native Client library (C driver) is used to connect applications
|
The MariaDB Native Client library (C driver) is used to connect applications
|
||||||
developed in C/C++ to MariaDB and MySQL databases.
|
developed in C/C++ to MariaDB and MySQL databases.
|
||||||
@ -29,15 +36,21 @@ Development files for mariadb-connector-c.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n mariadb-connector-c-%{version}-src
|
%setup -q -n mariadb-connector-c-%{version}-src
|
||||||
|
%patch1 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%cmake \
|
%cmake . \
|
||||||
.\
|
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
|
||||||
-DMYSQL_UNIX_ADDR=/var/lib/mysql/mysql.sock\
|
-DMYSQL_UNIX_ADDR=/var/lib/mysql/mysql.sock \
|
||||||
-DWITH_EXTERNAL_ZLIB=ON\
|
-DWITH_EXTERNAL_ZLIB=ON \
|
||||||
-DPREFIX_INSTALL_DIR="/"\
|
-DCMAKE_SYSTEM_PROCESSOR="%{_arch}" \
|
||||||
-DCMAKE_SYSTEM_PROCESSOR="%{_arch}"\
|
-DPLUGIN_INSTALL_DIR="%{_libdir}/mariadb/plugin" \
|
||||||
-DPLUGIN_INSTALL_DIR="%{_libdir}/mariadb/plugin"
|
-DWITH_MYSQLCOMPAT=ON \
|
||||||
|
-DINSTALL_LAYOUT=RPM \
|
||||||
|
-DWITH_SSL=OPENSSL \
|
||||||
|
|
||||||
|
# Causes build errors
|
||||||
|
# -DAUTH_NATIVE=DYNAMIC
|
||||||
|
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
@ -47,17 +60,10 @@ make install DESTDIR=%{buildroot}
|
|||||||
mkdir -p %{buildroot}%{_sysconfdir}/ld.so.conf.d
|
mkdir -p %{buildroot}%{_sysconfdir}/ld.so.conf.d
|
||||||
echo "%{_libdir}/mariadb" > %{buildroot}%{_sysconfdir}/ld.so.conf.d/%{name}-%{_arch}.conf
|
echo "%{_libdir}/mariadb" > %{buildroot}%{_sysconfdir}/ld.so.conf.d/%{name}-%{_arch}.conf
|
||||||
|
|
||||||
# static linked libraries
|
# static linked libraries and symlinks to them
|
||||||
rm %{buildroot}%{_libdir}/mariadb/*.a
|
rm %{buildroot}%{_libdir}/mariadb/libmariadbclient.a
|
||||||
|
rm %{buildroot}%{_libdir}/mariadb/libmysqlclient.a
|
||||||
rm -r %{buildroot}%{_includedir}/mariadb/CMakeFiles
|
rm %{buildroot}%{_libdir}/mariadb/libmysqlclient_r.a
|
||||||
rm %{buildroot}%{_includedir}/mariadb/Makefile
|
|
||||||
rm %{buildroot}%{_includedir}/mariadb/CMakeLists.txt
|
|
||||||
rm %{buildroot}%{_includedir}/mariadb/cmake_install.cmake
|
|
||||||
|
|
||||||
# *.in files are produced while creating final *.h files
|
|
||||||
rm %{buildroot}%{_includedir}/mariadb/mysql_version.h.in
|
|
||||||
rm %{buildroot}%{_includedir}/mariadb/my_config.h.in
|
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
@ -67,7 +73,7 @@ rm %{buildroot}%{_includedir}/mariadb/my_config.h.in
|
|||||||
|
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%{_libdir}/mariadb/libmariadb.so.2
|
%{_libdir}/mariadb/libmariadb.so.*
|
||||||
%{_libdir}/mariadb/plugin
|
%{_libdir}/mariadb/plugin
|
||||||
|
|
||||||
# fix of RPATH. If there is a set config file, libdir/mariadb/ is added to search for libraries
|
# fix of RPATH. If there is a set config file, libdir/mariadb/ is added to search for libraries
|
||||||
@ -83,20 +89,20 @@ rm %{buildroot}%{_includedir}/mariadb/my_config.h.in
|
|||||||
%{_bindir}/mariadb_config
|
%{_bindir}/mariadb_config
|
||||||
|
|
||||||
%{_libdir}/mariadb
|
%{_libdir}/mariadb
|
||||||
%exclude %{_libdir}/mariadb/libmariadb.so.2
|
%exclude %{_libdir}/mariadb/libmariadb.so.*
|
||||||
%exclude %{_libdir}/mariadb/plugin
|
%exclude %{_libdir}/mariadb/plugin
|
||||||
|
|
||||||
# header files
|
# header files
|
||||||
%{_includedir}/mariadb
|
%{_includedir}/*
|
||||||
|
|
||||||
%license COPYING.LIB
|
%license COPYING.LIB
|
||||||
|
|
||||||
# Check everytime, if all the symlinks to the .so lib remained
|
|
||||||
#%{_libdir}/mariadb/libmariadb.so
|
|
||||||
#%{_libdir}/mariadb/libmysqlclient_r.so
|
|
||||||
#%{_libdir}/mariadb/libmysqlclient.so
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jun 07 2017 Michal Schorm <mschorm@redhat.com> - 3.0.2-1
|
||||||
|
- Rebase to version 3.0.2
|
||||||
|
- Library libmariadb.so.3 introduced
|
||||||
|
- Plugin Remote-IO enabled
|
||||||
|
|
||||||
* Wed Jun 07 2017 Michal Schorm <mschorm@redhat.com> - 2.3.3-1
|
* Wed Jun 07 2017 Michal Schorm <mschorm@redhat.com> - 2.3.3-1
|
||||||
- Rebase to version 2.3.3
|
- Rebase to version 2.3.3
|
||||||
- Patch dropped, solved by upstream; https://jira.mariadb.org/browse/CONC-231
|
- Patch dropped, solved by upstream; https://jira.mariadb.org/browse/CONC-231
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (mariadb-connector-c-2.3.3-src.tar.gz) = 52c3e8fbb91d3689c63f4ef2cdd6dbfbf0e039b87a6b8b7e17ee473817f076dcb26603330853e69e166c86d5dff9f25c9e98f36cded7d2ad97ef929e4b4e664d
|
SHA512 (mariadb-connector-c-3.0.2-src.tar.gz) = 215881164aae749f93b75d370815875a9b30179d14773a4be641fdb0d38b3a7eff112a0b322279b6980afe354d2f24da122d5c48caa5427d2be7761b4fa2277d
|
||||||
|
Loading…
Reference in New Issue
Block a user