Rebase to version 2.3.3
Patch "v2.3.2" dropped, solved by upstream
This commit is contained in:
parent
ab4d524cec
commit
d4edcb7114
1
.gitignore
vendored
1
.gitignore
vendored
@ -2,3 +2,4 @@
|
||||
/mariadb-connector-c-2.1.0-src.tar.gz
|
||||
/mariadb-connector-c-2.3.1-src.tar.gz
|
||||
/mariadb-connector-c-2.3.2-src.tar.gz
|
||||
/mariadb-connector-c-2.3.3-src.tar.gz
|
||||
|
@ -1,6 +1,6 @@
|
||||
Name: mariadb-connector-c
|
||||
Version: 2.3.2
|
||||
Release: 2%{?dist}
|
||||
Version: 2.3.3
|
||||
Release: 1%{?dist}
|
||||
Summary: The MariaDB Native Client library (C driver)
|
||||
Group: Applications/Databases
|
||||
License: LGPLv2+
|
||||
@ -8,11 +8,7 @@ Source: http://mirror.hosting90.cz/mariadb/connector-c-%{version}/mariad
|
||||
Url: http://mariadb.org/
|
||||
BuildRequires: zlib-devel cmake openssl-devel
|
||||
|
||||
# Patch only for version 2.3.2. The issue on Big endian architectures has been solved by upstream and fixed in all later relases.
|
||||
Patch1: v2-3-2.patch
|
||||
|
||||
# RPMLint issues of 2.3.2 release tracked on the upstream JIRA:
|
||||
# https://jira.mariadb.org/browse/CONC-231
|
||||
# https://jira.mariadb.org/browse/CONC-232
|
||||
# https://jira.mariadb.org/browse/CONC-234
|
||||
|
||||
@ -33,7 +29,6 @@ Development files for mariadb-connector-c.
|
||||
|
||||
%prep
|
||||
%setup -q -n mariadb-connector-c-%{version}-src
|
||||
%patch1 -p1
|
||||
|
||||
%build
|
||||
%cmake \
|
||||
@ -55,9 +50,6 @@ echo "%{_libdir}/mariadb" > %{buildroot}%{_sysconfdir}/ld.so.conf.d/%{name}-%{_a
|
||||
# static linked libraries
|
||||
rm %{buildroot}%{_libdir}/mariadb/*.a
|
||||
|
||||
# Makefile.am is a programmer-defined file and is used by automake to generate the Makefile.in
|
||||
rm %{buildroot}%{_includedir}/mariadb/Makefile.am
|
||||
|
||||
rm -r %{buildroot}%{_includedir}/mariadb/CMakeFiles
|
||||
rm %{buildroot}%{_includedir}/mariadb/Makefile
|
||||
rm %{buildroot}%{_includedir}/mariadb/CMakeLists.txt
|
||||
@ -102,6 +94,10 @@ rm %{buildroot}%{_includedir}/mariadb/my_config.h.in
|
||||
%license COPYING.LIB
|
||||
|
||||
%changelog
|
||||
* Wed Jun 07 2017 Michal Schorm <mschorm@redhat.com> - 2.3.3-1
|
||||
- Rebase to version 2.3.3
|
||||
- Patch dropped, solved by upstream; https://jira.mariadb.org/browse/CONC-231
|
||||
|
||||
* Tue Feb 07 2017 Michal Schorm <mschorm@redhat.com> - 2.3.2-2
|
||||
- Fix based on output from RPMLint in previous version
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (mariadb-connector-c-2.3.2-src.tar.gz) = e0055403357b96fe1f14acb238749350e3e3455303d043af6f3ddf0157676b8cf6895964b6c2c21dd8b7c065ffa65a2e574b74257501a5e9e6f6d995624dfc98
|
||||
SHA512 (mariadb-connector-c-2.3.3-src.tar.gz) = 52c3e8fbb91d3689c63f4ef2cdd6dbfbf0e039b87a6b8b7e17ee473817f076dcb26603330853e69e166c86d5dff9f25c9e98f36cded7d2ad97ef929e4b4e664d
|
||||
|
14
v2-3-2.patch
14
v2-3-2.patch
@ -1,14 +0,0 @@
|
||||
This patch fixes FTBFS problems on big endian architectures (ppc64 and s390x)
|
||||
This patch is an upstream fix, which will appear in the next version
|
||||
|
||||
--- mariadb-connector-c-2.3.2-src/libmariadb/my_stmt_codec.c 2017-01-17 10:53:54.000000000 +0100
|
||||
+++ mariadb-connector-c-2.3.2-src/libmariadb/my_stmt_codec.c_patched 2017-01-23 23:24:00.489702554 +0100
|
||||
@@ -358,7 +358,7 @@ static void convert_from_long(MYSQL_BIND
|
||||
{
|
||||
float fval;
|
||||
fval= is_unsigned ? (float)(ulonglong)(val) : (float)val;
|
||||
- float4store(r_param->buffer, fval);
|
||||
+ float4store((float *)r_param->buffer, fval);
|
||||
*r_param->error= is_unsigned ? (ulonglong)fval != (ulonglong)val : (longlong)fval != val;
|
||||
r_param->buffer_length= 4;
|
||||
}
|
Loading…
Reference in New Issue
Block a user