Update to mandoc-1.14.5
This commit is contained in:
parent
e771fcd04a
commit
8e2f011858
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
||||
/mandoc-1.14.4.tar.gz
|
||||
/mandoc-1.14.5.tar.gz
|
||||
|
@ -1,19 +1,19 @@
|
||||
diff -purN mandoc-1.14.4.orig/Makefile mandoc-1.14.4/Makefile
|
||||
--- mandoc-1.14.4.orig/Makefile 2019-02-07 12:03:35.614493086 -0500
|
||||
+++ mandoc-1.14.4/Makefile 2019-02-07 12:04:04.825552194 -0500
|
||||
@@ -430,7 +430,7 @@ lib-install: libmandoc.so.$(SOVERSION)
|
||||
diff -up mandoc-1.14.5/Makefile.orig mandoc-1.14.5/Makefile
|
||||
--- mandoc-1.14.5/Makefile.orig 2019-10-16 10:12:02.427888365 -0400
|
||||
+++ mandoc-1.14.5/Makefile 2019-10-16 10:12:39.502809508 -0400
|
||||
@@ -446,7 +446,7 @@ lib-install: libmandoc.so.$(SOVERSION)
|
||||
$(INSTALL_LIB) libmandoc.so.$(SOVERSION) $(DESTDIR)$(LIBDIR)
|
||||
ln -s libmandoc.so.$(SOVERSION) $(DESTDIR)$(LIBDIR)/libmandoc.so.$(SOMAJOR)
|
||||
ln -s libmandoc.so.$(SOVERSION) $(DESTDIR)$(LIBDIR)/libmandoc.so
|
||||
- $(INSTALL_LIB) man.h mandoc.h mandoc_aux.h mdoc.h roff.h \
|
||||
+ $(INSTALL_HDR) man.h mandoc.h mandoc_aux.h mdoc.h roff.h \
|
||||
$(DESTDIR)$(INCLUDEDIR)
|
||||
- $(INSTALL_LIB) eqn.h man.h mandoc.h mandoc_aux.h mandoc_parse.h \
|
||||
+ $(INSTALL_HDR) eqn.h man.h mandoc.h mandoc_aux.h mandoc_parse.h \
|
||||
mdoc.h roff.h tbl.h $(DESTDIR)$(INCLUDEDIR)
|
||||
$(INSTALL_MAN) mandoc.3 mandoc_escape.3 mandoc_malloc.3 \
|
||||
mansearch.3 mchars_alloc.3 tbl.3 $(DESTDIR)$(MANDIR)/man3
|
||||
diff -purN mandoc-1.14.4.orig/configure mandoc-1.14.4/configure
|
||||
--- mandoc-1.14.4.orig/configure 2018-08-08 10:51:51.000000000 -0400
|
||||
+++ mandoc-1.14.4/configure 2019-02-07 12:04:04.826552196 -0500
|
||||
@@ -119,6 +119,7 @@ MANM_TBL="tbl"
|
||||
diff -up mandoc-1.14.5/configure.orig mandoc-1.14.5/configure
|
||||
--- mandoc-1.14.5/configure.orig 2019-03-10 05:56:43.000000000 -0400
|
||||
+++ mandoc-1.14.5/configure 2019-10-16 10:13:30.798700410 -0400
|
||||
@@ -124,6 +124,7 @@ MANM_TBL="tbl"
|
||||
INSTALL="install"
|
||||
INSTALL_PROGRAM=
|
||||
INSTALL_LIB=
|
||||
@ -21,7 +21,7 @@ diff -purN mandoc-1.14.4.orig/configure mandoc-1.14.4/configure
|
||||
INSTALL_MAN=
|
||||
INSTALL_DATA=
|
||||
LN="ln -f"
|
||||
@@ -523,6 +524,7 @@ exec > Makefile.local
|
||||
@@ -579,6 +580,7 @@ exec > Makefile.local
|
||||
|
||||
[ -z "${INSTALL_PROGRAM}" ] && INSTALL_PROGRAM="${INSTALL} -m 0555"
|
||||
[ -z "${INSTALL_LIB}" ] && INSTALL_LIB="${INSTALL} -m 0444"
|
||||
@ -29,7 +29,7 @@ diff -purN mandoc-1.14.4.orig/configure mandoc-1.14.4/configure
|
||||
[ -z "${INSTALL_MAN}" ] && INSTALL_MAN="${INSTALL} -m 0444"
|
||||
[ -z "${INSTALL_DATA}" ] && INSTALL_DATA="${INSTALL} -m 0444"
|
||||
|
||||
@@ -569,6 +571,7 @@ MANM_TBL = ${MANM_TBL}
|
||||
@@ -625,6 +627,7 @@ MANM_TBL = ${MANM_TBL}
|
||||
INSTALL = ${INSTALL}
|
||||
INSTALL_PROGRAM = ${INSTALL_PROGRAM}
|
||||
INSTALL_LIB = ${INSTALL_LIB}
|
||||
|
@ -1,18 +1,18 @@
|
||||
diff -purN mandoc-1.14.4.orig/Makefile mandoc-1.14.4/Makefile
|
||||
--- mandoc-1.14.4.orig/Makefile 2018-08-08 10:51:51.000000000 -0400
|
||||
+++ mandoc-1.14.4/Makefile 2019-02-07 12:23:55.743962101 -0500
|
||||
diff -up mandoc-1.14.5/Makefile.orig mandoc-1.14.5/Makefile
|
||||
--- mandoc-1.14.5/Makefile.orig 2019-03-10 05:56:43.000000000 -0400
|
||||
+++ mandoc-1.14.5/Makefile 2019-10-16 10:07:11.999691172 -0400
|
||||
@@ -17,6 +17,10 @@
|
||||
|
||||
VERSION = 1.14.4
|
||||
VERSION = 1.14.5
|
||||
|
||||
+# version for the shared object file
|
||||
+SOMAJOR = 1
|
||||
+SOMAJOR = 2
|
||||
+SOVERSION = $(SOMAJOR).0
|
||||
+
|
||||
# === LIST OF FILES ====================================================
|
||||
|
||||
TESTSRCS = test-be32toh.c \
|
||||
@@ -357,7 +361,7 @@ include Makefile.local
|
||||
@@ -373,7 +377,7 @@ include Makefile.local
|
||||
|
||||
# === DEPENDENCY HANDLING ==============================================
|
||||
|
||||
@ -21,7 +21,7 @@ diff -purN mandoc-1.14.4.orig/Makefile mandoc-1.14.4/Makefile
|
||||
|
||||
install: base-install $(INSTALL_TARGETS)
|
||||
|
||||
@@ -372,11 +376,15 @@ include Makefile.depend
|
||||
@@ -388,11 +392,15 @@ include Makefile.depend
|
||||
|
||||
# === TARGETS CONTAINING SHELL COMMANDS ================================
|
||||
|
||||
@ -38,7 +38,7 @@ diff -purN mandoc-1.14.4.orig/Makefile mandoc-1.14.4/Makefile
|
||||
rm -f mandoc $(MAIN_OBJS)
|
||||
rm -f man.cgi $(CGI_OBJS)
|
||||
rm -f mandocd catman catman.o $(MANDOCD_OBJS)
|
||||
@@ -415,11 +423,13 @@ base-install: mandoc demandoc soelim
|
||||
@@ -431,11 +439,13 @@ base-install: mandoc demandoc soelim
|
||||
$(INSTALL_MAN) makewhatis.8 \
|
||||
$(DESTDIR)$(MANDIR)/man8/$(BINM_MAKEWHATIS).8
|
||||
|
||||
@ -51,10 +51,10 @@ diff -purN mandoc-1.14.4.orig/Makefile mandoc-1.14.4/Makefile
|
||||
+ $(INSTALL_LIB) libmandoc.so.$(SOVERSION) $(DESTDIR)$(LIBDIR)
|
||||
+ ln -s libmandoc.so.$(SOVERSION) $(DESTDIR)$(LIBDIR)/libmandoc.so.$(SOMAJOR)
|
||||
+ ln -s libmandoc.so.$(SOVERSION) $(DESTDIR)$(LIBDIR)/libmandoc.so
|
||||
$(INSTALL_LIB) man.h mandoc.h mandoc_aux.h mdoc.h roff.h \
|
||||
$(DESTDIR)$(INCLUDEDIR)
|
||||
$(INSTALL_LIB) eqn.h man.h mandoc.h mandoc_aux.h mandoc_parse.h \
|
||||
mdoc.h roff.h tbl.h $(DESTDIR)$(INCLUDEDIR)
|
||||
$(INSTALL_MAN) mandoc.3 mandoc_escape.3 mandoc_malloc.3 \
|
||||
@@ -468,7 +478,8 @@ uninstall:
|
||||
@@ -484,7 +494,8 @@ uninstall:
|
||||
rm -f $(DESTDIR)$(SBINDIR)/$(BINM_CATMAN)
|
||||
rm -f $(DESTDIR)$(MANDIR)/man8/mandocd.8
|
||||
rm -f $(DESTDIR)$(MANDIR)/man8/$(BINM_CATMAN).8
|
||||
@ -64,7 +64,7 @@ diff -purN mandoc-1.14.4.orig/Makefile mandoc-1.14.4/Makefile
|
||||
rm -f $(DESTDIR)$(MANDIR)/man3/mandoc.3
|
||||
rm -f $(DESTDIR)$(MANDIR)/man3/mandoc_escape.3
|
||||
rm -f $(DESTDIR)$(MANDIR)/man3/mandoc_malloc.3
|
||||
@@ -495,20 +506,29 @@ Makefile.local config.h: configure $(TES
|
||||
@@ -514,20 +525,29 @@ Makefile.local config.h: configure $(TES
|
||||
libmandoc.a: $(COMPAT_OBJS) $(LIBMANDOC_OBJS)
|
||||
ar rs $@ $(COMPAT_OBJS) $(LIBMANDOC_OBJS)
|
||||
|
||||
|
14
mandoc.spec
14
mandoc.spec
@ -1,6 +1,6 @@
|
||||
Name: mandoc
|
||||
Version: 1.14.4
|
||||
Release: 3%{?dist}
|
||||
Version: 1.14.5
|
||||
Release: 1%{?dist}
|
||||
Summary: A suite of tools for compiling mdoc and man
|
||||
|
||||
License: ISC
|
||||
@ -121,17 +121,20 @@ env LD_LIBRARY_PATH="$PWD" make regress
|
||||
|
||||
%files -n libmandoc
|
||||
%license LICENSE
|
||||
%{_libdir}/libmandoc.so.1.0
|
||||
%{_libdir}/libmandoc.so.1
|
||||
%{_libdir}/libmandoc.so.2.0
|
||||
%{_libdir}/libmandoc.so.2
|
||||
|
||||
%files -n libmandoc-devel
|
||||
%license LICENSE
|
||||
%{_libdir}/libmandoc.so
|
||||
%{_includedir}/eqn.h
|
||||
%{_includedir}/man.h
|
||||
%{_includedir}/mandoc.h
|
||||
%{_includedir}/mandoc_aux.h
|
||||
%{_includedir}/mandoc_parse.h
|
||||
%{_includedir}/mdoc.h
|
||||
%{_includedir}/roff.h
|
||||
%{_includedir}/tbl.h
|
||||
%{_mandir}/man3/mandoc.3*
|
||||
%{_mandir}/man3/mandoc_escape.3*
|
||||
%{_mandir}/man3/mandoc_malloc.3*
|
||||
@ -140,6 +143,9 @@ env LD_LIBRARY_PATH="$PWD" make regress
|
||||
%{_mandir}/man3/tbl.3*
|
||||
|
||||
%changelog
|
||||
* Wed Oct 16 2019 David Cantrell <dcantrell@redhat.com> - 1.14.5-1
|
||||
- Update to mandoc-1.14.5
|
||||
|
||||
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.14.4-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (mandoc-1.14.4.tar.gz) = c68390711a739284ad9a61364f3fea76c0c48c02b4830d6326b07c4188d099e3720ae3b91fc3b083269381b417b7e3f3647d13a54ed2548f8c2f94122f8a7d97
|
||||
SHA512 (mandoc-1.14.5.tar.gz) = 848f290847f3095757f25647e6d73eb7044018b145bf6f9dc8b5db164b1421911efdc5b3b9022ec3a2c5af9687a84d5acedee810f2bd2f7caaa9242dadb2cc52
|
||||
|
Loading…
Reference in New Issue
Block a user