Import rpm: c8s

This commit is contained in:
James Antill 2023-02-27 14:20:28 -05:00
commit 221c974397
12 changed files with 768 additions and 0 deletions

2
.gitignore vendored Normal file
View File

@ -0,0 +1,2 @@
SOURCES/man-pages-overrides-8.6.0.0.tar.xz
/man-pages-overrides-8.6.0.0.tar.xz

View File

@ -0,0 +1,280 @@
From f5546b84f888fe41d0b3288f237a7d7d5fa16a4d Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Nikola=20Forr=C3=B3?= <nforro@redhat.com>
Date: Wed, 18 Dec 2019 17:25:40 +0100
Subject: [PATCH] jose-*.1: fix typographical errors
---
jose/man1/jose-fmt.1 | 6 +++---
jose/man1/jose-jwe-enc.1 | 10 +++++-----
jose/man1/jose-jwk-exc.1 | 6 +++---
jose/man1/jose-jwk-gen.1 | 20 ++++++++++----------
jose/man1/jose-jwk-pub.1 | 4 ++--
jose/man1/jose-jwk-thp.1 | 4 ++--
jose/man1/jose-jwk-use.1 | 4 ++--
jose/man1/jose-jws-sig.1 | 8 ++++----
8 files changed, 31 insertions(+), 31 deletions(-)
diff --git a/jose/man1/jose-fmt.1 b/jose/man1/jose-fmt.1
index 8e1b042..a423a99 100644
--- a/jose/man1/jose-fmt.1
+++ b/jose/man1/jose-fmt.1
@@ -1,7 +1,7 @@
.\" generated with Ronn/v0.7.3
.\" http://github.com/rtomayko/ronn/tree/0.7.3
.
-.TH "JOSE\-FMT" "1" "June 2017" "" ""
+.TH "JOSE\-FMT" "1" "August 2019" "" ""
.
.SH "NAME"
\fBjose\-fmt\fR \- Converts JSON between serialization formats
@@ -237,7 +237,7 @@ Change the algorithm in a JWK:
.
.nf
-$ echo "$jwk" | jose fmt \-j\- \-j \'"A128GCM"\' \-s alg \-Uo\-
+$ echo "$jwk" | jose fmt \-j\- \-j \(aq"A128GCM"\(aq \-s alg \-Uo\-
{"kty":"oct","alg":"A128GCM",\.\.\.}
.
.fi
@@ -251,7 +251,7 @@ Build a JWE template:
.
.nf
-$ jose fmt \-j \'{}\' \-cs unprotected \-q A128KW \-s alg \-UUo\-
+$ jose fmt \-j \(aq{}\(aq \-cs unprotected \-q A128KW \-s alg \-UUo\-
{"unprotected":{"alg":"A128KW"}}
.
.fi
diff --git a/jose/man1/jose-jwe-enc.1 b/jose/man1/jose-jwe-enc.1
index ad4f49b..7cbed11 100644
--- a/jose/man1/jose-jwe-enc.1
+++ b/jose/man1/jose-jwe-enc.1
@@ -1,7 +1,7 @@
.\" generated with Ronn/v0.7.3
.\" http://github.com/rtomayko/ronn/tree/0.7.3
.
-.TH "JOSE\-JWE\-ENC" "1" "May 2017" "" ""
+.TH "JOSE\-JWE\-ENC" "1" "August 2019" "" ""
.
.SH "NAME"
\fBjose\-jwe\-enc\fR \- Encrypts plaintext using one or more JWK/password
@@ -66,7 +66,7 @@ Read JWK(Set) from FILE
Read JWK(Set) from standard input
.
.TP
-\fB\-p\fR, `\-\-password
+\fB\-p\fR, \fB\-\-password\fR
Prompt for an encryption password
.
.TP
@@ -96,7 +96,7 @@ Encrypt data with a symmetric key using JWE JSON Serialization:
.
.nf
-$ jose jwk gen \-i \'{"alg":"A128GCM"}\' \-o key\.jwk
+$ jose jwk gen \-i \(aq{"alg":"A128GCM"}\(aq \-o key\.jwk
$ jose jwe enc \-I msg\.txt \-k key\.jwk \-o msg\.jwe
.
.fi
@@ -125,14 +125,14 @@ Compress plaintext before encryption:
.
.nf
-$ jose jwe enc \-i \'{"protected":{"zip":"DEF"}}\' \.\.\.
+$ jose jwe enc \-i \(aq{"protected":{"zip":"DEF"}}\(aq \.\.\.
.
.fi
.
.IP "" 0
.
.P
-Encrypt with two keys and two passwords: $ jose jwk gen \-i \'{"alg":"ECDH\-ES+A128KW"}\' \-o ec\.jwk $ jose jwk gen \-i \'{"alg":"RSA1_5"}\' \-o rsa\.jwk $ jose jwe enc \-I msg\.txt \-p \-k ec\.jwk \-p \-k rsa\.jwk \-o msg\.jwe Please enter a password: Please re\-enter the previous password: Please enter a password: Please re\-enter the previous password:
+Encrypt with two keys and two passwords: $ jose jwk gen \-i \(aq{"alg":"ECDH\-ES+A128KW"}\(aq \-o ec\.jwk $ jose jwk gen \-i \(aq{"alg":"RSA1_5"}\(aq \-o rsa\.jwk $ jose jwe enc \-I msg\.txt \-p \-k ec\.jwk \-p \-k rsa\.jwk \-o msg\.jwe Please enter a password: Please re\-enter the previous password: Please enter a password: Please re\-enter the previous password:
.
.SH "AUTHOR"
Nathaniel McCallum <npmccallum@redhat\.com>
diff --git a/jose/man1/jose-jwk-exc.1 b/jose/man1/jose-jwk-exc.1
index adf25fa..39a1e22 100644
--- a/jose/man1/jose-jwk-exc.1
+++ b/jose/man1/jose-jwk-exc.1
@@ -1,7 +1,7 @@
.\" generated with Ronn/v0.7.3
.\" http://github.com/rtomayko/ronn/tree/0.7.3
.
-.TH "JOSE\-JWK\-EXC" "1" "June 2017" "" ""
+.TH "JOSE\-JWK\-EXC" "1" "July 2019" "" ""
.
.SH "NAME"
\fBjose\-jwk\-exc\fR \- Performs a key exchange using the two input keys
@@ -77,8 +77,8 @@ Perform a key exchange:
.
.nf
-$ jose jwk gen \-i \'{"alg":"ECDH"}\' \-o local\.jwk
-$ jose jwk gen \-i \'{"alg":"ECDH"}\' | jose jwk pub \-i\- \-o remote\.jwk
+$ jose jwk gen \-i \(aq{"alg":"ECDH"}\(aq \-o local\.jwk
+$ jose jwk gen \-i \(aq{"alg":"ECDH"}\(aq | jose jwk pub \-i\- \-o remote\.jwk
$ jose jwk exc \-l local\.jwk \-r remote\.jwk \-o exchanged\.jwk
.
.fi
diff --git a/jose/man1/jose-jwk-gen.1 b/jose/man1/jose-jwk-gen.1
index ac0d9e7..a422a01 100644
--- a/jose/man1/jose-jwk-gen.1
+++ b/jose/man1/jose-jwk-gen.1
@@ -1,7 +1,7 @@
.\" generated with Ronn/v0.7.3
.\" http://github.com/rtomayko/ronn/tree/0.7.3
.
-.TH "JOSE\-JWK\-GEN" "1" "June 2017" "" ""
+.TH "JOSE\-JWK\-GEN" "1" "July 2019" "" ""
.
.SH "NAME"
\fBjose\-jwk\-gen\fR \- Creates a random JWK for each input JWK template
@@ -51,9 +51,9 @@ Generate three keys, each targeting a different algorithm:
.
.nf
-$ jose jwk gen \-i \'{"alg":"HS256"}\' \-o oct\.jwk
-$ jose jwk gen \-i \'{"alg":"RS256"}\' \-o rsa\.jwk
-$ jose jwk gen \-i \'{"alg":"ES256"}\' \-o ec\.jwk
+$ jose jwk gen \-i \(aq{"alg":"HS256"}\(aq \-o oct\.jwk
+$ jose jwk gen \-i \(aq{"alg":"RS256"}\(aq \-o rsa\.jwk
+$ jose jwk gen \-i \(aq{"alg":"ES256"}\(aq \-o ec\.jwk
.
.fi
.
@@ -66,9 +66,9 @@ Generate three keys using key parameters rather than algorithms:
.
.nf
-$ jose jwk gen \-i \'{"kty":"oct","bytes":32}\' \-o oct\.jwk
-$ jose jwk gen \-i \'{"kty":"RSA","bits":4096}\' \-o rsa\.jwk
-$ jose jwk gen \-i \'{"kty":"EC","crv":"P\-256"}\' \-o ec\.jwk
+$ jose jwk gen \-i \(aq{"kty":"oct","bytes":32}\(aq \-o oct\.jwk
+$ jose jwk gen \-i \(aq{"kty":"RSA","bits":4096}\(aq \-o rsa\.jwk
+$ jose jwk gen \-i \(aq{"kty":"EC","crv":"P\-256"}\(aq \-o ec\.jwk
.
.fi
.
@@ -82,7 +82,7 @@ Create multiple keys at once using a JWKSet template:
.nf
$ jose jwk gen \e
- \-i \'{"keys":[{"alg":"HS256"},{"alg":"ES256"}]}\' \e
+ \-i \(aq{"keys":[{"alg":"HS256"},{"alg":"ES256"}]}\(aq \e
\-o keys\.jwkset
.
.fi
@@ -97,8 +97,8 @@ Create multiple keys at once using multiple JWK templates:
.nf
$ jose jwk gen \e
- \-i \'{"alg":"HS256"}\' \e
- \-i \'{"alg":"ES256"}\' \e
+ \-i \(aq{"alg":"HS256"}\(aq \e
+ \-i \(aq{"alg":"ES256"}\(aq \e
\-o keys\.jwkset
.
.fi
diff --git a/jose/man1/jose-jwk-pub.1 b/jose/man1/jose-jwk-pub.1
index 108256c..c0332c9 100644
--- a/jose/man1/jose-jwk-pub.1
+++ b/jose/man1/jose-jwk-pub.1
@@ -1,7 +1,7 @@
.\" generated with Ronn/v0.7.3
.\" http://github.com/rtomayko/ronn/tree/0.7.3
.
-.TH "JOSE\-JWK\-PUB" "1" "June 2017" "" ""
+.TH "JOSE\-JWK\-PUB" "1" "July 2019" "" ""
.
.SH "NAME"
\fBjose\-jwk\-pub\fR \- Cleans private keys from a JWK
@@ -48,7 +48,7 @@ Clean private key material from a JWK:
.
.nf
-$ jose jwk gen \-i \'{"alg":"ES256"}\' \-o prv\.jwk
+$ jose jwk gen \-i \(aq{"alg":"ES256"}\(aq \-o prv\.jwk
$ cat prv\.jwk
{"alg":"ES256","crv":"P\-256","key_ops":["sign","verify"],"kty":"EC", \.\.\.}
$ jose jwk pub \-i prv\.jwk \-o pub\.jwk
diff --git a/jose/man1/jose-jwk-thp.1 b/jose/man1/jose-jwk-thp.1
index 4b037cf..4b0c4f6 100644
--- a/jose/man1/jose-jwk-thp.1
+++ b/jose/man1/jose-jwk-thp.1
@@ -1,7 +1,7 @@
.\" generated with Ronn/v0.7.3
.\" http://github.com/rtomayko/ronn/tree/0.7.3
.
-.TH "JOSE\-JWK\-THP" "1" "June 2017" "" ""
+.TH "JOSE\-JWK\-THP" "1" "July 2019" "" ""
.
.SH "NAME"
\fBjose\-jwk\-thp\fR \- Calculates the JWK thumbprint
@@ -53,7 +53,7 @@ Calculate the S1 thumbprint of a newly generated key:
.
.nf
-$ jose jwk gen \-i \'{"alg":"ES256"}\' \-a S1 | jose jwk thp \-i\-
+$ jose jwk gen \-i \(aq{"alg":"ES256"}\(aq \-a S1 | jose jwk thp \-i\-
BzmSH6W8a8LlbQ1mD0iBJdYj4x4
.
.fi
diff --git a/jose/man1/jose-jwk-use.1 b/jose/man1/jose-jwk-use.1
index a9ef2ef..adf1540 100644
--- a/jose/man1/jose-jwk-use.1
+++ b/jose/man1/jose-jwk-use.1
@@ -1,7 +1,7 @@
.\" generated with Ronn/v0.7.3
.\" http://github.com/rtomayko/ronn/tree/0.7.3
.
-.TH "JOSE\-JWK\-USE" "1" "June 2017" "" ""
+.TH "JOSE\-JWK\-USE" "1" "July 2019" "" ""
.
.SH "NAME"
\fBjose\-jwk\-use\fR \- Validates a key for the specified use(s)
@@ -91,7 +91,7 @@ Examples of both success and failure from a private and public key:
.
.nf
-$ jose jwk gen \-i \'{"alg":"ES256"}\' \-o prv\.jwk
+$ jose jwk gen \-i \(aq{"alg":"ES256"}\(aq \-o prv\.jwk
$ jose jwk pub \-i prv\.jwk \-o pub\.jwk
$ jose jwk use \-i prv\.jwk \-u sign
$ echo $?
diff --git a/jose/man1/jose-jws-sig.1 b/jose/man1/jose-jws-sig.1
index ee827a3..336ead8 100644
--- a/jose/man1/jose-jws-sig.1
+++ b/jose/man1/jose-jws-sig.1
@@ -1,7 +1,7 @@
.\" generated with Ronn/v0.7.3
.\" http://github.com/rtomayko/ronn/tree/0.7.3
.
-.TH "JOSE\-JWS\-SIG" "1" "June 2017" "" ""
+.TH "JOSE\-JWS\-SIG" "1" "July 2019" "" ""
.
.SH "NAME"
\fBjose\-jws\-sig\fR \- Signs a payload using one or more JWKs
@@ -99,7 +99,7 @@ Sign data with a symmetric key using JWE JSON Serialization:
.
.nf
-$ jose jwk gen \-i \'{"alg":"HS256"}\' \-o key\.jwk
+$ jose jwk gen \-i \(aq{"alg":"HS256"}\(aq \-o key\.jwk
$ jose jws sig \-I msg\.txt \-k key\.jwk \-o msg\.jws
.
.fi
@@ -126,8 +126,8 @@ Sign with two keys:
.
.nf
-$ jose jwk gen \-i \'{"alg":"ES256"}\' \-o ec\.jwk
-$ jose jwk gen \-i \'{"alg":"RS256"}\' \-o rsa\.jwk
+$ jose jwk gen \-i \(aq{"alg":"ES256"}\(aq \-o ec\.jwk
+$ jose jwk gen \-i \(aq{"alg":"RS256"}\(aq \-o rsa\.jwk
$ jose jws sig \-I msg\.txt \-k ec\.jwk \-k rsa\.jwk \-o msg\.jws
.
.fi
--
2.21.0

View File

@ -0,0 +1,46 @@
From 077bf992f0deb7d9bb17568726be33ca4209e89c Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Nikola=20Forr=C3=B3?= <nforro@redhat.com>
Date: Fri, 13 Dec 2019 14:21:57 +0100
Subject: [PATCH] copy_file_range.2: update ERRORS
---
man-pages/man2/copy_file_range.2 | 9 +++++++--
1 file changed, 7 insertions(+), 2 deletions(-)
diff --git a/man-pages/man2/copy_file_range.2 b/man-pages/man2/copy_file_range.2
index 35c0967..f25ea95 100644
--- a/man-pages/man2/copy_file_range.2
+++ b/man-pages/man2/copy_file_range.2
@@ -78,7 +78,7 @@ is adjusted appropriately.
The
.I flags
argument is provided to allow for future extensions
-and currently must be to 0.
+and currently must be set to 0.
.SH RETURN VALUE
Upon successful completion,
.BR copy_file_range ()
@@ -109,7 +109,11 @@ maximum file size or the process's file size limit,
or to write at a position past the maximum allowed offset.
.TP
.B EINVAL
-Requested range extends beyond the end of the source file; or the
+Requested range extends beyond the end of the source file; or either
+.I fd_in
+or
+.I fd_out
+is not a regular file; or the
.I flags
argument is not 0.
.TP
@@ -117,6 +121,7 @@ argument is not 0.
A low-level I/O error occurred while copying.
.TP
.B EISDIR
+Either
.I fd_in
or
.I fd_out
--
2.21.0

View File

@ -0,0 +1,34 @@
From 32cb6e3dcdcd26746653f5a4a3359c4b5a5a1789 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Nikola=20Forr=C3=B3?= <nforro@redhat.com>
Date: Mon, 15 Jun 2020 14:23:35 +0200
Subject: [PATCH] radvd.8: add nodaemon option
---
radvd/man8/radvd.8 | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/radvd/man8/radvd.8 b/radvd/man8/radvd.8
index 6a98b12..4c71247 100644
--- a/radvd/man8/radvd.8
+++ b/radvd/man8/radvd.8
@@ -23,6 +23,7 @@ radvd \- router advertisement daemon for IPv6
.BI "[ \-p " pidfile " ]"
.BI "[ \-m " logmethod " ]"
.BI "[ \-l " logfile " ]"
+.BI "[ \-n " nodaemon " ]"
.BI "[ \-f " facility " ]"
.BI "[ \-t " chrootdir " ]"
.BI "[ \-u " username " ]"
@@ -57,6 +58,9 @@ Displays a short usage description and then aborts.
.BR "\-c" , " \-\-configtest"
Test configuration and do startup tests and then exit.
.TP
+.BR "\-n" , " \-\-nodaemon"
+Prevent the daemonizing.
+.TP
.BR "\-d " debuglevel, " \-\-debug " debuglevel
With this option you turn on debugging information. The debugging level is
an integer in the range from 1 to 5, from quiet to very verbose. A
--
2.26.2

View File

@ -0,0 +1,33 @@
From 09804c9f4bd48d4bf2798abd218d58f9a1cb417c Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Nikola=20Forr=C3=B3?= <nforro@redhat.com>
Date: Thu, 30 Apr 2020 17:09:41 +0200
Subject: [PATCH] xattr.7: add attr(1) and selinux(8) as relevant pages to SEE
ALSO
---
man-pages/man7/xattr.7 | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/man-pages/man7/xattr.7 b/man-pages/man7/xattr.7
index fa67ab8..9ea8859 100644
--- a/man-pages/man7/xattr.7
+++ b/man-pages/man7/xattr.7
@@ -189,12 +189,14 @@ This page was formerly named
.BR getfattr (1),
.BR setfattr (1),
.BR getxattr (2),
+.BR attr (1),
.BR ioctl_iflags (2),
.BR listxattr (2),
.BR removexattr (2),
.BR setxattr (2),
.BR acl (5),
-.BR capabilities (7)
+.BR capabilities (7),
+.BR selinux (8)
.SH COLOPHON
This page is part of release 4.15 of the Linux
.I man-pages
--
2.26.2

View File

@ -0,0 +1,29 @@
From 72e4973f03c65b416ceb8f57595eeb0180facb02 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Nikola=20Forr=C3=B3?= <nforro@redhat.com>
Date: Thu, 30 Apr 2020 17:24:59 +0200
Subject: [PATCH 2/2] execve.2: clarify signal sent to the process on late
failure
---
man-pages/man2/execve.2 | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)
diff --git a/man-pages/man2/execve.2 b/man-pages/man2/execve.2
index 7aaa64b..6d86cc4 100644
--- a/man-pages/man2/execve.2
+++ b/man-pages/man2/execve.2
@@ -585,7 +585,10 @@ failure may occur past the point of no return:
the original executable image has been torn down,
but the new image could not be completely built.
In such cases, the kernel kills the process with a
-.BR SIGKILL
+.\" commit 19d860a140beac48a1377f179e693abe86a9dac9
+.BR SIGSEGV
+.RB ( SIGKILL
+until Linux 3.17)
signal.
.\"
.SS Interpreter scripts
--
2.26.2

View File

@ -0,0 +1,25 @@
From 41c7c280da30adafb63e4af949ce537ecb0b4227 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Nikola=20Forr=C3=B3?= <nforro@redhat.com>
Date: Thu, 25 Jun 2020 15:59:13 +0200
Subject: [PATCH] sgdisk.8: fix typo
---
gdisk/man8/sgdisk.8 | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/gdisk/man8/sgdisk.8 b/gdisk/man8/sgdisk.8
index 2cb18b9..d05f0bd 100644
--- a/gdisk/man8/sgdisk.8
+++ b/gdisk/man8/sgdisk.8
@@ -219,7 +219,7 @@ of the sector value reported by this option. You can change the alignment value
with the \-a option.
.TP
-.B e, \-\-move\-second\-header
+.B \-e, \-\-move\-second\-header
Move backup GPT data structures to the end of the disk. Use this option if
you've added disks to a RAID array, thus creating a virtual disk with space
that follows the backup GPT data structures. This command moves the backup
--
2.26.2

View File

@ -0,0 +1,53 @@
From d06094d4469258a722c94f8bb5bc25b5c9711718 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Nikola=20Forr=C3=B3?= <nforro@redhat.com>
Date: Fri, 9 Jul 2021 18:34:34 +0200
Subject: [PATCH 1/2] statx.2: add STATX_ATTR_DAX
---
man-pages/man2/statx.2 | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)
diff --git a/man-pages/man2/statx.2 b/man-pages/man2/statx.2
index bb04455..686edc8 100644
--- a/man-pages/man2/statx.2
+++ b/man-pages/man2/statx.2
@@ -462,6 +462,36 @@ See
.TP
.B STATX_ATTR_ENCRYPTED
A key is required for the file to be encrypted by the filesystem.
+.TP
+.BR STATX_ATTR_DAX " (since Linux 5.8)"
+The file is in the DAX (cpu direct access) state.
+DAX state attempts to
+minimize software cache effects for both I/O and memory mappings of this file.
+It requires a file system which has been configured to support DAX.
+.IP
+DAX generally assumes all accesses are via CPU load / store instructions
+which can minimize overhead for small accesses,
+but may adversely affect CPU utilization for large transfers.
+.IP
+File I/O is done directly to/from user-space buffers and memory mapped I/O may
+be performed with direct memory mappings that bypass the kernel page cache.
+.IP
+While the DAX property tends to result in data being transferred synchronously,
+it does not give the same guarantees as the
+.B O_SYNC
+flag (see
+.BR open (2)),
+where data and the necessary metadata are transferred together.
+.IP
+A DAX file may support being mapped with the
+.B MAP_SYNC
+flag, which enables a
+program to use CPU cache flush instructions to persist CPU store operations
+without an explicit
+.BR fsync (2).
+See
+.BR mmap (2)
+for more information.
.SH RETURN VALUE
On success, zero is returned.
On error, \-1 is returned, and
--
2.31.1

View File

@ -0,0 +1,94 @@
From 900812481ed9f7bd425301399ab22196aa9d1324 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Nikola=20Forr=C3=B3?= <nforro@redhat.com>
Date: Fri, 9 Jul 2021 17:45:37 +0200
Subject: [PATCH 2/2] resolv.conf.5: update information about search list and
attempt to clarify domain/search interaction
---
man-pages/man5/resolv.conf.5 | 47 +++++++++++++++++++-----------------
1 file changed, 25 insertions(+), 22 deletions(-)
diff --git a/man-pages/man5/resolv.conf.5 b/man-pages/man5/resolv.conf.5
index 93c6b47..a14e0ca 100644
--- a/man-pages/man5/resolv.conf.5
+++ b/man-pages/man5/resolv.conf.5
@@ -39,10 +39,9 @@ The configuration file is considered a trusted source of DNS information
(e.g., DNSSEC AD-bit information will be returned unmodified from this
source).
.PP
-If this file does not exist,
-only the name server on the local machine will be queried;
-the domain name is determined from the hostname
-and the domain search path is constructed from the domain name.
+If this file does not exist, only the name server on the local machine
+will be queried, and the search list contains the local domain name
+determined from the hostname.
.PP
The different configuration options are:
.TP
@@ -63,20 +62,15 @@ try the next, until out of name servers,
then repeat trying all the name servers
until a maximum number of retries are made.)
.TP
-\fBdomain\fP Local domain name.
-Most queries for names within this domain can use short names
-relative to the local domain.
-If set to \(aq.\(aq, the root domain is considered.
-If no \fBdomain\fP entry is present, the domain is determined
-from the local hostname returned by
-.BR gethostname (2);
-the domain part is taken to be everything after the first \(aq.\(aq.
-Finally, if the hostname does not contain a domain part, the root
-domain is assumed.
-.TP
\fBsearch\fP Search list for host-name lookup.
-The search list is normally determined from the local domain name;
-by default, it contains only the local domain name.
+By default, the search list contains one entry, the local domain name.
+It is determined from the local hostname returned by
+.BR gethostname (2);
+the local domain name is taken to be everything after the first
+\(aq.\(aq.
+Finally, if the hostname does not contain a \(aq.\(aq, the
+root domain is assumed as the local domain name.
+.IP
This may be changed by listing the desired domain search path
following the \fIsearch\fP keyword with spaces or tabs separating
the names.
@@ -104,8 +98,21 @@ traffic if the servers for the listed domains are not local,
and that queries will time out if no server is available
for one of the domains.
.IP
-The search list is currently limited to six domains
+If there are multiple
+.B search
+directives, only the search list from the last instance is used.
+.IP
+In glibc 2.25 and earlier, the search list is limited to six domains
with a total of 256 characters.
+Since glibc 2.26,
+.\" glibc commit 3f853f22c87f0b671c0366eb290919719fa56c0e
+the search list is unlimited.
+.IP
+The
+.B domain
+directive is an obsolete name for the
+.B search
+directive that handles one search list entry only.
.TP
\fBsortlist\fP
This option allows addresses returned by
@@ -312,10 +319,6 @@ in
This option disables automatic reloading of a changed configuration file.
.RE
.PP
-The \fIdomain\fP and \fIsearch\fP keywords are mutually exclusive.
-If more than one instance of these keywords is present,
-the last instance wins.
-.PP
The \fIsearch\fP keyword of a system's \fIresolv.conf\fP file can be
overridden on a per-process basis by setting the environment variable
.B LOCALDOMAIN
--
2.31.1

View File

@ -0,0 +1,33 @@
From 1d6d37ced8828bd33efeeeda598030d709a66a57 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Nikola=20Forr=C3=B3?= <nforro@redhat.com>
Date: Fri, 16 Jul 2021 17:53:28 +0200
Subject: [PATCH] tcp.7: remove tcp_tso_win_divisor option
---
man-pages/man7/tcp.7 | 10 ----------
1 file changed, 10 deletions(-)
diff --git a/man-pages/man7/tcp.7 b/man-pages/man7/tcp.7
index 0ff5030..e5cc587 100644
--- a/man-pages/man7/tcp.7
+++ b/man-pages/man7/tcp.7
@@ -863,16 +863,6 @@ This parameter controls what percentage of the congestion window
can be consumed by a single TCP Segmentation Offload (TSO) frame.
The setting of this parameter is a tradeoff between burstiness and
building larger TSO frames.
-.TP
-.IR tcp_tw_recycle " (Boolean; default: disabled; Linux 2.4 to 4.11)"
-.\" Since 2.3.15
-.\" removed in 4.12; commit 4396e46187ca5070219b81773c4e65088dac50cc
-Enable fast recycling of TIME_WAIT sockets.
-Enabling this option is
-not recommended as the remote IP may not use monotonically increasing
-timestamps (devices behind NAT, devices with per-connection timestamp
-offsets).
-See RFC 1323 (PAWS) and RFC 6191.
.\"
.\" The following is from 2.6.12: Documentation/networking/ip-sysctl.txt
.TP
--
2.31.1

138
man-pages-overrides.spec Normal file
View File

@ -0,0 +1,138 @@
%global debug_package %{nil}
Summary: Complementary and updated manual pages
Name: man-pages-overrides
Version: 8.6.0.0
Release: 1%{?dist}
# license is the same as for the man-pages package
License: GPL+ and GPLv2+ and BSD and MIT and Copyright only and IEEE
Group: Documentation
# there is no public download location for this package
Source: man-pages-overrides-%{version}.tar.xz
Patch1: 1673142-mpo-8.2.0.0-copy_file_range.2.patch
Patch2: 1517305-mpo-8.2.0.1-jose-.1.patch
Patch3: 1828296-mpo-8.3.0.0-xattr.7.patch
Patch4: 1829031-mpo-8.3.0.0-execve.2.patch
Patch5: 1731058-mpo-8.3.0.1-radvd.8.patch
Patch6: 1850065-mpo-8.3.0.2-sgdisk.8.patch
Patch7: 1899552-mpo-8.5.0.0-statx.2.patch
Patch8: 1928160-mpo-8.5.0.0-resolv.conf.5.patch
Patch9: 1981853-mpo-8.5.0.1-tcp.7.patch
BuildArch: noarch
# make sure man-pages-overrides is installed with man-pages
Supplements: man-pages
%description
A collection of manual ("man") pages to complement other packages or update
those contained therein. Always have the latest version of this package
installed.
%prep
%autosetup -p1
# remove unwanted *.orig files
find -name "*.orig" -delete
%build
# nothing to build
%install
mkdir -p $RPM_BUILD_ROOT%{_mandir}/overrides
mkdir -p $RPM_BUILD_ROOT%{_docdir}/%{name}
for i in *; do
if [[ -d "$i" ]]; then
for j in $(ls "$i"); do
if [[ -d "$i/$j" ]]; then
mkdir -p "$RPM_BUILD_ROOT%{_mandir}/overrides/$j"
for k in $(ls "$i/$j"); do
if [[ -d "$i/$j/$k" ]]; then
mkdir -p "$RPM_BUILD_ROOT%{_mandir}/overrides/$j/$k"
cp -f "$i/$j/$k"/* "$RPM_BUILD_ROOT%{_mandir}/overrides/$j/$k"
else
cp -f "$i/$j"/* "$RPM_BUILD_ROOT%{_mandir}/overrides/$j"
fi
done
else
mkdir -p "$RPM_BUILD_ROOT%{_docdir}/%{name}/$i"
cp "$i/$j" "$RPM_BUILD_ROOT%{_docdir}/%{name}/$i"
fi
done
fi
done
%files
%doc %{_docdir}/%{name}
%{_mandir}/overrides/
%changelog
* Thu Feb 03 2022 Nikola Forró <nforro@redhat.com> - 8.6.0.0-1
- Upload new tarball
- rpc.3: remove the man page
resolves: #2042972
* Fri Jul 16 2021 Nikola Forró <nforro@redhat.com> - 8.5.0.1-1
- Upload new tarball
- tcp.7: remove tcp_tso_win_divisor option
resolves: #1981853
* Fri Jul 09 2021 Nikola Forró <nforro@redhat.com> - 8.5.0.0-1
- Upload new tarball
- statx.2: add STATX_ATTR_DAX
resolves: #1899552
- resolv.conf.5: update information about search list and
attempt to clarify domain/search interaction
resolves: #1928160
* Thu Aug 20 2020 Nikola Forró <nforro@redhat.com> - 8.3.0.2-2
- xattr.7: add attr(1) and selinux(8) as relevant pages to SEE ALSO
related: #1828296
* Thu Jun 25 2020 Nikola Forró <nforro@redhat.com> - 8.3.0.2-1
- Upload new tarball
- sgdisk.8: fix typo
resolves: #1850065
* Mon Jun 15 2020 Nikola Forró <nforro@redhat.com> - 8.3.0.1-1
- Upload new tarball
- radvd.8: add nodaemon option
resolves: #1731058
* Thu Apr 30 2020 Nikola Forró <nforro@redhat.com> - 8.3.0.0-1
- Upload new tarball
- Use unversioned docdir
resolves: #1824824
- xattr.7: add attr(1) as a relevant page to SEE ALSO
resolves: #1828296
- execve.2: clarify signal sent to the process on late failure
resolves: #1829031
* Thu Dec 19 2019 Nikola Forró <nforro@redhat.com> - 8.2.0.2-1
- Upload new tarball
- kernel_lockdown.7: add missing .RE macro
related: #1781945
* Wed Dec 18 2019 Nikola Forró <nforro@redhat.com> - 8.2.0.1-1
- Upload new tarball
- jose-*.1: fix typographical errors
resolves: #1517305
* Fri Dec 13 2019 Nikola Forró <nforro@redhat.com> - 8.2.0.0-1
- Upload new tarball
- kernel_lockdown.7: add new manpage
resolves: #1781945
- copy_file_range.2: update ERRORS
resolves: #1673142
* Wed Jun 19 2019 Nikola Forró <nforro@redhat.com> - 8.1.0.0-2
- Mark this package as man-pages supplement
related: #1706882
* Wed May 29 2019 Nikola Forró <nforro@redhat.com> - 8.1.0.0-1
- Upload new tarball
- rpc.3: indicate that <rpc/rpc.h> is provided by libtirpc-devel, not glibc
resolves: #1706882
* Thu Jul 26 2018 Nikola Forró <nforro@redhat.com> - 8.0.0-1
- Initial package for RHEL 8.0

1
sources Normal file
View File

@ -0,0 +1 @@
SHA512 (man-pages-overrides-8.6.0.0.tar.xz) = 614191828e6365c8327896febe7158ccd54c53fa65a43b3fb4449a1261773631270edc54d89ee19ab91c65e79cf2762ed98839aa77f94a53f246b17848f1a6c1