man-db/1263930-fix-replace-sed-prerequisite-syntax.patch
2015-09-22 19:14:06 +02:00

378 lines
14 KiB
Diff

From 32ee575a45d3a7e221a7b29c457049b659315152 Mon Sep 17 00:00:00 2001
From: Colin Watson <cjwatson@debian.org>
Date: Tue, 22 Sep 2015 14:17:39 +0000
Subject: Fix replace.sed prerequisite syntax
Suffix rules may not have prerequisites. Thanks to Nikola Forró; fixes
Fedora bug #1263930.
* man/Rules.man: Declare dependency of $(MANS) on replace.sed
separately rather than trying to do so in suffix rules.
---
diff --git a/man/Makefile.in b/man/Makefile.in
index 5948349..e8571c7 100644
--- a/man/Makefile.in
+++ b/man/Makefile.in
@@ -2307,18 +2307,17 @@ uninstall-man: uninstall-man1 uninstall-man5 uninstall-man8
replace.sed: $(top_builddir)/man/replace.sin
$(AM_V_GEN)sed -e 's,%REPLACE_CONFIG_FILE%,$(config_file),g' $(top_builddir)/man/replace.sin > $@
-.man1.1: replace.sed
+$(MANS): replace.sed
+
+.man1.1:
$(AM_V_at)$(MKDIR_P) man1
- @$(MAKE) $(AM_MAKEFLAGS) replace.sed
$(AM_V_GEN)program=`echo '$@' | sed -e 's/\.1//' -e 's,.*/,,' -e '$(program_transform_name)'`; \
sed -f replace.sed -e "s,%program%,$$program,g" $< > $@
-.man5.5: replace.sed
+.man5.5:
$(AM_V_at)$(MKDIR_P) man5
- @$(MAKE) $(AM_MAKEFLAGS) replace.sed
$(AM_V_GEN)sed -f replace.sed $< > $@
-.man8.8: replace.sed
+.man8.8:
$(AM_V_at)$(MKDIR_P) man8
- @$(MAKE) $(AM_MAKEFLAGS) replace.sed
$(AM_V_GEN)program=`echo '$@' | sed -e 's/\.8//' -e 's,.*/,,' -e '$(program_transform_name)'`; \
sed -f replace.sed -e "s,%program%,$$program,g" $< > $@
diff --git a/man/Rules.man b/man/Rules.man
index 4ce8ac0..55ff35d 100644
--- a/man/Rules.man
+++ b/man/Rules.man
@@ -34,18 +34,17 @@ endif
replace.sed: $(top_builddir)/man/replace.sin
$(AM_V_GEN)sed -e 's,%REPLACE_CONFIG_FILE%,$(config_file),g' $(top_builddir)/man/replace.sin > $@
-.man1.1: replace.sed
+$(MANS): replace.sed
+
+.man1.1:
$(AM_V_at)$(MKDIR_P) man1
- @$(MAKE) $(AM_MAKEFLAGS) replace.sed
$(AM_V_GEN)program=`echo '$@' | sed -e 's/\.1//' -e 's,.*/,,' -e '$(program_transform_name)'`; \
sed -f replace.sed -e "s,%program%,$$program,g" $< > $@
-.man5.5: replace.sed
+.man5.5:
$(AM_V_at)$(MKDIR_P) man5
- @$(MAKE) $(AM_MAKEFLAGS) replace.sed
$(AM_V_GEN)sed -f replace.sed $< > $@
-.man8.8: replace.sed
+.man8.8:
$(AM_V_at)$(MKDIR_P) man8
- @$(MAKE) $(AM_MAKEFLAGS) replace.sed
$(AM_V_GEN)program=`echo '$@' | sed -e 's/\.8//' -e 's,.*/,,' -e '$(program_transform_name)'`; \
sed -f replace.sed -e "s,%program%,$$program,g" $< > $@
diff --git a/man/da/Makefile.in b/man/da/Makefile.in
index 585cd8f..07fede8 100644
--- a/man/da/Makefile.in
+++ b/man/da/Makefile.in
@@ -2125,18 +2125,17 @@ uninstall-man: uninstall-man1 uninstall-man5 uninstall-man8
replace.sed: $(top_builddir)/man/replace.sin
$(AM_V_GEN)sed -e 's,%REPLACE_CONFIG_FILE%,$(config_file),g' $(top_builddir)/man/replace.sin > $@
-.man1.1: replace.sed
+$(MANS): replace.sed
+
+.man1.1:
$(AM_V_at)$(MKDIR_P) man1
- @$(MAKE) $(AM_MAKEFLAGS) replace.sed
$(AM_V_GEN)program=`echo '$@' | sed -e 's/\.1//' -e 's,.*/,,' -e '$(program_transform_name)'`; \
sed -f replace.sed -e "s,%program%,$$program,g" $< > $@
-.man5.5: replace.sed
+.man5.5:
$(AM_V_at)$(MKDIR_P) man5
- @$(MAKE) $(AM_MAKEFLAGS) replace.sed
$(AM_V_GEN)sed -f replace.sed $< > $@
-.man8.8: replace.sed
+.man8.8:
$(AM_V_at)$(MKDIR_P) man8
- @$(MAKE) $(AM_MAKEFLAGS) replace.sed
$(AM_V_GEN)program=`echo '$@' | sed -e 's/\.8//' -e 's,.*/,,' -e '$(program_transform_name)'`; \
sed -f replace.sed -e "s,%program%,$$program,g" $< > $@
diff --git a/man/de/Makefile.in b/man/de/Makefile.in
index 6ae0a62..db75fa3 100644
--- a/man/de/Makefile.in
+++ b/man/de/Makefile.in
@@ -2125,18 +2125,17 @@ uninstall-man: uninstall-man1 uninstall-man5 uninstall-man8
replace.sed: $(top_builddir)/man/replace.sin
$(AM_V_GEN)sed -e 's,%REPLACE_CONFIG_FILE%,$(config_file),g' $(top_builddir)/man/replace.sin > $@
-.man1.1: replace.sed
+$(MANS): replace.sed
+
+.man1.1:
$(AM_V_at)$(MKDIR_P) man1
- @$(MAKE) $(AM_MAKEFLAGS) replace.sed
$(AM_V_GEN)program=`echo '$@' | sed -e 's/\.1//' -e 's,.*/,,' -e '$(program_transform_name)'`; \
sed -f replace.sed -e "s,%program%,$$program,g" $< > $@
-.man5.5: replace.sed
+.man5.5:
$(AM_V_at)$(MKDIR_P) man5
- @$(MAKE) $(AM_MAKEFLAGS) replace.sed
$(AM_V_GEN)sed -f replace.sed $< > $@
-.man8.8: replace.sed
+.man8.8:
$(AM_V_at)$(MKDIR_P) man8
- @$(MAKE) $(AM_MAKEFLAGS) replace.sed
$(AM_V_GEN)program=`echo '$@' | sed -e 's/\.8//' -e 's,.*/,,' -e '$(program_transform_name)'`; \
sed -f replace.sed -e "s,%program%,$$program,g" $< > $@
diff --git a/man/es/Makefile.in b/man/es/Makefile.in
index 7681f14..3702d0e 100644
--- a/man/es/Makefile.in
+++ b/man/es/Makefile.in
@@ -2099,18 +2099,17 @@ uninstall-man: uninstall-man1 uninstall-man5 uninstall-man8
replace.sed: $(top_builddir)/man/replace.sin
$(AM_V_GEN)sed -e 's,%REPLACE_CONFIG_FILE%,$(config_file),g' $(top_builddir)/man/replace.sin > $@
-.man1.1: replace.sed
+$(MANS): replace.sed
+
+.man1.1:
$(AM_V_at)$(MKDIR_P) man1
- @$(MAKE) $(AM_MAKEFLAGS) replace.sed
$(AM_V_GEN)program=`echo '$@' | sed -e 's/\.1//' -e 's,.*/,,' -e '$(program_transform_name)'`; \
sed -f replace.sed -e "s,%program%,$$program,g" $< > $@
-.man5.5: replace.sed
+.man5.5:
$(AM_V_at)$(MKDIR_P) man5
- @$(MAKE) $(AM_MAKEFLAGS) replace.sed
$(AM_V_GEN)sed -f replace.sed $< > $@
-.man8.8: replace.sed
+.man8.8:
$(AM_V_at)$(MKDIR_P) man8
- @$(MAKE) $(AM_MAKEFLAGS) replace.sed
$(AM_V_GEN)program=`echo '$@' | sed -e 's/\.8//' -e 's,.*/,,' -e '$(program_transform_name)'`; \
sed -f replace.sed -e "s,%program%,$$program,g" $< > $@
diff --git a/man/fr/Makefile.in b/man/fr/Makefile.in
index 04befbb..f743ecc 100644
--- a/man/fr/Makefile.in
+++ b/man/fr/Makefile.in
@@ -2125,18 +2125,17 @@ uninstall-man: uninstall-man1 uninstall-man5 uninstall-man8
replace.sed: $(top_builddir)/man/replace.sin
$(AM_V_GEN)sed -e 's,%REPLACE_CONFIG_FILE%,$(config_file),g' $(top_builddir)/man/replace.sin > $@
-.man1.1: replace.sed
+$(MANS): replace.sed
+
+.man1.1:
$(AM_V_at)$(MKDIR_P) man1
- @$(MAKE) $(AM_MAKEFLAGS) replace.sed
$(AM_V_GEN)program=`echo '$@' | sed -e 's/\.1//' -e 's,.*/,,' -e '$(program_transform_name)'`; \
sed -f replace.sed -e "s,%program%,$$program,g" $< > $@
-.man5.5: replace.sed
+.man5.5:
$(AM_V_at)$(MKDIR_P) man5
- @$(MAKE) $(AM_MAKEFLAGS) replace.sed
$(AM_V_GEN)sed -f replace.sed $< > $@
-.man8.8: replace.sed
+.man8.8:
$(AM_V_at)$(MKDIR_P) man8
- @$(MAKE) $(AM_MAKEFLAGS) replace.sed
$(AM_V_GEN)program=`echo '$@' | sed -e 's/\.8//' -e 's,.*/,,' -e '$(program_transform_name)'`; \
sed -f replace.sed -e "s,%program%,$$program,g" $< > $@
diff --git a/man/id/Makefile.in b/man/id/Makefile.in
index b08b240..fc7f8ab 100644
--- a/man/id/Makefile.in
+++ b/man/id/Makefile.in
@@ -2125,18 +2125,17 @@ uninstall-man: uninstall-man1 uninstall-man5 uninstall-man8
replace.sed: $(top_builddir)/man/replace.sin
$(AM_V_GEN)sed -e 's,%REPLACE_CONFIG_FILE%,$(config_file),g' $(top_builddir)/man/replace.sin > $@
-.man1.1: replace.sed
+$(MANS): replace.sed
+
+.man1.1:
$(AM_V_at)$(MKDIR_P) man1
- @$(MAKE) $(AM_MAKEFLAGS) replace.sed
$(AM_V_GEN)program=`echo '$@' | sed -e 's/\.1//' -e 's,.*/,,' -e '$(program_transform_name)'`; \
sed -f replace.sed -e "s,%program%,$$program,g" $< > $@
-.man5.5: replace.sed
+.man5.5:
$(AM_V_at)$(MKDIR_P) man5
- @$(MAKE) $(AM_MAKEFLAGS) replace.sed
$(AM_V_GEN)sed -f replace.sed $< > $@
-.man8.8: replace.sed
+.man8.8:
$(AM_V_at)$(MKDIR_P) man8
- @$(MAKE) $(AM_MAKEFLAGS) replace.sed
$(AM_V_GEN)program=`echo '$@' | sed -e 's/\.8//' -e 's,.*/,,' -e '$(program_transform_name)'`; \
sed -f replace.sed -e "s,%program%,$$program,g" $< > $@
diff --git a/man/it/Makefile.in b/man/it/Makefile.in
index 34b6242..a6d2c3d 100644
--- a/man/it/Makefile.in
+++ b/man/it/Makefile.in
@@ -2107,18 +2107,17 @@ uninstall-man: uninstall-man1 uninstall-man5 uninstall-man8
replace.sed: $(top_builddir)/man/replace.sin
$(AM_V_GEN)sed -e 's,%REPLACE_CONFIG_FILE%,$(config_file),g' $(top_builddir)/man/replace.sin > $@
-.man1.1: replace.sed
+$(MANS): replace.sed
+
+.man1.1:
$(AM_V_at)$(MKDIR_P) man1
- @$(MAKE) $(AM_MAKEFLAGS) replace.sed
$(AM_V_GEN)program=`echo '$@' | sed -e 's/\.1//' -e 's,.*/,,' -e '$(program_transform_name)'`; \
sed -f replace.sed -e "s,%program%,$$program,g" $< > $@
-.man5.5: replace.sed
+.man5.5:
$(AM_V_at)$(MKDIR_P) man5
- @$(MAKE) $(AM_MAKEFLAGS) replace.sed
$(AM_V_GEN)sed -f replace.sed $< > $@
-.man8.8: replace.sed
+.man8.8:
$(AM_V_at)$(MKDIR_P) man8
- @$(MAKE) $(AM_MAKEFLAGS) replace.sed
$(AM_V_GEN)program=`echo '$@' | sed -e 's/\.8//' -e 's,.*/,,' -e '$(program_transform_name)'`; \
sed -f replace.sed -e "s,%program%,$$program,g" $< > $@
diff --git a/man/ja/Makefile.in b/man/ja/Makefile.in
index acc11fa..794bb6b 100644
--- a/man/ja/Makefile.in
+++ b/man/ja/Makefile.in
@@ -2125,18 +2125,17 @@ uninstall-man: uninstall-man1 uninstall-man5 uninstall-man8
replace.sed: $(top_builddir)/man/replace.sin
$(AM_V_GEN)sed -e 's,%REPLACE_CONFIG_FILE%,$(config_file),g' $(top_builddir)/man/replace.sin > $@
-.man1.1: replace.sed
+$(MANS): replace.sed
+
+.man1.1:
$(AM_V_at)$(MKDIR_P) man1
- @$(MAKE) $(AM_MAKEFLAGS) replace.sed
$(AM_V_GEN)program=`echo '$@' | sed -e 's/\.1//' -e 's,.*/,,' -e '$(program_transform_name)'`; \
sed -f replace.sed -e "s,%program%,$$program,g" $< > $@
-.man5.5: replace.sed
+.man5.5:
$(AM_V_at)$(MKDIR_P) man5
- @$(MAKE) $(AM_MAKEFLAGS) replace.sed
$(AM_V_GEN)sed -f replace.sed $< > $@
-.man8.8: replace.sed
+.man8.8:
$(AM_V_at)$(MKDIR_P) man8
- @$(MAKE) $(AM_MAKEFLAGS) replace.sed
$(AM_V_GEN)program=`echo '$@' | sed -e 's/\.8//' -e 's,.*/,,' -e '$(program_transform_name)'`; \
sed -f replace.sed -e "s,%program%,$$program,g" $< > $@
diff --git a/man/nl/Makefile.in b/man/nl/Makefile.in
index 9cb4c2d..b01c287 100644
--- a/man/nl/Makefile.in
+++ b/man/nl/Makefile.in
@@ -2125,18 +2125,17 @@ uninstall-man: uninstall-man1 uninstall-man5 uninstall-man8
replace.sed: $(top_builddir)/man/replace.sin
$(AM_V_GEN)sed -e 's,%REPLACE_CONFIG_FILE%,$(config_file),g' $(top_builddir)/man/replace.sin > $@
-.man1.1: replace.sed
+$(MANS): replace.sed
+
+.man1.1:
$(AM_V_at)$(MKDIR_P) man1
- @$(MAKE) $(AM_MAKEFLAGS) replace.sed
$(AM_V_GEN)program=`echo '$@' | sed -e 's/\.1//' -e 's,.*/,,' -e '$(program_transform_name)'`; \
sed -f replace.sed -e "s,%program%,$$program,g" $< > $@
-.man5.5: replace.sed
+.man5.5:
$(AM_V_at)$(MKDIR_P) man5
- @$(MAKE) $(AM_MAKEFLAGS) replace.sed
$(AM_V_GEN)sed -f replace.sed $< > $@
-.man8.8: replace.sed
+.man8.8:
$(AM_V_at)$(MKDIR_P) man8
- @$(MAKE) $(AM_MAKEFLAGS) replace.sed
$(AM_V_GEN)program=`echo '$@' | sed -e 's/\.8//' -e 's,.*/,,' -e '$(program_transform_name)'`; \
sed -f replace.sed -e "s,%program%,$$program,g" $< > $@
diff --git a/man/pl/Makefile.in b/man/pl/Makefile.in
index 0c8bd4d..727fb3e 100644
--- a/man/pl/Makefile.in
+++ b/man/pl/Makefile.in
@@ -2125,18 +2125,17 @@ uninstall-man: uninstall-man1 uninstall-man5 uninstall-man8
replace.sed: $(top_builddir)/man/replace.sin
$(AM_V_GEN)sed -e 's,%REPLACE_CONFIG_FILE%,$(config_file),g' $(top_builddir)/man/replace.sin > $@
-.man1.1: replace.sed
+$(MANS): replace.sed
+
+.man1.1:
$(AM_V_at)$(MKDIR_P) man1
- @$(MAKE) $(AM_MAKEFLAGS) replace.sed
$(AM_V_GEN)program=`echo '$@' | sed -e 's/\.1//' -e 's,.*/,,' -e '$(program_transform_name)'`; \
sed -f replace.sed -e "s,%program%,$$program,g" $< > $@
-.man5.5: replace.sed
+.man5.5:
$(AM_V_at)$(MKDIR_P) man5
- @$(MAKE) $(AM_MAKEFLAGS) replace.sed
$(AM_V_GEN)sed -f replace.sed $< > $@
-.man8.8: replace.sed
+.man8.8:
$(AM_V_at)$(MKDIR_P) man8
- @$(MAKE) $(AM_MAKEFLAGS) replace.sed
$(AM_V_GEN)program=`echo '$@' | sed -e 's/\.8//' -e 's,.*/,,' -e '$(program_transform_name)'`; \
sed -f replace.sed -e "s,%program%,$$program,g" $< > $@
diff --git a/man/ru/Makefile.in b/man/ru/Makefile.in
index 5a32661..df6cdca 100644
--- a/man/ru/Makefile.in
+++ b/man/ru/Makefile.in
@@ -2125,18 +2125,17 @@ uninstall-man: uninstall-man1 uninstall-man5 uninstall-man8
replace.sed: $(top_builddir)/man/replace.sin
$(AM_V_GEN)sed -e 's,%REPLACE_CONFIG_FILE%,$(config_file),g' $(top_builddir)/man/replace.sin > $@
-.man1.1: replace.sed
+$(MANS): replace.sed
+
+.man1.1:
$(AM_V_at)$(MKDIR_P) man1
- @$(MAKE) $(AM_MAKEFLAGS) replace.sed
$(AM_V_GEN)program=`echo '$@' | sed -e 's/\.1//' -e 's,.*/,,' -e '$(program_transform_name)'`; \
sed -f replace.sed -e "s,%program%,$$program,g" $< > $@
-.man5.5: replace.sed
+.man5.5:
$(AM_V_at)$(MKDIR_P) man5
- @$(MAKE) $(AM_MAKEFLAGS) replace.sed
$(AM_V_GEN)sed -f replace.sed $< > $@
-.man8.8: replace.sed
+.man8.8:
$(AM_V_at)$(MKDIR_P) man8
- @$(MAKE) $(AM_MAKEFLAGS) replace.sed
$(AM_V_GEN)program=`echo '$@' | sed -e 's/\.8//' -e 's,.*/,,' -e '$(program_transform_name)'`; \
sed -f replace.sed -e "s,%program%,$$program,g" $< > $@
diff --git a/man/zh_CN/Makefile.in b/man/zh_CN/Makefile.in
index e9afb77..5a438ea 100644
--- a/man/zh_CN/Makefile.in
+++ b/man/zh_CN/Makefile.in
@@ -2125,18 +2125,17 @@ uninstall-man: uninstall-man1 uninstall-man5 uninstall-man8
replace.sed: $(top_builddir)/man/replace.sin
$(AM_V_GEN)sed -e 's,%REPLACE_CONFIG_FILE%,$(config_file),g' $(top_builddir)/man/replace.sin > $@
-.man1.1: replace.sed
+$(MANS): replace.sed
+
+.man1.1:
$(AM_V_at)$(MKDIR_P) man1
- @$(MAKE) $(AM_MAKEFLAGS) replace.sed
$(AM_V_GEN)program=`echo '$@' | sed -e 's/\.1//' -e 's,.*/,,' -e '$(program_transform_name)'`; \
sed -f replace.sed -e "s,%program%,$$program,g" $< > $@
-.man5.5: replace.sed
+.man5.5:
$(AM_V_at)$(MKDIR_P) man5
- @$(MAKE) $(AM_MAKEFLAGS) replace.sed
$(AM_V_GEN)sed -f replace.sed $< > $@
-.man8.8: replace.sed
+.man8.8:
$(AM_V_at)$(MKDIR_P) man8
- @$(MAKE) $(AM_MAKEFLAGS) replace.sed
$(AM_V_GEN)program=`echo '$@' | sed -e 's/\.8//' -e 's,.*/,,' -e '$(program_transform_name)'`; \
sed -f replace.sed -e "s,%program%,$$program,g" $< > $@
--
cgit v0.9.0.2