parent
b5ede82990
commit
fd1fd80475
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,2 +1,3 @@
|
|||||||
/man-db-2.7.5.tar.xz
|
/man-db-2.7.5.tar.xz
|
||||||
/man-db-2.7.6.1.tar.xz
|
/man-db-2.7.6.1.tar.xz
|
||||||
|
/man-db-2.8.3.tar.xz
|
||||||
|
@ -1,19 +1,19 @@
|
|||||||
From b872ee2e8ba470ed869db7dcf37eeb96563a62fa Mon Sep 17 00:00:00 2001
|
From 99dd120b952a2a27fa31ae005149e6aaaed28755 Mon Sep 17 00:00:00 2001
|
||||||
From: =?UTF-8?q?Nikola=20Forr=C3=B3?= <nforro@redhat.com>
|
From: =?UTF-8?q?Nikola=20Forr=C3=B3?= <nforro@redhat.com>
|
||||||
Date: Thu, 19 Jan 2017 14:06:30 +0100
|
Date: Fri, 6 Apr 2018 11:52:33 +0200
|
||||||
Subject: [PATCH] Set owner of man cache to root instead of man
|
Subject: [PATCH] Set owner of man cache to root
|
||||||
|
|
||||||
---
|
---
|
||||||
init/systemd/man-db.conf | 2 +-
|
init/systemd/man-db.conf.in | 2 +-
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
diff --git a/init/systemd/man-db.conf b/init/systemd/man-db.conf
|
diff --git a/init/systemd/man-db.conf.in b/init/systemd/man-db.conf.in
|
||||||
index 1eb40ce..21936d5 100644
|
index 90ca7f6..cac2b52 100644
|
||||||
--- a/init/systemd/man-db.conf
|
--- a/init/systemd/man-db.conf.in
|
||||||
+++ b/init/systemd/man-db.conf
|
+++ b/init/systemd/man-db.conf.in
|
||||||
@@ -1 +1 @@
|
@@ -1 +1 @@
|
||||||
-d /var/cache/man 0755 man man 1w
|
-d /var/cache/man 0755 @man_owner@ @man_owner@ 1w
|
||||||
+d /var/cache/man 0755 root root 1w
|
+d /var/cache/man 0755 root root 1w
|
||||||
--
|
--
|
||||||
2.7.4
|
2.13.6
|
||||||
|
|
||||||
|
@ -1,90 +0,0 @@
|
|||||||
From 79308ac147be9e9c889798cba78bab2af05048e1 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Jiri Kucera <jkucera@redhat.com>
|
|
||||||
Date: Wed, 17 Jan 2018 13:57:34 +0100
|
|
||||||
Subject: [PATCH] Fix a segfault in 'man -D --help'
|
|
||||||
|
|
||||||
This patch is an adjusted version (due to the patch rejected hunk issues) of its original (by Colin Watson) from: https://git.savannah.gnu.org/cgit/man-db.git/patch/?id=b32977ff73220cd351387abe558fb523d1deedbb
|
|
||||||
|
|
||||||
Reported by Jiri Kucera.
|
|
||||||
|
|
||||||
* src/man.c (init_html_pager): New function.
|
|
||||||
(parse_opt): Call init_html_pager rather than setting html_pager to
|
|
||||||
NULL.
|
|
||||||
(help_filter): Assert that browser is non-NULL.
|
|
||||||
(main): Call init_html_pager rather than doing the same thing directly.
|
|
||||||
* NEWS: Document this.
|
|
||||||
---
|
|
||||||
NEWS | 10 ++++++++++
|
|
||||||
src/man.c | 17 +++++++++++------
|
|
||||||
2 files changed, 21 insertions(+), 6 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/NEWS b/NEWS
|
|
||||||
index 366a0263..ff35e884 100644
|
|
||||||
--- a/NEWS
|
|
||||||
+++ b/NEWS
|
|
||||||
@@ -1,3 +1,13 @@
|
|
||||||
+man-db 2.7.7
|
|
||||||
+============
|
|
||||||
+
|
|
||||||
+Major changes since man-db 2.7.6.1:
|
|
||||||
+
|
|
||||||
+ Fixes:
|
|
||||||
+ ------
|
|
||||||
+
|
|
||||||
+ o Fix a segfault in 'man -D --help'.
|
|
||||||
+
|
|
||||||
man-db 2.7.6.1 (12 December 2016)
|
|
||||||
=================================
|
|
||||||
|
|
||||||
diff --git a/src/man.c b/src/man.c
|
|
||||||
index 8b11f43e..cb0930b8 100644
|
|
||||||
--- a/src/man.c
|
|
||||||
+++ b/src/man.c
|
|
||||||
@@ -345,6 +345,13 @@ static struct argp_option options[] = {
|
|
||||||
{ 0 }
|
|
||||||
};
|
|
||||||
|
|
||||||
+static void init_html_pager (void)
|
|
||||||
+{
|
|
||||||
+ html_pager = getenv ("BROWSER");
|
|
||||||
+ if (!html_pager)
|
|
||||||
+ html_pager = WEB_BROWSER;
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
static error_t parse_opt (int key, char *arg, struct argp_state *state)
|
|
||||||
{
|
|
||||||
static int apropos, whatis; /* retain values between calls */
|
|
||||||
@@ -369,7 +376,7 @@ static error_t parse_opt (int key, char *arg, struct argp_state *state)
|
|
||||||
ditroff = 0;
|
|
||||||
gxditview = NULL;
|
|
||||||
htmlout = 0;
|
|
||||||
- html_pager = NULL;
|
|
||||||
+ init_html_pager ();
|
|
||||||
#endif
|
|
||||||
roff_device = want_encoding = extension = pager =
|
|
||||||
locale = alt_system_name = external =
|
|
||||||
@@ -582,6 +589,7 @@ static char *help_filter (int key, const char *text,
|
|
||||||
# ifdef TROFF_IS_GROFF
|
|
||||||
case 'H':
|
|
||||||
browser = html_pager;
|
|
||||||
+ assert (browser);
|
|
||||||
if (STRNEQ (browser, "exec ", 5))
|
|
||||||
browser += 5;
|
|
||||||
return xasprintf (text, browser);
|
|
||||||
@@ -4018,11 +4026,8 @@ int main (int argc, char *argv[])
|
|
||||||
|
|
||||||
#ifdef TROFF_IS_GROFF
|
|
||||||
/* used in --help, so initialise early */
|
|
||||||
- if (!html_pager) {
|
|
||||||
- html_pager = getenv ("BROWSER");
|
|
||||||
- if (!html_pager)
|
|
||||||
- html_pager = WEB_BROWSER;
|
|
||||||
- }
|
|
||||||
+ if (!html_pager)
|
|
||||||
+ init_html_pager ();
|
|
||||||
#endif /* TROFF_IS_GROFF */
|
|
||||||
|
|
||||||
/* First of all, find out if $MANOPT is set. If so, put it in
|
|
||||||
--
|
|
||||||
2.14.3
|
|
||||||
|
|
38
man-db.spec
38
man-db.spec
@ -3,8 +3,8 @@
|
|||||||
|
|
||||||
Summary: Tools for searching and reading man pages
|
Summary: Tools for searching and reading man pages
|
||||||
Name: man-db
|
Name: man-db
|
||||||
Version: 2.7.6.1
|
Version: 2.8.3
|
||||||
Release: 15%{?dist}
|
Release: 1%{?dist}
|
||||||
# GPLv2+ .. man-db
|
# GPLv2+ .. man-db
|
||||||
# GPLv3+ .. gnulib
|
# GPLv3+ .. gnulib
|
||||||
License: GPLv2+ and GPLv3+
|
License: GPLv2+ and GPLv3+
|
||||||
@ -19,9 +19,6 @@ Patch0: man-db-2.7.6.1-change-owner-of-man-cache.patch
|
|||||||
|
|
||||||
# http://lists.nongnu.org/archive/html/man-db-devel/2017-01/msg00013.html
|
# http://lists.nongnu.org/archive/html/man-db-devel/2017-01/msg00013.html
|
||||||
Patch1: man-db-2.7.6.1-fix-override-dir-handling.patch
|
Patch1: man-db-2.7.6.1-fix-override-dir-handling.patch
|
||||||
# http://lists.nongnu.org/archive/html/man-db-devel/2018-01/msg00005.html
|
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1495507
|
|
||||||
Patch2: man-db-2.7.6.1-fix_rhbz1495507.patch
|
|
||||||
|
|
||||||
Obsoletes: man < 2.0
|
Obsoletes: man < 2.0
|
||||||
Provides: man = %{version}
|
Provides: man = %{version}
|
||||||
@ -161,23 +158,30 @@ fi
|
|||||||
%{_mandir}/man8/accessdb.8*
|
%{_mandir}/man8/accessdb.8*
|
||||||
%{_mandir}/man8/catman.8*
|
%{_mandir}/man8/catman.8*
|
||||||
%{_mandir}/man8/mandb.8*
|
%{_mandir}/man8/mandb.8*
|
||||||
%lang(da) %{_datadir}/man/da/man*/*
|
%lang(da) %{_datadir}/man/da/man*/*
|
||||||
%lang(de) %{_datadir}/man/de/man*/*
|
%lang(de) %{_datadir}/man/de/man*/*
|
||||||
%lang(es) %{_datadir}/man/es/man*/*
|
%lang(es) %{_datadir}/man/es/man*/*
|
||||||
%lang(fr) %{_datadir}/man/fr/man*/*
|
%lang(fr) %{_datadir}/man/fr/man*/*
|
||||||
%lang(id) %{_datadir}/man/id/man*/*
|
%lang(id) %{_datadir}/man/id/man*/*
|
||||||
%lang(it) %{_datadir}/man/it/man*/*
|
%lang(it) %{_datadir}/man/it/man*/*
|
||||||
%lang(ja) %{_datadir}/man/ja/man*/*
|
%lang(ja) %{_datadir}/man/ja/man*/*
|
||||||
%lang(nl) %{_datadir}/man/nl/man*/*
|
%lang(nl) %{_datadir}/man/nl/man*/*
|
||||||
%lang(pl) %{_datadir}/man/pl/man*/*
|
%lang(pl) %{_datadir}/man/pl/man*/*
|
||||||
%lang(ru) %{_datadir}/man/ru/man*/*
|
%lang(pt_BR) %{_datadir}/man/pt_BR/man*/*
|
||||||
%lang(sv) %{_datadir}/man/sv/man*/*
|
%lang(ru) %{_datadir}/man/ru/man*/*
|
||||||
%lang(zh_CN) %{_datadir}/man/zh_CN/man*/*
|
%lang(sr) %{_datadir}/man/sr/man*/*
|
||||||
|
%lang(sv) %{_datadir}/man/sv/man*/*
|
||||||
|
%lang(tr) %{_datadir}/man/tr/man*/*
|
||||||
|
%lang(zh_CN) %{_datadir}/man/zh_CN/man*/*
|
||||||
|
|
||||||
%files cron
|
%files cron
|
||||||
%config(noreplace) %{_sysconfdir}/cron.daily/man-db.cron
|
%config(noreplace) %{_sysconfdir}/cron.daily/man-db.cron
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Apr 06 2018 Nikola Forró <nforro@redhat.com> - 2.8.3-1
|
||||||
|
- update to 2.8.3
|
||||||
|
resolves #1564220
|
||||||
|
|
||||||
* Tue Feb 20 2018 Nikola Forró <nforro@redhat.com> - 2.7.6.1-15
|
* Tue Feb 20 2018 Nikola Forró <nforro@redhat.com> - 2.7.6.1-15
|
||||||
- add missing gcc build dependency
|
- add missing gcc build dependency
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (man-db-2.7.6.1.tar.xz) = 623c5e7f8b7c289908b2c926f8777293b8d39aeceef0d2509d701a8b0bfa81408650f655c8608318221786c751a79ee91124b07993de5298cd7fa6d8bb737301
|
SHA512 (man-db-2.8.3.tar.xz) = 35d5dda7a2bda94978d10770d24d4c78b3c62c71a68cfeb400df61b0df289ed17aa8aa223d4ae3ffa094d76df8d9172b878230fd7b0397ce7728b9c8ac0b1745
|
||||||
|
Loading…
Reference in New Issue
Block a user