- update to 2.6.0.2

- remove obsolete patches
- add libpipe dependency
This commit is contained in:
Ivana Hutarova Varekova 2011-04-21 13:06:39 +02:00
parent d98c4103f5
commit 44366dacab
5 changed files with 10 additions and 63 deletions

2
.gitignore vendored
View File

@ -1 +1 @@
/man-db-2.5.9.tar.gz
/man-db-2.6.0.2.tar.gz

View File

@ -1,26 +0,0 @@
diff -up man-db-2.5.9/src/Makefile.in.pom man-db-2.5.9/src/Makefile.in
--- man-db-2.5.9/src/Makefile.in.pom 2010-11-17 12:46:26.000000000 +0100
+++ man-db-2.5.9/src/Makefile.in 2010-11-22 16:39:25.000000000 +0100
@@ -1138,16 +1138,17 @@ AM_CPPFLAGS = \
LIBMAN = $(top_builddir)/lib/libman.la
LIBMANDB = $(top_builddir)/libdb/libmandb.la
-accessdb_LDADD = $(LIBMANDB)
-catman_LDADD = $(LIBMANDB)
+accessdb_LDADD = $(LIBMANDB) $(LIBMAN) -lgdbm
+catman_LDADD = $(LIBMANDB) $(LIBMAN) -lgdbm
globbing_LDADD = $(LIBMAN)
lexgrog_LDADD = $(LIBMAN)
-man_LDADD = $(LIBMANDB)
+man_LDADD = $(LIBMANDB) $(LIBMAN) -lgdbm
manconv_LDADD = $(LIBMAN)
-mandb_LDADD = $(LIBMANDB)
+mandb_LDADD = $(LIBMANDB) $(LIBMAN) -lgdbm
manpath_LDADD = $(LIBMAN)
-whatis_LDADD = $(LIBMANDB) $(LTLIBICONV)
+whatis_LDADD = $(LIBMANDB) $(LTLIBICONV) $(LIBMAN) -lgdbm
zsoelim_LDADD = $(LIBMAN)
+
accessdb_SOURCES = \
accessdb.c

View File

@ -1,29 +0,0 @@
diff -up man-db-2.5.9/src/man.c.sec man-db-2.5.9/src/man.c
--- man-db-2.5.9/src/man.c.sec 2010-11-17 12:31:24.000000000 +0100
+++ man-db-2.5.9/src/man.c 2011-03-23 15:28:41.000000000 +0100
@@ -2827,10 +2827,24 @@ static int compare_candidates (const str
* moved out of order with respect to their parent sections.
*/
if (strcmp (lsource->ext, rsource->ext)) {
+ const char **sp;
+
+ /* If the user asked for an explicit section, sort exact
+ * matches first.
+ */
+ if (section) {
+ if (STREQ (lsource->ext, section)) {
+ if (!STREQ (rsource->ext, section))
+ return -1;
+ } else {
+ if (STREQ (rsource->ext, section))
+ return 1;
+ }
+ }
+
/* Find out whether lsource->ext is ahead of rsource->ext in
* section_list.
*/
- const char **sp;
for (sp = section_list; *sp; ++sp) {
if (!*(*sp + 1)) {
/* No extension */

View File

@ -2,8 +2,8 @@
Summary: Tools for searching and reading man pages
Name: man-db
Version: 2.5.9
Release: 6%{?dist}
Version: 2.6.0.2
Release: 1%{?dist}
# project man-db GPLv2+
# Gnulib part GPLv3+
License: GPLv2+ and GPLv3+
@ -12,10 +12,8 @@ URL: http://www.nongnu.org/man-db/
Source0: http://mirrors.igsobe.com/nongnu/man-db/%{name}-%{version}.tar.gz
Source1: man-db.crondaily
Source2: man-db.sysconfig
Patch0: man-db-2.5.9-config.patch
# Resolves: #655385 - use old format of nroff output
Patch1: man-db-2.5.9-sgr.patch
Patch2: man-db-2.5.9-sec.patch
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Obsoletes: man < 2.0
Provides: man-pages-reader = %{version}
@ -23,6 +21,7 @@ Provides: man = %{version}
BuildRequires: less
Requires: less, coreutils, grep, groff, gzip, crontabs
BuildRequires: gdbm-devel, groff, gettext, zlib-devel
BuildRequires: libpipeline-devel
%description
The man-db package includes five tools for browsing man-pages:
@ -34,9 +33,7 @@ manual pages.
%prep
%setup -q
%patch0 -p1 -b .conf
%patch1 -p1 -b .sgr
%patch2 -p1 -b .sec
%build
%configure\
@ -118,6 +115,11 @@ rm -rf $RPM_BUILD_ROOT
%lang(ja) %{_datadir}/man/ja/man*/*
%changelog
* Thu Apr 21 2011 Ivana Hutarova Varekova <varekova@redhat.com> - 2.6.0.2-1
- update to 2.6.0.2
- remove obsolete patches
- add libpipe dependency
* Wed Mar 23 2011 Ivana Hutarova Varekova <varekova@redhat.com> - 2.5.9-6
- Build with zlib support.
- Use elinks as default HTML browser.

View File

@ -1 +1 @@
9841394f5c5fe7e2dd2e0c5fb4766d0f man-db-2.5.9.tar.gz
2b41c96efec032d2b74ccbf2e401f93e man-db-2.6.0.2.tar.gz