parent
f0f502e5da
commit
3547306052
1
.gitignore
vendored
1
.gitignore
vendored
@ -9,3 +9,4 @@
|
||||
/man-db-2.9.2.tar.xz
|
||||
/man-db-2.9.3.tar.xz
|
||||
/man-db-2.9.4.tar.xz
|
||||
/man-db-2.10.0.tar.xz
|
||||
|
@ -1,4 +1,4 @@
|
||||
From c73e7dd16b7915ac9c67a376e014ea1220095348 Mon Sep 17 00:00:00 2001
|
||||
From 28ca281040720168679bc23baeaa767b64f29201 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Nikola=20Forr=C3=B3?= <nforro@redhat.com>
|
||||
Date: Tue, 27 Aug 2019 17:53:03 +0200
|
||||
Subject: [PATCH] man(1): Fix override dir handling
|
||||
@ -21,15 +21,15 @@ is passed to ./configure.
|
||||
Reported-by: Nikola Forró <nforro@redhat.com>
|
||||
Tested-by: Nikola Forró <nforro@redhat.com>
|
||||
---
|
||||
src/man.c | 33 ++++++++++++++++++++++++++++++++
|
||||
src/manp.c | 55 +++++++++++++++++++++---------------------------------
|
||||
2 files changed, 54 insertions(+), 34 deletions(-)
|
||||
src/man.c | 33 +++++++++++++++++++++++++++++++++
|
||||
src/manp.c | 52 ++++++++++++++++++++--------------------------------
|
||||
2 files changed, 53 insertions(+), 32 deletions(-)
|
||||
|
||||
diff --git a/src/man.c b/src/man.c
|
||||
index 6d1cba7..b3d13d1 100644
|
||||
index c91abf1..262e916 100644
|
||||
--- a/src/man.c
|
||||
+++ b/src/man.c
|
||||
@@ -2712,6 +2712,32 @@ static bool duplicate_candidates (struct candidate *left,
|
||||
@@ -2725,6 +2725,32 @@ static bool duplicate_candidates (struct candidate *left,
|
||||
return ret;
|
||||
}
|
||||
|
||||
@ -62,7 +62,7 @@ index 6d1cba7..b3d13d1 100644
|
||||
static int compare_candidates (const struct candidate *left,
|
||||
const struct candidate *right)
|
||||
{
|
||||
@@ -2801,6 +2827,13 @@ static int compare_candidates (const struct candidate *left,
|
||||
@@ -2814,6 +2840,13 @@ static int compare_candidates (const struct candidate *left,
|
||||
if (cmp)
|
||||
return cmp;
|
||||
|
||||
@ -77,10 +77,10 @@ index 6d1cba7..b3d13d1 100644
|
||||
* page in the user's preferred language than a page from a better
|
||||
* section, but that attracted objections, so now we prefer to get
|
||||
diff --git a/src/manp.c b/src/manp.c
|
||||
index 5441339..e437183 100644
|
||||
index 80b309a..4e3bff0 100644
|
||||
--- a/src/manp.c
|
||||
+++ b/src/manp.c
|
||||
@@ -903,23 +903,6 @@ static char *def_path (enum config_flag flag)
|
||||
@@ -911,23 +911,6 @@ static char *def_path (enum config_flag flag)
|
||||
return manpath;
|
||||
}
|
||||
|
||||
@ -104,28 +104,24 @@ index 5441339..e437183 100644
|
||||
/*
|
||||
* For each directory in the user's path, see if it is one of the
|
||||
* directories listed in the man_db.config file. If so, and it is
|
||||
@@ -968,7 +951,6 @@ char *get_manpath_from_path (const char *path, int mandatory)
|
||||
@@ -976,7 +959,6 @@ char *get_manpath_from_path (const char *path, int mandatory)
|
||||
if (!manpath_map_found)
|
||||
debug ("is in the config file\n");
|
||||
manpath_map_found = true;
|
||||
- insert_override_dir (tmplist, config_item->cont);
|
||||
add_dir_to_list (tmplist, config_item->cont);
|
||||
} GL_LIST_FOREACH_END (config);
|
||||
}
|
||||
|
||||
@@ -989,11 +971,8 @@ char *get_manpath_from_path (const char *path, int mandatory)
|
||||
debug ("adding mandatory man directories\n");
|
||||
@@ -998,8 +980,6 @@ char *get_manpath_from_path (const char *path, int mandatory)
|
||||
|
||||
GL_LIST_FOREACH_START (config, config_item) {
|
||||
- if (config_item->flag == MANDATORY) {
|
||||
GL_LIST_FOREACH (config, config_item) {
|
||||
if (config_item->flag == MANDATORY) {
|
||||
- insert_override_dir (tmplist,
|
||||
- config_item->key);
|
||||
+ if (config_item->flag == MANDATORY)
|
||||
add_dir_to_list (tmplist, config_item->key);
|
||||
- }
|
||||
} GL_LIST_FOREACH_END (config);
|
||||
}
|
||||
|
||||
@@ -1078,7 +1057,6 @@ static void add_man_subdirs (gl_list_t list, const char *path)
|
||||
}
|
||||
}
|
||||
@@ -1084,7 +1064,6 @@ static void add_man_subdirs (gl_list_t list, const char *path)
|
||||
if (subdir) {
|
||||
newpath = xasprintf ("%.*s/man", (int) (subdir - path), path);
|
||||
if (is_directory (newpath) == 1) {
|
||||
@ -133,7 +129,7 @@ index 5441339..e437183 100644
|
||||
add_dir_to_list (list, newpath);
|
||||
}
|
||||
free (newpath);
|
||||
@@ -1086,7 +1064,6 @@ static void add_man_subdirs (gl_list_t list, const char *path)
|
||||
@@ -1092,7 +1071,6 @@ static void add_man_subdirs (gl_list_t list, const char *path)
|
||||
|
||||
newpath = xasprintf ("%s/man", path);
|
||||
if (is_directory (newpath) == 1) {
|
||||
@ -141,7 +137,7 @@ index 5441339..e437183 100644
|
||||
add_dir_to_list (list, newpath);
|
||||
}
|
||||
free (newpath);
|
||||
@@ -1095,7 +1072,6 @@ static void add_man_subdirs (gl_list_t list, const char *path)
|
||||
@@ -1101,7 +1079,6 @@ static void add_man_subdirs (gl_list_t list, const char *path)
|
||||
newpath = xasprintf ("%.*s/share/man",
|
||||
(int) (subdir - path), path);
|
||||
if (is_directory (newpath) == 1) {
|
||||
@ -149,7 +145,7 @@ index 5441339..e437183 100644
|
||||
add_dir_to_list (list, newpath);
|
||||
}
|
||||
free (newpath);
|
||||
@@ -1103,7 +1079,6 @@ static void add_man_subdirs (gl_list_t list, const char *path)
|
||||
@@ -1109,7 +1086,6 @@ static void add_man_subdirs (gl_list_t list, const char *path)
|
||||
|
||||
newpath = xasprintf ("%s/share/man", path);
|
||||
if (is_directory (newpath) == 1) {
|
||||
@ -157,7 +153,7 @@ index 5441339..e437183 100644
|
||||
add_dir_to_list (list, newpath);
|
||||
}
|
||||
free (newpath);
|
||||
@@ -1199,7 +1174,9 @@ gl_list_t create_pathlist (const char *manp)
|
||||
@@ -1205,7 +1181,9 @@ gl_list_t create_pathlist (const char *manp)
|
||||
const struct canonicalized_path *cp;
|
||||
|
||||
/* Expand the manpath into a list of (path, canonicalized path)
|
||||
@ -168,7 +164,7 @@ index 5441339..e437183 100644
|
||||
* if they do not have the same canonicalized path as an existing
|
||||
* item, thereby eliminating duplicates due to symlinks.
|
||||
*/
|
||||
@@ -1208,15 +1185,25 @@ gl_list_t create_pathlist (const char *manp)
|
||||
@@ -1214,15 +1192,25 @@ gl_list_t create_pathlist (const char *manp)
|
||||
(GL_LINKEDHASH_LIST, canonicalized_path_equals,
|
||||
canonicalized_path_hash, canonicalized_path_free, false);
|
||||
for (p = manp;; p = end + 1) {
|
||||
@ -202,5 +198,5 @@ index 5441339..e437183 100644
|
||||
|
||||
list = new_string_list (GL_ARRAY_LIST, false);
|
||||
--
|
||||
2.26.2
|
||||
2.34.1
|
||||
|
14
man-db.spec
14
man-db.spec
@ -3,8 +3,8 @@
|
||||
|
||||
Summary: Tools for searching and reading man pages
|
||||
Name: man-db
|
||||
Version: 2.9.4
|
||||
Release: 3%{?dist}
|
||||
Version: 2.10.0
|
||||
Release: 1%{?dist}
|
||||
# GPLv2+ .. man-db
|
||||
# GPLv3+ .. gnulib
|
||||
License: GPLv2+ and GPLv3+
|
||||
@ -18,7 +18,7 @@ Source4: man-db-restart-cache-update.service
|
||||
Patch0: man-db-2.8.3-change-owner-of-man-cache.patch
|
||||
|
||||
# http://lists.nongnu.org/archive/html/man-db-devel/2017-01/msg00013.html
|
||||
Patch1: man-db-2.8.7-fix-override-dir-handling.patch
|
||||
Patch1: man-db-2.10.0-fix-override-dir-handling.patch
|
||||
|
||||
# change snap system directory from /snap to /var/lib/snapd/snap
|
||||
# https://lists.gnu.org/archive/html/man-db-devel/2020-02/msg00000.html
|
||||
@ -170,8 +170,8 @@ fi
|
||||
|
||||
%files -f %{name}.lang -f %{name}-gnulib.lang
|
||||
%{!?_licensedir:%global license %%doc}
|
||||
%license docs/COPYING
|
||||
%doc README man-db-manual.txt man-db-manual.ps ChangeLog NEWS
|
||||
%license COPYING
|
||||
%doc README.md man-db-manual.txt man-db-manual.ps ChangeLog NEWS.md
|
||||
%config(noreplace) %{_sysconfdir}/man_db.conf
|
||||
%config(noreplace) %{_sysconfdir}/sysconfig/man-db
|
||||
%config(noreplace) %{_tmpfilesdir}/man-db.conf
|
||||
@ -233,6 +233,10 @@ fi
|
||||
%config(noreplace) %{_sysconfdir}/cron.daily/man-db.cron
|
||||
|
||||
%changelog
|
||||
* Sun Feb 06 2022 Nikola Forró <nforro@redhat.com> - 2.10.0-1
|
||||
- update to 2.10.0
|
||||
resolves #2050778
|
||||
|
||||
* Thu Jan 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 2.9.4-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (man-db-2.9.4.tar.xz) = 169f091dd0a1d0dbd1583366f8257afb8f57e030d0f7d4213c14ce0b1fc5debf8b9cf2731de503830cb2826b3a22b3cff7da993d44ec18557935bd293529133c
|
||||
SHA512 (man-db-2.10.0.tar.xz) = de9c9f3dd9e6a578eb99aca0d04ce5c98cf6733e83e3be5299b6cafc4aad202896429a263a34111529eccdf07c353438afdade278818fc5d884471df7a4816c9
|
||||
|
Loading…
Reference in New Issue
Block a user