parent
2d66679cb9
commit
293922b07a
1
.gitignore
vendored
1
.gitignore
vendored
@ -10,3 +10,4 @@
|
|||||||
/man-db-2.9.3.tar.xz
|
/man-db-2.9.3.tar.xz
|
||||||
/man-db-2.9.4.tar.xz
|
/man-db-2.9.4.tar.xz
|
||||||
/man-db-2.10.0.tar.xz
|
/man-db-2.10.0.tar.xz
|
||||||
|
/man-db-2.10.1.tar.xz
|
||||||
|
@ -1,33 +0,0 @@
|
|||||||
From b86431ba72c3a21484fb221db6b6a82a78cc4bd8 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Colin Watson <cjwatson@debian.org>
|
|
||||||
Date: Fri, 4 Feb 2022 16:13:09 +0000
|
|
||||||
Subject: [PATCH] Fix mandb-symlink-target-timestamp test
|
|
||||||
|
|
||||||
* src/tests/mandb-symlink-target-timestamp: Fix handling of the case
|
|
||||||
where the nanosecond part of a timestamp starts with a zero.
|
|
||||||
|
|
||||||
* src/tests/mandb-symlink-target-timestamp: Fix handling of the case
|
|
||||||
where the nanosecond part of a timestamp is exactly 0 (probably because
|
|
||||||
the filesystem doesn't support nanosecond resolution).
|
|
||||||
---
|
|
||||||
src/tests/mandb-symlink-target-timestamp | 4 ++--
|
|
||||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/src/tests/mandb-symlink-target-timestamp b/src/tests/mandb-symlink-target-timestamp
|
|
||||||
index 1c87d3d..bc1baf1 100755
|
|
||||||
--- a/src/tests/mandb-symlink-target-timestamp
|
|
||||||
+++ b/src/tests/mandb-symlink-target-timestamp
|
|
||||||
@@ -21,8 +21,8 @@ write_page test 1 "$tmpdir/usr/share/man/man1/test.1.gz" \
|
|
||||||
ln -s test.1.gz "$tmpdir/usr/share/man/man1/test-link.1.gz"
|
|
||||||
run $MANDB -C "$tmpdir/manpath.config" -u -q "$tmpdir/usr/share/man"
|
|
||||||
cat >"$tmpdir/1.exp" <<EOF
|
|
||||||
-test -> "- 1 1 $(./get-mtime "$tmpdir/usr/share/man/man1/test.1.gz" | tr . ' ') A - - gz test(1)"
|
|
||||||
-test-link -> "- 1 1 $(./get-mtime "$tmpdir/usr/share/man/man1/test-link.1.gz" | tr . ' ') B - - gz test(1)"
|
|
||||||
+test -> "- 1 1 $(./get-mtime "$tmpdir/usr/share/man/man1/test.1.gz" | sed 's/\.0*\([0-9]\)/ \1/') A - - gz test(1)"
|
|
||||||
+test-link -> "- 1 1 $(./get-mtime "$tmpdir/usr/share/man/man1/test-link.1.gz" | sed 's/\.0*\([0-9]\)/ \1/') B - - gz test(1)"
|
|
||||||
EOF
|
|
||||||
run $ACCESSDB "$tmpdir/usr/share/man/index$db_ext" | \
|
|
||||||
grep -v '^\$' >"$tmpdir/1.out"
|
|
||||||
--
|
|
||||||
2.34.1
|
|
||||||
|
|
@ -1,4 +1,4 @@
|
|||||||
From 28ca281040720168679bc23baeaa767b64f29201 Mon Sep 17 00:00:00 2001
|
From b8483c4db97f6f879fe5e532a2ec66e9363033c9 Mon Sep 17 00:00:00 2001
|
||||||
From: =?UTF-8?q?Nikola=20Forr=C3=B3?= <nforro@redhat.com>
|
From: =?UTF-8?q?Nikola=20Forr=C3=B3?= <nforro@redhat.com>
|
||||||
Date: Tue, 27 Aug 2019 17:53:03 +0200
|
Date: Tue, 27 Aug 2019 17:53:03 +0200
|
||||||
Subject: [PATCH] man(1): Fix override dir handling
|
Subject: [PATCH] man(1): Fix override dir handling
|
||||||
@ -26,10 +26,10 @@ Tested-by: Nikola Forró <nforro@redhat.com>
|
|||||||
2 files changed, 53 insertions(+), 32 deletions(-)
|
2 files changed, 53 insertions(+), 32 deletions(-)
|
||||||
|
|
||||||
diff --git a/src/man.c b/src/man.c
|
diff --git a/src/man.c b/src/man.c
|
||||||
index c91abf1..262e916 100644
|
index f16fae8..29c8671 100644
|
||||||
--- a/src/man.c
|
--- a/src/man.c
|
||||||
+++ b/src/man.c
|
+++ b/src/man.c
|
||||||
@@ -2725,6 +2725,32 @@ static bool duplicate_candidates (struct candidate *left,
|
@@ -2728,6 +2728,32 @@ static bool duplicate_candidates (struct candidate *left,
|
||||||
return ret;
|
return ret;
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -62,7 +62,7 @@ index c91abf1..262e916 100644
|
|||||||
static int compare_candidates (const struct candidate *left,
|
static int compare_candidates (const struct candidate *left,
|
||||||
const struct candidate *right)
|
const struct candidate *right)
|
||||||
{
|
{
|
||||||
@@ -2814,6 +2840,13 @@ static int compare_candidates (const struct candidate *left,
|
@@ -2817,6 +2843,13 @@ static int compare_candidates (const struct candidate *left,
|
||||||
if (cmp)
|
if (cmp)
|
||||||
return cmp;
|
return cmp;
|
||||||
|
|
||||||
|
11
man-db.spec
11
man-db.spec
@ -3,8 +3,8 @@
|
|||||||
|
|
||||||
Summary: Tools for searching and reading man pages
|
Summary: Tools for searching and reading man pages
|
||||||
Name: man-db
|
Name: man-db
|
||||||
Version: 2.10.0
|
Version: 2.10.1
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
# GPLv2+ .. man-db
|
# GPLv2+ .. man-db
|
||||||
# GPLv3+ .. gnulib
|
# GPLv3+ .. gnulib
|
||||||
License: GPLv2+ and GPLv3+
|
License: GPLv2+ and GPLv3+
|
||||||
@ -24,9 +24,6 @@ Patch1: man-db-2.10.0-fix-override-dir-handling.patch
|
|||||||
# https://lists.gnu.org/archive/html/man-db-devel/2020-02/msg00000.html
|
# https://lists.gnu.org/archive/html/man-db-devel/2020-02/msg00000.html
|
||||||
Patch2: man-db-2.9.1-snap.patch
|
Patch2: man-db-2.9.1-snap.patch
|
||||||
|
|
||||||
# https://gitlab.com/cjwatson/man-db/-/issues/3
|
|
||||||
Patch3: man-db-2.10.0-fix-mandb-symlink-target-timestamp-test.patch
|
|
||||||
|
|
||||||
Obsoletes: man < 2.0
|
Obsoletes: man < 2.0
|
||||||
Provides: man = %{version}
|
Provides: man = %{version}
|
||||||
Provides: man-pages-reader = %{version}
|
Provides: man-pages-reader = %{version}
|
||||||
@ -236,6 +233,10 @@ fi
|
|||||||
%config(noreplace) %{_sysconfdir}/cron.daily/man-db.cron
|
%config(noreplace) %{_sysconfdir}/cron.daily/man-db.cron
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Feb 11 2022 Nikola Forró <nforro@redhat.com> - 2.10.1-1
|
||||||
|
- update to 2.10.1
|
||||||
|
resolves #2053020
|
||||||
|
|
||||||
* Tue Feb 08 2022 Nikola Forró <nforro@redhat.com> - 2.10.0-3
|
* Tue Feb 08 2022 Nikola Forró <nforro@redhat.com> - 2.10.0-3
|
||||||
- backport upstream fixes for the unstable test
|
- backport upstream fixes for the unstable test
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (man-db-2.10.0.tar.xz) = de9c9f3dd9e6a578eb99aca0d04ce5c98cf6733e83e3be5299b6cafc4aad202896429a263a34111529eccdf07c353438afdade278818fc5d884471df7a4816c9
|
SHA512 (man-db-2.10.1.tar.xz) = 25a3c4e3d7b171faf0771885a7a7d502c4af801881777231c79d7ee9768c2e48e44afbf5603af13f5ac63e6981cfdb8e36ba8a33d5f926d8122635cf45fcff7a
|
||||||
|
Loading…
Reference in New Issue
Block a user