import malaga-7.12-23.el8
This commit is contained in:
commit
7e47c837a9
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/malaga-7.12.tgz
|
1
.malaga.metadata
Normal file
1
.malaga.metadata
Normal file
@ -0,0 +1 @@
|
||||
19d74697575229231c18c83bb7a16b7ee6c31a51 SOURCES/malaga-7.12.tgz
|
1713
SOURCES/malaga-aarch64.patch
Normal file
1713
SOURCES/malaga-aarch64.patch
Normal file
File diff suppressed because it is too large
Load Diff
12
SOURCES/malaga-malshow-lm.patch
Normal file
12
SOURCES/malaga-malshow-lm.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -Naur malaga-7.12.orig/Makefile.in malaga-7.12/Makefile.in
|
||||
--- malaga-7.12.orig/Makefile.in 2008-02-28 20:38:21.000000000 +0200
|
||||
+++ malaga-7.12/Makefile.in 2010-02-10 20:59:54.506702713 +0200
|
||||
@@ -243,7 +243,7 @@
|
||||
malshow: $(MALSHOW_OBJS) libmalaga.la
|
||||
@echo "Linking malshow"
|
||||
@$(LIBTOOL) --mode=link $(LINK) $(MALSHOW_OBJS) $(GTK_LIBS) \
|
||||
- libmalaga.la -o malshow
|
||||
+ -lm libmalaga.la -o malshow
|
||||
|
||||
# malsym ----------------------------------------------------------------------
|
||||
|
92
SOURCES/malaga-rename-map_file.diff
Normal file
92
SOURCES/malaga-rename-map_file.diff
Normal file
@ -0,0 +1,92 @@
|
||||
diff -Nru malaga-7.12-orig/files.c malaga-7.12/files.c
|
||||
--- malaga-7.12-orig/files.c 2009-06-10 18:02:28.000000000 +0300
|
||||
+++ malaga-7.12/files.c 2009-06-10 18:04:38.000000000 +0300
|
||||
@@ -131,10 +131,10 @@
|
||||
/*---------------------------------------------------------------------------*/
|
||||
|
||||
void
|
||||
-map_file( string_t file_name, void **address, int_t *length )
|
||||
+malaga_map_file( string_t file_name, void **address, int_t *length )
|
||||
/* Map file "file_name" into the memory. It will be available in the
|
||||
* memory region starting at *ADDRESS and will occupy LENGTH bytes.
|
||||
- * After usage, return the memory region via "unmap_file". */
|
||||
+ * After usage, return the memory region via "malaga_unmap_file". */
|
||||
{
|
||||
#ifdef POSIX
|
||||
int file_descriptor;
|
||||
@@ -186,8 +186,8 @@
|
||||
/*---------------------------------------------------------------------------*/
|
||||
|
||||
void
|
||||
-unmap_file( void **address, int_t length )
|
||||
-/* Return the memory region that has been allocated by "map_file".
|
||||
+malaga_unmap_file( void **address, int_t length )
|
||||
+/* Return the memory region that has been allocated by "malaga_map_file".
|
||||
* The region starts at *ADDRESS and occupies LENGTH bytes. */
|
||||
{
|
||||
#ifdef POSIX
|
||||
diff -Nru malaga-7.12-orig/files.h malaga-7.12/files.h
|
||||
--- malaga-7.12-orig/files.h 2009-06-10 18:02:28.000000000 +0300
|
||||
+++ malaga-7.12/files.h 2009-06-10 18:05:19.000000000 +0300
|
||||
@@ -45,13 +45,13 @@
|
||||
* which is connected to file FILE_NAME, into allocated memory block,
|
||||
* and return a pointer to that block. */
|
||||
|
||||
-extern void map_file( string_t file_name, void **address, int_t *length );
|
||||
+extern void malaga_map_file( string_t file_name, void **address, int_t *length );
|
||||
/* Map file "file_name" into the memory. It will be available in the
|
||||
* memory region starting at *ADDRESS and will occupy LENGTH bytes.
|
||||
- * After usage, return the memory region via "unmap_file". */
|
||||
+ * After usage, return the memory region via "malaga_unmap_file". */
|
||||
|
||||
-extern void unmap_file( void **address, int_t length );
|
||||
-/* Return the memory region that has been allocated by "map_file".
|
||||
+extern void malaga_unmap_file( void **address, int_t length );
|
||||
+/* Return the memory region that has been allocated by "malaga_map_file".
|
||||
* The region starts at *ADDRESS and occupies LENGTH bytes. */
|
||||
|
||||
/* File name operations. ====================================================*/
|
||||
diff -Nru malaga-7.12-orig/lex_compiler.c malaga-7.12/lex_compiler.c
|
||||
--- malaga-7.12-orig/lex_compiler.c 2009-06-10 18:02:28.000000000 +0300
|
||||
+++ malaga-7.12/lex_compiler.c 2009-06-10 18:06:57.000000000 +0300
|
||||
@@ -846,7 +846,7 @@
|
||||
int_t i;
|
||||
|
||||
/* Map file into main memory. */
|
||||
- map_file( file_name, &prelex_data, &prelex_length );
|
||||
+ malaga_map_file( file_name, &prelex_data, &prelex_length );
|
||||
header = (prelex_header_t *) prelex_data;
|
||||
check_header( &header->common_header, file_name,
|
||||
PRELEX_FILE, MIN_PRELEX_CODE_VERSION, PRELEX_CODE_VERSION );
|
||||
@@ -859,7 +859,7 @@
|
||||
lex_add_allo( strings + entries[i].surface, values + entries[i].feat );
|
||||
|
||||
prelex_count = header->entry_count;
|
||||
- unmap_file( &prelex_data, prelex_length );
|
||||
+ malaga_unmap_file( &prelex_data, prelex_length );
|
||||
allomorph_count = 0;
|
||||
}
|
||||
|
||||
diff -Nru malaga-7.12-orig/lexicon.c malaga-7.12/lexicon.c
|
||||
--- malaga-7.12-orig/lexicon.c 2009-06-10 18:02:28.000000000 +0300
|
||||
+++ malaga-7.12/lexicon.c 2009-06-10 18:06:37.000000000 +0300
|
||||
@@ -90,7 +90,7 @@
|
||||
lexicon_header_t *header; /* Lexicon file header. */
|
||||
|
||||
/* Map the lexicon file into memory. */
|
||||
- map_file( file_name, &lexicon_data, &lexicon_length );
|
||||
+ malaga_map_file( file_name, &lexicon_data, &lexicon_length );
|
||||
|
||||
/* Check lexicon header. */
|
||||
header = (lexicon_header_t *) lexicon_data;
|
||||
@@ -117,7 +117,7 @@
|
||||
terminate_lexicon( void )
|
||||
/* Terminate this module. */
|
||||
{
|
||||
- unmap_file( &lexicon_data, lexicon_length );
|
||||
+ malaga_unmap_file( &lexicon_data, lexicon_length );
|
||||
}
|
||||
|
||||
/* End of file. =============================================================*/
|
||||
|
||||
|
239
SPECS/malaga.spec
Normal file
239
SPECS/malaga.spec
Normal file
@ -0,0 +1,239 @@
|
||||
Name: malaga
|
||||
Version: 7.12
|
||||
Release: 23%{?dist}
|
||||
Summary: A programming language for automatic language analysis
|
||||
|
||||
Group: Development/Languages
|
||||
License: GPLv2+
|
||||
URL: http://home.arcor.de/bjoern-beutel/malaga/
|
||||
Source0: http://home.arcor.de/bjoern-beutel/malaga/%{name}-%{version}.tgz
|
||||
# Fix map_file symbol conflict with samba. Upstream can be considered
|
||||
# inactive but as libvoikko >= 2.2 doesn't use libmalaga anymore, these kind
|
||||
# of problems won't probably come up. The only executables in Fedora which
|
||||
# link to libmalaga currently are the malaga tools.
|
||||
Patch0: malaga-rename-map_file.diff
|
||||
# Malshow needs to be linked with -lm as Fedora's ld doesn't do implicit
|
||||
# linking anymore
|
||||
Patch1: malaga-malshow-lm.patch
|
||||
Patch2: malaga-aarch64.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
BuildRequires: gtk2-devel readline-devel
|
||||
Requires(post): /sbin/install-info
|
||||
Requires(preun): /sbin/install-info
|
||||
Requires: lib%{name} = %{version}-%{release}
|
||||
|
||||
%description
|
||||
A software package for the development and application of
|
||||
grammars that are used for the analysis of words and sentences of natural
|
||||
languages. It is a language-independent system that offers a programming
|
||||
language for the modelling of the language-dependent grammatical
|
||||
information. This language is also called Malaga.
|
||||
|
||||
Malaga is based on the grammatical theory of the "Left Associative Grammar"
|
||||
(LAG), developed by Roland Hausser, professor for Computational Linguistics at
|
||||
University of Erlangen, Germany.
|
||||
|
||||
%package devel
|
||||
Summary: Development files for %{name}
|
||||
Group: Development/Languages
|
||||
Requires: lib%{name} = %{version}-%{release}
|
||||
|
||||
%description devel
|
||||
The %{name}-devel package contains libraries and header files for
|
||||
developing applications that use %{name}.
|
||||
|
||||
%package -n lib%{name}
|
||||
Summary: Library files for %{name}
|
||||
Group: Development/Libraries
|
||||
|
||||
%description -n lib%{name}
|
||||
Library files for %{name}.
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
# Remove "@" marks so that the build process is more verbose
|
||||
sed -i.debug -e 's|^\([ \t][ \t]*\)@|\1|' Makefile.in
|
||||
# Remove "-s" so binaries won't be stripped
|
||||
sed -i.strip -e 's| -s | |' Makefile.in
|
||||
# Make libtool output more verbose
|
||||
sed -i.silent -e 's|--silent||' Makefile.in
|
||||
|
||||
%build
|
||||
%configure --with-readline
|
||||
# Remove rpath,
|
||||
# https://fedoraproject.org/wiki/Packaging/Guidelines#Removing_Rpath
|
||||
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
|
||||
sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
|
||||
make %{?_smp_mflags}
|
||||
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
make install DESTDIR=$RPM_BUILD_ROOT INSTALL_INFO=/sbin/install-info INSTALL="install -p"
|
||||
rm -f $RPM_BUILD_ROOT%{_infodir}/dir
|
||||
find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
|
||||
# Remove static archive
|
||||
find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} ';'
|
||||
# Change permission of libmalaga.so*
|
||||
chmod 0755 $RPM_BUILD_ROOT%{_libdir}/libmalaga.so*
|
||||
|
||||
|
||||
%clean
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%post
|
||||
/sbin/install-info %{_infodir}/%{name}.info %{_infodir}/dir || :
|
||||
|
||||
%post -n lib%{name} -p /sbin/ldconfig
|
||||
|
||||
%preun
|
||||
if [ $1 = 0 ]; then
|
||||
/sbin/install-info --delete %{_infodir}/%{name}.info %{_infodir}/dir || :
|
||||
fi
|
||||
|
||||
%postun -n lib%{name} -p /sbin/ldconfig
|
||||
|
||||
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%{_infodir}/%{name}*
|
||||
%{_bindir}/mal*
|
||||
%{_datadir}/%{name}
|
||||
%{_mandir}/man1/mal*
|
||||
|
||||
%files -n lib%{name}
|
||||
%defattr(-,root,root,-)
|
||||
%doc CHANGES.txt GPL.txt README.txt
|
||||
%{_libdir}/lib%{name}.so.*
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root,-)
|
||||
%{_libdir}/lib%{name}*.so
|
||||
%{_includedir}/malaga.h
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 7.12-23
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 7.12-22
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 7.12-21
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Thu Jan 12 2017 Igor Gnatenko <ignatenko@redhat.com> - 7.12-20
|
||||
- Rebuild for readline 7.x
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 7.12-19
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.12-18
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.12-17
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.12-16
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.12-15
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Sun Apr 14 2013 Ville-Pekka Vainio <vpvainio@iki.fi> - 7.12-14
|
||||
- Add aarch64 patch from rhbz #926118
|
||||
|
||||
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.12-13
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.12-12
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.12-11
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Thu Nov 10 2011 Ville-Pekka Vainio <vpvainio@iki.fi> - 7.12-10
|
||||
- Rebuilt for new libpng
|
||||
|
||||
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.12-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Thu Jul 08 2010 Ville-Pekka Vainio <vpivaini AT cs.helsinki.fi> 7.12-8
|
||||
- The libmalaga subpackage had two defattrs, remove the other
|
||||
|
||||
* Wed Feb 10 2010 Ville-Pekka Vainio <vpivaini AT cs.helsinki.fi> - 7.12-7
|
||||
- Add patch to link malshow with -lm, hopefully fixes FTBFS caused by
|
||||
https://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking
|
||||
|
||||
* Wed Sep 16 2009 Ville-Pekka Vainio <vpivaini AT cs.helsinki.fi> - 7.12-6
|
||||
- Remove rpath which was set for the malaga binaries in 64 bit architechtures
|
||||
|
||||
* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.12-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
* Sun Jun 14 2009 Ville-Pekka Vainio <vpivaini AT cs.helsinki.fi> 7.12-4
|
||||
- Add patch to change the (un)map_file functions to malaga_(un)map_file,
|
||||
there was a symbol conflict with the samba libraries causing a segfault
|
||||
if enchant-voikko and evolution-mapi were both installed when using
|
||||
Evolution. Bugs rhbz #502546 and sourceforge #2802548, patch by Harri
|
||||
Pitkänen.
|
||||
- Add defattr to the libmalaga subpackage
|
||||
|
||||
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.12-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
* Thu Apr 03 2008 Ville-Pekka Vainio <vpivaini AT cs.helsinki.fi> 7.12-2
|
||||
- Upstream changed the source tarball of the current release, use the current
|
||||
upstream sources
|
||||
|
||||
* Sun Mar 02 2008 Ville-Pekka Vainio <vpivaini AT cs.helsinki.fi> 7.12-1
|
||||
- New version
|
||||
- Drop upstreamed linking patch
|
||||
- Re-add a Makefile.in sed build verbosity trick, which was done in the
|
||||
dropped patch but not upstream
|
||||
|
||||
* Sat Feb 23 2008 Ville-Pekka Vainio <vpivaini AT cs.helsinki.fi> 7.11-3
|
||||
- Add Makefile.in patch to link the executables against libmalaga
|
||||
|
||||
* Sat Feb 16 2008 Ville-Pekka Vainio <vpivaini AT cs.helsinki.fi> 7.11-2
|
||||
- Rebuild for GCC 4.3
|
||||
|
||||
* Mon Oct 29 2007 Ville-Pekka Vainio <vpivaini AT cs.helsinki.fi> 7.11-1
|
||||
- Increment release for the first Fedora build
|
||||
|
||||
* Sun Oct 28 2007 Ville-Pekka Vainio <vpivaini AT cs.helsinki.fi> 7.11-0.5
|
||||
- -devel requires only libmalaga, not malaga
|
||||
|
||||
* Sun Oct 28 2007 Ville-Pekka Vainio <vpivaini AT cs.helsinki.fi> 7.11-0.4
|
||||
- Add option --with-readline to configure
|
||||
- Add BR readline-devel
|
||||
|
||||
* Sat Oct 27 2007 Ville-Pekka Vainio <vpivaini AT cs.helsinki.fi> 7.11-0.3
|
||||
- Don't strip binaries
|
||||
- Remove static archive
|
||||
- Make build procedure more verbose
|
||||
- Make libtool output more verbose
|
||||
- Remove redundant requires gtk2
|
||||
- Add INSTALL="install -p" to make install to preserve timestamps
|
||||
- Change libmalaga.so* to have permissions 0755
|
||||
|
||||
* Wed Oct 24 2007 Ville-Pekka Vainio <vpivaini AT cs.helsinki.fi> 7.11-0.2
|
||||
- Main package requires libmalaga version-release and gtk2 (malshow needs it)
|
||||
- libmalaga requires in -devel removed, that's implicit
|
||||
- install-info called in post of main package
|
||||
- Unneeded postun line removed
|
||||
- INSTALL.txt is not needed in this package
|
||||
- All documents are now in libmalaga
|
||||
- /usr/share/malaga/ now owned by the malaga package
|
||||
- A shorter Summary so rpmlint won't complain
|
||||
- Currently writes an empty debuginfo package, "install -s" is called in
|
||||
Makefile, how do I remove it?
|
||||
|
||||
* Mon Oct 22 2007 Ville-Pekka Vainio <vpivaini AT cs.helsinki.fi> 7.11-0.1
|
||||
- Initial package
|
Loading…
Reference in New Issue
Block a user