Merge branch 'f14/master'
Conflicts: make.spec
This commit is contained in:
commit
ccbdcb62ff
22
make-3.82-sort-blank.patch
Normal file
22
make-3.82-sort-blank.patch
Normal file
@ -0,0 +1,22 @@
|
|||||||
|
diff -urp make-3.82/function.c make-3.82-pm/function.c
|
||||||
|
--- make-3.82/function.c 2010-07-13 03:20:39.000000000 +0200
|
||||||
|
+++ make-3.82-pm/function.c 2010-10-27 01:43:27.000000000 +0200
|
||||||
|
@@ -1138,12 +1138,12 @@ func_sort (char *o, char **argv, const c
|
||||||
|
{
|
||||||
|
char c = *(t++);
|
||||||
|
|
||||||
|
- if (! isspace ((unsigned char)c))
|
||||||
|
+ if (! isblank ((unsigned char)c))
|
||||||
|
continue;
|
||||||
|
|
||||||
|
++wordi;
|
||||||
|
|
||||||
|
- while (isspace ((unsigned char)*t))
|
||||||
|
+ while (isblank ((unsigned char)*t))
|
||||||
|
++t;
|
||||||
|
}
|
||||||
|
|
||||||
|
Только в make-3.82-pm: function.c~
|
||||||
|
Двоичные файлы make-3.82/function.o и make-3.82-pm/function.o различаются
|
||||||
|
Двоичные файлы make-3.82/make и make-3.82-pm/make различаются
|
||||||
|
Только в make-3.82-pm: misc.c~
|
@ -3,7 +3,7 @@ Summary: A GNU tool which simplifies the build process for users
|
|||||||
Name: make
|
Name: make
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 3.82
|
Version: 3.82
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
URL: http://www.gnu.org/software/make/
|
URL: http://www.gnu.org/software/make/
|
||||||
@ -17,6 +17,7 @@ Patch6: make-3.82-weird-shell.patch
|
|||||||
Patch7: make-3.82-newlines.patch
|
Patch7: make-3.82-newlines.patch
|
||||||
Patch8: make-3.82-jobserver.patch
|
Patch8: make-3.82-jobserver.patch
|
||||||
Patch9: make-3.82-bugfixes.patch
|
Patch9: make-3.82-bugfixes.patch
|
||||||
|
Patch10: make-3.82-sort-blank.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
Requires(post): /sbin/install-info
|
Requires(post): /sbin/install-info
|
||||||
Requires(preun): /sbin/install-info
|
Requires(preun): /sbin/install-info
|
||||||
@ -41,6 +42,7 @@ makefile.
|
|||||||
%patch7 -p1
|
%patch7 -p1
|
||||||
%patch8 -p1
|
%patch8 -p1
|
||||||
%patch9 -p1
|
%patch9 -p1
|
||||||
|
%patch10 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure
|
%configure
|
||||||
@ -83,6 +85,11 @@ fi
|
|||||||
%{_infodir}/*.info*
|
%{_infodir}/*.info*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Oct 27 2010 Petr Machata <pmachata@redhat.com> - 1:3.82-4
|
||||||
|
- Fix a discrepancy between behavior of find_next_token and
|
||||||
|
pre-allocation of token memory in func_sort.
|
||||||
|
- Resolves: #643359
|
||||||
|
|
||||||
* Wed Sep 29 2010 jkeating - 1:3.82-3
|
* Wed Sep 29 2010 jkeating - 1:3.82-3
|
||||||
- Rebuilt for gcc bug 634757
|
- Rebuilt for gcc bug 634757
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user