Update to 4.4.1
Remove patch which has been applied upstream.
This commit is contained in:
parent
d82cede64b
commit
64883e56da
1
.gitignore
vendored
1
.gitignore
vendored
@ -7,3 +7,4 @@ make-3.82.tar.bz2
|
|||||||
/make-4.2.1.tar.bz2
|
/make-4.2.1.tar.bz2
|
||||||
/make-4.3.tar.gz
|
/make-4.3.tar.gz
|
||||||
/make-4.4.tar.gz
|
/make-4.4.tar.gz
|
||||||
|
/make-4.4.1.tar.gz
|
||||||
|
@ -1,33 +0,0 @@
|
|||||||
From 92ab2e642d2c04b3dcb5a736ae6193680bfd5f74 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Paul Smith <psmith@gnu.org>
|
|
||||||
Date: Sun, 6 Nov 2022 15:22:02 -0500
|
|
||||||
Subject: * src/main.c (main): [SV 63307] Handle SIGPIPE as a fatal signal
|
|
||||||
|
|
||||||
Always ignoring SIGPIPE is visible to child processes.
|
|
||||||
|
|
||||||
diff --git a/src/main.c b/src/main.c
|
|
||||||
index eec93656..f2caf7a8 100644
|
|
||||||
--- a/src/main.c
|
|
||||||
+++ b/src/main.c
|
|
||||||
@@ -1182,11 +1182,6 @@ main (int argc, char **argv, char **envp)
|
|
||||||
/* Useful for attaching debuggers, etc. */
|
|
||||||
SPIN ("main-entry");
|
|
||||||
|
|
||||||
- /* Don't die if our stdout sends us SIGPIPE. */
|
|
||||||
-#ifdef SIGPIPE
|
|
||||||
- bsd_signal (SIGPIPE, SIG_IGN);
|
|
||||||
-#endif
|
|
||||||
-
|
|
||||||
#ifdef HAVE_ATEXIT
|
|
||||||
if (ANY_SET (check_io_state (), IO_STDOUT_OK))
|
|
||||||
atexit (close_stdout);
|
|
||||||
@@ -1264,6 +1259,9 @@ main (int argc, char **argv, char **envp)
|
|
||||||
#endif
|
|
||||||
#ifdef SIGQUIT
|
|
||||||
FATAL_SIG (SIGQUIT);
|
|
||||||
+#endif
|
|
||||||
+#ifdef SIGPIPE
|
|
||||||
+ FATAL_SIG (SIGPIPE);
|
|
||||||
#endif
|
|
||||||
FATAL_SIG (SIGINT);
|
|
||||||
FATAL_SIG (SIGTERM);
|
|
13
make.spec
13
make.spec
@ -4,15 +4,15 @@
|
|||||||
# optional versioned updates.
|
# optional versioned updates.
|
||||||
Name: make
|
Name: make
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 4.4
|
Version: 4.4.1
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
URL: http://www.gnu.org/software/make/
|
URL: http://www.gnu.org/software/make/
|
||||||
Source: ftp://ftp.gnu.org/gnu/make/make-%{version}.tar.gz
|
Source: ftp://ftp.gnu.org/gnu/make/make-%{version}.tar.gz
|
||||||
|
|
||||||
%if "%{name}" != "make"
|
%if "%{name}" != "make"
|
||||||
# Set this to the sub-package base name, for "make-latest"
|
# Set this to the sub-package base name, for "make-latest"
|
||||||
%global make make44
|
%global make make441
|
||||||
%if 0%{?rhel} > 0
|
%if 0%{?rhel} > 0
|
||||||
%global _prefix /opt/rh/%{make}
|
%global _prefix /opt/rh/%{make}
|
||||||
%else
|
%else
|
||||||
@ -44,10 +44,6 @@ Patch1: make-4.0-noclock_gettime.patch
|
|||||||
# BZs #142691, #17374
|
# BZs #142691, #17374
|
||||||
Patch2: make-4.3-j8k.patch
|
Patch2: make-4.3-j8k.patch
|
||||||
|
|
||||||
# Upstream commit 92ab2e642d2c04b3dcb5a736ae6193680bfd5f74
|
|
||||||
# Remove for 4.4.1 or later
|
|
||||||
Patch3: make-4.4-sigpipe.patch
|
|
||||||
|
|
||||||
# autoreconf
|
# autoreconf
|
||||||
BuildRequires: make
|
BuildRequires: make
|
||||||
BuildRequires: autoconf, automake, gettext-devel
|
BuildRequires: autoconf, automake, gettext-devel
|
||||||
@ -138,6 +134,9 @@ echo ============END TESTING===========
|
|||||||
%{_includedir}/gnumake.h
|
%{_includedir}/gnumake.h
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Mar 31 2023 DJ Delorie <dj@redhat.com> - 1:4.4.1-1
|
||||||
|
- Rebase to make 4.4
|
||||||
|
|
||||||
* Mon Jan 30 2023 DJ Delorie <dj@redhat.com> - 1:4.4-3
|
* Mon Jan 30 2023 DJ Delorie <dj@redhat.com> - 1:4.4-3
|
||||||
- Handle SIGPIPE as a fatal signal
|
- Handle SIGPIPE as a fatal signal
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (make-4.4.tar.gz) = 4be73f494295dcfa10034531b0d920cfdb5438bc20625f863f5c878549c140e1e67195162580c53060c3c11c67a2c739c09051f02cdd283e5aa9ebcd68975a1f
|
SHA512 (make-4.4.1.tar.gz) = 145260cbd6a8226cef3dfef0c8baba31847beaebc7e6b65d39d02715fd4f4cab9b139b6c3772e550088d4f9ae80c6d3ed20b9a7664c693644dfb96b4cb60e67c
|
||||||
|
Loading…
Reference in New Issue
Block a user