parent
d6bbfbfe82
commit
2bfdac0113
1
.gitignore
vendored
1
.gitignore
vendored
@ -4,3 +4,4 @@ make-3.82.tar.bz2
|
||||
*.rpm
|
||||
/make-4.0.tar.bz2
|
||||
/make-4.1.tar.bz2
|
||||
/make-4.2.1.tar.bz2
|
||||
|
12
make-4.2-getcwd.patch
Normal file
12
make-4.2-getcwd.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -Nrup a/makeint.h b/makeint.h
|
||||
--- a/makeint.h 2016-05-21 16:22:32.000000000 -0400
|
||||
+++ b/makeint.h 2016-09-22 16:12:38.606702160 -0400
|
||||
@@ -596,7 +596,7 @@ long int lseek ();
|
||||
# endif
|
||||
|
||||
# ifdef HAVE_GETCWD
|
||||
-# if !defined(VMS) && !defined(__DECC)
|
||||
+# if !defined(VMS) && !defined(__DECC) && !defined(getcwd)
|
||||
char *getcwd ();
|
||||
# endif
|
||||
# else
|
25
make-4.2-j8k.patch
Normal file
25
make-4.2-j8k.patch
Normal file
@ -0,0 +1,25 @@
|
||||
diff -Nrup a/main.c b/main.c
|
||||
--- a/main.c 2016-05-31 03:17:26.000000000 -0400
|
||||
+++ b/main.c 2016-09-22 16:18:52.283889265 -0400
|
||||
@@ -2051,6 +2051,21 @@ main (int argc, char **argv, char **envp
|
||||
}
|
||||
#endif
|
||||
|
||||
+#ifdef PIPE_BUF
|
||||
+ if (job_slots > PIPE_BUF)
|
||||
+#elif defined _POSIX_PIPE_BUF
|
||||
+ if (job_slots > _POSIX_PIPE_BUF)
|
||||
+#else
|
||||
+ if (job_slots > 512)
|
||||
+#endif
|
||||
+ {
|
||||
+ O (error, NILF,
|
||||
+ _("More parallel jobs (-jN) than this platform can handle requested."));
|
||||
+ O (error, NILF, _("Resetting to single job (-j1) mode."));
|
||||
+ job_slots = 1;
|
||||
+ }
|
||||
+
|
||||
+
|
||||
/* If we have >1 slot at this point, then we're a top-level make.
|
||||
Set up the jobserver.
|
||||
|
21
make.spec
21
make.spec
@ -2,14 +2,14 @@
|
||||
Summary: A GNU tool which simplifies the build process for users
|
||||
Name: make
|
||||
Epoch: 1
|
||||
Version: 4.1
|
||||
Release: 6%{?dist}
|
||||
Version: 4.2.1
|
||||
Release: 1%{?dist}
|
||||
License: GPLv3+
|
||||
Group: Development/Tools
|
||||
URL: http://www.gnu.org/software/make/
|
||||
Source: ftp://ftp.gnu.org/gnu/make/make-%{version}.tar.bz2
|
||||
|
||||
Patch0: make-4.0-getcwd.patch
|
||||
Patch0: make-4.2-getcwd.patch
|
||||
Patch1: make-4.0-newlines.patch
|
||||
|
||||
# Assume we don't have clock_gettime in configure, so that
|
||||
@ -18,17 +18,11 @@ Patch1: make-4.0-newlines.patch
|
||||
Patch2: make-4.0-noclock_gettime.patch
|
||||
|
||||
# BZs #142691, #17374
|
||||
Patch3: make-4.0-j8k.patch
|
||||
|
||||
# make sure errno for error reporting is not lost accross _() calls
|
||||
Patch4: make-4.0-err-reporting.patch
|
||||
Patch3: make-4.2-j8k.patch
|
||||
|
||||
# Upstream: https://savannah.gnu.org/bugs/?30748
|
||||
# The default value of .SHELL_FLAGS is -c.
|
||||
Patch5: make-4.0-weird-shell.patch
|
||||
|
||||
# make seg faults when run with no arguments
|
||||
Patch6: make-4.1-rh1277968.patch
|
||||
Patch4: make-4.0-weird-shell.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
Requires(post): /sbin/install-info
|
||||
@ -59,8 +53,6 @@ The make-devel package contains gnumake.h.
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
%patch5 -p1
|
||||
%patch6 -p1
|
||||
|
||||
rm -f tests/scripts/features/parallelism.orig
|
||||
|
||||
@ -110,6 +102,9 @@ fi
|
||||
%{_includedir}/gnumake.h
|
||||
|
||||
%changelog
|
||||
* Sun Sep 25 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1:4.2.1-1
|
||||
- Rebase to make-4.2.1. Remove obsolete patches. BZ #1338558
|
||||
|
||||
* Sun Sep 25 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1:4.1-6
|
||||
- Make test suite requires Perl to run.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user