Switch to latest guile version
Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
This commit is contained in:
parent
3c945c8317
commit
0bdbc64c9d
55
0001-configure.ac-SV-50648-Detect-Guile-2.2-packages.patch
Normal file
55
0001-configure.ac-SV-50648-Detect-Guile-2.2-packages.patch
Normal file
@ -0,0 +1,55 @@
|
||||
From fbf71ec25a5986d9003ac16ee9e23675feac9053 Mon Sep 17 00:00:00 2001
|
||||
From: Paul Smith <psmith@gnu.org>
|
||||
Date: Sun, 16 Apr 2017 15:03:48 -0400
|
||||
Subject: [PATCH] * configure.ac: [SV 50648] Detect Guile 2.2 packages.
|
||||
|
||||
---
|
||||
configure.ac | 26 ++++++++++++++++----------
|
||||
1 file changed, 16 insertions(+), 10 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 1187ad4..a78fb93 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -160,22 +160,28 @@ AC_FUNC_ALLOCA
|
||||
AC_FUNC_CLOSEDIR_VOID
|
||||
|
||||
# See if the user wants to add (or not) GNU Guile support
|
||||
-PKG_PROG_PKG_CONFIG
|
||||
AC_ARG_WITH([guile], [AS_HELP_STRING([--with-guile],
|
||||
[Support GNU Guile for embedded scripting])])
|
||||
|
||||
-# For some strange reason, at least on Ubuntu, each version of Guile
|
||||
-# comes with it's own PC file so we have to specify them as individual
|
||||
-# packages. Ugh.
|
||||
+# Annoyingly, each version of Guile comes with it's own PC file so we have to
|
||||
+# specify them as individual packages. Ugh.
|
||||
+PKG_PROG_PKG_CONFIG
|
||||
+
|
||||
AS_IF([test "x$with_guile" != xno],
|
||||
-[ PKG_CHECK_MODULES([GUILE], [guile-2.0], [have_guile=yes],
|
||||
- [PKG_CHECK_MODULES([GUILE], [guile-1.8], [have_guile=yes],
|
||||
- [have_guile=no])])
|
||||
+[ guile_versions="2.2 2.0 1.8"
|
||||
+ guile_version=no
|
||||
+ have_guile=no
|
||||
+ AC_MSG_CHECKING([for GNU Guile])
|
||||
+ for v in $guile_versions; do
|
||||
+ PKG_CHECK_EXISTS([guile-$v], [guile_version=$v; have_guile=yes; break], [])
|
||||
+ done
|
||||
+ AC_MSG_RESULT([$guile_version])
|
||||
+ if test "$have_guile" = yes; then
|
||||
+ PKG_CHECK_MODULES(GUILE, [guile-$guile_version])
|
||||
+ AC_DEFINE([HAVE_GUILE], [1], [Embed GNU Guile support])
|
||||
+ fi
|
||||
])
|
||||
|
||||
-AS_IF([test "$have_guile" = yes],
|
||||
- [AC_DEFINE([HAVE_GUILE], [1], [Embed GNU Guile support])])
|
||||
-
|
||||
AM_CONDITIONAL([HAVE_GUILE], [test "$have_guile" = yes])
|
||||
|
||||
AC_FUNC_GETLOADAVG
|
||||
--
|
||||
2.21.0.rc1
|
||||
|
19
make.spec
19
make.spec
@ -3,7 +3,7 @@ Summary: A GNU tool which simplifies the build process for users
|
||||
Name: make
|
||||
Epoch: 1
|
||||
Version: 4.2.1
|
||||
Release: 11%{?dist}
|
||||
Release: 12%{?dist}
|
||||
License: GPLv3+
|
||||
URL: http://www.gnu.org/software/make/
|
||||
Source: ftp://ftp.gnu.org/gnu/make/make-%{version}.tar.bz2
|
||||
@ -31,14 +31,18 @@ Patch5: make-4.2.1-glob-fix-2.patch
|
||||
Patch6: make-4.2.1-glob-fix.patch
|
||||
Patch7: make-4.2.1-glob-fix-3.patch
|
||||
|
||||
# Perl 5.26 removed the implicit CWD in @INC.
|
||||
# Perl 5.26 removed the implicit CWD in @INC.
|
||||
Patch8: make-4.2.1-test-driver.patch
|
||||
|
||||
# Upstream patch: https://git.savannah.gnu.org/cgit/make.git/commit/?id=fbf71ec25a5986d9003ac16ee9e23675feac9053
|
||||
# Adds support of guile 2.2
|
||||
Patch9: 0001-configure.ac-SV-50648-Detect-Guile-2.2-packages.patch
|
||||
|
||||
# Unfortunately the glob patches configure.ac, so:
|
||||
BuildRequires: autoconf, automake
|
||||
BuildRequires: procps
|
||||
BuildRequires: perl-interpreter
|
||||
BuildRequires: guile-devel
|
||||
BuildRequires: pkgconfig(guile-2.2)
|
||||
BuildRequires: gcc
|
||||
|
||||
%description
|
||||
@ -97,6 +101,9 @@ echo ============END TESTING===========
|
||||
%{_includedir}/gnumake.h
|
||||
|
||||
%changelog
|
||||
* Sun Feb 17 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1:4.2.1-12
|
||||
- Switch to latest guile version
|
||||
|
||||
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1:4.2.1-11
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
@ -139,7 +146,7 @@ echo ============END TESTING===========
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Wed Nov 4 2015 Patsy Franklin <pfrankli@redhat.com> 1:4.1-4
|
||||
- Handle NULL returns from ttyname() Upstream Bug 43434.
|
||||
- Handle NULL returns from ttyname() Upstream Bug 43434.
|
||||
Resolves: #1277968
|
||||
|
||||
* Thu Oct 29 2015 Patsy Franklin <pfrankli@redhat.com> 1:4.1-3
|
||||
@ -467,12 +474,12 @@ echo ============END TESTING===========
|
||||
* Thu Apr 15 1999 Bill Nottingham <notting@redhat.com>
|
||||
- added a serial tag so it upgrades right
|
||||
|
||||
* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
|
||||
* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
|
||||
- auto rebuild in the new build environment (release 5)
|
||||
|
||||
* Wed Sep 16 1998 Cristian Gafton <gafton@redhat.com>
|
||||
- added a patch for large file support in glob
|
||||
|
||||
|
||||
* Tue Aug 18 1998 Jeff Johnson <jbj@redhat.com>
|
||||
- update to 3.77
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user