Update to m4-1.4.19
This commit is contained in:
parent
dec446dc1d
commit
745918953c
4
.gitignore
vendored
4
.gitignore
vendored
@ -1,2 +1,2 @@
|
|||||||
/m4-1.4.18.tar.xz
|
/m4-1.4.19.tar.xz
|
||||||
/m4-1.4.18.tar.xz.sig
|
/m4-1.4.19.tar.xz.sig
|
||||||
|
@ -1,115 +0,0 @@
|
|||||||
diff -up m4-1.4.18/lib/fflush.c.orig m4-1.4.18/lib/fflush.c
|
|
||||||
--- m4-1.4.18/lib/fflush.c.orig 2018-05-02 12:35:59.536851666 +0200
|
|
||||||
+++ m4-1.4.18/lib/fflush.c 2018-05-02 12:37:02.768958606 +0200
|
|
||||||
@@ -33,7 +33,7 @@
|
|
||||||
#undef fflush
|
|
||||||
|
|
||||||
|
|
||||||
-#if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
|
|
||||||
+#if defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
|
|
||||||
|
|
||||||
/* Clear the stream's ungetc buffer, preserving the value of ftello (fp). */
|
|
||||||
static void
|
|
||||||
@@ -72,7 +72,7 @@ clear_ungetc_buffer (FILE *fp)
|
|
||||||
|
|
||||||
#endif
|
|
||||||
|
|
||||||
-#if ! (defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */)
|
|
||||||
+#if ! (defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */)
|
|
||||||
|
|
||||||
# if (defined __sferror || defined __DragonFly__ || defined __ANDROID__) && defined __SNPT
|
|
||||||
/* FreeBSD, NetBSD, OpenBSD, DragonFly, Mac OS X, Cygwin, Android */
|
|
||||||
@@ -148,7 +148,7 @@ rpl_fflush (FILE *stream)
|
|
||||||
if (stream == NULL || ! freading (stream))
|
|
||||||
return fflush (stream);
|
|
||||||
|
|
||||||
-#if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
|
|
||||||
+#if defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
|
|
||||||
|
|
||||||
clear_ungetc_buffer_preserving_position (stream);
|
|
||||||
|
|
||||||
diff -up m4-1.4.18/lib/fpending.c.orig m4-1.4.18/lib/fpending.c
|
|
||||||
--- m4-1.4.18/lib/fpending.c.orig 2018-05-02 12:35:32.305806774 +0200
|
|
||||||
+++ m4-1.4.18/lib/fpending.c 2018-05-02 12:35:44.944827347 +0200
|
|
||||||
@@ -32,7 +32,7 @@ __fpending (FILE *fp)
|
|
||||||
/* Most systems provide FILE as a struct and the necessary bitmask in
|
|
||||||
<stdio.h>, because they need it for implementing getc() and putc() as
|
|
||||||
fast macros. */
|
|
||||||
-#if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
|
|
||||||
+#if defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
|
|
||||||
return fp->_IO_write_ptr - fp->_IO_write_base;
|
|
||||||
#elif defined __sferror || defined __DragonFly__ || defined __ANDROID__
|
|
||||||
/* FreeBSD, NetBSD, OpenBSD, DragonFly, Mac OS X, Cygwin, Android */
|
|
||||||
diff -up m4-1.4.18/lib/fpurge.c.orig m4-1.4.18/lib/fpurge.c
|
|
||||||
--- m4-1.4.18/lib/fpurge.c.orig 2018-05-02 12:38:13.586078669 +0200
|
|
||||||
+++ m4-1.4.18/lib/fpurge.c 2018-05-02 12:38:38.785121867 +0200
|
|
||||||
@@ -62,7 +62,7 @@ fpurge (FILE *fp)
|
|
||||||
/* Most systems provide FILE as a struct and the necessary bitmask in
|
|
||||||
<stdio.h>, because they need it for implementing getc() and putc() as
|
|
||||||
fast macros. */
|
|
||||||
-# if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
|
|
||||||
+# if defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
|
|
||||||
fp->_IO_read_end = fp->_IO_read_ptr;
|
|
||||||
fp->_IO_write_ptr = fp->_IO_write_base;
|
|
||||||
/* Avoid memory leak when there is an active ungetc buffer. */
|
|
||||||
diff -up m4-1.4.18/lib/freadahead.c.orig m4-1.4.18/lib/freadahead.c
|
|
||||||
--- m4-1.4.18/lib/freadahead.c.orig 2016-12-31 14:54:41.000000000 +0100
|
|
||||||
+++ m4-1.4.18/lib/freadahead.c 2018-05-02 11:43:19.570336724 +0200
|
|
||||||
@@ -25,7 +25,7 @@
|
|
||||||
size_t
|
|
||||||
freadahead (FILE *fp)
|
|
||||||
{
|
|
||||||
-#if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
|
|
||||||
+#if defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
|
|
||||||
if (fp->_IO_write_ptr > fp->_IO_write_base)
|
|
||||||
return 0;
|
|
||||||
return (fp->_IO_read_end - fp->_IO_read_ptr)
|
|
||||||
diff -up m4-1.4.18/lib/freading.c.orig m4-1.4.18/lib/freading.c
|
|
||||||
--- m4-1.4.18/lib/freading.c.orig 2018-05-02 12:37:33.970011368 +0200
|
|
||||||
+++ m4-1.4.18/lib/freading.c 2018-05-02 12:37:59.393054359 +0200
|
|
||||||
@@ -31,7 +31,7 @@ freading (FILE *fp)
|
|
||||||
/* Most systems provide FILE as a struct and the necessary bitmask in
|
|
||||||
<stdio.h>, because they need it for implementing getc() and putc() as
|
|
||||||
fast macros. */
|
|
||||||
-# if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
|
|
||||||
+# if defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
|
|
||||||
return ((fp->_flags & _IO_NO_WRITES) != 0
|
|
||||||
|| ((fp->_flags & (_IO_NO_READS | _IO_CURRENTLY_PUTTING)) == 0
|
|
||||||
&& fp->_IO_read_base != NULL));
|
|
||||||
diff -up m4-1.4.18/lib/fseeko.c.orig m4-1.4.18/lib/fseeko.c
|
|
||||||
--- m4-1.4.18/lib/fseeko.c.orig 2018-05-02 11:44:17.947460233 +0200
|
|
||||||
+++ m4-1.4.18/lib/fseeko.c 2018-05-02 12:39:49.537216897 +0200
|
|
||||||
@@ -47,7 +47,7 @@ fseeko (FILE *fp, off_t offset, int when
|
|
||||||
#endif
|
|
||||||
|
|
||||||
/* These tests are based on fpurge.c. */
|
|
||||||
-#if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
|
|
||||||
+#if defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
|
|
||||||
if (fp->_IO_read_end == fp->_IO_read_ptr
|
|
||||||
&& fp->_IO_write_ptr == fp->_IO_write_base
|
|
||||||
&& fp->_IO_save_base == NULL)
|
|
||||||
@@ -123,7 +123,7 @@ fseeko (FILE *fp, off_t offset, int when
|
|
||||||
return -1;
|
|
||||||
}
|
|
||||||
|
|
||||||
-#if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
|
|
||||||
+#if defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
|
|
||||||
fp->_flags &= ~_IO_EOF_SEEN;
|
|
||||||
fp->_offset = pos;
|
|
||||||
#elif defined __sferror || defined __DragonFly__ || defined __ANDROID__
|
|
||||||
diff -up m4-1.4.18/lib/stdio-impl.h.orig m4-1.4.18/lib/stdio-impl.h
|
|
||||||
--- m4-1.4.18/lib/stdio-impl.h.orig 2016-12-31 14:54:42.000000000 +0100
|
|
||||||
+++ m4-1.4.18/lib/stdio-impl.h 2018-05-02 11:43:19.570336724 +0200
|
|
||||||
@@ -18,6 +18,12 @@
|
|
||||||
the same implementation of stdio extension API, except that some fields
|
|
||||||
have different naming conventions, or their access requires some casts. */
|
|
||||||
|
|
||||||
+/* Glibc 2.28 made _IO_IN_BACKUP private. For now, work around this
|
|
||||||
+ problem by defining it ourselves. FIXME: Do not rely on glibc
|
|
||||||
+ internals. */
|
|
||||||
+#if !defined _IO_IN_BACKUP && defined _IO_EOF_SEEN
|
|
||||||
+# define _IO_IN_BACKUP 0x100
|
|
||||||
+#endif
|
|
||||||
|
|
||||||
/* BSD stdio derived implementations. */
|
|
||||||
|
|
16
m4.spec
16
m4.spec
@ -1,15 +1,14 @@
|
|||||||
Summary: GNU macro processor
|
Summary: GNU macro processor
|
||||||
Name: m4
|
Name: m4
|
||||||
Version: 1.4.18
|
Version: 1.4.19
|
||||||
Release: 17%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
Source0: https://ftp.gnu.org/gnu/m4/m4-%{version}.tar.xz
|
Source0: https://ftp.gnu.org/gnu/m4/m4-%{version}.tar.xz
|
||||||
Source1: https://ftp.gnu.org/gnu/m4/m4-%{version}.tar.xz.sig
|
Source1: https://ftp.gnu.org/gnu/m4/m4-%{version}.tar.xz.sig
|
||||||
# Patch0: update to glibc libio.h removal, rhbz#1573342
|
|
||||||
Patch0: m4-1.4.18-glibc-change-work-around.patch
|
|
||||||
URL: https://www.gnu.org/software/m4/
|
URL: https://www.gnu.org/software/m4/
|
||||||
BuildRequires: make
|
BuildRequires: make
|
||||||
BuildRequires: gcc autoconf automake
|
BuildRequires: gcc autoconf automake
|
||||||
|
BuildRequires: gettext
|
||||||
%ifarch ppc ppc64
|
%ifarch ppc ppc64
|
||||||
BuildRequires: texinfo
|
BuildRequires: texinfo
|
||||||
%endif
|
%endif
|
||||||
@ -29,22 +28,21 @@ Install m4 if you need a macro processor.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .glibc-change-work-around
|
|
||||||
chmod 644 COPYING
|
chmod 644 COPYING
|
||||||
|
|
||||||
%build
|
%build
|
||||||
autoreconf -ivf
|
|
||||||
%configure
|
%configure
|
||||||
%make_build
|
%make_build
|
||||||
|
|
||||||
%install
|
%install
|
||||||
%make_install
|
%make_install
|
||||||
rm -f $RPM_BUILD_ROOT%{_infodir}/dir
|
rm -f $RPM_BUILD_ROOT%{_infodir}/dir
|
||||||
|
%find_lang %{name}
|
||||||
|
|
||||||
%check
|
%check
|
||||||
make %{?_smp_mflags} check
|
make %{?_smp_mflags} check
|
||||||
|
|
||||||
%files
|
%files -f %{name}.lang
|
||||||
%license COPYING
|
%license COPYING
|
||||||
%doc AUTHORS ChangeLog NEWS README THANKS TODO
|
%doc AUTHORS ChangeLog NEWS README THANKS TODO
|
||||||
%{_bindir}/m4
|
%{_bindir}/m4
|
||||||
@ -52,6 +50,10 @@ make %{?_smp_mflags} check
|
|||||||
%{_mandir}/man1/m4.1*
|
%{_mandir}/man1/m4.1*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon May 31 2021 Vitezslav Crhonek <vcrhonek@redhat.com> - 1.4.19-1
|
||||||
|
- Update to m4-1.4.19
|
||||||
|
Resolves: #1965719
|
||||||
|
|
||||||
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.18-17
|
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.18-17
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||||
|
|
||||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
|||||||
SHA512 (m4-1.4.18.tar.xz) = 06f583efc3855cd8477d8347544f4ae5153a3e50aea74d21968afa7214784ea3ddfc02d0a2b11324120d76a19f2e804d20de11a456b5da929eb6ae469519b174
|
SHA512 (m4-1.4.19.tar.xz) = 47f595845c89709727bda0b3fc78e3188ef78ec818965b395532e7041cabe9e49677ee4aca3d042930095a7f8df81de3da1026b23b6897be471f6cf13ddd512b
|
||||||
SHA512 (m4-1.4.18.tar.xz.sig) = effc857a19f1496d6dde2887c0314b37d4b142a435e77614936c730878c798491ad93b28860dddd2601f99a43fa41923729b961004faafc6f798f7bc1842f980
|
SHA512 (m4-1.4.19.tar.xz.sig) = d6ac9c6a54c57e9b53fb3e34a60d49df2f46a6e494da0a0c9ae8246b984e68a853b5d8c42677c1a0485c3f36b0bce10a481d3775c0edc1dbdfb27b43545bc31e
|
||||||
|
Loading…
Reference in New Issue
Block a user