Temporarily fix readlink test to accept EINVAL also

This commit is contained in:
Vitezslav Crhonek 2011-09-20 12:41:00 +02:00
parent 2bbbe80b77
commit 4e8ea6fed9
2 changed files with 21 additions and 1 deletions

View File

@ -0,0 +1,12 @@
diff -up m4-1.4.16/tests/test-readlink.h.orig m4-1.4.16/tests/test-readlink.h
--- m4-1.4.16/tests/test-readlink.h.orig 2011-09-19 12:44:58.745546826 +0200
+++ m4-1.4.16/tests/test-readlink.h 2011-09-19 12:46:00.079548410 +0200
@@ -38,7 +38,7 @@ test_readlink (ssize_t (*func) (char con
ASSERT (errno == ENOENT);
errno = 0;
ASSERT (func ("", buf, sizeof buf) == -1);
- ASSERT (errno == ENOENT);
+ ASSERT (errno == ENOENT || errno == EINVAL);
errno = 0;
ASSERT (func (".", buf, sizeof buf) == -1);
ASSERT (errno == EINVAL);

10
m4.spec
View File

@ -1,12 +1,15 @@
Summary: The GNU macro processor
Name: m4
Version: 1.4.16
Release: 1%{?dist}
Release: 2%{?dist}
License: GPLv3+
Group: Applications/Text
Source0: http://ftp.gnu.org/gnu/m4/m4-%{version}.tar.xz
Source1: http://ftp.gnu.org/gnu/m4/m4-%{version}.tar.xz.sig
URL: http://www.gnu.org/software/m4/
# Patch0: Temporary fix to avoid fails, already fixed in gnulib, this patch
# should be removed after updating m4 to newer gnulib
Patch0: m4-1.4.16-readlink-einval.patch
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Requires(post): /sbin/install-info
Requires(preun): /sbin/install-info
@ -23,6 +26,7 @@ Install m4 if you need a macro processor.
%prep
%setup -q
%patch0 -p1 -b .readlink-einval
chmod 644 COPYING
%build
@ -60,6 +64,10 @@ fi
rm -rf $RPM_BUILD_ROOT
%changelog
* Tue Sep 20 2011 Vitezslav Crhonek <vcrhonek@redhat.com> - 1.4.16-2
- Temporarily fix readlink test to accept EINVAL also
Resolves: #739189
* Wed Mar 02 2011 Vitezslav Crhonek <vcrhonek@redhat.com> - 1.4.16-1
- Update to m4-1.4.16