- add bcond for otf, anthy, and gui

- subpackage flt for emacs, etc
- add subpackages for anthy and ispell modules
- disable new gui subpackage (and hence ispell)
This commit is contained in:
Jens Petersen 2009-12-23 09:44:36 +00:00
parent deb0efb392
commit b431e666c7
3 changed files with 98 additions and 97 deletions

View File

@ -1,53 +0,0 @@
/* internal-flt.h -- common header file for the internal FLT API.
Copyright (C) 2007
National Institute of Advanced Industrial Science and Technology (AIST)
Registration Number H15PRO112
This file is part of the m17n library.
The m17n library is free software; you can redistribute it and/or
modify it under the terms of the GNU Lesser General Public License
as published by the Free Software Foundation; either version 2.1 of
the License, or (at your option) any later version.
The m17n library is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
Lesser General Public License for more details.
You should have received a copy of the GNU Lesser General Public
License along with the m17n library; if not, write to the Free
Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
02111-1307, USA. */
#ifndef _M_INTERNAL_FLT_H
#define _M_INTERNAL_FLT_H
#define MAKE_COMBINING_CODE(base_y, base_x, add_y, add_x, off_y, off_x) \
(((off_y) << 16) \
| ((off_x) << 8) \
| ((base_x) << 6) \
| ((base_y) << 4) \
| ((add_x) << 2) \
| (add_y))
#define COMBINING_CODE_OFF_Y(code) ((((code) >> 16) & 0xFF) - 128)
#define COMBINING_CODE_OFF_X(code) ((((code) >> 8) & 0xFF) - 128)
#define COMBINING_CODE_BASE_X(code) (((code) >> 6) & 0x3)
#define COMBINING_CODE_BASE_Y(code) (((code) >> 4) & 0x3)
#define COMBINING_CODE_ADD_X(code) (((code) >> 2) & 0x3)
#define COMBINING_CODE_ADD_Y(code) ((code) & 0x3)
#define MAKE_COMBINING_CODE_BY_CLASS(class) (0x1000000 | class)
#define COMBINING_BY_CLASS_P(code) ((code) & 0x1000000)
#define COMBINING_CODE_CLASS(code) ((code) & 0xFFFFFF)
#define MAKE_PRECOMPUTED_COMBINDING_CODE() (0x2000000)
#define COMBINING_PRECOMPUTED_P(code) ((code) & 0x2000000)
extern MSymbol Mcombining;
#endif /* _M_INTERNAL_FLT_H */

View File

@ -1,11 +0,0 @@
--- m17n-lib-1.3.1/Makefile.am~ 2005-11-21 16:39:00.000000000 +0900
+++ m17n-lib-1.3.1/Makefile.am 2006-02-02 16:01:48.000000000 +0900
@@ -22,7 +22,7 @@
## Process this file with Automake to create Makefile.in
-SUBDIRS = intl po src example
+SUBDIRS = intl po src
bin_SCRIPTS = m17n-config

View File

@ -1,11 +1,13 @@
# set to 1 to build with GUI and OpenType Font support %bcond_without otf
%define with_gui 0
# set to 1 to build examples (including anthy support) # note this duplicates native anthy IMEs
%define with_examples 0 %bcond_without anthy
# use --with gui to build GUI library
%bcond_with gui
Name: m17n-lib Name: m17n-lib
Version: 1.5.5 Version: 1.5.5
Release: 1%{?dist} Release: 2%{?dist}
Summary: Multilingual text library Summary: Multilingual text library
Group: System Environment/Libraries Group: System Environment/Libraries
@ -13,52 +15,79 @@ License: LGPLv2
URL: http://www.m17n.org/m17n-lib/index.html URL: http://www.m17n.org/m17n-lib/index.html
Source0: http://www.m17n.org/m17n-lib-download/%{name}-%{version}.tar.gz Source0: http://www.m17n.org/m17n-lib-download/%{name}-%{version}.tar.gz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: m17n-db-devel = %{version}
%if %{with_gui} %if %{with anthy}
BuildRequires: libxml2-devel, xorg-x11-devel
BuildRequires: freetype-devel >= 2.0, fribidi-devel, gd-devel >= 2.0
BuildRequires: libotf-devel >= %{libotf_version}
%else
BuildRequires: autoconf
BuildRequires: libtool
BuildRequires: pkgconfig
%endif
%if %{with_examples}
BuildRequires: anthy-devel BuildRequires: anthy-devel
%endif %endif
Requires: m17n-db >= 1.4.0 %if %{with gui}
Patch2: m17n-lib-nobuild-examples.patch BuildRequires: libxml2-devel, libXft-devel, fontconfig-devel
BuildRequires: freetype-devel >= 2.0, fribidi-devel, gd-devel >= 2.0, libXaw-devel
# ispell seems to depend on gui
BuildRequires: aspell
%endif
%if %{with otf}
BuildRequires: libotf-devel
%endif
Requires: m17n-db = %{version}
%description %description
m17n-lib is a multilingual text library used primarily to allow m17n-lib is a multilingual text library used primarily to allow
the input of many languages with the input table maps from m17n-db. the input of many languages with the input table maps from m17n-db.
The package provides the core and input method backend libraries.
%package anthy
Summary: Anthy module for m17n
Group: System Environment/Libraries
%description anthy
Anthy module for %{name} allows ja-anthy.mim to support input conversion.
%package devel %package devel
Summary: m17n-lib development files Summary: m17n-lib development files
Group: Development/Libraries Group: Development/Libraries
Requires: %{name} = %{version}-%{release} Requires: %{name} = %{version}-%{release}
Requires: %{name}-flt = %{version}-%{release}
Requires: %{name}-anthy = %{version}-%{release}
%description devel %description devel
Development files for %{name}. Development files for %{name}.
%package flt
Summary: m17n Font Layout Library
Group: System Environment/Libraries
Requires: m17n-db-flt
%description flt
Font layout library for complex text rendering.
%if %{with gui}
%package gui
Summary: m17n GUI Library
Group: System Environment/Libraries
Requires: m17n-db-datafiles
%description gui
M17n GUI widget library.
%package ispell
Summary: Spelling module for m17n
Group: System Environment/Libraries
%description ispell
Ispell module for m17n input.
%endif
%prep %prep
%setup -q %setup -q
%if ! %{with_examples}
%patch2 -p1 -b .examples
%endif
# patch2 touches Makefile.am
autoreconf
%build %build
%configure --disable-static \ %configure --disable-static %{!?with_gui:--without-gui}
%if ! %{with_gui}
--without-gui
%else
%{nil}
%endif
make make
@ -67,9 +96,12 @@ rm -rf $RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT INSTALL="%{__install} -c -p" make install DESTDIR=$RPM_BUILD_ROOT INSTALL="%{__install} -c -p"
# remove unneeded files # remove unneeded files
rm $RPM_BUILD_ROOT%{_bindir}/m17n-config
rm $RPM_BUILD_ROOT%{_libdir}/lib*.la rm $RPM_BUILD_ROOT%{_libdir}/lib*.la
%if %{without anthy}
rm $RPM_BUILD_ROOT%{_libdir}/libmimx-anthy*
%endif
%clean %clean
rm -rf $RPM_BUILD_ROOT rm -rf $RPM_BUILD_ROOT
@ -84,17 +116,50 @@ rm -rf $RPM_BUILD_ROOT
%files %files
%defattr(-,root,root) %defattr(-,root,root)
%doc AUTHORS COPYING NEWS %doc AUTHORS COPYING NEWS
%{_libdir}/lib*.so.* %{_bindir}/m17n-conv
%{_libdir}/libm17n.so.*
%{_libdir}/libm17n-core.so.*
%files anthy
%defattr(-,root,root)
%{_libdir}/libmimx-anthy.so.*
%files devel %files devel
%defattr(-,root,root) %defattr(-,root,root)
%doc ChangeLog README %doc ChangeLog README
%{_bindir}/m17n-config
%{_includedir}/* %{_includedir}/*
%{_libdir}/lib*.so %{_libdir}/lib*.so
%{_libdir}/pkgconfig/* %{_libdir}/pkgconfig/*
%files flt
%defattr(-,root,root)
%{_libdir}/libm17n-flt.so.*
%if %{with gui}
%files gui
%defattr(-,root,root)
%{_bindir}/m17n-date
%{_bindir}/m17n-dump
%{_bindir}/m17n-edit
%{_bindir}/m17n-view
%{_libdir}/libm17n-X.so.*
%{_libdir}/libm17n-gd.so.*
%{_libdir}/libm17n-gui.so.*
%files ispell
%defattr(-,root,root)
%{_libdir}/libmimx-ispell.so.*
%endif
%changelog %changelog
* Wed Dec 23 2009 Jens Petersen <petersen@redhat.com> - 1.5.5-2
- add bcond for otf, anthy, and gui
- subpackage flt for emacs, etc
- add subpackages for anthy and ispell modules
- disable new gui subpackage (and hence ispell)
* Mon Aug 17 2009 Parag Nemade <pnemade@redhat.com> - 1.5.5-1 * Mon Aug 17 2009 Parag Nemade <pnemade@redhat.com> - 1.5.5-1
- update to new upstream release 1.5.5 - update to new upstream release 1.5.5