- Fix configure failure with -Werror-implicit-function-declaration in
CFLAGS - Add a minilzo subpackage which contains a shared version of minilzo, to be used by all applications which ship with their own copy of it (bz 439979)
This commit is contained in:
parent
05909da254
commit
9bf3970318
@ -1,6 +1,18 @@
|
||||
diff -up lzo-2.02/configure.configure lzo-2.02/configure
|
||||
--- lzo-2.02/configure.configure 2005-10-17 18:10:50.000000000 +0200
|
||||
+++ lzo-2.02/configure 2006-07-26 12:51:27.000000000 +0200
|
||||
@@ -19994,7 +19994,7 @@
|
||||
+++ lzo-2.02/configure 2008-04-02 12:51:50.000000000 +0200
|
||||
@@ -5096,8 +5096,8 @@ main ()
|
||||
for (i = 0; i < 256; i++)
|
||||
if (XOR (islower (i), ISLOWER (i))
|
||||
|| toupper (i) != TOUPPER (i))
|
||||
- exit(2);
|
||||
- exit (0);
|
||||
+ return (2);
|
||||
+ return (0);
|
||||
}
|
||||
_ACEOF
|
||||
rm -f conftest$ac_exeext
|
||||
@@ -19994,7 +19994,7 @@ asm_dir=
|
||||
asm_msg_amd64=no
|
||||
asm_msg_i386=no
|
||||
|
||||
@ -9,9 +21,10 @@
|
||||
amd64 | x86_64) asm_arch="amd64"; asm_dir="asm/amd64/src_gas/elf64" ;;
|
||||
i?86) asm_arch="i386"; asm_dir="asm/i386/src_gas" ;;
|
||||
*) enable_asm=no ;;
|
||||
--- lzo-2.02/configure.ac.configure 2006-07-26 12:54:58.000000000 +0200
|
||||
+++ lzo-2.02/configure.ac 2006-07-26 12:55:17.000000000 +0200
|
||||
@@ -79,7 +79,7 @@
|
||||
diff -up lzo-2.02/configure.ac.configure lzo-2.02/configure.ac
|
||||
--- lzo-2.02/configure.ac.configure 2005-10-17 18:10:50.000000000 +0200
|
||||
+++ lzo-2.02/configure.ac 2008-04-02 11:53:37.000000000 +0200
|
||||
@@ -79,7 +79,7 @@ asm_dir=
|
||||
asm_msg_amd64=no
|
||||
asm_msg_i386=no
|
||||
|
||||
|
34
lzo.spec
34
lzo.spec
@ -1,6 +1,6 @@
|
||||
Name: lzo
|
||||
Version: 2.02
|
||||
Release: 4%{?dist}
|
||||
Release: 5%{?dist}
|
||||
Summary: Data compression library with very fast (de)compression
|
||||
Group: System Environment/Libraries
|
||||
License: GPLv2
|
||||
@ -18,10 +18,20 @@ compression levels achieving a quite competitive compression ratio
|
||||
while still decompressing at this very high speed.
|
||||
|
||||
|
||||
%package minilzo
|
||||
Summary: Mini version of lzo for apps which don't need the full version
|
||||
Group: System Environment/Libraries
|
||||
|
||||
%description minilzo
|
||||
A small (mini) version of lzo for embedding into applications which don't need
|
||||
full blown lzo compression support.
|
||||
|
||||
|
||||
%package devel
|
||||
Summary: Development files for the lzo library
|
||||
Group: Development/Libraries
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
Requires: %{name}-minilzo = %{version}-%{release}
|
||||
Requires: zlib-devel
|
||||
|
||||
%description devel
|
||||
@ -42,12 +52,18 @@ done
|
||||
%build
|
||||
%configure --disable-dependency-tracking --disable-static --enable-shared
|
||||
make %{?_smp_mflags}
|
||||
# build minilzo too (bz 439979)
|
||||
gcc %{optflags} -fpic -Iinclude/lzo -o minilzo/minilzo.o -c minilzo/minilzo.c
|
||||
gcc -g -shared -o libminilzo.so.0 -Wl,-soname,libminilzo.so.0 minilzo/minilzo.o
|
||||
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
make install DESTDIR=$RPM_BUILD_ROOT
|
||||
rm $RPM_BUILD_ROOT%{_libdir}/liblzo2.la
|
||||
install -m 755 libminilzo.so.0 $RPM_BUILD_ROOT%{_libdir}
|
||||
ln -s libminilzo.so.0 $RPM_BUILD_ROOT%{_libdir}/libminilzo.so
|
||||
install -p -m 644 minilzo/minilzo.h $RPM_BUILD_ROOT%{_includedir}/lzo
|
||||
|
||||
|
||||
%check
|
||||
@ -62,20 +78,34 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%post minilzo -p /sbin/ldconfig
|
||||
|
||||
%postun minilzo -p /sbin/ldconfig
|
||||
|
||||
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%doc AUTHORS COPYING THANKS NEWS
|
||||
%{_libdir}/liblzo2.so.*
|
||||
|
||||
%files minilzo
|
||||
%defattr(-,root,root,-)
|
||||
%doc minilzo/README.LZO
|
||||
%{_libdir}/libminilzo.so.0
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root,-)
|
||||
%doc doc/LZOAPI.TXT doc/LZO.FAQ doc/LZO.TXT
|
||||
%{_includedir}/lzo
|
||||
%{_libdir}/liblzo2.so
|
||||
%{_libdir}/lib*lzo*.so
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Apr 2 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 2.02-5
|
||||
- Fix configure failure with -Werror-implicit-function-declaration in CFLAGS
|
||||
- Add a minilzo subpackage which contains a shared version of minilzo, to be
|
||||
used by all applications which ship with their own copy of it (bz 439979)
|
||||
|
||||
* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.02-4
|
||||
- Autorebuild for GCC 4.3
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user