import lzo-2.08-14.el8

This commit is contained in:
CentOS Sources 2019-07-29 22:54:24 -04:00 committed by Stepan Oksanichenko
commit 485c1c3a74
5 changed files with 271 additions and 0 deletions

1
.gitignore vendored Normal file
View File

@ -0,0 +1 @@
SOURCES/lzo-2.08.tar.gz

1
.lzo.metadata Normal file
View File

@ -0,0 +1 @@
64c3e44843a44ffc4533aa89e41516f42bfefa76 SOURCES/lzo-2.08.tar.gz

View File

@ -0,0 +1,24 @@
diff -Naur lzo-2.08/configure lzo-2.08.configure/configure
--- lzo-2.08/configure 2014-06-29 15:08:49.000000000 +0530
+++ lzo-2.08.configure/configure 2014-06-30 10:38:08.344604418 +0530
@@ -13875,7 +13875,7 @@
asm_msg_amd64=no
asm_msg_i386=no
-case "$host_cpu-$ac_cv_sizeof_void_p" in
+case "$target_cpu-$ac_cv_sizeof_void_p" in
amd64-8 | x86_64-8) asm_arch="amd64"; asm_dir="asm/amd64/src_gas/elf64"; asm_mode="amd64_src_gas_elf64" ;;
i?86-4) asm_arch="i386"; asm_dir="asm/i386/src_gas"; asm_mode="i386_src_gas" ;;
*) enable_asm=no ;;
diff -Naur lzo-2.08/configure.ac lzo-2.08.configure/configure.ac
--- lzo-2.08/configure.ac 2014-06-29 15:08:49.000000000 +0530
+++ lzo-2.08.configure/configure.ac 2014-06-30 10:38:38.706603340 +0530
@@ -123,7 +123,7 @@
asm_msg_amd64=no
asm_msg_i386=no
-case "$host_cpu-$ac_cv_sizeof_void_p" in
+case "$target_cpu-$ac_cv_sizeof_void_p" in
amd64-8 | x86_64-8) asm_arch="amd64"; asm_dir="asm/amd64/src_gas/elf64"; asm_mode="amd64_src_gas_elf64" ;;
i?86-4) asm_arch="i386"; asm_dir="asm/i386/src_gas"; asm_mode="i386_src_gas" ;;
*) enable_asm=no ;;

View File

@ -0,0 +1,14 @@
diff -up lzo-2.08/include/lzo/lzodefs.h.rhbz1309225 lzo-2.08/include/lzo/lzodefs.h
--- lzo-2.08/include/lzo/lzodefs.h.rhbz1309225 2016-02-19 13:38:02.604220910 +0100
+++ lzo-2.08/include/lzo/lzodefs.h 2016-02-19 13:37:30.619073085 +0100
@@ -1686,6 +1686,10 @@ extern "C" {
# define __lzo_byte_struct_ma(s,n) struct s { unsigned char a[n]; } __lzo_may_alias __attribute__((__packed__));
#endif
#endif
+#if (LZO_CC_GNUC >= 0x060000ul) && defined(__lzo_byte_struct_ma)
+# undef __lzo_byte_struct
+# define __lzo_byte_struct(s,n) __lzo_byte_struct_ma(s,n)
+#endif
#if defined(__lzo_byte_struct) && !defined(__lzo_byte_struct_ma)
# define __lzo_byte_struct_ma(s,n) __lzo_byte_struct(s,n)
#endif

231
SPECS/lzo.spec Normal file
View File

@ -0,0 +1,231 @@
Name: lzo
Version: 2.08
Release: 14%{?dist}
Summary: Data compression library with very fast (de)compression
Group: System Environment/Libraries
License: GPLv2+
URL: http://www.oberhumer.com/opensource/lzo/
Source0: http://www.oberhumer.com/opensource/lzo/download/%{name}-%{version}.tar.gz
Patch0: lzo-2.08-configure.patch
Patch1: lzo-2.08-rhbz1309225.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: zlib-devel
%description
LZO is a portable lossless data compression library written in ANSI C.
It offers pretty fast compression and very fast decompression.
Decompression requires no memory. In addition there are slower
compression levels achieving a quite competitive compression ratio
while still decompressing at this very high speed.
%package minilzo
Summary: Mini version of lzo for apps which don't need the full version
Group: System Environment/Libraries
%description minilzo
A small (mini) version of lzo for embedding into applications which don't need
full blown lzo compression support.
%package devel
Summary: Development files for the lzo library
Group: Development/Libraries
Requires: %{name} = %{version}-%{release}
Requires: %{name}-minilzo = %{version}-%{release}
Requires: zlib-devel
%description devel
LZO is a portable lossless data compression library written in ANSI C.
It offers pretty fast compression and very fast decompression.
This package contains development files needed for lzo.
%prep
%setup -q
%patch0 -p1 -z .configure
%patch1 -p1 -z .rhbz1309225
# mark asm files as NOT needing execstack
for i in asm/i386/src_gas/*.S; do
echo '.section .note.GNU-stack,"",@progbits' >> $i
done
# remove objects
rm -rf asm/i386/obj
%build
# workaround for annocheck
export CCASFLAGS="--generate-missing-build-notes=yes"
%configure --disable-dependency-tracking --disable-static --enable-shared
make %{?_smp_mflags}
# build minilzo too (bz 439979)
gcc %{optflags} -fpic -Iinclude/lzo -o minilzo/minilzo.o -c minilzo/minilzo.c
gcc -g -shared -Wl,-z,now -o libminilzo.so.0 -Wl,-soname,libminilzo.so.0 minilzo/minilzo.o
%install
rm -rf $RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
install -m 755 libminilzo.so.0 $RPM_BUILD_ROOT%{_libdir}
ln -s libminilzo.so.0 $RPM_BUILD_ROOT%{_libdir}/libminilzo.so
install -p -m 644 minilzo/minilzo.h $RPM_BUILD_ROOT%{_includedir}/lzo
#Remove doc
rm -rf $RPM_BUILD_ROOT%{_datadir}/doc/lzo
%check
make check test
%clean
rm -rf $RPM_BUILD_ROOT
%ldconfig_scriptlets
%ldconfig_scriptlets minilzo
%files
%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license COPYING
%doc AUTHORS THANKS NEWS
%{_libdir}/liblzo2.so.*
%files minilzo
%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license COPYING
%doc minilzo/README.LZO
%{_libdir}/libminilzo.so.0
%files devel
%defattr(-,root,root,-)
%doc doc/LZOAPI.TXT doc/LZO.FAQ doc/LZO.TXT
%{_includedir}/lzo
%{_libdir}/lib*lzo*.so
%changelog
* Tue Oct 9 2018 Jaroslav Škarvada <jskarvad@redhat.com> - 2.08-14
- Added build notes to AS generated objects
Resolves: rhbz#1630594
* Fri Jul 27 2018 Jaroslav Škarvada <jskarvad@redhat.com> - 2.08-13
- Dropped unused patches
* Sat Feb 03 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 2.08-12
- Switch to %%ldconfig_scriptlets
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.08-11
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.08-10
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.08-9
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
* Fri Feb 19 2016 Karsten Hopp <karsten@redhat.com> - 2.08-8
- remove -O1 workaround, add patch by Jakub Jelinek instead (bug #1309225)
* Wed Feb 17 2016 Karsten Hopp <karsten@redhat.com> - 2.08-7
- use -O1 compiler optimizations on ppc64le (bug #1309225)
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.08-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
* Fri Aug 14 2015 Adam Jackson <ajax@redhat.com> 2.08-5
- Link libminilzo with -z now
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.08-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.08-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
* Fri Jul 18 2014 Tom Callaway <spot@fedoraproject.org> - 2.08-2
- fix license handling
* Mon Jun 30 2014 Huzaifa Sidhpurwala <huzaifas@redhat.com> - 2.08-1
- New upstream
- Fix CVE-2014-4607
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.06-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.06-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.06-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.06-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.06-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
* Wed Sep 14 2011 Huzaifa Sidhpurwala <huzaifas@redhat.com> - 2.06-1
- Upgrade to latest upstream
- Apply patch from Nicolas Chauvet
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.03-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.03-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.03-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
* Thu May 1 2008 Lubomir Rintel <lkundrak@v3.sk> 2.03-1
- New upstream release
- Changed the license to GPLv2+
* Wed Apr 2 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 2.02-5
- Fix configure failure with -Werror-implicit-function-declaration in CFLAGS
- Add a minilzo subpackage which contains a shared version of minilzo, to be
used by all applications which ship with their own copy of it (bz 439979)
* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.02-4
- Autorebuild for GCC 4.3
* Wed Aug 15 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 2.02-3
- Update License tag for new Licensing Guidelines compliance
* Mon Aug 28 2006 Hans de Goede <j.w.r.degoede@hhs.nl> 2.02-2
- FE6 Rebuild
* Wed Jul 26 2006 Hans de Goede <j.w.r.degoede@hhs.nl> 2.02-1
- New upstream release 2.02, soname change!
* Mon Jul 24 2006 Hans de Goede <j.w.r.degoede@hhs.nl> 1.08-7
- Taking over as maintainer since Anvil has other priorities
- Add a patch to fix asm detection on i386 (bug 145882, 145893). Thanks to
Carlo Marcelo Arenas Belon <carenas@sajinet.com.pe> for the initial patch.
- Removed unused build dependency on nasm
- Remove static lib
- Cleanup %%doc a bit
* Thu Mar 16 2006 Dams <anvil[AT]livna.org> - 1.08-6.fc5
- Rebuild for new gcc
* Tue Jan 17 2006 Dams <anvil[AT]livna.org> - 1.08-5.fc5
- Bumped release for gcc 4.1 rebuild
* Sun May 22 2005 Jeremy Katz <katzj@redhat.com> - 1.08-4
- rebuild on all arches
* Fri Apr 7 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
- rebuilt
* Sun Apr 27 2003 Dams <anvil[AT]livna.org> 0:1.08-0.fdr.2
- Typo un devel description
- Added post and postun scriptlets
- Added URL in Source0
* Fri Apr 25 2003 Dams <anvil[AT]livna.org>
- Initial build.