- New upstream release 2.02, soname change!

This commit is contained in:
Hans de Goede 2006-07-26 10:58:35 +00:00
parent 30191b4e06
commit 23bd2c2833
6 changed files with 47 additions and 110 deletions

View File

@ -1 +1 @@
lzo-1.08.tar.gz
lzo-2.02.tar.gz

View File

@ -1,80 +0,0 @@
--- lzo-1.08/configure.asm 2006-07-24 16:26:28.000000000 +0200
+++ lzo-1.08/configure 2006-07-24 16:54:29.000000000 +0200
@@ -12177,13 +12177,13 @@
#include <stdio.h>
int test() {
#if defined(__GNUC__)
- __asm__ __volatile__ ("
- .align 4
-mfx_a1:
- .byte 0
- .align 4
-mfx_a2:
- ");
+ __asm__ __volatile__ (
+ ".align 4\n"
+"mfx_a1:\n"
+ ".byte 0\n"
+ ".align 4\n"
+"mfx_a2:\n"
+ );
#endif
return 0;
}
@@ -12253,11 +12253,11 @@
#endif
int mfx_asm_func();
static void test() {
- __asm__ __volatile__("
- .globl mfx_asm_func
- mfx_asm_func:
- .byte 0
- ");
+ __asm__ __volatile__(
+ ".globl mfx_asm_func\n"
+ "mfx_asm_func:\n"
+ ".byte 0\n"
+ );
}
#ifdef F77_DUMMY_MAIN
--- lzo-1.08/configure.in.asm 2006-07-24 16:26:15.000000000 +0200
+++ lzo-1.08/configure.in 2006-07-24 16:26:22.000000000 +0200
@@ -319,13 +319,13 @@
[AC_TRY_RUN([#include <stdio.h>
int test() {
#if defined(__GNUC__)
- __asm__ __volatile__ ("
- .align 4
-mfx_a1:
- .byte 0
- .align 4
-mfx_a2:
- ");
+ __asm__ __volatile__ (
+ ".align 4\n"
+"mfx_a1:\n"
+ ".byte 0\n"
+ ".align 4\n"
+"mfx_a2:\n"
+ );
#endif
return 0;
}
@@ -363,11 +363,11 @@
#endif
int mfx_asm_func();
static void test() {
- __asm__ __volatile__("
- .globl mfx_asm_func
- mfx_asm_func:
- .byte 0
- ");
+ __asm__ __volatile__(
+ ".globl mfx_asm_func\n"
+ "mfx_asm_func:\n"
+ ".byte 0\n"
+ );
}
], [
return mfx_asm_func();

View File

@ -1,11 +0,0 @@
--- lzo-1.08/src/i386/src/leave.sh~ 2006-07-24 17:47:49.000000000 +0200
+++ lzo-1.08/src/i386/src/leave.sh 2006-07-24 17:47:49.000000000 +0200
@@ -94,6 +94,8 @@
.L_end:
+.section .note.GNU-stack,"",@progbits
+
/*
vi:ts=4
*/

22
lzo-2.02-configure.patch Normal file
View File

@ -0,0 +1,22 @@
--- lzo-2.02/configure.configure 2005-10-17 18:10:50.000000000 +0200
+++ lzo-2.02/configure 2006-07-26 12:51:27.000000000 +0200
@@ -19994,7 +19994,7 @@
asm_msg_amd64=no
asm_msg_i386=no
-case $host_cpu in
+case $target_cpu in
amd64 | x86_64) asm_arch="amd64"; asm_dir="asm/amd64/src_gas/elf64" ;;
i?86) asm_arch="i386"; asm_dir="asm/i386/src_gas" ;;
*) enable_asm=no ;;
--- lzo-2.02/configure.ac.configure 2006-07-26 12:54:58.000000000 +0200
+++ lzo-2.02/configure.ac 2006-07-26 12:55:17.000000000 +0200
@@ -79,7 +79,7 @@
asm_msg_amd64=no
asm_msg_i386=no
-case $host_cpu in
+case $target_cpu in
amd64 | x86_64) asm_arch="amd64"; asm_dir="asm/amd64/src_gas/elf64" ;;
i?86) asm_arch="i386"; asm_dir="asm/i386/src_gas" ;;
*) enable_asm=no ;;

View File

@ -1,14 +1,13 @@
Summary: Data compression library with very fast (de)compression
Name: lzo
Version: 1.08
Release: 7%{?dist}
License: GPL
Version: 2.02
Release: 1%{?dist}
Summary: Data compression library with very fast (de)compression
Group: System Environment/Libraries
License: GPL
URL: http://www.oberhumer.com/opensource/lzo/
Source0: http://www.oberhumer.com/opensource/lzo/download/%{name}-%{version}.tar.gz
Patch0: lzo-1.08-asm.patch
Patch1: lzo-1.08-noexecstack.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
Patch0: lzo-2.02-configure.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: zlib-devel
%description
@ -33,8 +32,11 @@ This package contains development files needed for lzo.
%prep
%setup -q
%patch0 -p1 -z .asm
%patch1 -p1 -z .execstack
%patch0 -p1 -z .configure
# mark asm files as NOT needing execstack
for i in asm/i386/src_gas/*.S; do
echo '.section .note.GNU-stack,"",@progbits' >> $i
done
%build
@ -42,14 +44,14 @@ This package contains development files needed for lzo.
make %{?_smp_mflags}
%check || :
make check test
%install
rm -rf $RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT
rm $RPM_BUILD_ROOT%{_libdir}/liblzo.la
rm $RPM_BUILD_ROOT%{_libdir}/liblzo2.la
%check
make check test
%clean
@ -57,22 +59,26 @@ rm -rf $RPM_BUILD_ROOT
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%defattr(-,root,root,-)
%doc AUTHORS COPYING THANKS NEWS
%{_libdir}/liblzo.so.*
%{_libdir}/liblzo2.so.*
%files devel
%defattr(-,root,root,-)
%doc doc/LZOAPI.TXT doc/LZO.FAQ doc/LZO.TXT
%{_includedir}/lzo*.h
%{_libdir}/liblzo.so
%{_includedir}/lzo
%{_libdir}/liblzo2.so
%changelog
* Wed Jul 26 2006 Hans de Goede <j.w.r.degoede@hhs.nl> 2.02-1
- New upstream release 2.02, soname change!
* Mon Jul 24 2006 Hans de Goede <j.w.r.degoede@hhs.nl> 1.08-7
- Taking over as maintainer since Anvil has other priorities
- Add a patch to fix asm detection on i386 (bug 145882, 145893). Thanks to

View File

@ -1 +1 @@
ab94d3da364c7cbd5b78d76f1875b0f6 lzo-1.08.tar.gz
6760e5819f4238328709bf93bf10071c lzo-2.02.tar.gz