- make it possible to delete a bookmark when ~/lynx_bookmarks.html is
writable by group (#486070)
This commit is contained in:
parent
eedfd30651
commit
d727bc092a
13
lynx-2.8.7-bm-del.patch
Normal file
13
lynx-2.8.7-bm-del.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff --git a/src/LYBookmark.c b/src/LYBookmark.c
|
||||
index 6d3a9ca..deaab00 100644
|
||||
--- a/src/LYBookmark.c
|
||||
+++ b/src/LYBookmark.c
|
||||
@@ -496,7 +496,7 @@ void remove_bookmark_link(int cur,
|
||||
*/
|
||||
if (stat(filename_buffer, &stat_buf) == 0) {
|
||||
regular = (BOOLEAN) (S_ISREG(stat_buf.st_mode) && stat_buf.st_nlink == 1);
|
||||
- mode = ((stat_buf.st_mode & 0777) | 0600); /* make it writable */
|
||||
+ mode = ((stat_buf.st_mode & HIDE_CHMOD) | 0600); /* make it writable */
|
||||
(void) chmod(newfile, mode);
|
||||
if ((nfp = LYReopenTemp(newfile)) == NULL) {
|
||||
(void) LYCloseInput(fp);
|
@ -121,7 +121,7 @@ index 4183bf0..d9c1587 100644
|
||||
clean:
|
||||
rm -f lynx$x core *.core *.leaks *.i *$o *.bak tags TAGS test_*
|
||||
- cd chrtrans && $(MAKE) clean
|
||||
+ $(MAKE) -C chstrans clean
|
||||
+ $(MAKE) -C chrtrans clean
|
||||
|
||||
tags:
|
||||
ctags *.[ch]
|
||||
|
22
lynx.spec
22
lynx.spec
@ -10,6 +10,7 @@ Patch0: lynx-2.8.6-redhat.patch
|
||||
Patch1: lynx-2.8.6-backgrcolor.patch
|
||||
Patch2: lynx-build-fixes.patch
|
||||
Patch3: lynx-CVE-2008-4690.patch
|
||||
Patch4: lynx-2.8.7-bm-del.patch
|
||||
Provides: webclient
|
||||
Provides: text-www-browser
|
||||
BuildRequires: gettext
|
||||
@ -31,10 +32,27 @@ exits quickly and swiftly displays web pages.
|
||||
|
||||
%prep
|
||||
%setup -q -n lynx2-8-7
|
||||
|
||||
# RH specific tweaks - directory layout, utf-8 by default, misc. configuration
|
||||
# and home page
|
||||
%patch0 -p1
|
||||
|
||||
# tweaks colors
|
||||
%patch1 -p1
|
||||
|
||||
# patch preparing upstream sources for rpmbuild, in particular for parallel make
|
||||
%patch2 -p1
|
||||
|
||||
# prompt user before executing command via a lynxcgi link even in advanced mode,
|
||||
# as the actual URL may not be shown but hidden behind an HTTP redirect and set
|
||||
# TRUSTED_LYNXCGI:none in lynx.cfg to disable all lynxcgi URLs by default
|
||||
# [CVE-2008-4690]
|
||||
%patch3 -p1
|
||||
|
||||
# make it possible to delete a bookmark when ~/lynx_bookmarks.html is writable
|
||||
# by group (#486070)
|
||||
%patch4 -p1
|
||||
|
||||
perl -pi -e "s,^HELPFILE:.*,HELPFILE:file://localhost/usr/share/doc/lynx-%{version}/lynx_help/lynx_help_main.html,g" lynx.cfg
|
||||
perl -pi -e "s,^DEFAULT_INDEX_FILE:.*,DEFAULT_INDEX_FILE:http://www.google.com/,g" lynx.cfg
|
||||
perl -pi -e 's,^#LOCALE_CHARSET:.*,LOCALE_CHARSET:TRUE,' lynx.cfg
|
||||
@ -106,6 +124,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%config(noreplace,missingok) %{_sysconfdir}/lynx-site.cfg
|
||||
|
||||
%changelog
|
||||
* Wed Jan 13 2010 Kamil Dudka <kdudka@redhat.com> - 2.8.7-2
|
||||
- make it possible to delete a bookmark when ~/lynx_bookmarks.html is writable
|
||||
by group (#486070)
|
||||
|
||||
* Tue Jan 05 2010 Kamil Dudka <kdudka@redhat.com> - 2.8.7-1
|
||||
- new upstream release
|
||||
- dropped applied patches
|
||||
|
Loading…
Reference in New Issue
Block a user