update to the latest upstream pre-release: lynx2.8.9dev.11
Resolves: CVE-2016-9179
This commit is contained in:
parent
c65c126eb4
commit
d00198ebf0
@ -1,25 +0,0 @@
|
|||||||
From 778a766d5a4fc891412edfc856e439770f54bc5b Mon Sep 17 00:00:00 2001
|
|
||||||
From: Kamil Dudka <kdudka@redhat.com>
|
|
||||||
Date: Thu, 20 Oct 2016 15:46:53 +0200
|
|
||||||
Subject: [PATCH] lynx: fix compatibility with OpenSSL 1.1
|
|
||||||
|
|
||||||
---
|
|
||||||
WWW/Library/Implementation/HTTP.c | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/WWW/Library/Implementation/HTTP.c b/WWW/Library/Implementation/HTTP.c
|
|
||||||
index 925512d..0909013 100644
|
|
||||||
--- a/WWW/Library/Implementation/HTTP.c
|
|
||||||
+++ b/WWW/Library/Implementation/HTTP.c
|
|
||||||
@@ -802,7 +802,7 @@ static int HTLoadHTTP(const char *arg,
|
|
||||||
#elif SSLEAY_VERSION_NUMBER >= 0x0900
|
|
||||||
#ifndef USE_NSS_COMPAT_INCL
|
|
||||||
if (!try_tls) {
|
|
||||||
- handle->options |= SSL_OP_NO_TLSv1;
|
|
||||||
+ SSL_set_options(handle, SSL_OP_NO_TLSv1);
|
|
||||||
CTRACE((tfp, "...adding SSL_OP_NO_TLSv1\n"));
|
|
||||||
}
|
|
||||||
#if OPENSSL_VERSION_NUMBER >= 0x0090806fL && !defined(OPENSSL_NO_TLSEXT)
|
|
||||||
--
|
|
||||||
2.7.4
|
|
||||||
|
|
@ -13,7 +13,7 @@ index f01782f..ccc0846 100644
|
|||||||
--- a/lynx.cfg
|
--- a/lynx.cfg
|
||||||
+++ b/lynx.cfg
|
+++ b/lynx.cfg
|
||||||
@@ -1,7 +1,9 @@
|
@@ -1,7 +1,9 @@
|
||||||
# $LynxId: lynx.cfg,v 1.272 2016/04/11 00:23:19 tom Exp $
|
# $LynxId: lynx.cfg,v 1.274 2016/11/15 09:04:25 tom Exp $
|
||||||
# lynx.cfg file.
|
# lynx.cfg file.
|
||||||
-# The default placement for this file is /usr/local/lib/lynx.cfg (Unix)
|
-# The default placement for this file is /usr/local/lib/lynx.cfg (Unix)
|
||||||
-# or Lynx_Dir:lynx.cfg (VMS)
|
-# or Lynx_Dir:lynx.cfg (VMS)
|
||||||
@ -23,7 +23,7 @@ index f01782f..ccc0846 100644
|
|||||||
+# Linux update, overwriting your changes). Instead, edit /etc/lynx-site.cfg.
|
+# Linux update, overwriting your changes). Instead, edit /etc/lynx-site.cfg.
|
||||||
#
|
#
|
||||||
# $Format: "#PRCS LYNX_VERSION \"$ProjectVersion$\""$
|
# $Format: "#PRCS LYNX_VERSION \"$ProjectVersion$\""$
|
||||||
#PRCS LYNX_VERSION "2.8.9dev.9"
|
#PRCS LYNX_VERSION "2.8.9dev.11"
|
||||||
@@ -90,7 +92,7 @@
|
@@ -90,7 +92,7 @@
|
||||||
#
|
#
|
||||||
# Normally we expect you will connect to a remote site, e.g., the Lynx starting
|
# Normally we expect you will connect to a remote site, e.g., the Lynx starting
|
||||||
|
@ -16,7 +16,7 @@ diff --git a/CHANGES b/CHANGES
|
|||||||
index 360be68..8eca013 100644
|
index 360be68..8eca013 100644
|
||||||
--- a/CHANGES
|
--- a/CHANGES
|
||||||
+++ b/CHANGES
|
+++ b/CHANGES
|
||||||
@@ -1108,6 +1108,13 @@ Changes since Lynx 2.8 release
|
@@ -1140,6 +1140,13 @@ Changes since Lynx 2.8 release
|
||||||
* update win32 makefiles/build scripts to add LYmktime, parsdate modules -TD
|
* update win32 makefiles/build scripts to add LYmktime, parsdate modules -TD
|
||||||
* update config.guess (2008-04-14), config.sub (2008-06-16)
|
* update config.guess (2008-04-14), config.sub (2008-06-16)
|
||||||
|
|
||||||
|
11
lynx.spec
11
lynx.spec
@ -1,9 +1,9 @@
|
|||||||
%global devrel 9
|
%global devrel 11
|
||||||
|
|
||||||
Summary: A text-based Web browser
|
Summary: A text-based Web browser
|
||||||
Name: lynx
|
Name: lynx
|
||||||
Version: 2.8.9
|
Version: 2.8.9
|
||||||
Release: 0.13.dev%{devrel}%{?dist}
|
Release: 0.14.dev%{devrel}%{?dist}
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
Group: Applications/Internet
|
Group: Applications/Internet
|
||||||
Source: http://invisible-mirror.net/archives/lynx/tarballs/lynx%{version}dev.%{devrel}.tar.bz2
|
Source: http://invisible-mirror.net/archives/lynx/tarballs/lynx%{version}dev.%{devrel}.tar.bz2
|
||||||
@ -24,9 +24,6 @@ Patch2: lynx-CVE-2008-4690.patch
|
|||||||
# avoid build failure caused by mistakenly excluded <locale.h>
|
# avoid build failure caused by mistakenly excluded <locale.h>
|
||||||
Patch3: lynx-2.8.8-locale.patch
|
Patch3: lynx-2.8.8-locale.patch
|
||||||
|
|
||||||
# fix compatibility with OpenSSL 1.1
|
|
||||||
Patch4: lynx-2.8.9-openssl.patch
|
|
||||||
|
|
||||||
Provides: webclient
|
Provides: webclient
|
||||||
Provides: text-www-browser
|
Provides: text-www-browser
|
||||||
BuildRequires: gettext
|
BuildRequires: gettext
|
||||||
@ -58,7 +55,6 @@ exits quickly and swiftly displays web pages.
|
|||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
%patch2 -p1
|
%patch2 -p1
|
||||||
%patch3 -p1
|
%patch3 -p1
|
||||||
%patch4 -p1
|
|
||||||
|
|
||||||
%{!?_pkgdocdir: %global _pkgdocdir %{_docdir}/%{name}-%{version}}
|
%{!?_pkgdocdir: %global _pkgdocdir %{_docdir}/%{name}-%{version}}
|
||||||
perl -pi -e "s,^HELPFILE:.*,HELPFILE:file://localhost%{_pkgdocdir}/lynx_help/lynx_help_main.html,g" lynx.cfg
|
perl -pi -e "s,^HELPFILE:.*,HELPFILE:file://localhost%{_pkgdocdir}/lynx_help/lynx_help_main.html,g" lynx.cfg
|
||||||
@ -132,6 +128,9 @@ EOF
|
|||||||
%config(noreplace,missingok) %{_sysconfdir}/lynx-site.cfg
|
%config(noreplace,missingok) %{_sysconfdir}/lynx-site.cfg
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jan 24 2017 Kamil Dudka <kdudka@redhat.com> - 2.8.9-0.14.dev11
|
||||||
|
- update to the latest upstream pre-release (fixes CVE-2016-9179)
|
||||||
|
|
||||||
* Thu Oct 20 2016 Kamil Dudka <kdudka@redhat.com> - 2.8.9-0.13.dev9
|
* Thu Oct 20 2016 Kamil Dudka <kdudka@redhat.com> - 2.8.9-0.13.dev9
|
||||||
- fix compatibility with OpenSSL 1.1
|
- fix compatibility with OpenSSL 1.1
|
||||||
|
|
||||||
|
@ -2,7 +2,7 @@
|
|||||||
Version: GnuPG v1.4.12 (GNU/Linux)
|
Version: GnuPG v1.4.12 (GNU/Linux)
|
||||||
Comment: See http://invisible-island.net/public/public.html for info
|
Comment: See http://invisible-island.net/public/public.html for info
|
||||||
|
|
||||||
iEYEABECAAYFAlcgEKAACgkQcCNT4Pfkjtt8kwCffEwMJYViI9cKKNh3kdksIM4l
|
iEYEABECAAYFAlgrtAYACgkQcCNT4Pfkjtv2LQCeKSwUw3Veke5dKTYO+lR8Pn3/
|
||||||
4iQAoLNIxH4pH5sysbMZlKOBrkCuwzDv
|
z7sAnj4xLoPBqC1NW7gGeIt6UBk8dFAR
|
||||||
=z14W
|
=YZyv
|
||||||
-----END PGP SIGNATURE-----
|
-----END PGP SIGNATURE-----
|
Loading…
Reference in New Issue
Block a user