update to the latest upstream pre-release: lynx2.8.9dev.1
This commit is contained in:
parent
f0f44444e6
commit
a3731e2b4a
4
.gitignore
vendored
4
.gitignore
vendored
@ -1,3 +1 @@
|
|||||||
lynx2.8.7.tar.bz2
|
/lynx2.*.tar.bz2
|
||||||
/lynx2.8.8dev.15.tar.bz2
|
|
||||||
/lynx2.8.8dev.16.tar.bz2
|
|
||||||
|
@ -1,18 +1,18 @@
|
|||||||
From 1d1198847124798b7467d33b2aee2d8cdffc6a24 Mon Sep 17 00:00:00 2001
|
From e6f2bec676f7abb4962821475fbc7cf918503e00 Mon Sep 17 00:00:00 2001
|
||||||
From: Kamil Dudka <kdudka@redhat.com>
|
From: Kamil Dudka <kdudka@redhat.com>
|
||||||
Date: Wed, 13 Feb 2013 15:25:00 +0100
|
Date: Wed, 13 Feb 2013 15:25:00 +0100
|
||||||
Subject: [PATCH] prepare upstream sources for parallel make
|
Subject: [PATCH] prepare upstream sources for parallel make
|
||||||
|
|
||||||
---
|
---
|
||||||
makefile.in | 46 ++++++++++++++++++++++------------------------
|
makefile.in | 48 +++++++++++++++++++++++-------------------------
|
||||||
src/makefile.in | 10 ++++------
|
src/makefile.in | 10 ++++------
|
||||||
2 files changed, 26 insertions(+), 30 deletions(-)
|
2 files changed, 27 insertions(+), 31 deletions(-)
|
||||||
|
|
||||||
diff --git a/makefile.in b/makefile.in
|
diff --git a/makefile.in b/makefile.in
|
||||||
index 671ae0f..feb9a24 100644
|
index ad78441..0fd8b1e 100644
|
||||||
--- a/makefile.in
|
--- a/makefile.in
|
||||||
+++ b/makefile.in
|
+++ b/makefile.in
|
||||||
@@ -101,8 +101,6 @@ COMPRESS_EXT=@COMPRESS_EXT@
|
@@ -109,8 +109,6 @@ COMPRESS_EXT=@COMPRESS_EXT@
|
||||||
# Path of scripts directory
|
# Path of scripts directory
|
||||||
scripts_dir=$(srcdir)/scripts
|
scripts_dir=$(srcdir)/scripts
|
||||||
|
|
||||||
@ -21,15 +21,17 @@ index 671ae0f..feb9a24 100644
|
|||||||
@LYNXCFG_MAKE@CFG2HTML = alphatoc.html body.html cattoc.html
|
@LYNXCFG_MAKE@CFG2HTML = alphatoc.html body.html cattoc.html
|
||||||
|
|
||||||
# !!!!!!!!!!! SUN resolv LIBRARY !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
|
# !!!!!!!!!!! SUN resolv LIBRARY !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
|
||||||
@@ -199,19 +197,19 @@ binary_PROG = $(actual_PROG)$x
|
@@ -215,20 +213,20 @@ binary_PROG = $(actual_PROG)$x
|
||||||
|
|
||||||
all lynx$x: cfg_defs.h LYHelp.h
|
all lynx$x: cfg_defs.h LYHelp.h
|
||||||
@MSG_DIR_MAKE@ $(SHELL) $(scripts_dir)/fixtext.sh $(srcdir)/LYMessages_en.h >LYMessages.c
|
@MSG_DIR_MAKE@ $(SHELL) $(scripts_dir)/fixtext.sh $(srcdir)/LYMessages_en.h >LYMessages.c
|
||||||
-@MSG_DIR_MAKE@ cd $(PO_DIR) && $(MAKE_RECUR)
|
-@MSG_DIR_MAKE@ cd $(PO_DIR) && $(MAKE_RECUR)
|
||||||
- cd $(WWW_DIR) && $(MAKE_RECUR) $(WWW_CFLAGS)
|
- cd $(WWW_DIR) && $(MAKE_RECUR) $(WWW_CFLAGS)
|
||||||
|
- cd $(CHR_DIR) && $(MAKE_RECUR) all $(CHR_CFLAGS)
|
||||||
- cd $(SRC_DIR) && $(MAKE_RECUR) all $(SRC_CFLAGS)
|
- cd $(SRC_DIR) && $(MAKE_RECUR) all $(SRC_CFLAGS)
|
||||||
+@MSG_DIR_MAKE@ $(MAKE) -C $(PO_DIR)
|
+@MSG_DIR_MAKE@ $(MAKE) -C $(PO_DIR)
|
||||||
+ $(MAKE) -C $(WWW_DIR) $(WWW_CFLAGS)
|
+ $(MAKE) -C $(WWW_DIR) $(WWW_CFLAGS)
|
||||||
|
+ $(MAKE) -C $(CHR_DIR) all $(CHR_CFLAGS)
|
||||||
+ $(MAKE) -C $(SRC_DIR) all $(SRC_CFLAGS)
|
+ $(MAKE) -C $(SRC_DIR) all $(SRC_CFLAGS)
|
||||||
|
|
||||||
lint:
|
lint:
|
||||||
@ -50,7 +52,7 @@ index 671ae0f..feb9a24 100644
|
|||||||
|
|
||||||
etags:
|
etags:
|
||||||
$(ETAGS) *.[ch] */*.[ch] */*/*.[ch] */*/*/*.[ch]
|
$(ETAGS) *.[ch] */*.[ch] */*/*.[ch] */*/*/*.[ch]
|
||||||
@@ -231,27 +229,27 @@ help:
|
@@ -246,27 +244,27 @@ help:
|
||||||
clean:
|
clean:
|
||||||
rm -f WWW/Library/*/*.[aoib]
|
rm -f WWW/Library/*/*.[aoib]
|
||||||
rm -f WWW/Library/*/.created
|
rm -f WWW/Library/*/.created
|
||||||
@ -87,7 +89,7 @@ index 671ae0f..feb9a24 100644
|
|||||||
@MSG_DIR_MAKE@ -rmdir $(PO_DIR)
|
@MSG_DIR_MAKE@ -rmdir $(PO_DIR)
|
||||||
-rm -f *~ *.bak *.sav tags TAGS
|
-rm -f *~ *.bak *.sav tags TAGS
|
||||||
-rm -f $(WWW_DIR)/makefile $(SRC_DIR)/makefile $(CHR_DIR)/makefile
|
-rm -f $(WWW_DIR)/makefile $(SRC_DIR)/makefile $(CHR_DIR)/makefile
|
||||||
@@ -320,7 +318,7 @@ install-full: install install-help install-doc
|
@@ -312,7 +310,7 @@ install-full: install install-help install-doc
|
||||||
@echo Full installation complete.
|
@echo Full installation complete.
|
||||||
|
|
||||||
install-bin: $(BINDIR) lynx$x
|
install-bin: $(BINDIR) lynx$x
|
||||||
@ -96,7 +98,7 @@ index 671ae0f..feb9a24 100644
|
|||||||
@ECHO_CC@$(SHELL) -c \
|
@ECHO_CC@$(SHELL) -c \
|
||||||
'if test -f $(BINDIR)/$(binary_PROG) ; then \
|
'if test -f $(BINDIR)/$(binary_PROG) ; then \
|
||||||
mv -f $(BINDIR)/$(binary_PROG) $(BINDIR)/lynx.old; fi'
|
mv -f $(BINDIR)/$(binary_PROG) $(BINDIR)/lynx.old; fi'
|
||||||
@@ -354,7 +352,7 @@ LYNXHELP_URL='$(LYNX_URL)/lynx_help/'
|
@@ -353,7 +351,7 @@ LYNXHELP_URL='$(LYNX_URL)/lynx_help/'
|
||||||
|
|
||||||
@LYNXCFG_MAKE@$(CFG2HTML) :
|
@LYNXCFG_MAKE@$(CFG2HTML) :
|
||||||
@LYNXCFG_MAKE@ @echo 'Making htmlized lynx.cfg'
|
@LYNXCFG_MAKE@ @echo 'Making htmlized lynx.cfg'
|
||||||
@ -105,7 +107,7 @@ index 671ae0f..feb9a24 100644
|
|||||||
@LYNXCFG_MAKE@ @-rm -f $(CFG2HTML)
|
@LYNXCFG_MAKE@ @-rm -f $(CFG2HTML)
|
||||||
@LYNXCFG_MAKE@ sed -n -e '/Config_Type *Config_Table/,/{0, *0, *0}/ p' $(SRC_DIR)/LYReadCFG.i | \
|
@LYNXCFG_MAKE@ sed -n -e '/Config_Type *Config_Table/,/{0, *0, *0}/ p' $(SRC_DIR)/LYReadCFG.i | \
|
||||||
@LYNXCFG_MAKE@ sed -e 's/ *{ *"\([^"]*\)".*/\1/' | \
|
@LYNXCFG_MAKE@ sed -e 's/ *{ *"\([^"]*\)".*/\1/' | \
|
||||||
@@ -452,7 +450,7 @@ install-lss : $(SYSCONFDIR)
|
@@ -451,7 +449,7 @@ install-lss : $(SYSCONFDIR)
|
||||||
@$(SHELL) $(scripts_dir)/install-lss.sh "$(INSTALL_DATA)" $(srcdir)/samples/lynx.lss $(SYSCONFDIR)/lynx.lss
|
@$(SHELL) $(scripts_dir)/install-lss.sh "$(INSTALL_DATA)" $(srcdir)/samples/lynx.lss $(SYSCONFDIR)/lynx.lss
|
||||||
|
|
||||||
uninstall ::
|
uninstall ::
|
||||||
@ -114,7 +116,7 @@ index 671ae0f..feb9a24 100644
|
|||||||
-rm -f $(BINDIR)/$(binary_PROG)
|
-rm -f $(BINDIR)/$(binary_PROG)
|
||||||
-rm -f $(MANDIR)/$(actual_PROG).1
|
-rm -f $(MANDIR)/$(actual_PROG).1
|
||||||
-rm -f $(SYSCONFDIR)/lynx.cfg
|
-rm -f $(SYSCONFDIR)/lynx.cfg
|
||||||
@@ -485,7 +483,7 @@ uninstall-doc ::
|
@@ -484,7 +482,7 @@ uninstall-doc ::
|
||||||
|
|
||||||
update-po:
|
update-po:
|
||||||
rsync -Lrtvz translationproject.org::tp/latest/lynx/ $(PO_SRCDIR)
|
rsync -Lrtvz translationproject.org::tp/latest/lynx/ $(PO_SRCDIR)
|
||||||
@ -124,19 +126,19 @@ index 671ae0f..feb9a24 100644
|
|||||||
preinstall :
|
preinstall :
|
||||||
@ echo ''
|
@ echo ''
|
||||||
diff --git a/src/makefile.in b/src/makefile.in
|
diff --git a/src/makefile.in b/src/makefile.in
|
||||||
index a18b653..589df1a 100644
|
index 55611da..7cceaa8 100644
|
||||||
--- a/src/makefile.in
|
--- a/src/makefile.in
|
||||||
+++ b/src/makefile.in
|
+++ b/src/makefile.in
|
||||||
@@ -35,8 +35,6 @@ BUILD_CFLAGS = @BUILD_CFLAGS@
|
@@ -37,8 +37,6 @@ BUILD_EXEEXT = @BUILD_EXEEXT@
|
||||||
BUILD_CPPFLAGS = @BUILD_CPPFLAGS@ @DEFS@
|
BUILD_LDFLAGS = @BUILD_LDFLAGS@
|
||||||
BUILD_EXEEXT = @BUILD_EXEEXT@
|
BUILD_LIBS = @BUILD_LIBS@
|
||||||
|
|
||||||
-MAKE_RECUR = $(MAKE) @cf_cv_makeflags@ DESTDIR="$(DESTDIR)" CC="$(CC)"
|
-MAKE_RECUR = $(MAKE) @cf_cv_makeflags@ DESTDIR="$(DESTDIR)" CC="$(CC)"
|
||||||
-
|
-
|
||||||
YACC = @YACC@
|
YACC = @YACC@
|
||||||
WINDRES = @WINDRES@
|
WINDRES = @WINDRES@
|
||||||
|
|
||||||
@@ -116,7 +114,7 @@ message:
|
@@ -118,7 +116,7 @@ message:
|
||||||
@echo "Compiling Lynx sources"
|
@echo "Compiling Lynx sources"
|
||||||
|
|
||||||
do_chartrans_stuff:
|
do_chartrans_stuff:
|
||||||
@ -145,7 +147,7 @@ index a18b653..589df1a 100644
|
|||||||
SITE_DEFS="$(SITE_DEFS)" \
|
SITE_DEFS="$(SITE_DEFS)" \
|
||||||
BUILD_CFLAGS="$(BUILD_CFLAGS)" \
|
BUILD_CFLAGS="$(BUILD_CFLAGS)" \
|
||||||
BUILD_CPPFLAGS="$(BUILD_CPPFLAGS)" \
|
BUILD_CPPFLAGS="$(BUILD_CPPFLAGS)" \
|
||||||
@@ -129,7 +127,7 @@ lint:
|
@@ -131,7 +129,7 @@ lint:
|
||||||
|
|
||||||
clean:
|
clean:
|
||||||
rm -f lynx$x core *.core *.leaks *.i *$o *.bak tags TAGS test_*
|
rm -f lynx$x core *.core *.leaks *.i *$o *.bak tags TAGS test_*
|
||||||
@ -154,7 +156,7 @@ index a18b653..589df1a 100644
|
|||||||
|
|
||||||
tags:
|
tags:
|
||||||
$(CTAGS) *.[ch]
|
$(CTAGS) *.[ch]
|
||||||
@@ -207,7 +205,7 @@ TABLES= \
|
@@ -209,7 +207,7 @@ TABLES= \
|
||||||
$(CHRTR)viscii_uni.h
|
$(CHRTR)viscii_uni.h
|
||||||
|
|
||||||
$(TABLES):
|
$(TABLES):
|
||||||
@ -163,7 +165,7 @@ index a18b653..589df1a 100644
|
|||||||
|
|
||||||
UCdomap$o : UCdomap.c \
|
UCdomap$o : UCdomap.c \
|
||||||
chrtrans/UCkd.h \
|
chrtrans/UCkd.h \
|
||||||
@@ -216,7 +214,7 @@ UCdomap$o : UCdomap.c \
|
@@ -218,7 +216,7 @@ UCdomap$o : UCdomap.c \
|
||||||
UCdomap.h $(CMN)UCMap.h $(TABLES) $(top_srcdir)/userdefs.h
|
UCdomap.h $(CMN)UCMap.h $(TABLES) $(top_srcdir)/userdefs.h
|
||||||
|
|
||||||
chrtrans/makeuctb$(BUILD_EXEEXT):
|
chrtrans/makeuctb$(BUILD_EXEEXT):
|
||||||
@ -173,5 +175,5 @@ index a18b653..589df1a 100644
|
|||||||
UCAux$o : UCAux.c $(CMN)UCAux.h $(CMN)UCDefs.h
|
UCAux$o : UCAux.c $(CMN)UCAux.h $(CMN)UCDefs.h
|
||||||
LYCookie$o : $(top_srcdir)/userdefs.h
|
LYCookie$o : $(top_srcdir)/userdefs.h
|
||||||
--
|
--
|
||||||
1.7.1
|
1.8.3.1
|
||||||
|
|
@ -1,19 +1,19 @@
|
|||||||
From 8c053103d8253f5868807853cb7b921e5cb07214 Mon Sep 17 00:00:00 2001
|
From bccfb8ac43da56cb1f53c4b421e09dcac1fd1af0 Mon Sep 17 00:00:00 2001
|
||||||
From: Kamil Dudka <kdudka@redhat.com>
|
From: Kamil Dudka <kdudka@redhat.com>
|
||||||
Date: Wed, 13 Feb 2013 15:17:08 +0100
|
Date: Wed, 13 Feb 2013 15:17:08 +0100
|
||||||
Subject: [PATCH] lynx-2.8.6-redhat.patch rebased for 2.8.8
|
Subject: [PATCH] lynx-2.8.6-redhat.patch rebased for 2.8.9
|
||||||
|
|
||||||
---
|
---
|
||||||
lynx.cfg | 14 +++++++++++---
|
lynx.cfg | 14 +++++++++++---
|
||||||
userdefs.h | 16 ++++++++--------
|
userdefs.h | 18 +++++++++---------
|
||||||
2 files changed, 19 insertions(+), 11 deletions(-)
|
2 files changed, 20 insertions(+), 12 deletions(-)
|
||||||
|
|
||||||
diff --git a/lynx.cfg b/lynx.cfg
|
diff --git a/lynx.cfg b/lynx.cfg
|
||||||
index ee2aad3..f732558 100644
|
index f01782f..ccc0846 100644
|
||||||
--- a/lynx.cfg
|
--- a/lynx.cfg
|
||||||
+++ b/lynx.cfg
|
+++ b/lynx.cfg
|
||||||
@@ -1,8 +1,11 @@
|
@@ -1,8 +1,11 @@
|
||||||
# $LynxId: lynx.cfg,v 1.225 2013/06/02 20:06:02 tom Exp $
|
# $LynxId: lynx.cfg,v 1.247 2014/03/10 22:07:34 tom Exp $
|
||||||
# lynx.cfg file.
|
# lynx.cfg file.
|
||||||
-# The default placement for this file is /usr/local/lib/lynx.cfg (Unix)
|
-# The default placement for this file is /usr/local/lib/lynx.cfg (Unix)
|
||||||
+# The default placement for this file is /etc/lynx.cfg (Red Hat Linux, Fedora)
|
+# The default placement for this file is /etc/lynx.cfg (Red Hat Linux, Fedora)
|
||||||
@ -23,7 +23,7 @@ index ee2aad3..f732558 100644
|
|||||||
+# Linux update, overwriting your changes). Instead, edit /etc/lynx-site.cfg.
|
+# Linux update, overwriting your changes). Instead, edit /etc/lynx-site.cfg.
|
||||||
+#
|
+#
|
||||||
# $Format: "#PRCS LYNX_VERSION \"$ProjectVersion$\""$
|
# $Format: "#PRCS LYNX_VERSION \"$ProjectVersion$\""$
|
||||||
#PRCS LYNX_VERSION "2.8.8dev.16"
|
#PRCS LYNX_VERSION "2.8.9dev.1"
|
||||||
#
|
#
|
||||||
@@ -90,7 +93,7 @@
|
@@ -90,7 +93,7 @@
|
||||||
#
|
#
|
||||||
@ -43,7 +43,7 @@ index ee2aad3..f732558 100644
|
|||||||
|
|
||||||
.h2 LOCALE_CHARSET
|
.h2 LOCALE_CHARSET
|
||||||
# LOCALE_CHARSET overrides CHARACTER_SET if true, using the current locale to
|
# LOCALE_CHARSET overrides CHARACTER_SET if true, using the current locale to
|
||||||
@@ -1817,6 +1820,10 @@ DEFAULT_INDEX_FILE:http://scout.wisc.edu/
|
@@ -1823,6 +1826,10 @@ DEFAULT_INDEX_FILE:http://scout.wisc.edu/
|
||||||
.ex
|
.ex
|
||||||
#DOWNLOADER:Save OS/390 binary file: iconv -f IBM-1047 -t ISO8859-1 %s >%s:FALSE
|
#DOWNLOADER:Save OS/390 binary file: iconv -f IBM-1047 -t ISO8859-1 %s >%s:FALSE
|
||||||
|
|
||||||
@ -54,7 +54,7 @@ index ee2aad3..f732558 100644
|
|||||||
.h1 Interaction
|
.h1 Interaction
|
||||||
|
|
||||||
.h2 NO_DOT_FILES
|
.h2 NO_DOT_FILES
|
||||||
@@ -3399,6 +3406,7 @@ COLOR:6:brightred:black
|
@@ -3422,6 +3429,7 @@ COLOR:6:brightred:black
|
||||||
#ENABLE_LYNXRC:VI_KEYS:ON
|
#ENABLE_LYNXRC:VI_KEYS:ON
|
||||||
#ENABLE_LYNXRC:VISITED_LINKS:ON
|
#ENABLE_LYNXRC:VISITED_LINKS:ON
|
||||||
.fi
|
.fi
|
||||||
@ -63,7 +63,7 @@ index ee2aad3..f732558 100644
|
|||||||
.h1 External Programs
|
.h1 External Programs
|
||||||
# Any of the compiled-in pathnames of external programs can be overridden
|
# Any of the compiled-in pathnames of external programs can be overridden
|
||||||
diff --git a/userdefs.h b/userdefs.h
|
diff --git a/userdefs.h b/userdefs.h
|
||||||
index 066e01b..45a1642 100644
|
index 40a954b..4afe835 100644
|
||||||
--- a/userdefs.h
|
--- a/userdefs.h
|
||||||
+++ b/userdefs.h
|
+++ b/userdefs.h
|
||||||
@@ -105,7 +105,7 @@
|
@@ -105,7 +105,7 @@
|
||||||
@ -74,8 +74,8 @@ index 066e01b..45a1642 100644
|
|||||||
+#define LYNX_CFG_FILE "/etc/lynx.cfg"
|
+#define LYNX_CFG_FILE "/etc/lynx.cfg"
|
||||||
#endif /* LYNX_CFG_FILE */
|
#endif /* LYNX_CFG_FILE */
|
||||||
|
|
||||||
/**************************
|
#ifndef LYNX_CFG_PATH
|
||||||
@@ -115,8 +115,8 @@
|
@@ -119,8 +119,8 @@
|
||||||
* Mappings in these global and personal files override any SUFFIX
|
* Mappings in these global and personal files override any SUFFIX
|
||||||
* definitions in lynx.cfg and built-in defaults from src/HTInit.c.
|
* definitions in lynx.cfg and built-in defaults from src/HTInit.c.
|
||||||
*/
|
*/
|
||||||
@ -86,7 +86,7 @@ index 066e01b..45a1642 100644
|
|||||||
|
|
||||||
/**************************
|
/**************************
|
||||||
* The MAILCAP file allows you to map file MIME types to
|
* The MAILCAP file allows you to map file MIME types to
|
||||||
@@ -125,7 +125,7 @@
|
@@ -129,7 +129,7 @@
|
||||||
* Mappings in these global and personal files override any VIEWER
|
* Mappings in these global and personal files override any VIEWER
|
||||||
* definitions in lynx.cfg and built-in defaults from src/HTInit.c.
|
* definitions in lynx.cfg and built-in defaults from src/HTInit.c.
|
||||||
*/
|
*/
|
||||||
@ -95,16 +95,18 @@ index 066e01b..45a1642 100644
|
|||||||
#define PERSONAL_MAILCAP ".mailcap"
|
#define PERSONAL_MAILCAP ".mailcap"
|
||||||
|
|
||||||
/**************************
|
/**************************
|
||||||
@@ -295,7 +295,7 @@
|
@@ -300,8 +300,8 @@
|
||||||
#ifdef DOSPATH
|
#define LYNX_CFG_PATH "."
|
||||||
#define LYNX_CFG_FILE "./lynx.cfg"
|
#define LYNX_CFG_FILE "./lynx.cfg"
|
||||||
#else
|
#else
|
||||||
|
-#define LYNX_CFG_PATH "/usr/local/lib"
|
||||||
-#define LYNX_CFG_FILE "/usr/local/lib/lynx.cfg"
|
-#define LYNX_CFG_FILE "/usr/local/lib/lynx.cfg"
|
||||||
|
+#define LYNX_CFG_PATH "/etc"
|
||||||
+#define LYNX_CFG_FILE "/etc/lynx.cfg"
|
+#define LYNX_CFG_FILE "/etc/lynx.cfg"
|
||||||
#endif /* DOSPATH */
|
#endif /* DOSPATH */
|
||||||
#endif /* LYNX_CFG_FILE */
|
#endif /* LYNX_CFG_FILE */
|
||||||
#endif /* HAVE_CONFIG_H */
|
#endif /* HAVE_CONFIG_H */
|
||||||
@@ -339,7 +339,7 @@
|
@@ -345,7 +345,7 @@
|
||||||
* use any default viewers for image types. Note that open is used as
|
* use any default viewers for image types. Note that open is used as
|
||||||
* the default for NeXT, instead of the XLOADIMAGE_COMMAND definition.
|
* the default for NeXT, instead of the XLOADIMAGE_COMMAND definition.
|
||||||
*/
|
*/
|
||||||
@ -113,7 +115,7 @@ index 066e01b..45a1642 100644
|
|||||||
|
|
||||||
/**************************
|
/**************************
|
||||||
* For UNIX systems, SYSTEM_MAIL and SYSTEM_MAIL_FLAGS are set by the
|
* For UNIX systems, SYSTEM_MAIL and SYSTEM_MAIL_FLAGS are set by the
|
||||||
@@ -360,7 +360,7 @@
|
@@ -366,7 +366,7 @@
|
||||||
* the "TMPDIR" (unix), or "TEMP" or "TMP" (Windows,DOS,OS/2)
|
* the "TMPDIR" (unix), or "TEMP" or "TMP" (Windows,DOS,OS/2)
|
||||||
* variable.
|
* variable.
|
||||||
*/
|
*/
|
||||||
@ -122,7 +124,7 @@ index 066e01b..45a1642 100644
|
|||||||
|
|
||||||
/********************************
|
/********************************
|
||||||
* Comment this line out to disable code that implements command logging
|
* Comment this line out to disable code that implements command logging
|
||||||
@@ -1162,7 +1162,7 @@
|
@@ -1172,7 +1172,7 @@
|
||||||
* OSU server distribution.
|
* OSU server distribution.
|
||||||
*/
|
*/
|
||||||
#ifndef HAVE_CONFIG_H
|
#ifndef HAVE_CONFIG_H
|
||||||
@ -132,5 +134,5 @@ index 066e01b..45a1642 100644
|
|||||||
|
|
||||||
/*********************************
|
/*********************************
|
||||||
--
|
--
|
||||||
1.7.1
|
1.8.3.1
|
||||||
|
|
@ -16,7 +16,7 @@ diff --git a/CHANGES b/CHANGES
|
|||||||
index 360be68..8eca013 100644
|
index 360be68..8eca013 100644
|
||||||
--- a/CHANGES
|
--- a/CHANGES
|
||||||
+++ b/CHANGES
|
+++ b/CHANGES
|
||||||
@@ -753,6 +753,13 @@ Changes since Lynx 2.8 release
|
@@ -930,6 +930,13 @@ Changes since Lynx 2.8 release
|
||||||
* update win32 makefiles/build scripts to add LYmktime, parsdate modules -TD
|
* update win32 makefiles/build scripts to add LYmktime, parsdate modules -TD
|
||||||
* update config.guess (2008-04-14), config.sub (2008-06-16)
|
* update config.guess (2008-04-14), config.sub (2008-06-16)
|
||||||
|
|
||||||
@ -34,7 +34,7 @@ diff --git a/lynx.cfg b/lynx.cfg
|
|||||||
index ee2aad3..144050d 100644
|
index ee2aad3..144050d 100644
|
||||||
--- a/lynx.cfg
|
--- a/lynx.cfg
|
||||||
+++ b/lynx.cfg
|
+++ b/lynx.cfg
|
||||||
@@ -1064,7 +1064,7 @@ CHARACTER_SET:utf-8
|
@@ -1070,7 +1070,7 @@ CHARACTER_SET:utf-8
|
||||||
#
|
#
|
||||||
# The default TRUSTED_LYNXCGI rule is "none".
|
# The default TRUSTED_LYNXCGI rule is "none".
|
||||||
#
|
#
|
||||||
|
15
lynx.spec
15
lynx.spec
@ -1,19 +1,19 @@
|
|||||||
%global devrel 16
|
%global devrel 1
|
||||||
|
|
||||||
Summary: A text-based Web browser
|
Summary: A text-based Web browser
|
||||||
Name: lynx
|
Name: lynx
|
||||||
Version: 2.8.8
|
Version: 2.8.9
|
||||||
Release: 0.3.dev%{devrel}%{?dist}
|
Release: 0.1.dev%{devrel}%{?dist}
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
Group: Applications/Internet
|
Group: Applications/Internet
|
||||||
Source: http://lynx.isc.org/current/lynx%{version}dev.%{devrel}.tar.bz2
|
Source: http://lynx.isc.org/current/lynx%{version}dev.%{devrel}.tar.bz2
|
||||||
URL: http://lynx.isc.org/
|
URL: http://lynx.isc.org/
|
||||||
|
|
||||||
# RH specific tweaks - directory layout, utf-8 by default, misc. configuration
|
# RH specific tweaks - directory layout, utf-8 by default, misc. configuration
|
||||||
Patch0: lynx-2.8.8-redhat.patch
|
Patch0: lynx-2.8.9-redhat.patch
|
||||||
|
|
||||||
# patch preparing upstream sources for rpmbuild, in particular for parallel make
|
# patch preparing upstream sources for rpmbuild, in particular for parallel make
|
||||||
Patch1: lynx-2.8.8-build.patch
|
Patch1: lynx-2.8.9-build.patch
|
||||||
|
|
||||||
# prompt user before executing command via a lynxcgi link even in advanced mode,
|
# prompt user before executing command via a lynxcgi link even in advanced mode,
|
||||||
# as the actual URL may not be shown but hidden behind an HTTP redirect and set
|
# as the actual URL may not be shown but hidden behind an HTTP redirect and set
|
||||||
@ -48,7 +48,7 @@ advantage Lynx has over graphical browsers is speed; Lynx starts and
|
|||||||
exits quickly and swiftly displays web pages.
|
exits quickly and swiftly displays web pages.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n lynx2-8-8
|
%setup -q -n lynx2-8-9
|
||||||
|
|
||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
@ -141,6 +141,9 @@ EOF
|
|||||||
%config(noreplace,missingok) %{_sysconfdir}/lynx-site.cfg
|
%config(noreplace,missingok) %{_sysconfdir}/lynx-site.cfg
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Apr 28 2014 Kamil Dudka <kdudka@redhat.com> - 2.8.9-0.1.dev1
|
||||||
|
- update to the latest upstream pre-release
|
||||||
|
|
||||||
* Fri Aug 09 2013 Kamil Dudka <kdudka@redhat.com> - 2.8.8-0.3.dev16
|
* Fri Aug 09 2013 Kamil Dudka <kdudka@redhat.com> - 2.8.8-0.3.dev16
|
||||||
- update to the latest upstream pre-release
|
- update to the latest upstream pre-release
|
||||||
- make the help working with unversioned docdir (#993909)
|
- make the help working with unversioned docdir (#993909)
|
||||||
|
@ -2,7 +2,7 @@
|
|||||||
Version: GnuPG v2.0.17 (FreeBSD)
|
Version: GnuPG v2.0.17 (FreeBSD)
|
||||||
Comment: See http://lynx.isc.org/signatures.html for info
|
Comment: See http://lynx.isc.org/signatures.html for info
|
||||||
|
|
||||||
iEYEABECAAYFAlH24lsACgkQXd+Pt2iOMaYfugCePnm0MJ+L+7HEaP2ounCGb6C/
|
iEYEABECAAYFAlMguGUACgkQXd+Pt2iOMaaB9wCglicKerDIA5uo0Z4Lih8vHNoL
|
||||||
UPQAn1t4Ro0WZ9HdgMzNLr8VTkctzgp4
|
6D0AnRCpWcE32rUNZ7W6hO9QEJwVB9q+
|
||||||
=X9oV
|
=Vp4b
|
||||||
-----END PGP SIGNATURE-----
|
-----END PGP SIGNATURE-----
|
Loading…
Reference in New Issue
Block a user