- avoid build failure caused by mistakenly excluded <locale.h>
This commit is contained in:
parent
f9a1ceed52
commit
880b841b09
13
lynx-2.8.7-locale.patch
Normal file
13
lynx-2.8.7-locale.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
diff --git a/src/LYMain.c b/src/LYMain.c
|
||||||
|
index b3a00cc..126a30f 100644
|
||||||
|
--- a/src/LYMain.c
|
||||||
|
+++ b/src/LYMain.c
|
||||||
|
@@ -57,7 +57,7 @@
|
||||||
|
#include <io.h>
|
||||||
|
#endif
|
||||||
|
|
||||||
|
-#if defined(LOCALE) && !defined(HAVE_LIBINTL_H)
|
||||||
|
+#if defined(LOCALE)
|
||||||
|
#undef gettext /* Solaris locale.h prototypes gettext() */
|
||||||
|
#include <locale.h>
|
||||||
|
#ifndef HAVE_GETTEXT
|
98
lynx.spec
98
lynx.spec
@ -1,16 +1,35 @@
|
|||||||
Summary: A text-based Web browser
|
Summary: A text-based Web browser
|
||||||
Name: lynx
|
Name: lynx
|
||||||
Version: 2.8.7
|
Version: 2.8.7
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
Group: Applications/Internet
|
Group: Applications/Internet
|
||||||
Source: http://lynx.isc.org/lynx%{version}/lynx%{version}.tar.bz2
|
Source: http://lynx.isc.org/lynx%{version}/lynx%{version}.tar.bz2
|
||||||
URL: http://lynx.isc.org/
|
URL: http://lynx.isc.org/
|
||||||
|
|
||||||
|
# RH specific tweaks - directory layout, utf-8 by default, misc. configuration
|
||||||
|
# and home page
|
||||||
Patch0: lynx-2.8.6-redhat.patch
|
Patch0: lynx-2.8.6-redhat.patch
|
||||||
|
|
||||||
|
# tweaks colors
|
||||||
Patch1: lynx-2.8.6-backgrcolor.patch
|
Patch1: lynx-2.8.6-backgrcolor.patch
|
||||||
|
|
||||||
|
# patch preparing upstream sources for rpmbuild, in particular for parallel make
|
||||||
Patch2: lynx-build-fixes.patch
|
Patch2: lynx-build-fixes.patch
|
||||||
|
|
||||||
|
# prompt user before executing command via a lynxcgi link even in advanced mode,
|
||||||
|
# as the actual URL may not be shown but hidden behind an HTTP redirect and set
|
||||||
|
# TRUSTED_LYNXCGI:none in lynx.cfg to disable all lynxcgi URLs by default
|
||||||
|
# [CVE-2008-4690]
|
||||||
Patch3: lynx-CVE-2008-4690.patch
|
Patch3: lynx-CVE-2008-4690.patch
|
||||||
|
|
||||||
|
# make it possible to delete a bookmark when ~/lynx_bookmarks.html is writable
|
||||||
|
# by group (#486070)
|
||||||
Patch4: lynx-2.8.7-bm-del.patch
|
Patch4: lynx-2.8.7-bm-del.patch
|
||||||
|
|
||||||
|
# avoid build failure caused by mistakenly excluded <locale.h>
|
||||||
|
Patch5: lynx-2.8.7-locale.patch
|
||||||
|
|
||||||
Provides: webclient
|
Provides: webclient
|
||||||
Provides: text-www-browser
|
Provides: text-www-browser
|
||||||
BuildRequires: gettext
|
BuildRequires: gettext
|
||||||
@ -33,25 +52,12 @@ exits quickly and swiftly displays web pages.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n lynx2-8-7
|
%setup -q -n lynx2-8-7
|
||||||
|
|
||||||
# RH specific tweaks - directory layout, utf-8 by default, misc. configuration
|
|
||||||
# and home page
|
|
||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
|
|
||||||
# tweaks colors
|
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
|
|
||||||
# patch preparing upstream sources for rpmbuild, in particular for parallel make
|
|
||||||
%patch2 -p1
|
%patch2 -p1
|
||||||
|
|
||||||
# prompt user before executing command via a lynxcgi link even in advanced mode,
|
|
||||||
# as the actual URL may not be shown but hidden behind an HTTP redirect and set
|
|
||||||
# TRUSTED_LYNXCGI:none in lynx.cfg to disable all lynxcgi URLs by default
|
|
||||||
# [CVE-2008-4690]
|
|
||||||
%patch3 -p1
|
%patch3 -p1
|
||||||
|
|
||||||
# make it possible to delete a bookmark when ~/lynx_bookmarks.html is writable
|
|
||||||
# by group (#486070)
|
|
||||||
%patch4 -p1
|
%patch4 -p1
|
||||||
|
%patch5 -p1
|
||||||
|
|
||||||
perl -pi -e "s,^HELPFILE:.*,HELPFILE:file://localhost/usr/share/doc/lynx-%{version}/lynx_help/lynx_help_main.html,g" lynx.cfg
|
perl -pi -e "s,^HELPFILE:.*,HELPFILE:file://localhost/usr/share/doc/lynx-%{version}/lynx_help/lynx_help_main.html,g" lynx.cfg
|
||||||
perl -pi -e "s,^DEFAULT_INDEX_FILE:.*,DEFAULT_INDEX_FILE:http://www.google.com/,g" lynx.cfg
|
perl -pi -e "s,^DEFAULT_INDEX_FILE:.*,DEFAULT_INDEX_FILE:http://www.google.com/,g" lynx.cfg
|
||||||
@ -63,10 +69,10 @@ cat >gcc <<EOF
|
|||||||
#!/bin/sh
|
#!/bin/sh
|
||||||
ARGS=""
|
ARGS=""
|
||||||
while [ \$# != 0 ]; do
|
while [ \$# != 0 ]; do
|
||||||
if [ \$1 != "-I/usr/include" -a \$1 != "-I/usr/include/" ]; then
|
if [ \$1 != "-I/usr/include" -a \$1 != "-I/usr/include/" ]; then
|
||||||
ARGS="\$ARGS \$1"
|
ARGS="\$ARGS \$1"
|
||||||
fi
|
fi
|
||||||
shift
|
shift
|
||||||
done
|
done
|
||||||
exec /usr/bin/gcc \$ARGS
|
exec /usr/bin/gcc \$ARGS
|
||||||
EOF
|
EOF
|
||||||
@ -74,25 +80,40 @@ chmod 0755 gcc
|
|||||||
CFLAGS="-ggdb $RPM_OPT_FLAGS -DNCURSES -DNCURSES_MOUSE_VERSION" ; export CFLAGS
|
CFLAGS="-ggdb $RPM_OPT_FLAGS -DNCURSES -DNCURSES_MOUSE_VERSION" ; export CFLAGS
|
||||||
CXXFLAGS="-ggdb $RPM_OPT_FLAGS -DNCURSES -DNCURSES_MOUSE_VERSION" ; export CXXFLAGS
|
CXXFLAGS="-ggdb $RPM_OPT_FLAGS -DNCURSES -DNCURSES_MOUSE_VERSION" ; export CXXFLAGS
|
||||||
if pkg-config openssl ; then
|
if pkg-config openssl ; then
|
||||||
CPPFLAGS=`pkg-config --cflags openssl` ; export CPPFLAGS
|
CPPFLAGS=`pkg-config --cflags openssl` ; export CPPFLAGS
|
||||||
LDFLAGS=`pkg-config --libs-only-L openssl` ; export LDFLAGS
|
LDFLAGS=`pkg-config --libs-only-L openssl` ; export LDFLAGS
|
||||||
fi
|
fi
|
||||||
%configure --libdir=/etc \
|
%configure --libdir=/etc \
|
||||||
--with-screen=ncursesw --enable-warnings \
|
--disable-font-switch \
|
||||||
--enable-default-colors --enable-externs \
|
--enable-addrlist-page \
|
||||||
--enable-internal-links --enable-nsl-fork \
|
--enable-charset-choice \
|
||||||
--enable-persistent-cookies --enable-prettysrc \
|
--enable-cgi-links \
|
||||||
--disable-font-switch --enable-source-cache \
|
--enable-cjk \
|
||||||
--enable-kbd-layout --with-zlib \
|
--enable-default-colors \
|
||||||
--enable-charset-choice --enable-file-upload \
|
--enable-externs \
|
||||||
--enable-cgi-links --enable-read-eta \
|
--enable-file-upload \
|
||||||
--enable-addrlist-page --enable-cjk \
|
--enable-internal-links \
|
||||||
--enable-justify-elts --enable-scrollbar \
|
--enable-ipv6 \
|
||||||
--enable-libjs --enable-cgi-links --enable-nls \
|
--enable-japanese-utf8 \
|
||||||
--enable-ipv6 \
|
--enable-justify-elts \
|
||||||
--enable-locale-charset \
|
--enable-locale-charset \
|
||||||
--enable-japanese-utf8 \
|
--enable-kbd-layout \
|
||||||
--with-ssl=%{_libdir}
|
--enable-libjs \
|
||||||
|
--enable-nls \
|
||||||
|
--enable-nsl-fork \
|
||||||
|
--enable-persistent-cookies \
|
||||||
|
--enable-prettysrc \
|
||||||
|
--enable-read-eta \
|
||||||
|
--enable-scrollbar \
|
||||||
|
--enable-source-cache \
|
||||||
|
--enable-warnings \
|
||||||
|
--with-screen=ncursesw \
|
||||||
|
--with-ssl=%{_libdir} \
|
||||||
|
--with-zlib
|
||||||
|
|
||||||
|
# uncomment to turn off optimizations
|
||||||
|
#find -name makefile | xargs sed -i 's/-O2/-O0/'
|
||||||
|
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
%install
|
%install
|
||||||
@ -124,6 +145,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%config(noreplace,missingok) %{_sysconfdir}/lynx-site.cfg
|
%config(noreplace,missingok) %{_sysconfdir}/lynx-site.cfg
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Apr 07 2010 Kamil Dudka <kdudka@redhat.com> - 2.8.7-3
|
||||||
|
- avoid build failure caused by mistakenly excluded <locale.h>
|
||||||
|
|
||||||
* Wed Jan 13 2010 Kamil Dudka <kdudka@redhat.com> - 2.8.7-2
|
* Wed Jan 13 2010 Kamil Dudka <kdudka@redhat.com> - 2.8.7-2
|
||||||
- make it possible to delete a bookmark when ~/lynx_bookmarks.html is writable
|
- make it possible to delete a bookmark when ~/lynx_bookmarks.html is writable
|
||||||
by group (#486070)
|
by group (#486070)
|
||||||
|
Loading…
Reference in New Issue
Block a user