rebase to latest upstream version
This commit is contained in:
parent
85c5aa3201
commit
4fc2b491a1
@ -13,7 +13,7 @@ index f01782f..ccc0846 100644
|
||||
--- a/lynx.cfg
|
||||
+++ b/lynx.cfg
|
||||
@@ -1,7 +1,9 @@
|
||||
# $LynxId: lynx.cfg,v 1.330 2023/01/02 23:50:09 tom Exp $
|
||||
# $LynxId: lynx.cfg,v 1.335 2024/01/15 11:31:00 tom Exp $
|
||||
# lynx.cfg file.
|
||||
-# The default placement for this file is /usr/local/lib/lynx.cfg (Unix)
|
||||
-# or Lynx_Dir:lynx.cfg (VMS)
|
||||
@ -22,8 +22,8 @@ index f01782f..ccc0846 100644
|
||||
+# Please don't edit this file directly (it is updated with every Red Hat
|
||||
+# Linux update, overwriting your changes). Instead, edit /etc/lynx-site.cfg.
|
||||
#
|
||||
# $Format: "#PRCS LYNX_VERSION \"$ProjectVersion$\""$
|
||||
#PRCS LYNX_VERSION "2.9.0dev.12"
|
||||
# LYNX_VERSION "2.9.0"
|
||||
# LYNX_DATE "15 Jan 2024"
|
||||
@@ -108,7 +110,7 @@
|
||||
#
|
||||
# Normally we expect you will connect to a remote site, e.g., the Lynx starting
|
||||
|
@ -1,20 +0,0 @@
|
||||
From e54344bd3252108c7c113ea773b3ae9a4e72b427 Mon Sep 17 00:00:00 2001
|
||||
From: "Thomas E. Dickey" <dickey@invisible-island.net>
|
||||
Date: Mon, 10 Apr 2023 22:59:30 +0000
|
||||
Subject: [PATCH] snapshot of project "lynx", label v2-9-0dev_12c
|
||||
|
||||
Cherry-picked to fix rhbz#2185402.
|
||||
|
||||
Upstream-commit: e54344bd3252108c7c113ea773b3ae9a4e72b427
|
||||
Signed-off-by: Lukáš Zaoral <lzaoral@redhat.com>
|
||||
|
||||
diff --git a/WWW/Library/Implementation/HTTCP.c b/WWW/Library/Implementation/HTTCP.c
|
||||
@@ -1494,7 +1494,7 @@ static size_t fill_addrinfo(void **buffer,
|
||||
CTRACE((tfp, "filladdr_info %p\n", (const void *) phost));
|
||||
for (q = phost; q != 0; q = q->ai_next) {
|
||||
++limit;
|
||||
- need += phost->ai_addrlen;
|
||||
+ need += q->ai_addrlen;
|
||||
need += sizeof(LYNX_ADDRINFO);
|
||||
}
|
||||
CTRACE((tfp, "...fill_addrinfo %d:%lu\n", limit, (unsigned long) need));
|
19
lynx.spec
19
lynx.spec
@ -1,13 +1,15 @@
|
||||
%global devrel dev.12
|
||||
#%%global devrel dev.12
|
||||
%global devrel %{nil}
|
||||
|
||||
Summary: A text-based Web browser
|
||||
Name: lynx
|
||||
Version: 2.9.0
|
||||
Release: %{devrel}.2%{?dist}
|
||||
#Release: %%{devrel}.1%%{?dist}
|
||||
Release: 1%{?dist}
|
||||
License: GPL-2.0-only
|
||||
|
||||
Source0: https://invisible-mirror.net/archives/lynx/tarballs/lynx%{version}%{devrel}.tar.bz2
|
||||
Source1: https://invisible-mirror.net/archives/lynx/tarballs/lynx%{version}%{devrel}.tar.bz2.asc
|
||||
Source0: https://invisible-island.net/archives/lynx/tarballs/lynx%{version}%{devrel}.tar.bz2
|
||||
Source1: https://invisible-island.net/archives/lynx/tarballs/lynx%{version}%{devrel}.tar.bz2.asc
|
||||
Source2: https://invisible-island.net/public/dickey@invisible-island.net-rsa3072.asc
|
||||
|
||||
URL: https://lynx.invisible-island.net/
|
||||
@ -24,9 +26,6 @@ Patch1: lynx-2.8.9-build.patch
|
||||
# [CVE-2008-4690]
|
||||
Patch2: lynx-CVE-2008-4690.patch
|
||||
|
||||
# lynx: memcpy(): lynx killed by SIGABRT
|
||||
Patch3: lynx-2.9.0dev.10-sigabrt-after-start.patch
|
||||
|
||||
Provides: webclient
|
||||
Provides: text-www-browser
|
||||
BuildRequires: dos2unix
|
||||
@ -64,9 +63,6 @@ sed -e 's,^STARTFILE:.*,STARTFILE:file:/usr/share/doc/HTML/en-US/index.html,' -i
|
||||
%endif
|
||||
|
||||
%build
|
||||
# Fix compilation on F40
|
||||
CFLAGS="-D_GNU_SOURCE $CFLAGS"
|
||||
|
||||
%configure --libdir=/etc \
|
||||
--disable-font-switch \
|
||||
--disable-rpath-hack \
|
||||
@ -136,6 +132,9 @@ EOF
|
||||
%config(noreplace,missingok) %{_sysconfdir}/lynx-site.cfg
|
||||
|
||||
%changelog
|
||||
* Tue Jan 16 2024 Lukáš Zaoral <lzaoral@redhat.com> - 2.9.0-1
|
||||
- rebase to latest upstream version
|
||||
|
||||
* Fri Oct 13 2023 Lukáš Zaoral <lzaoral@redhat.com> - 2.9.0-dev.12.2
|
||||
- fix FTBFS in Fedora Rawhide (rhbz#2243829)
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (lynx2.9.0dev.12.tar.bz2) = 9dd85d335a0b2c4c28f362cbcbe6499662696286fcc78e827bfafe2787d4a7fcd3faec78a115df8c14ea6e4314a5ea272f5b6353cb13224ecaebb61ae271701b
|
||||
SHA512 (lynx2.9.0dev.12.tar.bz2.asc) = fecfcbbf41f83285019a93b59d3ee38263aa0b8fc03914d41af1f9f3f77e1e376c8c686754d3e1a777d6aa853b4f3cfdca5d2a4ffa2ab3fe6ae4952e61a22e16
|
||||
SHA512 (lynx2.9.0.tar.bz2.asc) = f08e46bf960a54656045d0874a3dd9811511589147bfe764efce43f87eb62d4a3e448b31edad60a485fc51f57d27dc0b87aae9df2e4dce5fbd9dea2f776a8f5d
|
||||
SHA512 (lynx2.9.0.tar.bz2) = 4c716a246d80db0558dcdb6599bff9854a7356c43da94e0c854453e68b84e8de8a082c6c48e6329e8f4b6f70711ea41dad5a8f5669c782a8c9ce6351083b2df0
|
||||
|
Loading…
Reference in New Issue
Block a user