remove/update patches
This commit is contained in:
parent
327d49d5cb
commit
36265c0653
135
lynx-2.8.6-redhat.patch
Normal file
135
lynx-2.8.6-redhat.patch
Normal file
@ -0,0 +1,135 @@
|
|||||||
|
--- lynx2-8-6/userdefs.h.pom 2004-12-30 13:11:59.000000000 +0100
|
||||||
|
+++ lynx2-8-6/userdefs.h 2006-10-24 12:19:45.000000000 +0200
|
||||||
|
@@ -100,7 +100,7 @@
|
||||||
|
* mailcap files (see the examples in the samples directory).
|
||||||
|
*/
|
||||||
|
#ifndef LYNX_CFG_FILE
|
||||||
|
-#define LYNX_CFG_FILE "Lynx_Dir:lynx.cfg"
|
||||||
|
+#define LYNX_CFG_FILE "/etc/lynx.cfg"
|
||||||
|
#endif /* LYNX_CFG_FILE */
|
||||||
|
|
||||||
|
/**************************
|
||||||
|
@@ -110,8 +110,8 @@
|
||||||
|
* Mappings in these global and personal files override any SUFFIX
|
||||||
|
* definitions in lynx.cfg and built-in defaults from src/HTInit.c.
|
||||||
|
*/
|
||||||
|
-#define GLOBAL_EXTENSION_MAP "Lynx_Dir:mime.types"
|
||||||
|
-#define PERSONAL_EXTENSION_MAP "mime.types"
|
||||||
|
+#define GLOBAL_EXTENSION_MAP "/etc/mime.types"
|
||||||
|
+#define PERSONAL_EXTENSION_MAP ".mime.types"
|
||||||
|
|
||||||
|
/**************************
|
||||||
|
* The MAILCAP file allows you to map file MIME types to
|
||||||
|
@@ -120,7 +120,7 @@
|
||||||
|
* Mappings in these global and personal files override any VIEWER
|
||||||
|
* definitions in lynx.cfg and built-in defaults from src/HTInit.c.
|
||||||
|
*/
|
||||||
|
-#define GLOBAL_MAILCAP "Lynx_Dir:mailcap"
|
||||||
|
+#define GLOBAL_MAILCAP "/etc/mailcap"
|
||||||
|
#define PERSONAL_MAILCAP ".mailcap"
|
||||||
|
|
||||||
|
/**************************
|
||||||
|
@@ -284,7 +284,7 @@
|
||||||
|
#ifdef DOSPATH
|
||||||
|
#define LYNX_CFG_FILE "./lynx.cfg"
|
||||||
|
#else
|
||||||
|
-#define LYNX_CFG_FILE "/usr/local/lib/lynx.cfg"
|
||||||
|
+#define LYNX_CFG_FILE "/etc/lynx.cfg"
|
||||||
|
#endif /* DOSPATH */
|
||||||
|
#endif /* LYNX_CFG_FILE */
|
||||||
|
#endif /* HAVE_CONFIG_H */
|
||||||
|
@@ -296,7 +296,7 @@
|
||||||
|
* Mappings in these global and personal files override any SUFFIX
|
||||||
|
* definitions in lynx.cfg and built-in defaults from src/HTInit.c.
|
||||||
|
*/
|
||||||
|
-#define GLOBAL_EXTENSION_MAP "/usr/local/lib/mosaic/mime.types"
|
||||||
|
+#define GLOBAL_EXTENSION_MAP "/etc/mime.types"
|
||||||
|
#define PERSONAL_EXTENSION_MAP ".mime.types"
|
||||||
|
|
||||||
|
/**************************
|
||||||
|
@@ -306,7 +306,7 @@
|
||||||
|
* Mappings in these global and personal files override any VIEWER
|
||||||
|
* definitions in lynx.cfg and built-in defaults from src/HTInit.c.
|
||||||
|
*/
|
||||||
|
-#define GLOBAL_MAILCAP "/usr/local/lib/mosaic/mailcap"
|
||||||
|
+#define GLOBAL_MAILCAP "/etc/mailcap"
|
||||||
|
#define PERSONAL_MAILCAP ".mailcap"
|
||||||
|
|
||||||
|
/**************************
|
||||||
|
@@ -324,7 +324,7 @@
|
||||||
|
* use any default viewers for image types. Note that open is used as
|
||||||
|
* the default for NeXT, instead of the XLOADIMAGE_COMMAND definition.
|
||||||
|
*/
|
||||||
|
-#define XLOADIMAGE_COMMAND "xli %s &"
|
||||||
|
+#define XLOADIMAGE_COMMAND "display %s &"
|
||||||
|
|
||||||
|
/**************************
|
||||||
|
* For UNIX systems, SYSTEM_MAIL and SYSTEM_MAIL_FLAGS are set by the
|
||||||
|
@@ -345,7 +345,7 @@
|
||||||
|
* the "TMPDIR" (unix), or "TEMP" or "TMP" (Windows,DOS,OS/2)
|
||||||
|
* variable.
|
||||||
|
*/
|
||||||
|
-#define TEMP_SPACE "/tmp/"
|
||||||
|
+#define TEMP_SPACE "~"
|
||||||
|
|
||||||
|
/********************************
|
||||||
|
* Comment this line out to disable code that implements command logging
|
||||||
|
@@ -1134,7 +1134,7 @@
|
||||||
|
* OSU server distribution.
|
||||||
|
*/
|
||||||
|
#ifndef HAVE_CONFIG_H
|
||||||
|
-/* #define LYNXCGI_LINKS */
|
||||||
|
+#define LYNXCGI_LINKS
|
||||||
|
#endif
|
||||||
|
|
||||||
|
/*********************************
|
||||||
|
--- lynx2-8-6/lynx.cfg.pom 2006-10-24 12:11:37.000000000 +0200
|
||||||
|
+++ lynx2-8-6/lynx.cfg 2006-10-24 12:39:02.000000000 +0200
|
||||||
|
@@ -1,7 +1,10 @@
|
||||||
|
# lynx.cfg file.
|
||||||
|
-# The default placement for this file is /usr/local/lib/lynx.cfg (Unix)
|
||||||
|
+# The default placement for this file is /etc/lynx.cfg (Red Hat Linux, Fedora)
|
||||||
|
# or Lynx_Dir:lynx.cfg (VMS)
|
||||||
|
#
|
||||||
|
+# Please don't edit this file directly (it is updated with every Red Hat
|
||||||
|
+# Linux update, overwriting your changes). Instead, edit /etc/lynx-site.cfg.
|
||||||
|
+#
|
||||||
|
# $Format: "#PRCS LYNX_VERSION \"$ProjectVersion$\""$
|
||||||
|
#PRCS LYNX_VERSION "2.8.6rel.2"
|
||||||
|
#
|
||||||
|
@@ -92,7 +95,7 @@
|
||||||
|
#
|
||||||
|
# Normally we expect you will connect to a remote site, e.g., the Lynx starting
|
||||||
|
# site:
|
||||||
|
-STARTFILE:http://lynx.isc.org/
|
||||||
|
+STARTFILE:file:/usr/share/doc/HTML/index.html
|
||||||
|
#
|
||||||
|
# As an alternative, you may want to use a local URL. A good choice for this is
|
||||||
|
# the user's home directory:
|
||||||
|
@@ -396,7 +399,7 @@
|
||||||
|
# Lynx (case insensitive).
|
||||||
|
# Find RFC 1345 at http://www.ics.uci.edu/pub/ietf/uri/rfc1345.txt .
|
||||||
|
#
|
||||||
|
-#CHARACTER_SET:iso-8859-1
|
||||||
|
+CHARACTER_SET:utf-8
|
||||||
|
|
||||||
|
.h2 LOCALE_CHARSET
|
||||||
|
# LOCALE_CHARSET overrides CHARACTER_SET if true, using the current locale to
|
||||||
|
@@ -1776,6 +1779,9 @@
|
||||||
|
.ex
|
||||||
|
#DOWNLOADER:Save OS/390 binary file: iconv -f IBM-1047 -t ISO8859-1 %s >%s:FALSE
|
||||||
|
|
||||||
|
+# Added by Red Hat:
|
||||||
|
+DOWNLOADER:View with less:less %s:TRUE
|
||||||
|
+
|
||||||
|
|
||||||
|
.h1 Interaction
|
||||||
|
|
||||||
|
@@ -3366,6 +3372,7 @@
|
||||||
|
#ENABLE_LYNXRC:vi_keys:ON
|
||||||
|
#ENABLE_LYNXRC:visited_links:ON
|
||||||
|
.fi
|
||||||
|
+INCLUDE:/etc/lynx-site.cfg
|
||||||
|
|
||||||
|
.h1 External Programs
|
||||||
|
# Any of the compiled-in pathnames of external programs can be overridden
|
10
lynx.spec
10
lynx.spec
@ -4,12 +4,10 @@ Version: 2.8.6
|
|||||||
Release: 1
|
Release: 1
|
||||||
License: GPL
|
License: GPL
|
||||||
Group: Applications/Internet
|
Group: Applications/Internet
|
||||||
Source: http://lynx.isc.org/current/lynx2.8.5rel.1.tar.bz2
|
Source: http://lynx.isc.org/current/lynx%{version}.tar.bz2
|
||||||
URL: http://lynx.isc.org/
|
URL: http://lynx.isc.org/
|
||||||
Patch0: lynx-2.8.4-redhat.patch
|
Patch0: lynx-2.8.6-redhat.patch
|
||||||
Patch1: lynx-crash.patch
|
Patch1: lynx-crash.patch
|
||||||
Patch2: lynx-CAN-2005-3120.patch
|
|
||||||
Patch3: lynx-CVE-2005-2929.patch
|
|
||||||
Requires: indexhtml
|
Requires: indexhtml
|
||||||
Provides: webclient
|
Provides: webclient
|
||||||
BuildRequires: openssl-devel, pkgconfig, ncurses-devel >= 5.3-5,
|
BuildRequires: openssl-devel, pkgconfig, ncurses-devel >= 5.3-5,
|
||||||
@ -23,11 +21,9 @@ advantage Lynx has over graphical browsers is speed; Lynx starts and
|
|||||||
exits quickly and swiftly displays webpages.
|
exits quickly and swiftly displays webpages.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n lynx2-8-5
|
%setup -q -n lynx2-8-6
|
||||||
%patch0 -p1 -b .redhat
|
%patch0 -p1 -b .redhat
|
||||||
%patch1 -p1 -b .crash
|
%patch1 -p1 -b .crash
|
||||||
%patch2 -p1 -b .CAN-2005-3120
|
|
||||||
%patch3 -p1 -b .CVE-2005-2929
|
|
||||||
perl -pi -e "s,^HELPFILE:.*,HELPFILE:file://localhost/usr/share/doc/lynx-%{version}/lynx_help/lynx_help_main.html,g" lynx.cfg
|
perl -pi -e "s,^HELPFILE:.*,HELPFILE:file://localhost/usr/share/doc/lynx-%{version}/lynx_help/lynx_help_main.html,g" lynx.cfg
|
||||||
perl -pi -e "s,^DEFAULT_INDEX_FILE:.*,DEFAULT_INDEX_FILE:http://www.google.com/,g" lynx.cfg
|
perl -pi -e "s,^DEFAULT_INDEX_FILE:.*,DEFAULT_INDEX_FILE:http://www.google.com/,g" lynx.cfg
|
||||||
perl -pi -e 's,^#LOCALE_CHARSET:.*,LOCALE_CHARSET:TRUE,' lynx.cfg
|
perl -pi -e 's,^#LOCALE_CHARSET:.*,LOCALE_CHARSET:TRUE,' lynx.cfg
|
||||||
|
Loading…
Reference in New Issue
Block a user