move lua(abi) provide to -libs, add fix for bug 6
This commit is contained in:
parent
6bf1d36134
commit
ed24e54f3b
23
lua-5.3.4-bug6.patch
Normal file
23
lua-5.3.4-bug6.patch
Normal file
@ -0,0 +1,23 @@
|
||||
diff -up lua-5.3.4/src/lapi.c.bug6 lua-5.3.4/src/lapi.c
|
||||
--- lua-5.3.4/src/lapi.c.bug6 2018-02-13 10:18:59.386451581 -0500
|
||||
+++ lua-5.3.4/src/lapi.c 2018-02-13 10:19:42.700575448 -0500
|
||||
@@ -533,6 +533,7 @@ LUA_API void lua_pushcclosure (lua_State
|
||||
lua_lock(L);
|
||||
if (n == 0) {
|
||||
setfvalue(L->top, fn);
|
||||
+ api_incr_top(L);
|
||||
}
|
||||
else {
|
||||
CClosure *cl;
|
||||
@@ -546,9 +547,9 @@ LUA_API void lua_pushcclosure (lua_State
|
||||
/* does not need barrier because closure is white */
|
||||
}
|
||||
setclCvalue(L, L->top, cl);
|
||||
+ api_incr_top(L);
|
||||
+ luaC_checkGC(L);
|
||||
}
|
||||
- api_incr_top(L);
|
||||
- luaC_checkGC(L);
|
||||
lua_unlock(L);
|
||||
}
|
||||
|
10
lua.spec
10
lua.spec
@ -12,7 +12,7 @@
|
||||
|
||||
Name: lua
|
||||
Version: %{major_version}.4
|
||||
Release: 9%{?dist}
|
||||
Release: 10%{?dist}
|
||||
Summary: Powerful light-weight programming language
|
||||
Group: Development/Languages
|
||||
License: MIT
|
||||
@ -43,9 +43,9 @@ Patch8: %{name}-5.2.2-configure-compat-module.patch
|
||||
Patch9: lua-5.3.4-bug1.patch
|
||||
Patch10: lua-5.3.4-bug4.patch
|
||||
Patch11: lua-5.3.4-bug5.patch
|
||||
Patch12: lua-5.3.4-bug6.patch
|
||||
|
||||
BuildRequires: automake autoconf libtool readline-devel ncurses-devel
|
||||
Provides: lua(abi) = %{major_version}
|
||||
Requires: lua-libs = %{version}-%{release}
|
||||
|
||||
%description
|
||||
@ -69,6 +69,7 @@ This package contains development files for %{name}.
|
||||
|
||||
%package libs
|
||||
Summary: Libraries for %{name}
|
||||
Provides: lua(abi) = %{major_version}
|
||||
|
||||
%description libs
|
||||
This package contains the shared libraries for %{name}.
|
||||
@ -98,6 +99,7 @@ mv src/luaconf.h src/luaconf.h.template.in
|
||||
%patch9 -p1 -b .bug1
|
||||
%patch10 -p1 -b .bug4
|
||||
%patch11 -p1 -b .bug5
|
||||
%patch12 -p1 -b .bug6
|
||||
# Put proper version in configure.ac, patch0 hardcodes 5.3.0
|
||||
sed -i 's|5.3.0|%{version}|g' configure.ac
|
||||
autoreconf -ifv
|
||||
@ -220,6 +222,10 @@ install -Dpm 0644 %{SOURCE1000} $RPM_BUILD_ROOT/%{macrosdir}/macros.lua
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Feb 13 2018 Tom Callaway <spot@fedoraproject.org> - 5.3.4-10
|
||||
- move lua(abi) provide to -libs
|
||||
- add fix for bug 6
|
||||
|
||||
* Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 5.3.4-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user