- update to 0.32 final
This commit is contained in:
parent
8006386a1a
commit
3f8d19d03e
@ -1,34 +0,0 @@
|
|||||||
From db8d419ba39e4547de602ef1ff58cd97d5e1102d Mon Sep 17 00:00:00 2001
|
|
||||||
From: Tomas Bzatek <tbzatek@redhat.com>
|
|
||||||
Date: Wed, 11 Nov 2020 15:39:16 +0100
|
|
||||||
Subject: [PATCH] fix uninitialized variable
|
|
||||||
|
|
||||||
Error: UNINIT (CWE-457): [#def1]
|
|
||||||
lsscsi-032r164/src/lsscsi.c:3341: var_decl: Declaring variable "type" without initializer.
|
|
||||||
lsscsi-032r164/src/lsscsi.c:3586: uninit_use_in_call: Using uninitialized value "type" when calling "is_direct_access_dev".
|
|
||||||
3584| my_strcopy(blkdir, buff, sizeof(blkdir));
|
|
||||||
3585| value[0] = 0;
|
|
||||||
3586|-> if (! (is_direct_access_dev(type) &&
|
|
||||||
3587| block_scan(blkdir) &&
|
|
||||||
3588| if_directory_chdir(blkdir, ".") &&
|
|
||||||
---
|
|
||||||
src/lsscsi.c | 3 ++-
|
|
||||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/src/lsscsi.c b/src/lsscsi.c
|
|
||||||
index 6544153..8a30299 100644
|
|
||||||
--- a/src/lsscsi.c
|
|
||||||
+++ b/src/lsscsi.c
|
|
||||||
@@ -3338,7 +3338,8 @@ one_sdev_entry(const char * dir_name, const char * devname,
|
|
||||||
const struct lsscsi_opts * op)
|
|
||||||
{
|
|
||||||
bool get_wwn = false;
|
|
||||||
- int type, n, vlen;
|
|
||||||
+ int type = 0;
|
|
||||||
+ int n, vlen;
|
|
||||||
int devname_len = 13;
|
|
||||||
char buff[LMAX_DEVPATH];
|
|
||||||
char extra[LMAX_DEVPATH];
|
|
||||||
--
|
|
||||||
2.26.2
|
|
||||||
|
|
10
lsscsi.spec
10
lsscsi.spec
@ -1,14 +1,13 @@
|
|||||||
Summary: List SCSI devices (or hosts) and associated information
|
Summary: List SCSI devices (or hosts) and associated information
|
||||||
Name: lsscsi
|
Name: lsscsi
|
||||||
Version: 0.32
|
Version: 0.32
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
# official git repository: https://github.com/doug-gilbert/lsscsi
|
# official git repository: https://github.com/doug-gilbert/lsscsi
|
||||||
Source0: http://sg.danny.cz/scsi/%{name}-%{version}.tgz
|
Source0: http://sg.danny.cz/scsi/%{name}-%{version}.tgz
|
||||||
URL: http://sg.danny.cz/scsi/lsscsi.html
|
URL: http://sg.danny.cz/scsi/lsscsi.html
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: make
|
BuildRequires: make
|
||||||
Patch0: lsscsi-0.32-fix-uninitialized-variable.patch
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Uses information provided by the sysfs pseudo file system in Linux kernel
|
Uses information provided by the sysfs pseudo file system in Linux kernel
|
||||||
@ -22,7 +21,7 @@ Author:
|
|||||||
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%autosetup -p 1 -n %{name}-032r164
|
%autosetup -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure
|
%configure
|
||||||
@ -40,6 +39,9 @@ Author:
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri May 07 2021 Dan Horák <dan[at]danny.cz> - 0.32-3
|
||||||
|
- update to 0.32 final
|
||||||
|
|
||||||
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.32-2
|
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.32-2
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (lsscsi-0.32.tgz) = 8755e6bbdb8daaf6ab28a62c8b3a10e1f57b70590a0da03e9a8bc96954b17606444e7f5577af2b176aa06d89244d9a5dd3f91251694676ba1dac1543b3788fb9
|
SHA512 (lsscsi-0.32.tgz) = 96cb87be53eae9fa3a7defa0065f4dee8ccc23805a9ed1dc93d101c5e0610b78765b61449bf6ce58c13de8aae8400e4ac6a60ad64f840d092b9d7293106c5145
|
||||||
|
Loading…
Reference in New Issue
Block a user