fix OSH findings
Resolves: RHEL-43531
This commit is contained in:
parent
8e3490899e
commit
4632587ff4
10
lsof.spec
10
lsof.spec
@ -17,6 +17,7 @@ Source1: upstream2downstream.sh
|
||||
|
||||
# BZ#1260300 - move lsof man page to section 1
|
||||
Patch0: lsof-man-page-section.patch
|
||||
Patch1: osh-findigs.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: libselinux-devel
|
||||
@ -25,15 +26,14 @@ BuildRequires: groff-base
|
||||
BuildRequires: make
|
||||
BuildRequires: automake
|
||||
BuildRequires: autoconf
|
||||
BuildRequires: git
|
||||
|
||||
%description
|
||||
Lsof stands for LiSt Open Files, and it does just that: it lists information
|
||||
about files that are open by the processes running on a UNIX system.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{lsofrh}
|
||||
%autopatch -p1
|
||||
#%patch1 -p1
|
||||
%autosetup -n %{lsofrh} -S git
|
||||
|
||||
%build
|
||||
%configure
|
||||
@ -53,6 +53,10 @@ install -p -m 0644 lsof.1 ${RPM_BUILD_ROOT}%{_mandir}/man1/lsof.1
|
||||
%{_mandir}/man*/*
|
||||
|
||||
%changelog
|
||||
* Mon Jan 27 2025 Jan Rybar <jrybar@redhat.com> - 4.98.0-7
|
||||
- fix OSH findings
|
||||
- Resolves: RHEL-43531
|
||||
|
||||
* Tue Oct 29 2024 Troy Dawson <tdawson@redhat.com> - 4.98.0-6
|
||||
- Bump release for October 2024 mass rebuild:
|
||||
Resolves: RHEL-64018
|
||||
|
13
osh-findigs.patch
Normal file
13
osh-findigs.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff --git a/arg.c b/arg.c
|
||||
index cd3d5b1..6551e65 100644
|
||||
--- a/arg.c
|
||||
+++ b/arg.c
|
||||
@@ -1830,6 +1830,8 @@ enter_network_address(na)
|
||||
}
|
||||
if (sn)
|
||||
(void) free((FREE_P *)sn);
|
||||
+ if (hn)
|
||||
+ free (hn);
|
||||
return(0);
|
||||
}
|
||||
|
Loading…
Reference in New Issue
Block a user