B.02.18
This commit is contained in:
parent
57c8cecac8
commit
be3b1f21ef
1
.gitignore
vendored
1
.gitignore
vendored
@ -2,3 +2,4 @@ lshw-B.02.14.tar.gz
|
|||||||
/lshw-B.02.15.tar.gz
|
/lshw-B.02.15.tar.gz
|
||||||
/lshw-B.02.16.tar.gz
|
/lshw-B.02.16.tar.gz
|
||||||
/lshw-B.02.17.tar.gz
|
/lshw-B.02.17.tar.gz
|
||||||
|
/lshw-B.02.18.tar.gz
|
||||||
|
@ -1,20 +0,0 @@
|
|||||||
------------------------------------------------------------------------
|
|
||||||
r2528 | lyonel | 2013-08-24 18:12:05 +0200 (lø., 24 aug. 2013) | 2 lines
|
|
||||||
|
|
||||||
fix #632: ensure that FAT superblock is at least 1 sector long
|
|
||||||
|
|
||||||
|
|
||||||
Index: src/core/fat.cc
|
|
||||||
===================================================================
|
|
||||||
--- src/core/fat.cc (revisjon 2527)
|
|
||||||
+++ src/core/fat.cc (revisjon 2528)
|
|
||||||
@@ -81,6 +81,7 @@
|
|
||||||
uint8_t dummy2[164];
|
|
||||||
uint8_t pmagic[2];
|
|
||||||
} __attribute__((__packed__)) fat32;
|
|
||||||
+ char sector[512]; // to make sure the whole struct is at least 512 bytes long
|
|
||||||
} __attribute__((__packed__)) type;
|
|
||||||
} __attribute__((__packed__));
|
|
||||||
|
|
||||||
|
|
||||||
------------------------------------------------------------------------
|
|
67
lshw.spec
67
lshw.spec
@ -1,11 +1,7 @@
|
|||||||
%if 0%{?fedora} <= 18
|
|
||||||
%global vendortag 1
|
|
||||||
%endif
|
|
||||||
|
|
||||||
Summary: Hardware lister
|
Summary: Hardware lister
|
||||||
Name: lshw
|
Name: lshw
|
||||||
Version: B.02.17
|
Version: B.02.18
|
||||||
Release: 7%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
URL: http://ezix.org/project/wiki/HardwareLiSter
|
URL: http://ezix.org/project/wiki/HardwareLiSter
|
||||||
@ -13,16 +9,13 @@ Source0: http://www.ezix.org/software/files/lshw-%{version}.tar.gz
|
|||||||
Source1: lshw.desktop
|
Source1: lshw.desktop
|
||||||
Source2: org.ezix.lshw.gui.policy
|
Source2: org.ezix.lshw.gui.policy
|
||||||
Source3: lshw-gui
|
Source3: lshw-gui
|
||||||
Patch0: lshw-B.02.17-scan-fat-mem-bug.patch
|
|
||||||
BuildRequires: sqlite-devel
|
|
||||||
Requires: hwdata
|
Requires: hwdata
|
||||||
|
|
||||||
%description
|
%description
|
||||||
lshw is a small tool to provide detailed informaton on the hardware
|
lshw is a small tool to provide detailed informaton on the hardware
|
||||||
configuration of the machine. It can report exact memory configuration,
|
configuration of the machine. It can report exact memory
|
||||||
firmware version, mainboard configuration, CPU version and speed, cache
|
configuration, firmware version, mainboard configuration, CPU version
|
||||||
configuration, bus speed, etc. on DMI-capable x86 systems and on some
|
and speed, cache configuration, bus speed, etc. on DMI-capable x86
|
||||||
PowerPC machines (PowerMac G4 is known to work).
|
systems and on some PowerPC machines (PowerMac G4 is known to work).
|
||||||
|
|
||||||
Information can be output in plain text, XML or HTML.
|
Information can be output in plain text, XML or HTML.
|
||||||
|
|
||||||
@ -33,62 +26,58 @@ Requires: polkit
|
|||||||
Requires: %{name} = %{version}-%{release}
|
Requires: %{name} = %{version}-%{release}
|
||||||
BuildRequires: gtk2-devel >= 2.4
|
BuildRequires: gtk2-devel >= 2.4
|
||||||
BuildRequires: desktop-file-utils
|
BuildRequires: desktop-file-utils
|
||||||
|
|
||||||
%description gui
|
%description gui
|
||||||
Graphical frontend for the hardware lister (lshw) tool.
|
Graphical frontend for the hardware lister (lshw) tool. If desired,
|
||||||
If desired, hardware information can be saved to file in
|
hardware information can be saved to file in plain, XML or HTML
|
||||||
plain, XML or HTML format.
|
format.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p0
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%{__make} %{?_smp_mflags} SBINDIR="%{_sbindir}" RPM_OPT_FLAGS="%{optflags}" SQLITE=1 gui
|
make %{?_smp_mflags} SBINDIR="%{_sbindir}" RPM_OPT_FLAGS="%{optflags}" gui
|
||||||
|
|
||||||
# Replace copyrighted icons
|
# Replace copyrighted icons
|
||||||
pushd src
|
pushd src
|
||||||
%{__make} nologo
|
make nologo
|
||||||
|
|
||||||
%install
|
%install
|
||||||
%{__make} install \
|
make install \
|
||||||
DESTDIR="%{buildroot}" \
|
DESTDIR="%{buildroot}" \
|
||||||
PREFIX="%{_prefix}" \
|
PREFIX="%{_prefix}" \
|
||||||
SBINDIR="%{_sbindir}" \
|
SBINDIR="%{_sbindir}" \
|
||||||
MANDIR="%{_mandir}" \
|
MANDIR="%{_mandir}" \
|
||||||
SQLITE=1 \
|
|
||||||
STRIP="/bin/true" \
|
STRIP="/bin/true" \
|
||||||
INSTALL="%{__install} -p"
|
INSTALL="install -p"
|
||||||
|
|
||||||
%{__make} install-gui \
|
make install-gui \
|
||||||
DESTDIR="%{buildroot}" \
|
DESTDIR="%{buildroot}" \
|
||||||
PREFIX="%{_prefix}" \
|
PREFIX="%{_prefix}" \
|
||||||
SBINDIR="%{_sbindir}" \
|
SBINDIR="%{_sbindir}" \
|
||||||
MANDIR="%{_mandir}" \
|
MANDIR="%{_mandir}" \
|
||||||
SQLITE=1 \
|
|
||||||
STRIP="/bin/true" \
|
STRIP="/bin/true" \
|
||||||
INSTALL="%{__install} -p"
|
INSTALL="install -p"
|
||||||
|
|
||||||
%{__ln_s} -f gtk-lshw %{buildroot}%{_sbindir}/lshw-gui
|
ln -s -f gtk-lshw %{buildroot}%{_sbindir}/lshw-gui
|
||||||
|
|
||||||
# don't package these copies, use the ones from hwdata instead
|
# don't package these copies, use the ones from hwdata instead
|
||||||
%{__rm} -f %{buildroot}%{_datadir}/%{name}/pci.ids
|
rm -f %{buildroot}%{_datadir}/%{name}/pci.ids
|
||||||
%{__rm} -f %{buildroot}%{_datadir}/%{name}/usb.ids
|
rm -f %{buildroot}%{_datadir}/%{name}/usb.ids
|
||||||
# don't package these copies, they're not actually used by the app,
|
# don't package these copies, they're not actually used by the app,
|
||||||
# and even if they were, should use the hwdata versions
|
# and even if they were, should use the hwdata versions
|
||||||
%{__rm} -f %{buildroot}%{_datadir}/%{name}/oui.txt
|
rm -f %{buildroot}%{_datadir}/%{name}/oui.txt
|
||||||
%{__rm} -f %{buildroot}%{_datadir}/%{name}/manuf.txt
|
rm -f %{buildroot}%{_datadir}/%{name}/manuf.txt
|
||||||
|
|
||||||
# desktop icon
|
# desktop icon
|
||||||
%{__install} -D -m 0644 -p ./src/gui/artwork/logo.svg \
|
install -D -m 0644 -p ./src/gui/artwork/logo.svg \
|
||||||
%{buildroot}%{_datadir}/pixmaps/%{name}-logo.svg
|
%{buildroot}%{_datadir}/pixmaps/%{name}-logo.svg
|
||||||
desktop-file-install %{?vendortag:--vendor fedora} \
|
desktop-file-install %{?vendortag:--vendor fedora} \
|
||||||
--dir %{buildroot}%{_datadir}/applications %{SOURCE1}
|
--dir %{buildroot}%{_datadir}/applications %{SOURCE1}
|
||||||
|
|
||||||
# PolicyKit
|
# PolicyKit
|
||||||
%{__install} -D -m 0644 %{SOURCE2} \
|
install -D -m 0644 %{SOURCE2} \
|
||||||
%{buildroot}%{_datadir}/polkit-1/actions/org.ezix.lshw.gui.policy
|
%{buildroot}%{_datadir}/polkit-1/actions/org.ezix.lshw.gui.policy
|
||||||
%{__install} -D -m 0755 %{SOURCE3} %{buildroot}%{_bindir}/lshw-gui
|
install -D -m 0755 %{SOURCE3} %{buildroot}%{_bindir}/lshw-gui
|
||||||
|
|
||||||
# translations seems borken, remove for now
|
# translations seems borken, remove for now
|
||||||
#find_lang %{name}
|
#find_lang %{name}
|
||||||
@ -96,12 +85,13 @@ rm -rf %{buildroot}%{_datadir}/locale/fr/
|
|||||||
|
|
||||||
#files -f %{name}.lang
|
#files -f %{name}.lang
|
||||||
%files
|
%files
|
||||||
%doc COPYING README docs/*
|
%license COPYING
|
||||||
%doc %{_mandir}/man1/lshw.1*
|
%doc README.md
|
||||||
|
%{_mandir}/man1/lshw.1*
|
||||||
%{_sbindir}/%{name}
|
%{_sbindir}/%{name}
|
||||||
|
|
||||||
%files gui
|
%files gui
|
||||||
%doc COPYING
|
%license COPYING
|
||||||
%{_bindir}/%{name}-gui
|
%{_bindir}/%{name}-gui
|
||||||
%{_sbindir}/gtk-%{name}
|
%{_sbindir}/gtk-%{name}
|
||||||
%{_sbindir}/%{name}-gui
|
%{_sbindir}/%{name}-gui
|
||||||
@ -111,6 +101,9 @@ rm -rf %{buildroot}%{_datadir}/locale/fr/
|
|||||||
%{_datadir}/polkit-1/actions/org.ezix.lshw.gui.policy
|
%{_datadir}/polkit-1/actions/org.ezix.lshw.gui.policy
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Apr 25 2016 Terje Rosten <terje.rosten@ntnu.no> - B.02.18-1
|
||||||
|
- B.02.18
|
||||||
|
|
||||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - B.02.17-7
|
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - B.02.17-7
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user