Update to commit d05baa7
This commit is contained in:
parent
a5312cc759
commit
756c2fb9b5
63250
lshw-B.02.18-d05baa7.patch
Normal file
63250
lshw-B.02.18-d05baa7.patch
Normal file
File diff suppressed because it is too large
Load Diff
@ -1,13 +0,0 @@
|
||||
diff --git a/src/core/abi.cc b/src/core/abi.cc
|
||||
index 76e5082..76c664c 100644
|
||||
--- a/src/core/abi.cc
|
||||
+++ b/src/core/abi.cc
|
||||
@@ -20,7 +20,7 @@ __ID("@(#) $Id: mem.cc 1352 2006-05-27 23:54:13Z ezix $");
|
||||
bool scan_abi(hwNode & system)
|
||||
{
|
||||
// are we compiled as 32- or 64-bit process ?
|
||||
- system.setWidth(sysconf(LONG_BIT));
|
||||
+ system.setWidth(LONG_BIT);
|
||||
|
||||
pushd(PROC_SYS);
|
||||
|
@ -1,13 +0,0 @@
|
||||
diff --git a/src/core/dmi.cc b/src/core/dmi.cc
|
||||
index ced891a..e89ff93 100644
|
||||
--- a/src/core/dmi.cc
|
||||
+++ b/src/core/dmi.cc
|
||||
@@ -1833,6 +1833,8 @@ static bool scan_dmi_sysfs(hwNode & n)
|
||||
ifstream ep_stream(SYSFSDMI "/smbios_entry_point",
|
||||
ifstream::in | ifstream::binary | ifstream::ate);
|
||||
ifstream::pos_type ep_len = ep_stream.tellg();
|
||||
+ if (ep_len == -1)
|
||||
+ return false;
|
||||
vector < u8 > ep_buf(ep_len);
|
||||
ep_stream.seekg(0, ifstream::beg);
|
||||
ep_stream.read((char *)ep_buf.data(), ep_len);
|
11
lshw.spec
11
lshw.spec
@ -1,7 +1,7 @@
|
||||
Summary: Hardware lister
|
||||
Name: lshw
|
||||
Version: B.02.18
|
||||
Release: 11%{?dist}
|
||||
Release: 12%{?dist}
|
||||
License: GPLv2
|
||||
Group: Applications/System
|
||||
URL: http://ezix.org/project/wiki/HardwareLiSter
|
||||
@ -10,9 +10,8 @@ Source1: lshw-gui.desktop
|
||||
Source2: org.ezix.lshw.gui.policy
|
||||
Source3: lshw-gui
|
||||
Source4: lshw-gui.appdata.xml
|
||||
Patch1: lshw-B.02.18-non-root.patch
|
||||
Patch2: lshw-B.02.18-long-bit.patch
|
||||
Patch3: lshw-B.02.18-scandir.patch
|
||||
Patch1: lshw-B.02.18-scandir.patch
|
||||
Patch2: lshw-B.02.18-d05baa7.patch
|
||||
BuildRequires: gtk2-devel >= 2.4
|
||||
BuildRequires: desktop-file-utils
|
||||
BuildRequires: libappstream-glib
|
||||
@ -40,7 +39,6 @@ format.
|
||||
%setup -q
|
||||
%patch01 -p1
|
||||
%patch02 -p1
|
||||
%patch03 -p1
|
||||
|
||||
%build
|
||||
make %{?_smp_mflags} SBINDIR="%{_sbindir}" RPM_OPT_FLAGS="%{optflags}" gui
|
||||
@ -121,6 +119,9 @@ appstream-util validate-relax --nonet %{buildroot}/%{_datadir}/appdata/*.appdata
|
||||
%{_datadir}/polkit-1/actions/org.ezix.lshw.gui.policy
|
||||
|
||||
%changelog
|
||||
* Sat Jan 26 2018 Terje Rosten <terje.rosten@ntnu.no> - B.02.18-12
|
||||
- Update to commit d05baa7
|
||||
|
||||
* Mon Aug 28 2017 Terje Rosten <terje.rosten@ntnu.no> - B.02.18-11
|
||||
- Prefer lshw-gui in lshw-gui context
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user