- Update Copyright year to 2018 in Sphinx docs (bcl@redhat.com)
- Add links to documentation for previous versions (bcl@redhat.com) - make docs now also builds html (bcl@redhat.com) - Update default releasever to Fedora 29 (rawhide) (jkonecny@redhat.com)
This commit is contained in:
parent
b9d3f8f973
commit
f80078fb42
1
.gitignore
vendored
1
.gitignore
vendored
@ -124,3 +124,4 @@
|
||||
/lorax-28.6.tar.gz
|
||||
/lorax-28.7.tar.gz
|
||||
/lorax-28.8.tar.gz
|
||||
/lorax-29.0.tar.gz
|
||||
|
@ -1,30 +0,0 @@
|
||||
From 4b16d267f20555cdc45df36ee6eb2fa737bfc587 Mon Sep 17 00:00:00 2001
|
||||
From: Adam Williamson <awilliam@redhat.com>
|
||||
Date: Tue, 27 Feb 2018 15:19:44 -0800
|
||||
Subject: [PATCH] Log a bit more around disk image file creation
|
||||
|
||||
Signed-off-by: Adam Williamson <awilliam@redhat.com>
|
||||
---
|
||||
src/pylorax/imgutils.py | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/src/pylorax/imgutils.py b/src/pylorax/imgutils.py
|
||||
index af53490..d1d7f84 100644
|
||||
--- a/src/pylorax/imgutils.py
|
||||
+++ b/src/pylorax/imgutils.py
|
||||
@@ -324,8 +324,12 @@ class LoopDev(object):
|
||||
def __init__(self, filename, size=None):
|
||||
self.loopdev = None
|
||||
self.filename = filename
|
||||
+ exists = os.path.exists(filename)
|
||||
+ logger.debug("LoopDev before mksparse: filename %s, exists %s, size %s", filename, exists, size)
|
||||
if size:
|
||||
mksparse(self.filename, size)
|
||||
+ exists = os.path.exists(filename)
|
||||
+ logger.debug("LoopDev after mksparse: filename %s, exists %s, size %s", filename, exists, size)
|
||||
def __enter__(self):
|
||||
self.loopdev = loop_attach(self.filename)
|
||||
return self.loopdev
|
||||
--
|
||||
2.16.1
|
||||
|
14
lorax.spec
14
lorax.spec
@ -3,8 +3,8 @@
|
||||
%define debug_package %{nil}
|
||||
|
||||
Name: lorax
|
||||
Version: 28.8
|
||||
Release: 2%{?dist}
|
||||
Version: 29.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Tool for creating the anaconda install images
|
||||
|
||||
Group: Applications/System
|
||||
@ -15,8 +15,6 @@ URL: https://github.com/rhinstaller/lorax
|
||||
# git checkout -b archive-branch lorax-%%{version}-%%{release}
|
||||
# tito build --tgz
|
||||
Source0: %{name}-%{version}.tar.gz
|
||||
# Add some logging to try and investigate https://pagure.io/releng/issue/7355
|
||||
Patch0: 0001-Log-a-bit-more-around-disk-image-file-creation.patch
|
||||
|
||||
BuildRequires: python3-devel
|
||||
|
||||
@ -123,7 +121,6 @@ Lorax templates for creating the boot.iso and live isos are placed in
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
|
||||
@ -158,8 +155,11 @@ make DESTDIR=$RPM_BUILD_ROOT mandir=%{_mandir} install
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Feb 27 2018 Adam Williamson <awilliam@redhat.com> - 28.8-2
|
||||
- Add a logging patch to investigate compose failures (releng #7355)
|
||||
* Thu Mar 15 2018 Brian C. Lane <bcl@redhat.com> 29.0-1
|
||||
- Update Copyright year to 2018 in Sphinx docs (bcl@redhat.com)
|
||||
- Add links to documentation for previous versions (bcl@redhat.com)
|
||||
- make docs now also builds html (bcl@redhat.com)
|
||||
- Update default releasever to Fedora 29 (rawhide) (jkonecny@redhat.com)
|
||||
|
||||
* Mon Feb 26 2018 Brian C. Lane <bcl@redhat.com> 28.8-1
|
||||
- cleanup: don't remove libgstgl (dusty@dustymabe.com)
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (lorax-28.8.tar.gz) = 0d2ee0306968f78ee183c0bb1fdc407d7b1500ff726085d1b02a79880cc25c139d9ac85664c86d0c1cdaa02fc2bcfe709520023763693cb839520360edf17d9f
|
||||
SHA512 (lorax-29.0.tar.gz) = 50faeb7a532cc79240abe6378ddfb8287a9ee62ce3921f9b99f030290c1fed4414abb93177f4a295ca20e5c92127933747d61985a58b8bb360d84cd7f8b41327
|
||||
|
Loading…
Reference in New Issue
Block a user