- Remove patches included in this release
- Add testing of the new mkksiso --updates command to run_tests.sh - mkksiso: Add support for adding an anaconda updates.img (jkonecny@redhat.com) - runtime-install: drop kdump-anaconda-addon (awilliam@redhat.com) - ltmpl: Handle installing provides with resolve_pkg_spec (bcl@redhat.com) - s390: Escape volid before using it (bcl@redhat.com) - aarch64: Escape volid before using it (bcl@redhat.com) - runtime-install: drop retired pcmciautils (awilliam@redhat.com) - runtime-install: wget2-wget has replaced wget (awilliam@redhat.com) - runtime-cleanup: anaconda's new interface needs stdbuf (kkoukiou@redhat.com) - ltmpl: Pass packages to add_rpm_install as strings (bcl@redhat.com)
This commit is contained in:
parent
cae9bc7940
commit
f383438923
1
.gitignore
vendored
1
.gitignore
vendored
@ -239,3 +239,4 @@
|
|||||||
/lorax-40.1.tar.gz
|
/lorax-40.1.tar.gz
|
||||||
/lorax-40.2.tar.gz
|
/lorax-40.2.tar.gz
|
||||||
/lorax-40.3.tar.gz
|
/lorax-40.3.tar.gz
|
||||||
|
/lorax-40.4.tar.gz
|
||||||
|
@ -1,30 +0,0 @@
|
|||||||
From de364416f3034d5e6382de5453facd0032a760c1 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Adam Williamson <awilliam@redhat.com>
|
|
||||||
Date: Mon, 29 Jan 2024 09:41:43 -0800
|
|
||||||
Subject: [PATCH] runtime-install: drop retired pcmciautils
|
|
||||||
|
|
||||||
pcmciautils was just retired in Rawhide:
|
|
||||||
https://src.fedoraproject.org/rpms/pcmciautils/c/24639b0
|
|
||||||
|
|
||||||
Signed-off-by: Adam Williamson <awilliam@redhat.com>
|
|
||||||
---
|
|
||||||
share/templates.d/99-generic/runtime-install.tmpl | 3 ---
|
|
||||||
1 file changed, 3 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/share/templates.d/99-generic/runtime-install.tmpl b/share/templates.d/99-generic/runtime-install.tmpl
|
|
||||||
index d6029830..904c42ba 100644
|
|
||||||
--- a/share/templates.d/99-generic/runtime-install.tmpl
|
|
||||||
+++ b/share/templates.d/99-generic/runtime-install.tmpl
|
|
||||||
@@ -141,9 +141,6 @@ installpkg nmap-ncat
|
|
||||||
installpkg pciutils usbutils ipmitool
|
|
||||||
installpkg mt-st smartmontools
|
|
||||||
installpkg hdparm
|
|
||||||
-%if basearch not in ("aarch64", "ppc64le", "s390x"):
|
|
||||||
-installpkg pcmciautils
|
|
||||||
-%endif
|
|
||||||
installpkg rdma-core
|
|
||||||
installpkg rng-tools
|
|
||||||
%if basearch in ("x86_64", "aarch64"):
|
|
||||||
--
|
|
||||||
2.43.0
|
|
||||||
|
|
@ -1,31 +0,0 @@
|
|||||||
From 0476a77915f678846f446f819c5fec66f2997386 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Adam Williamson <awilliam@redhat.com>
|
|
||||||
Date: Fri, 26 Jan 2024 11:19:59 -0800
|
|
||||||
Subject: [PATCH] runtime-install: wget2-wget has replaced wget
|
|
||||||
|
|
||||||
wget has been retired:
|
|
||||||
https://src.fedoraproject.org/rpms/wget/c/ce69c17
|
|
||||||
in favor of wget2-wget:
|
|
||||||
https://fedoraproject.org/wiki/Changes/Wget2asWget
|
|
||||||
|
|
||||||
Signed-off-by: Adam Williamson <awilliam@redhat.com>
|
|
||||||
---
|
|
||||||
share/templates.d/99-generic/runtime-install.tmpl | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/share/templates.d/99-generic/runtime-install.tmpl b/share/templates.d/99-generic/runtime-install.tmpl
|
|
||||||
index d6029830..80213366 100644
|
|
||||||
--- a/share/templates.d/99-generic/runtime-install.tmpl
|
|
||||||
+++ b/share/templates.d/99-generic/runtime-install.tmpl
|
|
||||||
@@ -184,7 +184,7 @@ installpkg python3-pyatspi
|
|
||||||
## extra tools not required by anaconda
|
|
||||||
installpkg nano nano-default-editor
|
|
||||||
installpkg vim-minimal strace lsof dump xz less
|
|
||||||
-installpkg wget rsync bind-utils ftp mtr vconfig
|
|
||||||
+installpkg wget2-wget rsync bind-utils ftp mtr vconfig
|
|
||||||
installpkg spice-vdagent
|
|
||||||
installpkg gdisk hexedit sg3_utils
|
|
||||||
|
|
||||||
--
|
|
||||||
2.43.0
|
|
||||||
|
|
32
lorax.spec
32
lorax.spec
@ -3,8 +3,8 @@
|
|||||||
%define debug_package %{nil}
|
%define debug_package %{nil}
|
||||||
|
|
||||||
Name: lorax
|
Name: lorax
|
||||||
Version: 40.3
|
Version: 40.4
|
||||||
Release: 5%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Tool for creating the anaconda install images
|
Summary: Tool for creating the anaconda install images
|
||||||
|
|
||||||
License: GPL-2.0-or-later
|
License: GPL-2.0-or-later
|
||||||
@ -15,13 +15,6 @@ URL: https://github.com/weldr/lorax
|
|||||||
# tito build --tgz
|
# tito build --tgz
|
||||||
Source0: %{name}-%{version}.tar.gz
|
Source0: %{name}-%{version}.tar.gz
|
||||||
|
|
||||||
# https://github.com/weldr/lorax/pull/1370
|
|
||||||
# wget replaced by wget2-wget
|
|
||||||
Patch: 0001-runtime-install-wget2-wget-has-replaced-wget.patch
|
|
||||||
# https://github.com/weldr/lorax/pull/1371
|
|
||||||
# pcmciautils retired
|
|
||||||
Patch: 0001-runtime-install-drop-retired-pcmciautils.patch
|
|
||||||
|
|
||||||
BuildRequires: python3-devel
|
BuildRequires: python3-devel
|
||||||
BuildRequires: python3-setuptools
|
BuildRequires: python3-setuptools
|
||||||
BuildRequires: make
|
BuildRequires: make
|
||||||
@ -175,17 +168,16 @@ make DESTDIR=$RPM_BUILD_ROOT mandir=%{_mandir} install
|
|||||||
%{_datadir}/lorax/templates.d/*
|
%{_datadir}/lorax/templates.d/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Mon Jan 29 2024 Adam Williamson <awilliam@redhat.com> - 40.3-5
|
* Thu Feb 01 2024 Brian C. Lane <bcl@redhat.com> 40.4-1
|
||||||
- Backport PR #1371 to handle pcmciautils being retired
|
- mkksiso: Add support for adding an anaconda updates.img (jkonecny@redhat.com)
|
||||||
|
- runtime-install: drop kdump-anaconda-addon (awilliam@redhat.com)
|
||||||
* Fri Jan 26 2024 Adam Williamson <awilliam@redhat.com> - 40.3-4
|
- ltmpl: Handle installing provides with resolve_pkg_spec (bcl@redhat.com)
|
||||||
- Backport PR #1370 to handle wget being replaced by wget2-wget
|
- s390: Escape volid before using it (bcl@redhat.com)
|
||||||
|
- aarch64: Escape volid before using it (bcl@redhat.com)
|
||||||
* Thu Jan 25 2024 Fedora Release Engineering <releng@fedoraproject.org> - 40.3-3
|
- runtime-install: drop retired pcmciautils (awilliam@redhat.com)
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
- runtime-install: wget2-wget has replaced wget (awilliam@redhat.com)
|
||||||
|
- runtime-cleanup: anaconda's new interface needs stdbuf (kkoukiou@redhat.com)
|
||||||
* Sun Jan 21 2024 Fedora Release Engineering <releng@fedoraproject.org> - 40.3-2
|
- ltmpl: Pass packages to add_rpm_install as strings (bcl@redhat.com)
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
|
||||||
|
|
||||||
* Wed Dec 20 2023 Brian C. Lane <bcl@redhat.com> 40.3-1
|
* Wed Dec 20 2023 Brian C. Lane <bcl@redhat.com> 40.3-1
|
||||||
- runtime-install: Work around problem with conflicting packages (bcl@redhat.com)
|
- runtime-install: Work around problem with conflicting packages (bcl@redhat.com)
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (lorax-40.3.tar.gz) = 169748add00cf2a4644abdf3b7157af3fbe30b0058c36b6746eb347737947e3e4faf93048a43e97c5f9c3243bb08144eb360214d36d3429d67da985df11993e8
|
SHA512 (lorax-40.4.tar.gz) = 65ac3451123b869d649c3b788b9ec0b2560052e553c969c5228fe42969beb8685678501ce9b7df57a6263dc0f1e90fb0a69f9e689c1ea86fd7588c19a322a6e2
|
||||||
|
@ -177,22 +177,42 @@ function test_two_kickstarts {
|
|||||||
status "Test two kickstart error"
|
status "Test two kickstart error"
|
||||||
}
|
}
|
||||||
|
|
||||||
|
|
||||||
function test_files {
|
function test_files {
|
||||||
[ -e "$ISODIR/services" ] || fail "Missing file from iso"
|
[ -e "$ISODIR/services" ] || fail "Missing file from iso"
|
||||||
}
|
}
|
||||||
|
|
||||||
|
# Test adding an updates.img file
|
||||||
|
function add_updatesimg {
|
||||||
|
running "Add updates.img"
|
||||||
|
|
||||||
|
# nothing in the file, just test that it is there
|
||||||
|
touch /tmp/test-updates.img
|
||||||
|
mkksiso -u /tmp/test-updates.img $BOOTISO $OUTISO || exit 1
|
||||||
|
mount $OUTISO $ISODIR || exit 1
|
||||||
|
|
||||||
|
test_updatesimg
|
||||||
|
|
||||||
|
status "Add updates.img"
|
||||||
|
umount_dirs
|
||||||
|
}
|
||||||
|
|
||||||
|
function test_updatesimg {
|
||||||
|
[ -e "$ISODIR/updates/updates.img" ] || fail "Missing file from iso"
|
||||||
|
}
|
||||||
|
|
||||||
# All of the changes
|
# All of the changes
|
||||||
function run_all {
|
function run_all {
|
||||||
running "Use all the options"
|
running "Use all the options"
|
||||||
|
|
||||||
mkksiso -a /etc/services -V "mkksiso-test" -c "console=ttyS0,115200n8" --rm "quiet" --ks $KS $BOOTISO $OUTISO || exit 1
|
touch /tmp/test-updates.img
|
||||||
|
mkksiso -u /tmp/test-updates.img -a /etc/services -V "mkksiso-test" -c "console=ttyS0,115200n8" --rm "quiet" --ks $KS $BOOTISO $OUTISO || exit 1
|
||||||
mount $OUTISO $ISODIR || exit 1
|
mount $OUTISO $ISODIR || exit 1
|
||||||
|
|
||||||
test_ks
|
test_ks
|
||||||
test_serial
|
test_serial
|
||||||
test_volid
|
test_volid
|
||||||
test_files
|
test_files
|
||||||
|
test_updatesimg
|
||||||
test_quiet
|
test_quiet
|
||||||
|
|
||||||
status "Use all the options"
|
status "Use all the options"
|
||||||
@ -204,13 +224,15 @@ function run_as_user {
|
|||||||
running "Use all the options as a user"
|
running "Use all the options as a user"
|
||||||
|
|
||||||
[ ! -e "/home/lorax-ted" ] && useradd -m lorax-ted
|
[ ! -e "/home/lorax-ted" ] && useradd -m lorax-ted
|
||||||
su - lorax-ted -c "mkksiso --skip-mkefiboot -a /etc/services -V "mkksiso-test" -c "console=ttyS0,115200n8" --rm "quiet" --ks $KS $BOOTISO $OUTISO" || exit 1
|
touch /tmp/test-updates.img
|
||||||
|
su - lorax-ted -c "mkksiso --skip-mkefiboot -u /tmp/test-updates.img -a /etc/services -V "mkksiso-test" -c "console=ttyS0,115200n8" --rm "quiet" --ks $KS $BOOTISO $OUTISO" || exit 1
|
||||||
mount $OUTISO $ISODIR || exit 1
|
mount $OUTISO $ISODIR || exit 1
|
||||||
|
|
||||||
test_ks
|
test_ks
|
||||||
test_serial
|
test_serial
|
||||||
test_volid
|
test_volid
|
||||||
test_files
|
test_files
|
||||||
|
test_updatesimg
|
||||||
test_quiet
|
test_quiet
|
||||||
|
|
||||||
status "Use all the options as a user with --skip-mkefiboot"
|
status "Use all the options as a user with --skip-mkefiboot"
|
||||||
@ -243,6 +265,7 @@ new_volid
|
|||||||
add_files
|
add_files
|
||||||
remove_quiet
|
remove_quiet
|
||||||
test_two_kickstarts
|
test_two_kickstarts
|
||||||
|
add_updatesimg
|
||||||
run_all
|
run_all
|
||||||
run_as_user
|
run_as_user
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user