- Drop patches included in new upstream tar
- Explicitly pull in more filesystem packages (awilliam@redhat.com) - runtime-postinstall: Turn off lvm monitoring (bcl@redhat.com) - runtime-cleanup.tmpl: fix typo 'gschadow' (chris.riches@nutanix.com) - runtime-cleanup: Change how logo pixmaps is cleaned up (bcl@redhat.com) - runtime-install: only pull in qcom-firmware on aarch64 (awilliam@redhat.com)
This commit is contained in:
parent
c2cce0630e
commit
d8facf9fcb
1
.gitignore
vendored
1
.gitignore
vendored
@ -234,3 +234,4 @@
|
||||
/lorax-39.2.tar.gz
|
||||
/lorax-39.3.tar.gz
|
||||
/lorax-39.4.tar.gz
|
||||
/lorax-39.5.tar.gz
|
||||
|
@ -1,38 +0,0 @@
|
||||
From cce0772ac2807f85b6dbe53f5af86718cc3017e3 Mon Sep 17 00:00:00 2001
|
||||
From: Adam Williamson <awilliam@redhat.com>
|
||||
Date: Thu, 7 Sep 2023 12:04:54 -0700
|
||||
Subject: [PATCH] Explicitly pull in more filesystem packages
|
||||
|
||||
Turns out we've been relying on udisks2 dependencies to pull in
|
||||
several filesystem tools packages that anaconda actually needs
|
||||
to create and read supported filesystems. udisks2 just changed
|
||||
all those dependencies to Recommends, which don't get pulled
|
||||
into the installer environment. So we need lorax to specifically
|
||||
list all of these. e2fsprogs was already being pulled in through
|
||||
some other dep chain, but let's explicitly list it just to make
|
||||
sure we don't hit the same problem in future. From a look through
|
||||
the blivet code, I don't think pulling in udftools, exfatprogs
|
||||
or nilfs-utils will be useful, but we can check that with
|
||||
@vojtechtrefny .
|
||||
|
||||
Signed-off-by: Adam Williamson <awilliam@redhat.com>
|
||||
---
|
||||
share/templates.d/99-generic/runtime-install.tmpl | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/share/templates.d/99-generic/runtime-install.tmpl b/share/templates.d/99-generic/runtime-install.tmpl
|
||||
index 93b76fb4..38b1d0cd 100644
|
||||
--- a/share/templates.d/99-generic/runtime-install.tmpl
|
||||
+++ b/share/templates.d/99-generic/runtime-install.tmpl
|
||||
@@ -118,7 +118,7 @@ installpkg systemd-sysv systemd-units
|
||||
installpkg rsyslog
|
||||
|
||||
## filesystem tools
|
||||
-installpkg btrfs-progs jfsutils xfsprogs ntfs-3g ntfsprogs
|
||||
+installpkg btrfs-progs jfsutils xfsprogs ntfs-3g ntfsprogs dosfstools e2fsprogs f2fs-tools
|
||||
installpkg system-storage-manager
|
||||
installpkg device-mapper-persistent-data
|
||||
installpkg xfsdump
|
||||
--
|
||||
2.41.0
|
||||
|
@ -1,47 +0,0 @@
|
||||
From ecd5934d942b36733c9dcc44d5ba98aba2a1a526 Mon Sep 17 00:00:00 2001
|
||||
From: Adam Williamson <awilliam@redhat.com>
|
||||
Date: Fri, 11 Aug 2023 09:39:20 -0700
|
||||
Subject: [PATCH] runtime-install: only pull in qcom-firmware on aarch64
|
||||
|
||||
See https://bugzilla.redhat.com/show_bug.cgi?id=2178852 . This
|
||||
should save a chunk of space on the installer images for x86_64.
|
||||
|
||||
Signed-off-by: Adam Williamson <awilliam@redhat.com>
|
||||
---
|
||||
share/templates.d/99-generic/runtime-install.tmpl | 6 +++++-
|
||||
1 file changed, 5 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/share/templates.d/99-generic/runtime-install.tmpl b/share/templates.d/99-generic/runtime-install.tmpl
|
||||
index 0ae8bb53..93b76fb4 100644
|
||||
--- a/share/templates.d/99-generic/runtime-install.tmpl
|
||||
+++ b/share/templates.d/99-generic/runtime-install.tmpl
|
||||
@@ -28,6 +28,8 @@ installpkg grubby
|
||||
## https://bugzilla.redhat.com/show_bug.cgi?id=2011615
|
||||
## bfa-firmware contains only obsolete files - see
|
||||
## https://bugzilla.redhat.com/show_bug.cgi?id=2152202
|
||||
+ ## qcom-firmware we pull in again lower down but *only* on aarch64, it is
|
||||
+ ## no use on other arches - https://bugzilla.redhat.com/show_bug.cgi?id=2178852
|
||||
## various iwl package names were changed in linux-firmware-20230625-151
|
||||
## so need to be excluded or else dnf gets sad - see
|
||||
## https://pagure.io/releng/issue/11511 . These exclusions can
|
||||
@@ -53,7 +55,8 @@ installpkg grubby
|
||||
--except iwlax2xx-firmware \
|
||||
--except libertas-sd8686-firmware --except libertas-sd8787-firmware \
|
||||
--except libertas-usb8388-firmware \
|
||||
- --except libertas-usb8388-olpc-firmware
|
||||
+ --except libertas-usb8388-olpc-firmware \
|
||||
+ --except qcom-firmware
|
||||
installpkg b43-openfwwf
|
||||
%endif
|
||||
|
||||
@@ -67,6 +70,7 @@ installpkg glibc-all-langpacks
|
||||
installpkg grub2-tools>=${GRUB2VER}
|
||||
installpkg shim-aa64
|
||||
installpkg uboot-tools
|
||||
+ installpkg qcom-firmware
|
||||
%endif
|
||||
%if basearch == "x86_64":
|
||||
installpkg grub2-tools-efi>=${GRUB2VER}
|
||||
--
|
||||
2.41.0
|
||||
|
23
lorax.spec
23
lorax.spec
@ -3,8 +3,8 @@
|
||||
%define debug_package %{nil}
|
||||
|
||||
Name: lorax
|
||||
Version: 39.4
|
||||
Release: 3%{?dist}
|
||||
Version: 39.5
|
||||
Release: 1%{?dist}
|
||||
Summary: Tool for creating the anaconda install images
|
||||
|
||||
License: GPL-2.0-or-later
|
||||
@ -14,14 +14,6 @@ URL: https://github.com/weldr/lorax
|
||||
# git checkout -b archive-branch lorax-%%{version}-%%{release}
|
||||
# tito build --tgz
|
||||
Source0: %{name}-%{version}.tar.gz
|
||||
# https://github.com/weldr/lorax/pull/1338
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=2231605
|
||||
# cut qcom firmwares from x86_64 installer images to save space
|
||||
Patch0: 0001-runtime-install-only-pull-in-qcom-firmware-on-aarch6.patch
|
||||
# https://github.com/weldr/lorax/pull/1344
|
||||
# pull in filesystem tools packages we previously relied on udisks2
|
||||
# to pull in
|
||||
Patch1: 0001-Explicitly-pull-in-more-filesystem-packages.patch
|
||||
|
||||
BuildRequires: python3-devel
|
||||
BuildRequires: python3-setuptools
|
||||
@ -176,11 +168,12 @@ make DESTDIR=$RPM_BUILD_ROOT mandir=%{_mandir} install
|
||||
%{_datadir}/lorax/templates.d/*
|
||||
|
||||
%changelog
|
||||
* Thu Sep 07 2023 Adam Williamson <awilliam@redhat.com> - 39.4-3
|
||||
- Backport PR #1344 to pull in required filesystem packages
|
||||
|
||||
* Mon Aug 28 2023 Adam Williamson <awilliam@redhat.com> - 39.4-2
|
||||
- Backport PR #1338 to cut qcom firmwares and save space
|
||||
* Thu Sep 07 2023 Brian C. Lane <bcl@redhat.com> 39.5-1
|
||||
- Explicitly pull in more filesystem packages (awilliam@redhat.com)
|
||||
- runtime-postinstall: Turn off lvm monitoring (bcl@redhat.com)
|
||||
- runtime-cleanup.tmpl: fix typo 'gschadow' (chris.riches@nutanix.com)
|
||||
- runtime-cleanup: Change how logo pixmaps is cleaned up (bcl@redhat.com)
|
||||
- runtime-install: only pull in qcom-firmware on aarch64 (awilliam@redhat.com)
|
||||
|
||||
* Wed Aug 09 2023 Brian C. Lane <bcl@redhat.com> 39.4-1
|
||||
- Exclude more obsoleted libertas firmware packages (awilliam@redhat.com)
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (lorax-39.4.tar.gz) = 647bedf8963dff626feef56423656da4eb4249a6a46093ee88c4acfdca0a5c895d1da0248c7bb919bd0d705f9426213bbcb878d94b4b57e218b2d427a6fa194d
|
||||
SHA512 (lorax-39.5.tar.gz) = 90f18266797fa446175d2e5836126f3bd7d48f094ca0c9ee8da5cab4dbb04262a14374c5193f4b24e62731f9cd7f156c032d890ca48b30a6457c98975de9ee3b
|
||||
|
Loading…
Reference in New Issue
Block a user