- Install unicode.pf2 from new directory (bcl@redhat.com)
- Makefile: Use sudo to fix ownership of docs (bcl@redhat.com) - Makefile: Make sure container is built before docs (bcl@redhat.com) - Makefile: Add local-srpm target to create a .src.rpm from HEAD (bcl@redhat.com) - mkksiso: cmdline should default to empty string (bcl@redhat.com) - runtime-install: Remove gfs2-utils (bcl@redhat.com) - mount.py: Fix docstring (jkucera@redhat.com)
This commit is contained in:
parent
434e3d7e24
commit
b50361af21
1
.gitignore
vendored
1
.gitignore
vendored
@ -201,3 +201,4 @@
|
||||
/lorax-35.3.tar.gz
|
||||
/lorax-35.4.tar.gz
|
||||
/lorax-35.5.tar.gz
|
||||
/lorax-35.6.tar.gz
|
||||
|
@ -1,40 +0,0 @@
|
||||
diff --color -Nur lorax-35.5.orig/share/templates.d/99-generic/efi.tmpl lorax-35.5/share/templates.d/99-generic/efi.tmpl
|
||||
--- lorax-35.5.orig/share/templates.d/99-generic/efi.tmpl 2021-06-11 10:19:38.000000000 -0700
|
||||
+++ lorax-35.5/share/templates.d/99-generic/efi.tmpl 2021-07-08 11:43:37.539689458 -0700
|
||||
@@ -6,7 +6,6 @@
|
||||
%>
|
||||
|
||||
mkdir ${EFIBOOTDIR}
|
||||
-mkdir ${EFIBOOTDIR}/fonts/
|
||||
%if efiarch64:
|
||||
install boot/efi/EFI/*/shim${efiarch64|lower}.efi ${EFIBOOTDIR}/BOOT${efiarch64}.EFI
|
||||
install boot/efi/EFI/*/mm${efiarch64|lower}.efi ${EFIBOOTDIR}/
|
||||
@@ -17,7 +16,7 @@
|
||||
install boot/efi/EFI/*/mm${efiarch32|lower}.efi ${EFIBOOTDIR}/
|
||||
install boot/efi/EFI/*/gcd${efiarch32|lower}.efi ${EFIBOOTDIR}/grub${efiarch32|lower}.efi
|
||||
%endif
|
||||
-install boot/efi/EFI/*/fonts/unicode.pf2 ${EFIBOOTDIR}/fonts/
|
||||
+install boot/grub2/fonts/unicode.pf2 grub2/fonts/unicode.pf2
|
||||
|
||||
## actually make the EFI images
|
||||
${make_efiboot("images/efiboot.img")}
|
||||
diff --color -Nur lorax-35.5.orig/share/templates.d/99-generic/live/efi.tmpl lorax-35.5/share/templates.d/99-generic/live/efi.tmpl
|
||||
--- lorax-35.5.orig/share/templates.d/99-generic/live/efi.tmpl 2021-06-11 10:19:38.000000000 -0700
|
||||
+++ lorax-35.5/share/templates.d/99-generic/live/efi.tmpl 2021-07-08 11:43:07.788631007 -0700
|
||||
@@ -6,7 +6,6 @@
|
||||
%>
|
||||
|
||||
mkdir ${EFIBOOTDIR}
|
||||
-mkdir ${EFIBOOTDIR}/fonts/
|
||||
%if efiarch64:
|
||||
install boot/efi/EFI/*/shim${efiarch64|lower}.efi ${EFIBOOTDIR}/BOOT${efiarch64}.EFI
|
||||
install boot/efi/EFI/*/mm${efiarch64|lower}.efi ${EFIBOOTDIR}/
|
||||
@@ -17,7 +16,7 @@
|
||||
install boot/efi/EFI/*/mm${efiarch32|lower}.efi ${EFIBOOTDIR}/
|
||||
install boot/efi/EFI/*/gcd${efiarch32|lower}.efi ${EFIBOOTDIR}/grub${efiarch32|lower}.efi
|
||||
%endif
|
||||
-install boot/efi/EFI/*/fonts/unicode.pf2 ${EFIBOOTDIR}/fonts/
|
||||
+install boot/grub2/fonts/unicode.pf2 grub2/fonts/
|
||||
|
||||
## actually make the EFI images
|
||||
${make_efiboot("images/efiboot.img")}
|
17
lorax.spec
17
lorax.spec
@ -3,8 +3,8 @@
|
||||
%define debug_package %{nil}
|
||||
|
||||
Name: lorax
|
||||
Version: 35.5
|
||||
Release: 2%{?dist}
|
||||
Version: 35.6
|
||||
Release: 1%{?dist}
|
||||
Summary: Tool for creating the anaconda install images
|
||||
|
||||
License: GPLv2+
|
||||
@ -14,7 +14,6 @@ URL: https://github.com/weldr/lorax
|
||||
# git checkout -b archive-branch lorax-%%{version}-%%{release}
|
||||
# tito build --tgz
|
||||
Source0: %{name}-%{version}.tar.gz
|
||||
Patch1: lorax-35.5-grub2-fonts.patch
|
||||
|
||||
BuildRequires: python3-devel
|
||||
BuildRequires: make
|
||||
@ -137,8 +136,6 @@ Lorax templates for creating the boot.iso and live isos are placed in
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}
|
||||
|
||||
%patch1 -p1
|
||||
|
||||
%build
|
||||
|
||||
%install
|
||||
@ -178,8 +175,14 @@ make DESTDIR=$RPM_BUILD_ROOT mandir=%{_mandir} install
|
||||
%{_datadir}/lorax/templates.d/*
|
||||
|
||||
%changelog
|
||||
* Thu Jul 08 2021 Kevin Fenzi <kevin@scrye.com> - 35.5-2
|
||||
- Add downstream patch to fix grub2 fonts location.
|
||||
* Thu Jul 08 2021 Brian C. Lane <bcl@redhat.com> 35.6-1
|
||||
- Install unicode.pf2 from new directory (bcl@redhat.com)
|
||||
- Makefile: Use sudo to fix ownership of docs (bcl@redhat.com)
|
||||
- Makefile: Make sure container is built before docs (bcl@redhat.com)
|
||||
- Makefile: Add local-srpm target to create a .src.rpm from HEAD (bcl@redhat.com)
|
||||
- mkksiso: cmdline should default to empty string (bcl@redhat.com)
|
||||
- runtime-install: Remove gfs2-utils (bcl@redhat.com)
|
||||
- mount.py: Fix docstring (jkucera@redhat.com)
|
||||
|
||||
* Fri Jun 11 2021 Brian C. Lane <bcl@redhat.com> 35.5-1
|
||||
- pylorax: Fix mksparse ftruncate size handling (bcl@redhat.com)
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (lorax-35.5.tar.gz) = 4ab041241503b50daf77691a7f511dc8da07c3cc20200df3a6010762dfa1b5c7750c127a2085d724e26c194bea099f0e92c69dbb888cff3d116bc94599489020
|
||||
SHA512 (lorax-35.6.tar.gz) = a2d3fe8585b24d896972436b9d74ea7cdcfdbb6d4d6abd5398e1fd6752bd59039fe2bc552cff5dd02e7675a6700410b954492139e9537c3d25bc6877e05b7ac6
|
||||
|
Loading…
Reference in New Issue
Block a user