- runtime-install: excluded renamed olpc firmware package (awilliam@redhat.com)
- drop unneeded patch for rsvg-pixbuf-loader librsvg2 now Requires it
This commit is contained in:
parent
fd747053b9
commit
a8825f7a07
1
.gitignore
vendored
1
.gitignore
vendored
@ -232,3 +232,4 @@
|
|||||||
/lorax-39.0.tar.gz
|
/lorax-39.0.tar.gz
|
||||||
/lorax-39.1.tar.gz
|
/lorax-39.1.tar.gz
|
||||||
/lorax-39.2.tar.gz
|
/lorax-39.2.tar.gz
|
||||||
|
/lorax-39.3.tar.gz
|
||||||
|
@ -1,43 +0,0 @@
|
|||||||
From c1a8a65a98eaee8543f103ad6f02435ccc3372ea Mon Sep 17 00:00:00 2001
|
|
||||||
From: Adam Williamson <awilliam@redhat.com>
|
|
||||||
Date: Fri, 21 Jul 2023 15:45:50 -0700
|
|
||||||
Subject: [PATCH] runtime-install: install rsvg-pixbuf-loader
|
|
||||||
|
|
||||||
This was split out of librsvg2 as a subpackage recently, and
|
|
||||||
is only Recommended by the parent (not Required). For size's
|
|
||||||
sake, we don't pull Recommends into the installer env by
|
|
||||||
default. But we do really need this package, because quite a
|
|
||||||
lot of icons used in the installer are only present as SVGs in
|
|
||||||
the installer environment, so if we don't have the SVG loader we
|
|
||||||
can't show the icons.
|
|
||||||
|
|
||||||
Right now anaconda actually crashes if the SVG renderer isn't
|
|
||||||
present, which wasn't an expected outcome, but even if the crash
|
|
||||||
is fixed, the result would be that anaconda would run but not
|
|
||||||
show a lot of icons, which obviously isn't what we want. So we
|
|
||||||
should add this regardless of a fix for the crash.
|
|
||||||
|
|
||||||
Signed-off-by: Adam Williamson <awilliam@redhat.com>
|
|
||||||
---
|
|
||||||
share/templates.d/99-generic/runtime-install.tmpl | 5 +++++
|
|
||||||
1 file changed, 5 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/share/templates.d/99-generic/runtime-install.tmpl b/share/templates.d/99-generic/runtime-install.tmpl
|
|
||||||
index 15177467..7ceec8f8 100644
|
|
||||||
--- a/share/templates.d/99-generic/runtime-install.tmpl
|
|
||||||
+++ b/share/templates.d/99-generic/runtime-install.tmpl
|
|
||||||
@@ -105,6 +105,11 @@ installpkg kbd kbd-misc
|
|
||||||
## required for anaconda-dracut (img-lib etc.)
|
|
||||||
installpkg tar xz curl bzip2
|
|
||||||
|
|
||||||
+## this is only recommended by librsvg2 since 2023-07, but in the
|
|
||||||
+## installer environment many icons used are only present as SVGs,
|
|
||||||
+## so we really need it
|
|
||||||
+installpkg rsvg-pixbuf-loader
|
|
||||||
+
|
|
||||||
## basic system stuff
|
|
||||||
installpkg systemd-sysv systemd-units
|
|
||||||
installpkg rsyslog
|
|
||||||
--
|
|
||||||
2.41.0
|
|
||||||
|
|
22
lorax.spec
22
lorax.spec
@ -3,8 +3,8 @@
|
|||||||
%define debug_package %{nil}
|
%define debug_package %{nil}
|
||||||
|
|
||||||
Name: lorax
|
Name: lorax
|
||||||
Version: 39.2
|
Version: 39.3
|
||||||
Release: 5%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Tool for creating the anaconda install images
|
Summary: Tool for creating the anaconda install images
|
||||||
|
|
||||||
License: GPL-2.0-or-later
|
License: GPL-2.0-or-later
|
||||||
@ -14,9 +14,6 @@ URL: https://github.com/weldr/lorax
|
|||||||
# git checkout -b archive-branch lorax-%%{version}-%%{release}
|
# git checkout -b archive-branch lorax-%%{version}-%%{release}
|
||||||
# tito build --tgz
|
# tito build --tgz
|
||||||
Source0: %{name}-%{version}.tar.gz
|
Source0: %{name}-%{version}.tar.gz
|
||||||
# https://github.com/weldr/lorax/pull/1334
|
|
||||||
# Ensure we have SVG pixbuf loader now it's split out of librsvg2
|
|
||||||
Patch0: 0001-runtime-install-install-rsvg-pixbuf-loader.patch
|
|
||||||
|
|
||||||
BuildRequires: python3-devel
|
BuildRequires: python3-devel
|
||||||
BuildRequires: python3-setuptools
|
BuildRequires: python3-setuptools
|
||||||
@ -171,17 +168,10 @@ make DESTDIR=$RPM_BUILD_ROOT mandir=%{_mandir} install
|
|||||||
%{_datadir}/lorax/templates.d/*
|
%{_datadir}/lorax/templates.d/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Sat Jul 22 2023 Adam Williamson <awilliam@redhat.com> - 39.2-5
|
* Mon Aug 07 2023 Brian C. Lane <bcl@redhat.com> 39.3-1
|
||||||
- Rebuild with no changes on a side tag to resolve test problems
|
- runtime-install: excluded renamed olpc firmware package (awilliam@redhat.com)
|
||||||
|
- drop unneeded patch for rsvg-pixbuf-loader
|
||||||
* Sat Jul 22 2023 Adam Williamson <awilliam@redhat.com> - 39.2-4
|
librsvg2 now Requires it
|
||||||
- Backport PR #1334 to fix installer with latest librsvg2
|
|
||||||
|
|
||||||
* Thu Jul 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 39.2-3
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
|
||||||
|
|
||||||
* Fri Jul 14 2023 Brian C. Lane <bcl@redhat.com> - 39.2-2
|
|
||||||
- plans: prepare is reported to be unneeded and causing issues
|
|
||||||
|
|
||||||
* Fri Jul 14 2023 Brian C. Lane <bcl@redhat.com> 39.2-1
|
* Fri Jul 14 2023 Brian C. Lane <bcl@redhat.com> 39.2-1
|
||||||
- pylint: Ignore false positive from pylint on rawhide (bcl@redhat.com)
|
- pylint: Ignore false positive from pylint on rawhide (bcl@redhat.com)
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (lorax-39.2.tar.gz) = c3dbb812b06107e26e49d1d360b3f0808f640ebbf813d4a09b9088e6a447667791b8f8c9f5131703cb6e02313a467819f57ce0ce4732e5edab1fef784dfe5121
|
SHA512 (lorax-39.3.tar.gz) = a6b964a877175b45068cc60ef5900af04c73e8a91f14745f4248f88263196a0a35f1b7c579f929f0c75ff5e5dac07f012387f1aac2f305c386b165c86d75301b
|
||||||
|
Loading…
Reference in New Issue
Block a user