Add patch for anaconda log-level removal (already upstream)
This commit is contained in:
parent
85ff10e99e
commit
9b301fe53c
23
78eec89cda687f9689978eedb5482d041577577a.patch
Normal file
23
78eec89cda687f9689978eedb5482d041577577a.patch
Normal file
@ -0,0 +1,23 @@
|
||||
From 78eec89cda687f9689978eedb5482d041577577a Mon Sep 17 00:00:00 2001
|
||||
From: Vojtech Trefny <vtrefny@redhat.com>
|
||||
Date: Wed, 18 Nov 2020 10:27:58 +0100
|
||||
Subject: [PATCH] Do not use '--loglevel' option when running Anaconda
|
||||
|
||||
This option has been removed, see https://github.com/rhinstaller/anaconda/pull/2864
|
||||
---
|
||||
src/pylorax/installer.py | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/pylorax/installer.py b/src/pylorax/installer.py
|
||||
index b882ecfe6..9d0a8527b 100644
|
||||
--- a/src/pylorax/installer.py
|
||||
+++ b/src/pylorax/installer.py
|
||||
@@ -355,7 +355,7 @@ def novirt_install(opts, disk_img, disk_size, cancel_func=None, tar_img=None):
|
||||
if os.path.isdir(path):
|
||||
shutil.rmtree(path)
|
||||
|
||||
- args = ["--kickstart", opts.ks[0], "--cmdline", "--loglevel", "debug"]
|
||||
+ args = ["--kickstart", opts.ks[0], "--cmdline"]
|
||||
if opts.anaconda_args:
|
||||
for arg in opts.anaconda_args:
|
||||
args += arg.split(" ", 1)
|
10
lorax.spec
10
lorax.spec
@ -4,7 +4,7 @@
|
||||
|
||||
Name: lorax
|
||||
Version: 34.4
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Summary: Tool for creating the anaconda install images
|
||||
|
||||
License: GPLv2+
|
||||
@ -14,6 +14,10 @@ URL: https://github.com/weldr/lorax
|
||||
# git checkout -b archive-branch lorax-%%{version}-%%{release}
|
||||
# tito build --tgz
|
||||
Source0: %{name}-%{version}.tar.gz
|
||||
# Patch to no longer pass to anaconda log-level as it's been removed.
|
||||
# Already upstream
|
||||
# https://github.com/weldr/lorax/commit/78eec89cda687f9689978eedb5482d041577577a
|
||||
Patch1: https://github.com/weldr/lorax/commit/78eec89cda687f9689978eedb5482d041577577a.patch
|
||||
|
||||
BuildRequires: python3-devel
|
||||
BuildRequires: make
|
||||
@ -146,6 +150,7 @@ build images, etc. from the command line.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}
|
||||
%patch1 -p1
|
||||
|
||||
%build
|
||||
|
||||
@ -193,6 +198,9 @@ make DESTDIR=$RPM_BUILD_ROOT mandir=%{_mandir} install
|
||||
%{_mandir}/man1/composer-cli.1*
|
||||
|
||||
%changelog
|
||||
* Thu Nov 26 2020 Kevin Fenzi <kevin@scrye.com> - 34.4-2
|
||||
- Add patch for anaconda log-level removal (already upstream)
|
||||
|
||||
* Mon Nov 02 2020 Brian C. Lane <bcl@redhat.com> 34.4-1
|
||||
- Update the default release version to 34 (bcl@redhat.com)
|
||||
- Remove mdmonitor service from boot.iso (bcl@redhat.com)
|
||||
|
Loading…
Reference in New Issue
Block a user