- drop included patches
- pylint: Ignore false positive from pylint on rawhide (bcl@redhat.com) - tests: Fix image_minimizer test dnf usage (bcl@redhat.com) - tests: Fix HFS test to work with new get_file_magic output (bcl@redhat.com) - ltmpl: Use ProcMount while running the dnf transaction (bcl@redhat.com) - imgutils: Split part DracutChroot into ProcMount (bcl@redhat.com) - runtime-postinstall: Remove libuser.conf (bcl@redhat.com) - runtime-install: exclude renamed iwl firmware packages (awilliam@redhat.com) - test_minimizer: dnf5 wants --use-host-config (bcl@redhat.com) - Install nvme-cli tool and remove machine specific nvme files (bcl@redhat.com) - Revert "Add blacklist_exceptions to multipath.conf" (jstodola@redhat.com)
This commit is contained in:
parent
ff16001b69
commit
86e0a84b54
1
.gitignore
vendored
1
.gitignore
vendored
@ -231,3 +231,4 @@
|
||||
/lorax-38.6.tar.gz
|
||||
/lorax-39.0.tar.gz
|
||||
/lorax-39.1.tar.gz
|
||||
/lorax-39.2.tar.gz
|
||||
|
@ -1,57 +0,0 @@
|
||||
From b0e04f47313eeb276ac57db6e769799cea25cc0b Mon Sep 17 00:00:00 2001
|
||||
From: Adam Williamson <awilliam@redhat.com>
|
||||
Date: Tue, 4 Jul 2023 08:45:03 -0700
|
||||
Subject: [PATCH] runtime-install: exclude renamed iwl firmware packages
|
||||
|
||||
@pbrobinson renamed the Intel wireless firmware packages in
|
||||
the 20230625 build of linux-firmware. This causes installer
|
||||
image builds to fail because they want to pull in the old packages
|
||||
from the release repo because they fall in the "*-firmware" glob,
|
||||
but those packages are now obsoleted by the newer ones from
|
||||
updates/updates-testing, and dnf doesn't like that. This should
|
||||
resolve the problem by specifically excluding all the renamed
|
||||
packages from the glob. Of course, this change must go along
|
||||
with the newer linux-firmware package, or else you'll get an
|
||||
image that's missing a lot of wireless firmware.
|
||||
|
||||
Signed-off-by: Adam Williamson <awilliam@redhat.com>
|
||||
---
|
||||
share/templates.d/99-generic/runtime-install.tmpl | 15 ++++++++++++++-
|
||||
1 file changed, 14 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/share/templates.d/99-generic/runtime-install.tmpl b/share/templates.d/99-generic/runtime-install.tmpl
|
||||
index f8f988b8..15177467 100644
|
||||
--- a/share/templates.d/99-generic/runtime-install.tmpl
|
||||
+++ b/share/templates.d/99-generic/runtime-install.tmpl
|
||||
@@ -28,6 +28,10 @@ installpkg grubby
|
||||
## https://bugzilla.redhat.com/show_bug.cgi?id=2011615
|
||||
## bfa-firmware contains only obsolete files - see
|
||||
## https://bugzilla.redhat.com/show_bug.cgi?id=2152202
|
||||
+ ## various iwl package names were changed in linux-firmware-20230625-151
|
||||
+ ## so need to be excluded or else dnf gets sad - see
|
||||
+ ## https://pagure.io/releng/issue/11511 . These exclusions can
|
||||
+ ## be dropped after F38 goes EOL
|
||||
installpkg --optional *-firmware --except alsa* --except midisport-firmware \
|
||||
--except crystalhd-firmware --except ivtv-firmware \
|
||||
--except cx18-firmware --except iscan-firmware \
|
||||
@@ -36,7 +40,16 @@ installpkg grubby
|
||||
--except liquidio-firmware --except netronome-firmware \
|
||||
--except mrvlprestera-firmware --except mlxsw_spectrum-firmware \
|
||||
--except hackrf-firmware --except python-virt-firmware \
|
||||
- --except python3-virt-firmware
|
||||
+ --except python3-virt-firmware \
|
||||
+ --except iwl3945-firmware --except iwl4965-firmware \
|
||||
+ --except iwl100-firmware --except iwl105-firmware \
|
||||
+ --except iwl135-firmware --except iwl1000-firmware \
|
||||
+ --except iwl2000-firmware --except iwl2030-firmware \
|
||||
+ --except iwl5000-firmware --except iwl5150-firmware \
|
||||
+ --except iwl6000-firmware --except iwl6000g2a-firmware \
|
||||
+ --except iwl6000g2b-firmware --except iwl6050-firmware \
|
||||
+ --except iwl3160-firmware --except iwl7260-firmware \
|
||||
+ --except iwlax2xx-firmware
|
||||
installpkg b43-openfwwf
|
||||
%endif
|
||||
|
||||
--
|
||||
2.41.0
|
||||
|
27
lorax.spec
27
lorax.spec
@ -3,8 +3,8 @@
|
||||
%define debug_package %{nil}
|
||||
|
||||
Name: lorax
|
||||
Version: 39.1
|
||||
Release: 4%{?dist}
|
||||
Version: 39.2
|
||||
Release: 1%{?dist}
|
||||
Summary: Tool for creating the anaconda install images
|
||||
|
||||
License: GPL-2.0-or-later
|
||||
@ -14,10 +14,6 @@ URL: https://github.com/weldr/lorax
|
||||
# git checkout -b archive-branch lorax-%%{version}-%%{release}
|
||||
# tito build --tgz
|
||||
Source0: %{name}-%{version}.tar.gz
|
||||
# https://github.com/weldr/lorax/pull/1332
|
||||
# https://pagure.io/releng/issue/11511
|
||||
# adapt to renamed iwl firmware packages
|
||||
Patch0: 0001-runtime-install-exclude-renamed-iwl-firmware-package.patch
|
||||
|
||||
BuildRequires: python3-devel
|
||||
BuildRequires: python3-setuptools
|
||||
@ -172,14 +168,17 @@ make DESTDIR=$RPM_BUILD_ROOT mandir=%{_mandir} install
|
||||
%{_datadir}/lorax/templates.d/*
|
||||
|
||||
%changelog
|
||||
* Tue Jul 04 2023 Adam Williamson <awilliam@redhat.com> - 39.1-4
|
||||
- Rebuilt for Python 3.12 again
|
||||
|
||||
* Tue Jul 04 2023 Adam Williamson <awilliam@redhat.com> - 39.1-3
|
||||
- Backport PR #1332 to handle renamed iwl firmware packages
|
||||
|
||||
* Tue Jun 13 2023 Python Maint <python-maint@redhat.com> - 39.1-2
|
||||
- Rebuilt for Python 3.12
|
||||
* Fri Jul 14 2023 Brian C. Lane <bcl@redhat.com> 39.2-1
|
||||
- pylint: Ignore false positive from pylint on rawhide (bcl@redhat.com)
|
||||
- tests: Fix image_minimizer test dnf usage (bcl@redhat.com)
|
||||
- tests: Fix HFS test to work with new get_file_magic output (bcl@redhat.com)
|
||||
- ltmpl: Use ProcMount while running the dnf transaction (bcl@redhat.com)
|
||||
- imgutils: Split part DracutChroot into ProcMount (bcl@redhat.com)
|
||||
- runtime-postinstall: Remove libuser.conf (bcl@redhat.com)
|
||||
- runtime-install: exclude renamed iwl firmware packages (awilliam@redhat.com)
|
||||
- test_minimizer: dnf5 wants --use-host-config (bcl@redhat.com)
|
||||
- Install nvme-cli tool and remove machine specific nvme files (bcl@redhat.com)
|
||||
- Revert "Add blacklist_exceptions to multipath.conf" (jstodola@redhat.com)
|
||||
|
||||
* Wed May 31 2023 Brian C. Lane <bcl@redhat.com> 39.1-1
|
||||
- livemedia-creator: Reorganize the qemu arch patch (bcl@redhat.com)
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (lorax-39.1.tar.gz) = b077849e56bdfb5d5a5a6d2b1e5dfe22f8e1ba625ad5b8bfcadb9f918565fa4897583cf105f78005ade316e6f85efac483c36d076896e4937f5fd1ee1756fb6e
|
||||
SHA512 (lorax-39.2.tar.gz) = c3dbb812b06107e26e49d1d360b3f0808f640ebbf813d4a09b9088e6a447667791b8f8c9f5131703cb6e02313a467819f57ce0ce4732e5edab1fef784dfe5121
|
||||
|
Loading…
Reference in New Issue
Block a user