- Update the default release version to 34 (bcl@redhat.com)
- Remove mdmonitor service from boot.iso (bcl@redhat.com) - Switch to using upstream mk-s390image for s390 cdboot.img creation (bcl@redhat.com) - sshd_config: Apply suggested changes (bcl@redhat.com) - lorax.spec: Add BuildRequires on systemd-rpm-macros for tmpfilesdir macro (bcl@redhat.com)
This commit is contained in:
parent
195074814e
commit
85ff10e99e
1
.gitignore
vendored
1
.gitignore
vendored
@ -189,3 +189,4 @@
|
||||
/lorax-34.1.tar.gz
|
||||
/lorax-34.2.tar.gz
|
||||
/lorax-34.3.tar.gz
|
||||
/lorax-34.4.tar.gz
|
||||
|
@ -1,45 +0,0 @@
|
||||
From 6ba02f734c481dfb7fa3feab11b6831b449d82cb Mon Sep 17 00:00:00 2001
|
||||
From: Adam Williamson <awilliam@redhat.com>
|
||||
Date: Mon, 15 Jun 2020 17:05:02 -0700
|
||||
Subject: [PATCH] Ensure /proc exists before trying to touch /proc/modules
|
||||
|
||||
The last few Rawhide composes failed because, when we try to
|
||||
touch /proc/modules here (in treebuilder.py), /proc does not
|
||||
exist in the inroot. I tried and failed all afternoon to figure
|
||||
out *why* it suddenly doesn't exist; I'd still like to know, but
|
||||
this at least should make it not an issue. `exist_ok=True` means
|
||||
that if the dir already exists we'll do nothing and carry on.
|
||||
|
||||
Signed-off-by: Adam Williamson <awilliam@redhat.com>
|
||||
---
|
||||
src/pylorax/creator.py | 1 +
|
||||
src/pylorax/treebuilder.py | 1 +
|
||||
2 files changed, 2 insertions(+)
|
||||
|
||||
diff --git a/src/pylorax/creator.py b/src/pylorax/creator.py
|
||||
index 7075d325..fc090a26 100644
|
||||
--- a/src/pylorax/creator.py
|
||||
+++ b/src/pylorax/creator.py
|
||||
@@ -256,6 +256,7 @@ def rebuild_initrds_for_live(opts, sys_root_dir, results_dir):
|
||||
raise Exception("No initrds found, cannot rebuild_initrds")
|
||||
|
||||
# Hush some dracut warnings. TODO: bind-mount proc in place?
|
||||
+ os.makedirs(joinpaths(sys_root_dir, "/proc"), exist_ok=True)
|
||||
open(joinpaths(sys_root_dir,"/proc/modules"),"w")
|
||||
|
||||
if opts.ostree:
|
||||
diff --git a/src/pylorax/treebuilder.py b/src/pylorax/treebuilder.py
|
||||
index cbb8872f..c30df638 100644
|
||||
--- a/src/pylorax/treebuilder.py
|
||||
+++ b/src/pylorax/treebuilder.py
|
||||
@@ -309,6 +309,7 @@ class TreeBuilder(object):
|
||||
raise Exception("No kernels found, cannot rebuild_initrds")
|
||||
|
||||
# Hush some dracut warnings. TODO: bind-mount proc in place?
|
||||
+ os.makedirs(joinpaths(self.vars.inroot, "/proc"), exist_ok=True)
|
||||
open(joinpaths(self.vars.inroot,"/proc/modules"),"w")
|
||||
for kernel in self.kernels:
|
||||
if prefix:
|
||||
--
|
||||
2.27.0
|
||||
|
11
lorax.spec
11
lorax.spec
@ -3,7 +3,7 @@
|
||||
%define debug_package %{nil}
|
||||
|
||||
Name: lorax
|
||||
Version: 34.3
|
||||
Version: 34.4
|
||||
Release: 1%{?dist}
|
||||
Summary: Tool for creating the anaconda install images
|
||||
|
||||
@ -73,6 +73,7 @@ Requires: grub2-tools
|
||||
|
||||
%ifarch s390 s390x
|
||||
Requires: openssh
|
||||
Requires: s390utils >= 2.15.0-2
|
||||
%endif
|
||||
|
||||
%ifarch %{arm}
|
||||
@ -166,7 +167,6 @@ make DESTDIR=$RPM_BUILD_ROOT mandir=%{_mandir} install
|
||||
%{_sbindir}/livemedia-creator
|
||||
%{_sbindir}/mkksiso
|
||||
%{_bindir}/image-minimizer
|
||||
%{_bindir}/mk-s390-cdboot
|
||||
%dir %{_sysconfdir}/lorax
|
||||
%config(noreplace) %{_sysconfdir}/lorax/lorax.conf
|
||||
%dir %{_datadir}/lorax
|
||||
@ -193,6 +193,13 @@ make DESTDIR=$RPM_BUILD_ROOT mandir=%{_mandir} install
|
||||
%{_mandir}/man1/composer-cli.1*
|
||||
|
||||
%changelog
|
||||
* Mon Nov 02 2020 Brian C. Lane <bcl@redhat.com> 34.4-1
|
||||
- Update the default release version to 34 (bcl@redhat.com)
|
||||
- Remove mdmonitor service from boot.iso (bcl@redhat.com)
|
||||
- Switch to using upstream mk-s390image for s390 cdboot.img creation (bcl@redhat.com)
|
||||
- sshd_config: Apply suggested changes (bcl@redhat.com)
|
||||
- lorax.spec: Add BuildRequires on systemd-rpm-macros for tmpfilesdir macro (bcl@redhat.com)
|
||||
|
||||
* Wed Oct 07 2020 Brian C. Lane <bcl@redhat.com> 34.3-1
|
||||
- composer: Fix open file warnings (bcl@redhat.com)
|
||||
- ltmpl: Fix deprecated escape in docstring (bcl@redhat.com)
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (lorax-34.3.tar.gz) = 7953664ca44c2591b2245ffdd58c004a623135ee540d4835f737f90361cc53ae903ba7f8f5d0ae45f6eff7d64144b3301e6cc16930c68c20d8d6fed91e1e9179
|
||||
SHA512 (lorax-34.4.tar.gz) = 0d83087677e4b3c8ef54c4f838f224d5d7130a1f9f9932e0b4b50935da99edc8924e06b4536b9bee50ecd2bc9314c287f0abcdf2bc2b8ebe8e3a8373873bf58f
|
||||
|
Loading…
Reference in New Issue
Block a user