- lorax: Add --rootfs-size (#1368743) (bcl@redhat.com)
- Revert "Use size=10 by default" (bcl@redhat.com)
This commit is contained in:
parent
5b67735bb1
commit
581624922c
1
.gitignore
vendored
1
.gitignore
vendored
@ -92,3 +92,4 @@
|
||||
/lorax-25.11.tar.gz
|
||||
/lorax-25.12.tar.gz
|
||||
/lorax-25.13.tar.gz
|
||||
/lorax-25.14.tar.gz
|
||||
|
@ -1,27 +0,0 @@
|
||||
From 893c2b59b01bac9ab8ef6764ed4b33f353a4d745 Mon Sep 17 00:00:00 2001
|
||||
From: Dennis Gilmore <dennis@ausil.us>
|
||||
Date: Thu, 18 Aug 2016 16:31:34 -0500
|
||||
Subject: [PATCH 1/3] in additoon to running fuser on /dev/shm also run ls to
|
||||
see whats in it
|
||||
|
||||
Signed-off-by: Dennis Gilmore <dennis@ausil.us>
|
||||
---
|
||||
src/pylorax/imgutils.py | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/src/pylorax/imgutils.py b/src/pylorax/imgutils.py
|
||||
index ca27e2c..68ec70a 100644
|
||||
--- a/src/pylorax/imgutils.py
|
||||
+++ b/src/pylorax/imgutils.py
|
||||
@@ -218,6 +218,8 @@ def umount(mnt, lazy=False, maxretry=3, retrysleep=1.0, delete=True):
|
||||
if logger.getEffectiveLevel() <= logging.DEBUG:
|
||||
fuser = execWithCapture("fuser", ["-vm", mnt])
|
||||
logger.debug("fuser -vm:\n%s\n", fuser)
|
||||
+ ls = execWithCapture("ls", ["-lah", mnt])
|
||||
+ logger.debug("ls -lah:\n%s\n", ls)
|
||||
sleep(retrysleep)
|
||||
else:
|
||||
break
|
||||
--
|
||||
2.7.4
|
||||
|
@ -1,26 +0,0 @@
|
||||
From 4428f16c9501c32d8ad159492bf728791d8d364a Mon Sep 17 00:00:00 2001
|
||||
From: Dennis Gilmore <dennis@ausil.us>
|
||||
Date: Fri, 19 Aug 2016 09:13:57 -0500
|
||||
Subject: [PATCH 2/3] run lsof on the mountpoints that fail to unmount
|
||||
|
||||
Signed-off-by: Dennis Gilmore <dennis@ausil.us>
|
||||
---
|
||||
src/pylorax/imgutils.py | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/src/pylorax/imgutils.py b/src/pylorax/imgutils.py
|
||||
index 68ec70a..77f4eba 100644
|
||||
--- a/src/pylorax/imgutils.py
|
||||
+++ b/src/pylorax/imgutils.py
|
||||
@@ -220,6 +220,8 @@ def umount(mnt, lazy=False, maxretry=3, retrysleep=1.0, delete=True):
|
||||
logger.debug("fuser -vm:\n%s\n", fuser)
|
||||
ls = execWithCapture("ls", ["-lah", mnt])
|
||||
logger.debug("ls -lah:\n%s\n", ls)
|
||||
+ lsof = execWithCapture("lsof", [mnt])
|
||||
+ logger.debug("lsof\n%s\n", lsof)
|
||||
sleep(retrysleep)
|
||||
else:
|
||||
break
|
||||
--
|
||||
2.7.4
|
||||
|
@ -1,28 +0,0 @@
|
||||
From 9b6a262b7cbe6f7a54ed80ea43266e7d10a6be0c Mon Sep 17 00:00:00 2001
|
||||
From: Dennis Gilmore <dennis@ausil.us>
|
||||
Date: Fri, 19 Aug 2016 17:24:16 -0500
|
||||
Subject: [PATCH 3/3] Revert "Use size=10 by default"
|
||||
|
||||
since this landed in rawhide composing has been broken on arm
|
||||
|
||||
This reverts commit e61223d486738c97369a98f81da7abd528c1cabf.
|
||||
---
|
||||
src/pylorax/__init__.py | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/pylorax/__init__.py b/src/pylorax/__init__.py
|
||||
index f6955c4..aafd0c9 100644
|
||||
--- a/src/pylorax/__init__.py
|
||||
+++ b/src/pylorax/__init__.py
|
||||
@@ -166,7 +166,7 @@ class Lorax(BaseLoraxClass):
|
||||
isfinal=False, workdir=None, outputdir=None, buildarch=None, volid=None,
|
||||
domacboot=True, doupgrade=True, remove_temp=False,
|
||||
installpkgs=None,
|
||||
- size=10,
|
||||
+ size=2,
|
||||
add_templates=None,
|
||||
add_template_vars=None,
|
||||
add_arch_templates=None,
|
||||
--
|
||||
2.7.4
|
||||
|
27
lorax.spec
27
lorax.spec
@ -3,8 +3,8 @@
|
||||
%define debug_package %{nil}
|
||||
|
||||
Name: lorax
|
||||
Version: 25.13
|
||||
Release: 6%{?dist}
|
||||
Version: 25.14
|
||||
Release: 1%{?dist}
|
||||
Summary: Tool for creating the anaconda install images
|
||||
|
||||
Group: Applications/System
|
||||
@ -15,9 +15,6 @@ URL: https://github.com/rhinstaller/lorax
|
||||
# git checkout -b archive-branch lorax-%%{version}-%%{release}
|
||||
# tito build --tgz
|
||||
Source0: %{name}-%{version}.tar.gz
|
||||
Patch0: 0001-in-additoon-to-running-fuser-on-dev-shm-also-run-ls-.patch
|
||||
Patch1: 0002-run-lsof-on-the-mountpoints-that-fail-to-unmount.patch
|
||||
Patch2: 0003-Revert-Use-size-10-by-default.patch
|
||||
|
||||
BuildRequires: python3-devel
|
||||
|
||||
@ -119,9 +116,6 @@ Lorax templates for creating the boot.iso and live isos are placed in
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
|
||||
%build
|
||||
|
||||
@ -154,20 +148,9 @@ make DESTDIR=$RPM_BUILD_ROOT mandir=%{_mandir} install
|
||||
|
||||
|
||||
%changelog
|
||||
* Sat Aug 20 2016 Kevin Fenzi <kevin@scrye.com> - 25.13-6
|
||||
- Actually apply last patch
|
||||
|
||||
* Fri Aug 19 2016 Dennis Gilmore <dennis@ausil.us> - 25.13-5
|
||||
- revert Use size=10 by default (walters@verbum.org)
|
||||
|
||||
* Fri Aug 19 2016 Dennis Gilmore <dennis@ausil.us> - 25.13-4
|
||||
- acctually apply the lsof patch
|
||||
|
||||
* Fri Aug 19 2016 Dennis Gilmore <dennis@ausil.us> - 25.13-3
|
||||
- add patch to run lsof as well as fuser and ls on mount points
|
||||
|
||||
* Thu Aug 18 2016 Dennis Gilmore <dennis@ausil.us> - 25.13-2
|
||||
- add a patch to do a ls of /dev/shm for testing of lives
|
||||
* Tue Aug 23 2016 Brian C. Lane <bcl@redhat.com> 25.14-1
|
||||
- lorax: Add --rootfs-size (#1368743) (bcl@redhat.com)
|
||||
- Revert "Use size=10 by default" (bcl@redhat.com)
|
||||
|
||||
* Fri Aug 12 2016 Brian C. Lane <bcl@redhat.com> 25.13-1
|
||||
- as of Fedora 25 s390x now has docker (pbrobinson@fedoraproject.org)
|
||||
|
Loading…
Reference in New Issue
Block a user